Ubuntu

Include experimental alx driver in the quantal kernel

Reported by James M. Leddy on 2012-02-06
324
This bug affects 58 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
AceLan Kao
Linux
New
Undecided
James M. Leddy
linux (Ubuntu)
Medium
AceLan Kao
Precise
Medium
AceLan Kao
Quantal
Medium
AceLan Kao
Raring
Medium
AceLan Kao
Saucy
Medium
AceLan Kao

Bug Description

Around the same time frame as the 12.04 release, we will see AR8131/AR8151/AR8152/AR8161 available on consumer machines. If the driver is not accepted into linux-next by the time we have a kernel freeze, we will probably need to support this via lbm or other means. This driver is alx - http://www.linuxfoundation.org/collaborate/workgroups/networking/alx

Here is the first post of the driver http://thread.gmane.org/gmane.linux.kernel/1205207

QCA's attempt in upstreaming alx: https://lkml.org/lkml/2012/2/28/537

Changed in udev (Ubuntu):
status: Triaged → Invalid
affects: udev (Ubuntu) → linux (Ubuntu)
Changed in linux:
assignee: nobody → James M. Leddy (jm-leddy)
tags: added: blocks-hwcert-enablement
Changed in linux (Ubuntu):
status: Invalid → Confirmed
description: updated
Chris Van Hoof (vanhoof) on 2012-04-11
Changed in linux (Ubuntu Oneiric):
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → James M. Leddy (jm-leddy)
Changed in linux (Ubuntu Precise):
milestone: ubuntu-12.04 → precise-updates
Changed in linux (Ubuntu Oneiric):
milestone: none → oneiric-updates
tags: removed: blocks-hwcert
James M. Leddy (jm-leddy) wrote :

This hasn't even hit net-next yet. We will defer until we have a release of this driver in the linux upstream that we can module backport.

What should "happy" Ubuntu users do to get networking support on their new machines?

frostschutz (frostschutz) wrote :

Argh. Oh well. I got myself one of these on an ASUS P8H77-V. Didn't notice it said Atheros in the specs. That's what you get for not having a hardware issue with Linux for 5+ years, you get careless when buying new stuff.

> What should "happy" Ubuntu users do to get networking support on their new machines?

I'll try to install that driver, but if it doesn't work right away, I'll probably spend $10 on a different NIC (and make sure it's supported this time)... probably even just a USB one since in my case it's just for a simple Internet connection. It never hurts to have one of these in your collection anyway. And then I'll just wait until the Linux kernel supports the onboard one out of the box, hopefully the problem will be gone in the next 1-2 years.

frostschutz (frostschutz) wrote :

Tested the driver, works fine, can be built even on the Live CD if you have the tarball on a USB stick and know how to use make and insmod... *Everything went better than expected*

Yes, it worked for me as well. I followed this instruction: http://www.jfdesignnet.com/?p=2133

But It seems it works only in 100Mbit mode for me, no 1GbE. Not sure whether it's a driver issue or bad cabling.

Also connection detection is incredibly slow - about 20sec after cable insertion before connection is recognized.

James M. Leddy (jm-leddy) wrote :

This is in the linux-next-pending directory of compat-wireless (even though it isn't even a wireless card). If we're lucky, this is already available by the (unsupported) linux-backports-modules-wireless package.

James M. Leddy (jm-leddy) wrote :

A few things have changed since I last read the thread:

Date Fri, 30 Mar 2012 13:52:34 -0700
From "Luis R. Rodriguez" <>
Subject Re: [PATCH] net: add QCA alx Ethernet driver

On Fri, Mar 30, 2012 at 04:45:54PM -0400, David Miller wrote:
>
> Submitting alx that only supports the newer chipsets is fine.

We will work on this and resubmit, the delta for the other chipsets
can also be addressed within atl1c, in addition to working on getting
documentation out to help enable further.

  Luis

We'll have to wait for QCA to finish alx for the new cards _only_. Likely this will make it in for quantal.

For precise and earlier, we'll have to wait for the compat wireless 3.4.0 package that has this module in it.

[0] https://lkml.org/lkml/2012/3/30/502

Tim Chen (ctf) on 2012-07-10
tags: added: blocks-hwcert
Changed in linux (Ubuntu):
milestone: precise-updates → none
Anthony Wong (anthonywong) wrote :

For users hit by this bug, we will provide the driver in linux-backports-modules-cw-3.4, which is tracked in bug 1023566.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu Precise):
status: Confirmed → In Progress
Changed in linux (Ubuntu Oneiric):
status: Confirmed → Won't Fix
summary: - include the Atheros AR8131/AR8151/AR8152/AR8161 Ethernet driver
+ include the Atheros AR8131/AR8151/AR8152/AR8161/AR8162 Ethernet driver
Ara Pulido (apulido) on 2012-08-08
tags: added: precise quantal

linux-backports-modules-3.2.0 (3.2.0-29.14) has just been released, which provides the drivers of this bug.

Changed in linux (Ubuntu Precise):
status: In Progress → Fix Released
Tim Chen (ctf) wrote :

I have installed linux-backports-modules-net-3.2.0-29-generic_3.2.0-29.14_amd64.deb and upgrade kernel to 3.2.0-29.46 on a fresh installed Precise, but the AR8161 ethernet still can't work on the system. What else should I take care? Thanks.

Tim Chen (ctf) wrote :

continue #10, the module should be "alx", however I can't find the module after linux-backports-*.deb installed.

Changed in linux (Ubuntu):
status: Invalid → Fix Released
Anthony Wong (anthonywong) wrote :

@ctf, you should install linux-backports-modules-cw-3.4-3.2.0-29-generic-pae, please try this package.

Is this package available for x86_64? I can see i386 only.

sami (miaousami) wrote :

Hi,
it worked well for me.
I installed linux-backports-modules-cw-3.4-3.2.0-29-generic, and the alx driver is working nicely.

Thanks !

One uestion : what will happen when a new kernel update will be released (e.g. 3.2.0-30) ?

Regards

Tim Chen (ctf) wrote :

linux-backports-modules-cw-3.4-3.2.0-29 works for me.

Tim Chen (ctf) wrote :

I just downloaded the Quantal daily image, http://cdimage.ubuntu.com/daily-live/current/quantal-desktop-amd64.iso
And made a usb installer, the Atheros 8162 ethernet is still not supported.

Tim Chen (ctf) wrote :

update comment #16, neither the Quantal installer nor the system installed using Quantal installer, the 8161/8162 doesn't work.
Kernel is 3.5.0-11.11.

Ara Pulido (apulido) wrote :

Reopening this bug, as it doesn't work in Quantal

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Tim Chen (ctf) wrote :

No extra packages are installed in #16,#17. The alx module is not being loaded.

sami (miaousami) wrote :

Hi,

would it be possible to make a generic package such as:
linux-backports-modules-cw-3.4-precise-generic

because at this time we have to update manually each time the kernel is updated...
Regards

tags: added: rls-q-incoming
James M. Leddy (jm-leddy) wrote :

Hi Sami,

First someone has to write a modalias script that will compare the compat-wireless modules with the currently installed modules. Then we can add it to jockey so that you don't have a manual upgrade. I'm planning on doing this if no one else does, but it will take some time.

Michael Steger (m-steger) wrote :

AR8161 Driver

Linux ubuntu 3.2.0-29 <- includes the driver
Linux ubuntu 3.2.0-30 <- again still missing :-/

Chris Hermansen (c-hermansen) wrote :

Ugh, for some reason I did not find this bug when I searched... so I filed

https://bugs.launchpad.net/bugs/1046435

A maintainer asked if I could file upstream as well, which I did. Maybe not necessary judging by the above.

Chris Hermansen (c-hermansen) wrote :

Ok, so I filed a kernel bug https://bugzilla.kernel.org/show_bug.cgi?id=47161 and here is the response:

Comment #1 From Alan 2012-09-07 15:34:27

Whoever said that was wrong in this case I think. It's up to Ubuntu what backports it ships in its 3.2 kernels

Status sent to "resolved invalid".

So... seems to me this needs to get resolved in an LTS, given that an increasing number of laptops are using this chip. Am I wrong?

sami (miaousami) wrote :

@Michael,
I have an AR8161 and it is working well with kernels 3.2.0-29, 3.2.0-30 and the brand new 3.2.0-31.

Moreover the meta package "linux-backports-modules-cw-3.4-precise-generic" is now available so updates should be automatic when upgrading the kernel.

Thank you guys !

#lspci -v
04:00.0 Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 10)
 Subsystem: ASUSTeK Computer Inc. Device 1477
 Flags: bus master, fast devsel, latency 0, IRQ 44
 Memory at f7800000 (64-bit, non-prefetchable) [size=256K]
 I/O ports at d000 [size=128]
 Capabilities: <access denied>
 Kernel driver in use: alx
 Kernel modules: alx

Michael Steger (m-steger) wrote :

@sami,
you are right linux-backports-modules-cw-3.4-3.2.0-30-generic is not installed. Thank you!

Changed in linux (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-2
tags: removed: rls-q-incoming
Hunter Smith (huntersmi) wrote :

Been trying to follow how this has been made available, I saw the backports module. But it sounds like if you upgrade the kernel it breaks the driver and you have to reinstall it again. Has this been added to the Kernel for Ubuntu 12.04 or will it be added to the next kernel update?

12.04 is our new standard for our development team and I've got 5 new computers that I'm deploying that have the AR8161 in them and it would be awesome if I could just pop in a live CD for 12.04 and the ethernet card would work instead of having to set it up via wireless and then installing the driver by hand (our developers need more power, hence the new machines).

Would also be very helpful with a clonezilla image server for creating images of new windows machines that have these cards since we've got a couple of desktops and laptops that we can't make images of and that's the NIC they are being shipped with.

My answers below, others may have better / newer information.

On Thu, Sep 13, 2012 at 7:29 AM, Hunter Smith <email address hidden> wrote:
> Been trying to follow how this has been made available, I saw the
> backports module. But it sounds like if you upgrade the kernel it breaks
> the driver and you have to reinstall it again. Has this been added to
> the Kernel for Ubuntu 12.04 or will it be added to the next kernel
> update?

It is not in the 12.04.1 distribution. The last time I spoke to my
daughters about updates, they had to re-do the installation from third
party sources after a kernel update (this is about one week ago).

>
> 12.04 is our new standard for our development team and I've got 5 new
> computers that I'm deploying that have the AR8161 in them and it would
> be awesome if I could just pop in a live CD for 12.04 and the ethernet
> card would work instead of having to set it up via wireless and then
> installing the driver by hand (our developers need more power, hence the
> new machines).

Hunter, based on my experience with my two daughters' Dells, you will
not realize what you hope, unless there is a 12.04.2 release that
fixes the problem.

You will either need to get the driver and a very brief install script
on a memory stick so that you can add the driver after the install,
and then re-run the script each time a new kernel arrives, or you will
have to find a newer kernel as per the suggestion of another recent
post.

> Would also be very helpful with a clonezilla image server for creating
> images of new windows machines that have these cards since we've got a
> couple of desktops and laptops that we can't make images of and that's
> the NIC they are being shipped with.

I can't help you there, sorry.
--
Chris Hermansen · <email address hidden>

C'est ma façon de parler.

I have an Asus N76VZ with an "Atheros Communications Inc. AR8161 Gigabit Ethernet".

I run in Precise (12.04.1 LTS) but with the latest kernel 3.5.0 from Quantal, for a better recent hardware support.

For Ethernet, I have to build the 'alx' driver manually from source of the compat-wireless project and it work at 1000 Mb/s.

I expect the standard inclusion of this driver for the final release.

Ara Pulido (apulido) wrote :

Any news on the status of this bug in Quantal?

Changed in linux (Ubuntu Quantal):
status: Confirmed → Incomplete
Eby (ebydavid) wrote :

Dear Sir, I am a novice in this field and I came to this forum since my Atheros Ethernet is not working. Sorry whatever you discuss is going above my head. What I want to tell is that Atheros is not supported in the latest version of the linux and the remedy u told of copying/installing files is very involved and is not working for me. So my doubt is whether u guys are trying to popularize ubuntu or trying to make it complicated. I sincerely hope that Ubuntu will surely fix this bug

Ara Pulido (apulido) wrote :

This is not a valid fix for certification. Reopening the Precise task

Changed in linux (Ubuntu Precise):
status: Fix Released → Confirmed
summary: - include the Atheros AR8131/AR8151/AR8152/AR8161/AR8162 Ethernet driver
+ integrate the Atheros AR8131/AR8151/AR8152/AR8161/AR8162 Ethernet driver
+ with Jockey

I just upgraded from 12.04 to 12.10beta2 on a Dell Vostro 3360 with a AR8161 chip. Under 12.04 I could install alx from compat-wireless, but in 12.10 there is no such package. Moreover, the module seems not to be built for the standard kernel.

This qualifies as a regression, no?

Aaron Whitehouse (luna-tick) wrote :

I also am using the 12.10 betas. I understand that the plan is for this to be integrated with Jockey by the time of the release, so that Jockey suggests the package and manages installation. Is the package/driver that will be used available anywhere for testing in advance of this Jockey integration? I'd be keen to try it out to ensure that this driver doesn't hit 12.10 untested.

James M. Leddy (jm-leddy) wrote :

Hi Aaron and Sagi,

We are fortunate in that 3.6 was released at the beginning of the month. We're currently putting together a compat-wireless based on the 3.6 kernel that will have the alx driver. We're going to have this available before 12.10 is officially released.

Tais Plougmann Hansen (taisph) wrote :

linux-backports-modules-cw-3.4-precise-generic works on our new HP Pavilion h8-1320eo with Ubuntu 12.04LTS.

$ lspci -v -s4:0.0
04:00.0 Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 08)
        Subsystem: Hewlett-Packard Company Device 2ad5
        Flags: bus master, fast devsel, latency 0, IRQ 46
        Memory at f6100000 (64-bit, non-prefetchable) [size=256K]
        I/O ports at d000 [size=128]
        Capabilities: <access denied>
        Kernel driver in use: alx
        Kernel modules: alx

red shaphiro (shaphiro) wrote :

I have installed kubuntu 12.10 and my AR8161 is not recognized by the current kernel. I have no internet connection in my laptop because also wireless card does not work. In order to compile alx driver I have to install build-essential etc.. but is too complicated (for me) without an internet connection. Can I download a compiled kernel with alx driver ? if yes, where?

red shaphiro (shaphiro) wrote :

Found the solution. Installed the package
linux-backports-modules-cw-3.6-3.5.0-17-generic_3.5.0-17.1_amd64.deb
the AR8161 works!

Anomaly (bertrand3000) wrote :

I confirm that AR8161 Gigabit (ALX driver) is still not working on Ubuntu 12.10. While I perfectly understand why it didn't work on 12.04 and that you had to compile the driver from sources, I really did not expected that it still would not work in 12.10.

I suppose I could install a package (like written just ahead)... if I had an Internet connection on that machine!

Tim Chen (ctf) wrote :

The bug still exists in Quantal installer.

Ara Pulido (apulido) on 2012-10-24
Changed in linux (Ubuntu Quantal):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Ara Pulido (apulido) on 2012-11-06
tags: added: raring
Changed in linux (Ubuntu Raring):
milestone: ubuntu-12.10-beta-2 → none
Bruce Kiacz (bruce-kiacz) wrote :

Have tried multiple solutions to get Ubuntu 12.10 wired Ethernet working with Atheros AR8161 on Hewlett Packard Pavillion Model P7-1240 without success.

todaioan (alan-ar06) on 2012-12-31
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
dotancohen (dotancohen) wrote :

This issue is becoming urgent. Every single budget motherboard available at the two large national computer chains where I live use these NICs. That is, Ubuntu will not work out of the box on any budget motherboard or prebuilt system from the large chains at the moment.

dotancohen (dotancohen) wrote :

The driver code is here:
http://www.linuxfoundation.org/collaborate/workgroups/networking/alx

The upstream kernel patch was rejected even though it works:
https://patchwork.kernel.org/patch/1376841/

James M. Leddy (jm-leddy) wrote :

Hi dotancohen,

If you or anyone else would like support for this hardware, please install the linux-backports-modules-cw-3.6 package. This bug is solely open for jockey integration at this point.

James M. Leddy (jm-leddy) wrote :

Qualcom is still having trouble getting this upstream:

https://lkml.org/lkml/2012/10/8/409

James M. Leddy (jm-leddy) wrote :

The only ones we definitely need this driver for are

1969:1091 - AR8161 Gigabit Ethernet
1969:1090 - AR8162 Fast Ethernet

because the others can be supported by the upstream atl1c drivers.

Chris Van Hoof (vanhoof) on 2013-01-15
Changed in linux (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-2 → quantal-updates
Changed in linux (Ubuntu Precise):
assignee: James M. Leddy (jm-leddy) → Alberto Milone (albertomilone)
Changed in linux (Ubuntu Quantal):
assignee: James M. Leddy (jm-leddy) → Alberto Milone (albertomilone)
Changed in linux (Ubuntu Raring):
assignee: James M. Leddy (jm-leddy) → Alberto Milone (albertomilone)
Changed in linux (Ubuntu Oneiric):
assignee: James M. Leddy (jm-leddy) → Alberto Milone (albertomilone)
Jaime Cruz (jaime-cruz) wrote :

Wow... just installed the latest batch of updates via the updater. It LOOKED like it included the correct modules, but after the reboot I had NO networking. Normally I at least had the wireless, but that was knocked out too. Good thing I had the old drivers sitting in my Home folder and was able to reinstall the old version!!

Tim Chen (ctf) wrote :

@Jaime Cruz:
Can you try to install linux-image-extra package according to your updated kernel version as well? It should fix your wifi problem.

Jaime Cruz (jaime-cruz) wrote :

Tim, I looked in the "Software Center" and all of the entries for "linux-image-extra" imply they are for virtual guests, not the hosting system. Is there someplace else I should be looking? I don't want to hose my system so I want to be ABSOLUTELY sure before I do anything. Thanks.

Stefano Lenzi (kismet-sl) wrote :

I have just download ubuntu 12.10 for amd64 and the installer does not contain the driver for
1969:1091 - AR8161 Gigabit Ethernet

I will add an extra NIC just for downloading the linux-image-extra , but I believe that we should provide a working Installer considering that the hardware is quite common.

summary: - integrate the Atheros AR8131/AR8151/AR8152/AR8161/AR8162 Ethernet driver
- with Jockey
+ integrate Linux Backports Modules with Jockey

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-24.37). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Dmitriy Nikitin (brain2dump) wrote :

I tested on kernel 3.5.0-24.37 with linux-backports-modules-cw-3.6-3.5.0-24-generic_3.5.0-24.10_amd64.
AR8161 don't work (Asus P8Z77-V LE motherboard)

Zygmunt Krynicki (zkrynicki) wrote :

This configuration file for pm-utils adds a workaround for the alx module to work after suspend/resume.

Chris Van Hoof (vanhoof) wrote :

Based on our testing with the driver in the 3.5.0-24.37 kernel on local hardware we have validated that the device itself is functional.

It does appear that the driver does have an issue when entering S3 which should be addressed in a new bug I'll file.

Dmitriy -- As for the failure in Comment #52 you posted, lets file a separate bug with more details if you're able to reproduce this without linux-backport-modules-cw installed as the alx driver is in the kernel proper.

tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Download full text (28.9 KiB)

This bug was fixed in the package linux - 3.5.0-24.37

---------------
linux (3.5.0-24.37) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1117492

  [ Tim Gardner ]

  * [Config] CONFIG_ALX=m for x86 only
    - LP: #927782

linux (3.5.0-24.36) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1116501

  [ Adam Lee ]

  * [Config] Enable RTSX_PCI modules
    - LP: #1057089

  [ Andy Whitcroft ]

  * [Config] enable various HVC consoles
    - LP: #1102206

  [ Brad Figg ]

  * Revert "SAUCE: samsung-laptop: disable in UEFI mode"
    - LP: #1111689

  [ Herton Ronaldo Krzesinski ]

  * [Config] updateconfigs for 3.5.7.3 stable update
  * d-i: Add mellanox ethernet drivers to nic-modules
    - LP: #1015339

  [ Kamal Mostafa ]

  * SAUCE: alx driver import script
    - LP: #927782

  [ Qualcomm Atheros, Inc ]

  * SAUCE: alx: Update to heads/master
    - LP: #927782

  [ Seth Forshee ]

  * SAUCE: samsung-laptop: Add quirk for broken acpi_video backlight on
    N250P
    - LP: #1086921

  [ Stefan Bader ]

  * (config) Move 9p modules into generic package
    - LP: #1107658

  [ Tim Gardner ]

  * [debian] Remove dangling symlink from headers package
    - LP: #1112442
  * [config] CONFIG_ALX=m
    - LP: #927782
  * [Config] Add alx to d-i nic-modules
    - LP: #927782

  [ Upstream Kernel Changes ]

  * Revert "8139cp: revert "set ring address before enabling receiver""
    - LP: #1102417
  * Revert "ath9k_hw: Update AR9003 high_power tx gain table"
    - LP: #1102417
  * Revert "drm/i915: no lvds quirk for Zotac ZDBOX SD ID12/ID13"
    - LP: #1102417
  * Revert "ALSA: hda - Shut up pins at power-saving mode with Conexnat
    codecs"
    - LP: #1106966, #886975
  * be2net: don't call vid_config() when there's no vlan config
    - LP: #1083088
  * be2net: cleanup be_vid_config()
    - LP: #1083088
  * be2net: do not modify PCI MaxReadReq size
    - LP: #1083088
  * be2net: fix reporting number of actual rx queues
    - LP: #1083088
  * be2net: do not use SCRATCHPAD register
    - LP: #1083088
  * be2net: Fix driver load for VFs for Lancer
    - LP: #1083088
  * be2net: Explicitly clear the reserved field in the Tx Descriptor
    - LP: #1083088
  * be2net: Regression bug wherein VFs creation broken for multiple cards.
    - LP: #1083088
  * be2net: Fix to trim skb for padded vlan packets to workaround an ASIC
    Bug
    - LP: #1083088
  * be2net: Fix Endian
    - LP: #1083088
  * be2net: Fix error while toggling autoneg of pause parameters
    - LP: #1083088
  * be2net : Fix die temperature stat for Lancer
    - LP: #1083088
  * be2net: Fix initialization sequence for Lancer
    - LP: #1083088
  * be2net: Activate new FW after FW download for Lancer
    - LP: #1083088
  * be2net: Fix cleanup path when EQ creation fails
    - LP: #1083088
  * be2net: Enable RSS UDP hashing for Lancer and Skyhawk
    - LP: #1083088
  * be2net: dont pull too much data in skb linear part
    - LP: #1083088
  * be2net: Fix VF driver load for Lancer
    - LP: #1083088
  * be2net: Ignore physical link async event for Lancer
    - LP: #1083088
  * be2net: Fix to parse RSS hash from Receive compl...

Changed in linux (Ubuntu Quantal):
status: Confirmed → Fix Released
Jaime Cruz (jaime-cruz) wrote :

Just updated with the latest from software updates and STILL lost network connectivity. Had to install the drivers again manually. What's going on??

Tim Chen (timchen119) wrote :

Confirmed here with AR8161 [1969:1091] too.
It keep dumping alx register message (see attached file) on console and ethernet can't connected with 3.5.0-24-generic kernel (lts-quantal) kernel on ubuntu 12.04.02.

AceLan Kao (acelankao) wrote :

For 3.5.0-24 kernel, we need linux-backports-modules-cw-3.6-3.5.0-24-generic to active the AR8161 device.

summary: - integrate Linux Backports Modules with Jockey
+ Include experimental alx driver in the quantal kernel
O. Emmerson (oemmerson) wrote :

Hello, will this driver be in 13.04 at install time? I have a card with the AR8162 chipset and no ethernet out of the box.

Cheers

Anthony Wong (anthonywong) wrote :

oemmerson, it's already in 3.8.0-13.22 raring kernel.

O. Emmerson (oemmerson) wrote :

Great, thanks!

James M. Leddy (jm-leddy) wrote :

The comments in #58 and #59 should be fixed by bug 1154238.

James M. Leddy (jm-leddy) wrote :

Also if anyone here can verify bug 1154238 fixes the problem in quantal, please test.

Bernardo Reino (reinob) wrote :

@jm-leddy,

I can verify that the alx module included in 3.5.0-24.37 (linux-lts-quantal) does NOT work, at least on 12.04.02. Installing alx again from sources makes it work.

I see that bug 1154238 is only for Quantal and Raring and the fix is in kernel 3.8.0-13.22 (raring). I might try that kernel on precise (but then I'm sure my WLAN will be busted), but I guess bug 1154238 should also be linked to precise (I'll see if I can do that..)

Anthony Wong (anthonywong) wrote :

Bernardo, have you tested 3.5.0-27.46 or above on 12.04.2? Bug 1154238 also fixes the linux-lts-quantal on Precise.

Bernardo Reino (reinob) wrote :

I just installed 3.5.0-27.46 on 12.04.02 yesterday evening. ALX module loaded fine (and 1154238 looks very promising), but I didn't actually plug the Ethernet cable (I normally use only WLAN). Will try to do that this evening and report back!

Bernardo Reino (reinob) wrote :

Follow up from #67 in response to #66.

Upgrading from 3.5.0-26 to 3.5.0-27 does NOT resolve the problem. ALX module is loaded OK, but plugging network cable is silently ignored (no dmesg activity, NM doesn't seem to notice anything).

After rmmod alx && modprobe alx the module is reloaded and dumps lots of garbage on dmesg. Network cable is detected but no packets go out or in.

Workaround is to:
# rm /lib/modules/3.5.0-27-generic/kernel/ubuntu/alx/alx.ko

then compile alx.ko from compat-wireless (I use 3.6.8-1-snpc) and make install. This puts alx.ko in /lib/modules/3.5.0-27-generic/update/drivers/net/ethernet/atheros/alx/alx.ko

After rebooting alx module works perfectly.

Given that the Ubuntu-provided alx module is so broken I suggest you remove it with a new kernel update, then fix it, TEST IT, and then include it in a future kernel version.

Changed in linux (Ubuntu Precise):
status: Confirmed → Won't Fix
Changed in linux (Ubuntu Raring):
status: Confirmed → Fix Released
status: Fix Released → Triaged
status: Triaged → In Progress
AceLan Kao (acelankao) wrote :

I can confirm that the alx driver in quantal kernel is not working.
I trird to rmmod alx; modprobe alx; and got the below warning message,
and then alx driver keeps dumping messages

[ 176.573926] ------------[ cut here ]------------
[ 176.573945] WARNING: at /build/buildd/linux-lts-quantal-3.5.0/net/sched/sch_generic.c:255 dev_watchdog+0x272/0x280()
[ 176.573949] Hardware name:
[ 176.573954] NETDEV WATCHDOG: eth0 (alx): transmit queue 1 timed out
[ 176.573957] Modules linked in: alx snd_hda_codec_idt arc4 snd_hda_intel ath9k snd_hda_codec mac80211 snd_hwdep ath9k_common ath9k_hw snd_pcm kvm_amd fglrx(PO) snd_seq_midi snd_rawmidi kvm snd_seq_midi_event snd_seq parport_pc psmouse ath ppdev snd_timer rfcomm i2c_piix4 ghash_clmulni_intel lp serio_raw snd_seq_device aesni_intel amd_iommu_v2 dm_multipath joydev mdio k10temp bnep btusb(O) cryptd ath3k(O) cfg80211 snd bluetooth parport aes_x86_64 soundcore snd_page_alloc scsi_dh microcode mac_hid binfmt_misc usb_storage hid_generic dm_raid45 usbhid hid ahci libahci xor dm_mirror dm_region_hash dm_log btrfs zlib_deflate libcrc32c [last unloaded: alx]
[ 176.574062] Pid: 0, comm: swapper/3 Tainted: P O 3.5.0-28-generic #47~precise1-Ubuntu
[ 176.574067] Call Trace:
[ 176.574071] <IRQ> [<ffffffff81052c8f>] warn_slowpath_common+0x7f/0xc0
[ 176.574268] [<ffffffffa09796fa>] ? R6XXIsr_ProcessInterrupts+0x1fa/0x2b0 [fglrx]
[ 176.574277] [<ffffffff81052d86>] warn_slowpath_fmt+0x46/0x50
[ 176.574287] [<ffffffff8159e682>] dev_watchdog+0x272/0x280
[ 176.574296] [<ffffffff8101be03>] ? native_sched_clock+0x13/0x80
[ 176.574303] [<ffffffff8159e410>] ? pfifo_fast_dequeue+0xe0/0xe0
[ 176.574310] [<ffffffff8159e410>] ? pfifo_fast_dequeue+0xe0/0xe0
[ 176.574319] [<ffffffff81062e36>] call_timer_fn+0x46/0x160
[ 176.574327] [<ffffffff8159e410>] ? pfifo_fast_dequeue+0xe0/0xe0
[ 176.574334] [<ffffffff81064782>] run_timer_softirq+0x132/0x2a0
[ 176.574343] [<ffffffff810a4315>] ? ktime_get+0x65/0xe0
[ 176.574353] [<ffffffff8105ba48>] __do_softirq+0xa8/0x210
[ 176.574361] [<ffffffff810ab474>] ? tick_program_event+0x24/0x30
[ 176.574369] [<ffffffff816a665c>] call_softirq+0x1c/0x30
[ 176.574378] [<ffffffff81016245>] do_softirq+0x65/0xa0
[ 176.574385] [<ffffffff8105be2e>] irq_exit+0x8e/0xb0
[ 176.574392] [<ffffffff816a6fbe>] smp_apic_timer_interrupt+0x6e/0x99
[ 176.574401] [<ffffffff816a5d0a>] apic_timer_interrupt+0x6a/0x70
[ 176.574404] <EOI> [<ffffffff8101be79>] ? sched_clock+0x9/0x10
[ 176.574418] [<ffffffff8103ff56>] ? native_safe_halt+0x6/0x10
[ 176.574426] [<ffffffff8101c993>] default_idle+0x53/0x1f0
[ 176.574433] [<ffffffff8101d8a9>] cpu_idle+0xd9/0x120
[ 176.574443] [<ffffffff8167983f>] start_secondary+0xc3/0xc5
[ 176.574449] ---[ end trace 7a951f4660a6c471 ]---

no longer affects: linux (Ubuntu Oneiric)
Changed in linux (Ubuntu Raring):
assignee: Alberto Milone (albertomilone) → nobody
James M. Leddy (jm-leddy) wrote :

Hi Acelan,

I've heard that the lbm for the alx driver (from compat-drivers) still works well. Would you please look into the difference between the drivers to see if we can fix the experimental driver in the ubuntu kernel?

Changed in linux (Ubuntu Raring):
assignee: nobody → AceLan Kao (acelankao)
Changed in linux (Ubuntu Quantal):
assignee: Alberto Milone (albertomilone) → AceLan Kao (acelankao)
Changed in linux (Ubuntu Precise):
assignee: Alberto Milone (albertomilone) → AceLan Kao (acelankao)
Changed in linux (Ubuntu Raring):
status: In Progress → Won't Fix
AceLan Kao (acelankao) wrote :

James,

I build the alx driver from
git://github.com/qca/alx.git
and the source code in that git tree and in ubuntu-precise are identical.
The latest commit of the alx driver is
f488842 alx: fix DMA-write-pending issue

Actually, there is one more commit in the qca git tree
8d41851 alx: revise self-test flag for external loopback
But, we don't need it to make eth0 work.

Bernardo Reino (reinob) wrote :

@AceLan Kao,

If I understand what you're saying, the alx module included with Ubuntu corresponds to the one from qca/alx, which itself is the same as mcgrof/alx plus 8d41851.

Now, I don't know if mcgrof/alx has ever worked on any machine, or if this is just some kind of work-in-progress not intended to be used. I really don't know.

What I *do* know is that the alx module from compat-wireless-3.6.8-1 (snpc), from http://wireless.kernel.org/en/users/Download/stable/#compat-wireless_3.6_stable_releases, works perfectly.

I count about 33 commits on mcgrof/alx, which I assume apply on top of the driver as found in compat-wireless. But I really don't know how the git module is related to the compat-wireless module.

In any case, since I suppose most users (at least I do) prefer a *working* module rather than a "bleeding edge" *non-working* module, I suggest you include the alx module from compat-wireless 3.6.8-1 in the Ubuntu kernel.

AceLan Kao (acelankao) wrote :

Bernardo,

I compared the alx driver in compat-wireless-3.6.8-1 and in qca/alx git tree, and found there are huge difference.
And the driver I built from qca/alt git tree works well for me, but the one from ubuntu kernel is crappy.
The source code should be identical.
I'll spend some time today to see if I can find any clue.

BTW, I'm not working on alx driver incorporation, Kamal is the man on bug 1154238.
We probably should assign this bug to him. :p

AceLan Kao (acelankao) wrote :

Bernardo,

Could you try the kernel I built
http://people.canonical.com/~acelan/bugs/lp927782/

The kernel works well for me, and if this kernel also works for you,
then we can add just one more code to the ubuntu kernel to fix this issue.

Bernardo Reino (reinob) wrote :

AceLan,

Thank you for the explanation above (#73).

What I find puzzling is that according to #71 the source code in git (qca/alx) is identical to the one included in the Ubuntu kernel but the former works and the latter doesn't.

Anyway, I hope i can test your kernel at some point during this weekend. I'll report back, hopefully with some useful information :)

Bernardo Reino (reinob) wrote :

Very quickly: the kernel you posted above on #74 works like a charm!

Please integrate that into the official kernel as soon as possible. This way at least the AR8161/AR8162 problem will be gone forever :)

Thanks *a lot* AceLan!

AceLan Kao (acelankao) wrote :

Bernardo,

Thanks for respond so quickly, I'll submit SRU to the ubuntu kernel team soon.

Yang Kun (YK) (dayangkuncn) wrote :

@AceLan, great to see this is fixed. thanks !

Bernardo Reino (reinob) wrote :

AceLan Kao,

Just an update: I see that 3.5.0-28 is now in precise-proposed. Is that the same "28" as the one you linked above? (post #74), http://people.canonical.com/~acelan/bugs/lp927782/.

I'm afraid to "update" my 28 with the "new" 28 :)

Furthermore, I have also installed the linux-generic-lts-raring kernel (3.8.0-19). Unfortunately that one includes the buggy alx module. It seems that every package version for every ubuntu version needs to be patched again and again (at least bcmwl and alx are two notorious examples, both of which affect me).

Now: would it be possible to include the working alx module in the raring kernel? From what I can see this bug is a "Won't fix" for raring. Is there a reason why a non-working module is included in the raring kernel (where we now have a working module in the quantal kernel) _and_ somebody has decided that this is fine?

I hereby request a working alx module for the raring kernel! :)

AceLan Kao (acelankao) wrote :

From the build log, the patch goes in 3.5.0-28.49 kernel, and the patch is applied to raring kernel as well.
So, you probably have to wait the next proposed kernel.
The launchpad bot will update the bug status when the proposed kernel is available,
so you will know when you can have a kernel with a fixed alx driver.

linux (3.5.0-28.49~pre201304260400) quantal; urgency=low

  [ AceLan Kao ]

  * SAUCE: (no-up) alx: disables MSI generation
    - LP: #927782

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring

works fine with a Dell Inspiron One 27

dmesg | grep alx
[ 8.289763] alx 0000:05:00.0: enabling device (0000 -> 0002)
[ 8.300686] alx 0000:05:00.0: alx(5c:f9:dd:eX:bX:5X): Qualcomm
Atheros Ethernet Network Connection
[ 13.675283] alx 0000:05:00.0: irq 54 for MSI/MSI-X
[ 13.675289] alx 0000:05:00.0: irq 55 for MSI/MSI-X
[ 13.675293] alx 0000:05:00.0: irq 56 for MSI/MSI-X
[ 13.675297] alx 0000:05:00.0: irq 57 for MSI/MSI-X
[ 13.675301] alx 0000:05:00.0: irq 58 for MSI/MSI-X
[ 13.676314] alx 0000:05:00.0 eth0: NIC Link Up: 1 Gbps Full

Am 08.05.2013 15:41, schrieb Brad Figg:
> This bug is awaiting verification that the kernel in -proposed solves
> the problem. Please test the kernel and update this bug with the
> results. If the problem is solved, change the tag 'verification-needed'
> to 'verification-done'.
>
> If verification is not done by one week from today, this fix will be
> dropped from the source code, and this bug will be closed.
>
> See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
> to enable and use -proposed. Thank you!
>
>
> ** Tags added: verification-needed-raring
>

AceLan Kao (acelankao) on 2013-05-09
tags: added: verification-done-raring
removed: verification-needed-raring
Rubeosis (faspie) wrote :

I am sorry, after update of 15. Mai 2013 alx driver does not work anymore. This is critical! Even a reinstall of the whole OS does not solve the problem. Here is my dmesg output.

Please help!

AceLan Kao (acelankao) wrote :

Rubeosis,
Sorry, I didn't see which kernel you are using.
I'm a little confused, you say the driver works in comment #82, but why it becomes not working in comment #84?
Could you explain more?
Thanks.

Rubeosis (faspie) wrote :

Am 16.05.2013 11:34, schrieb AceLan Kao:
> Rubeosis,
> Sorry, I didn't see which kernel you are using.
> I'm a little confused, you say the driver works in comment #82, but why it becomes not working in comment #84?
> Could you explain more?
> Thanks.
>
Kernel is 3.8.0-21-generic

I guess yesterday a proposed-update of the kernel was published.

In the time before alx driver worked properly

AceLan Kao (acelankao) wrote :

Rubeosis,
I checked the changelog and found that the patch had been in 3.8.0-20.31 kernel.

Could you help me to verify it again?
I copy the alx driver from raring kernel and change the Makefile and add dkms.conf file in it.
1. remove the compat-drivers you have installed
2. sudo cp -a alx-1.0 /usr/src
3. sudo dkms add -m alx -v 1.0
4. sudo dkms install -m alx -v 1.0
5. reboot and try to see if the driver works

6. you can safely remove it by
   sudo dkms remove -m alx -v 1.0 --all

If the alx-1.0 dkms works for you, then the 3.8.0-21 kernel should work for you as well. In this case, please help me to re-check again if the alx driver in 3.8 kernel really doesn't work.
If the alx-1.0 dkms doesn't work, then we have to patch the driver in ubuntu kernel again.

Anyway, thanks for your help and report the status.

Stefano Pecchenino (pekke) wrote :

I test with 3.8.0.22 Kernel (13.04 RARING) and the problem is still here...

AceLan Kao (acelankao) wrote :

Stefano,
Could you try the driver I attached on comment #87?
Thanks.

AceLan Kao (acelankao) wrote :

Hi all,
I just confirm the problem and found there is a new patch that broken the alx driver.
You can use the alx-2.0 dkms package before the kernel team release a new kernel.

AceLan Kao (acelankao) wrote :

I just checked the latest quantal proposed kernel 3.5.0-31, and it works.
And the latest released kernel 3.5.0-29.49 works as well.
But 3.5.0-30 doesn't work.
So, I think the kernel team has fixed the problem which introduced from 3.5.0-30.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Rifester (rife-mark) wrote :

Acelankao. Thank you so much for posting the kernel download in comment #74! I installed this kernel in 12.04 and it loaded the ALX driver. No more recomiling every time there is a kernel update! Thank you!

Po-Hsu Lin (cypressyew) on 2013-06-06
Changed in linux (Ubuntu Precise):
status: Won't Fix → Confirmed
status: Confirmed → Won't Fix
AceLan Kao (acelankao) on 2013-06-13
Changed in linux (Ubuntu Raring):
status: Won't Fix → Fix Released
Changed in hwe-next:
status: New → Fix Released
assignee: nobody → AceLan Kao (acelankao)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.