Ubuntu

The new (2.6.39+) samsung_laptop kernel module causes serious backlight flickering - makes the desktop unusable - part 2

Reported by papukaija on 2012-01-21
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

This bug is fixed in upstream's Linux 3.4.0-030400-generic-pae

dmesg | grep samsung
[ 19.490347] samsung_laptop: detected SABI interface: SwSmi@
[ 19.490358] samsung_laptop: Backlight controlled by ACPI video driver

--> No flickering!
-------
This is a continuation from bug 810093 but I'm using Samsung NC10. The backlight of the laptop often starts flickering (switching very fast between darkest and brightest) when gnome tries to reduce the screen brightness (automatically after some time) to save power.

This bug is caused by the new samsung_laptop kernel module which was introduced in kernel 2.6.39. I've found some documentation for it at github [1]. If the module is enabled, the flickering starts quite soon after desktop load and can be stopped by changing the baclight brigtness. However, the only available modes are 0%, 10%(estimate) and 100%. The two lowest values are too dark for my eyes and the full backlight uses too much battery power.

The main difference from bug 810093 is that this issue doesn't occur on every boot but maybe on 80% of boots.

-----------------------
WORKAROUND:

Disable the kernel module by adding:

blacklist samsung_laptop

to : /etc/modprobe.d/blacklist.conf

OR use the upstream v3.4. kernel (Precise only), please note that they're unsupported:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/

OR use Voria's patch/PPA (links in the above mentioned bug).

[1] https://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=2d70b73ae5b85c9d13f5dfbb8fc4fd5edae633dc

-----------------
ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image-3.0.0-15-generic 3.0.0-15.25
ProcVersionSignature: Ubuntu 3.0.0-15.25-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 1.23-0ubuntu4
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: user 1581 F.... pulseaudio
CRDA: Error: [Errno 2] Tiedostoa tai hakemistoa ei ole
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0340000 irq 43'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,144dca00,00100001'
   Controls : 19
   Simple ctrls : 11
Date: Sat Jan 21 18:35:12 2012
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=77010f3d-b94c-4718-8f0c-0324ea5ad852
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
MachineType: SAMSUNG ELECTRONICS CO., LTD. NC10
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-15-generic root=UUID=af51795b-87a7-4268-b370-05a38dffd4b6 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-15-generic N/A
 linux-backports-modules-3.0.0-15-generic N/A
 linux-firmware 1.60
SourcePackage: linux
UpgradeStatus: Upgraded to oneiric on 2011-10-01 (112 days ago)
dmi.bios.date: 09/08/2009
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 11CA.M015.20090908.RHU
dmi.board.name: NC10
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr11CA.M015.20090908.RHU:bd09/08/2009:svnSAMSUNGELECTRONICSCO.,LTD.:pnNC10:pvrNotApplicable:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNC10:rvrNotApplicable:cvnSAMSUNGELECTRONICSCO.,LTD.:ct10:cvrN/A:
dmi.product.name: NC10
dmi.product.version: Not Applicable
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

papukaija (papukaija) wrote :
description: updated
Brad Figg (brad-figg) on 2012-01-21
Changed in linux (Ubuntu):
status: New → Confirmed
papukaija (papukaija) on 2012-03-09
tags: added: precise

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.28
papukaija (papukaija) wrote :

Still an issue with 3.2.0-18-generic #28-Ubuntu SMP Fri Mar 2 20:05:41 UTC 2012 i686 i686 i386 GNU/Linux.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
papukaija (papukaija) wrote :

@Fortunato: Do your patches have any NC10 specific fixes?

description: updated

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.2.0-18.29
papukaija (papukaija) on 2012-03-12
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Fortunato Ventre (voria) wrote :

@papukaija:
no, the 'samsung-laptop' package available on my PPA has no specific fixes for NC10.
It's built from the latest sources taken from iksaif's git repository:

https://github.com/iksaif/samsung-laptop-dkms

Since iksaif is now the maintainer of the samsung-laptop module, his changes will eventually end up in the upstream kernel sources.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.3 kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc7-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
papukaija (papukaija) wrote :

The flickering started few mins after desktop load and the available brightness modes were 0%,10% and 100%.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
PulsatingQuasar (rkomduur) wrote :

I just added a new bug report about the backlight issue on my Samsung NC10 to get some attention. After all this time this issue should finally be fixed.

papukaija (papukaija) wrote :

This bug is now reported to upstream.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Benjamin Kerensa (bkerensa) wrote :

Removed bitesize tag since it has not been demonstrated that this is bitesize in nature.

tags: removed: bitesize
chud (richud.com) wrote :

still problem with 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:41:14 UTC 2012 i686 i686 i386 GNU/Linux

Kevin McCaughey (ohforfs) wrote :

As of AUGUST 2012 and after 6 months, this is still a bug and has not been patched.

This means that Ubuntu 12.04 FAILS on the Samsung NC10, an extremely popular netbook which has millions of users.

If Ubuntu want non-technical users to switch to their operating system then show-stopping fatal bugs like this need to be patched.

Leandro (leandromartinez98) wrote :

This bug also affect Samsung Ultrabooks (Ultrabook Samsung 530U3BAD1). I'm using Lucid Lynx up-to-date.

The PPA suggested above appears to have fixed the issue.

papukaija (papukaija) on 2012-09-03
tags: added: kernel-fixed-upstream kernel-fixed-upstream-3.4.0-030400
removed: kernel-bug-exists-upstream
description: updated
Changed in linux:
status: Confirmed → Fix Released
Leandro (leandromartinez98) wrote :

Correction from my previous post, the PPA does NOT fixed the issue. It comes and goes randomly.

papukaija (papukaija) wrote :

I noticed that too but the upstream kernel works well.

description: updated
papukaija (papukaija) wrote :

Btw, I haven't tested but the Ubuntu part of this bug should be fixed in Quantal unless an other commit has broken it.

papukaija (papukaija) wrote :

This bug is fixed in Raring. It should be fixed in Quantal too but I didn't use Quantal that much so I'm not certain that it's fixed there too.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.