Ubuntu

0489:e027 Bluetooth adapter Foxconn/Hon Hai not working

Reported by Paolo Stivanin on 2011-12-01
112
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Tim Gardner
Precise
Undecided
Tim Gardner
Quantal
Undecided
Tim Gardner
Raring
Medium
Unassigned

Bug Description

I've search *a lot* online and i've found that this is a kernel problem!
I have a Sony Vaio VPCEH and my internal bluetooth adapter is showing on "lsusb" as 0489:e027 Foxconn / Hon Hai but:
hcitool dev
show *no* devices and also if i start the bluetooth wizard it stays into "finding devices" 4ever.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: linux-image (not installed)
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: pol 1954 F.... pulseaudio
CRDA: Error: [Errno 2] File o directory non esistente
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xd2600000 irq 43'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,104d5a00,00100000 HDA:80862805,104d5a00,00100000'
   Controls : 20
   Simple ctrls : 11
Date: Thu Dec 1 22:33:51 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20111001)
MachineType: Sony Corporation VPCEH1S0E
ProcEnviron:
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=8815488f-2af7-4fb0-88bd-f8ead751d450 ro quiet splash acpi_osi=Linux vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-14-generic N/A
 linux-backports-modules-3.0.0-14-generic N/A
 linux-firmware 1.60
SourcePackage: linux
StagingDrivers: rts_pstor mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/28/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: R0180Z9
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnINSYDE:bvrR0180Z9:bd04/28/2011:svnSonyCorporation:pnVPCEH1S0E:pvrC105UWGM:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCEH1S0E
dmi.product.version: C105UWGM
dmi.sys.vendor: Sony Corporation

Paolo Stivanin (polslinux) wrote :
Brad Figg (brad-figg) on 2011-12-01
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest v3.2-rcN kernel (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.2-rc1 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.2-rc1'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'. If you believe this bug does not require upstream testing, please add the tag: 'kernel-upstream-testing-not-needed'.

Thanks in advance.

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Paolo Stivanin (polslinux) wrote :

Hello, i've tested the lastest kernel (3.2.0-030200rc4-generic_3.2.0-030200rc4.201112012035_amd64.deb) on Ubuntu 11.10 + i've tried Ubuntu 12.04 (Precise Pangolin with kernel 3.2.0.2.2) and both still have the issue :(

tags: removed: needs-upstream-testing
tags: added: kernel-bug-exists-upstream
Paolo Stivanin (polslinux) wrote :

This is a different adapter:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/714862

and also this is a different adapter:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/841673

i've searched in all of existent GNU/Linux forum and i've found some tech discussion that said this is a kernel problem because it doesn't recognized the adapter! :(

Pep (pepsi-farkas-peter) wrote :

Exactly the same to me. (Sony Vaio VPCEH notebook too).

It took me some hours to find nothing about this syndrome. It was even hard to find this bug.
I think we should put "bluetooth", "device not found" and maybe "sony vpceh" in the name of bug. Would you mind?

Dear developers: please let me know if you need me to share some logs or any other info. The lack of bluetooth makes my machine a bit like a medieval one :)

Thanks for your help! Best Regards!

Pep (pepsi-farkas-peter) wrote :

Seems to have the same issue at this bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/863051

iuiz (tim-2342) wrote :

I also have this bug on a Acer TimelineX 4830TG.

Pep (pepsi-farkas-peter) wrote :

In my last comment I refered to another bug.
Now I know that this bug is for a different HW.
Sorry for my inattention.

Same bug affecting me, Acer Aspire TimelineX 5830TG

Paolo Stivanin (polslinux) wrote :

So...there's a chance to have this fixed? :)

papukaija (papukaija) wrote :

Please be patient.

summary: - bluetooth adapter 0489:e027 Foxconn / Hon Hai
+ Bluetooth adapter 0489:e027 Foxconn/Hon Hai not working

I have the same symptoms too - Sony VPCF22

Mark Baas (mark-baas123) wrote :

After some research, I suspect that this device is actually an Atheros (?3012) device which should be supported by the ath3k driver. So I added the device to the btusb.c blacklist and enabled it in ath3k.c. However the ath3k driver loads with the error: Bluetooth:
Error in firmware loading err = -110,len = 0, size = 4096
ath3k: probe of 1-1.6:1.0 failed with error -110

Maybe someone can provide some more insights.

smiki (micouk) wrote :

This bluetooth device is also in some Acer Aspire One D257 netbooks. It report via lsusb as "0489:e03c Foxconn / Hon Hai"
And the documentation and also the sticker of the module says "Atheros AR5BBU22". So it definitely is an Atheros chip.

I have the same problem with my Sony VPCEH2Z1E/B. Using device manager of windows on my dual boot system I see that this device is an Aetheros AR 3011 on my laptop that should be supported by ath3k. May be it is a new derivate of this chip.

Oh, I should mention that first starting windows, activating bluetooth there and then restarting my laptop to linux the chip works well without ath3k loaded.

Mark Baas (mark-baas123) wrote :

The issue is actually already resolved however the patch is afaik not accepted upstream yet. The problem is that this device should be loaded with the ath3k. Here is the diff (you may need to adjust it for newer versions):

diff --git a/drivers/bluetooth/ath3k.c b/drivers/bluetooth/ath3k.c
index 57fd867..aba22b2 100644
--- a/drivers/bluetooth/ath3k.c
+++ b/drivers/bluetooth/ath3k.c
@@ -81,6 +81,9 @@ static struct usb_device_id ath3k_table[] = {
        /* Atheros AR5BBU12 with sflash firmware */
        { USB_DEVICE(0x0489, 0xE02C) },

+ /* Atheros AR5BBU22 with sflash firmware */
+ { USB_DEVICE(0x0489, 0xE03C) },
+
        { } /* Terminating entry */
 };

@@ -99,6 +102,9 @@ static struct usb_device_id ath3k_blist_tbl[] = {
        { USB_DEVICE(0x13d3, 0x3362), .driver_info = BTUSB_ATH3012 },
        { USB_DEVICE(0x0cf3, 0xe004), .driver_info = BTUSB_ATH3012 },

+ /* Atheros AR5BBU22 with sflash firmware */
+ { USB_DEVICE(0x0489, 0xE03C), .driver_info = BTUSB_ATH3012 },
+
        { } /* Terminating entry */
 };

diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
index de17121..cb480f1 100644
--- a/drivers/bluetooth/btusb.c
+++ b/drivers/bluetooth/btusb.c
@@ -143,6 +143,9 @@ static struct usb_device_id blacklist_table[] = {
        /* Atheros AR5BBU12 with sflash firmware */
        { USB_DEVICE(0x0489, 0xe02c), .driver_info = BTUSB_IGNORE },

+ /* Atheros AR5BBU12 with sflash firmware */
+ { USB_DEVICE(0x0489, 0xe03c), .driver_info = BTUSB_ATH3012 },
+
        /* Broadcom BCM2035 */
        { USB_DEVICE(0x0a5c, 0x2035), .driver_info = BTUSB_WRONG_SCO_MTU },
        { USB_DEVICE(0x0a5c, 0x200a), .driver_info = BTUSB_WRONG_SCO_MTU },

Paolo Stivanin (polslinux) wrote :

So there's a chance to have this fixed into Ubuntu 12.10?
And now, on Ubuntu 12.04, how can I get this fixed for my 0489:e027 device?

I have Linux 3.4 .0-3 kernel installed, and the problem exists even there, although the patch was made for 3.2 already. Isn't there any workaround for us to fix it ourselves before it's done officially?

summary: - Bluetooth adapter 0489:e027 Foxconn/Hon Hai not working
+ 0489:e027 Bluetooth adapter Foxconn/Hon Hai not working
tags: added: precise
jascha (jaschak) wrote :

Bug still present with Quantal and Kernel 3.6-rc4

Actually, I experienced some improvement with Quantal, that is with Kernel 3.5 anyway. On Persistent USB install of Quantal Bluetooth was partially working. So I installed Kernel 3.5 on Precise and got the same result. I can send files from the computer to a device, but not the other way roung. I also can't browse the Bluetooth device.

I'm not sure about Quantal, but for Precise it's Kernel Linux 3.5.0-13-generic

holyg (thierry-fredrich) wrote :

Same issue on my Vaio VPCCA3S1E.

Same issue on Asus X53u with ubuntu 12.04 32b

Mark Baas (mark-baas123) wrote :

fixed in latest quantal (12.10)

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Paolo Stivanin (polslinux) wrote :

No, Ubuntu 12.10 amd64 the bug is still there with:

Bus 001 Device 004: ID 0489:e027 Foxconn / Hon Hai

Changed in linux (Ubuntu):
status: Fix Released → New
Brad Figg (brad-figg) on 2012-10-20
Changed in linux (Ubuntu):
status: New → Confirmed
Paolo Stivanin (polslinux) wrote :

Finally i was able to wrote a patch that will solve this problem :D :D

tags: added: patch

How are we supposed to apply this patch? How can it be used?

Paolo Stivanin (polslinux) wrote :

1) download the ubuntu's linux-source
2) go into the linux-source root
3) mv drivers/bluetooth/ath3k.c drivers/bluetooth/ath3k.c.orig
4) mv drivers/bluetooth/btusb.c drivers/bluetooth/btusb.c.orig
5) put the 2 patches into drivers/bluetooth/
6) cd drivers/bluetooth/
7) patch < 0489e027-ath3k.patch
8) patch < 0489e027-btsub.patch
9) cd ../../
10) make -C /lib/modules/$(uname -r)/build M=`pwd` drivers/bluetooth/ath3k.ko
11) make -C /lib/modules/$(uname -r)/build M=`pwd` drivers/bluetooth/btusb.ko
12) sudo cp drivers/bluetooth/ath3k.ko /lib/modules/$(uname -r)/kernel/drivers/bluetooth/
13) sudo cp drivers/bluetooth/btusb.ko /lib/modules/$(uname -r)/kernel/drivers/bluetooth/
14) if you don't have the ath3k and btusb already loaded put it into /etc/modules
15) reboot :D

ps: the only problem is that you have to 1) activate bluetooth 2) you have to do "sudo hciconfig hci0 up" before you can use it
ppss: i have test it with kernel 3.6 and it works :)

Grazie mille for the detailed explanation :) Much appreciated.

Emiliano (emiliano-perulli) wrote :

Will this patch be merged into the mainline official linux kernel or not?

acemi (sadeceeray) wrote :

@Paolo , How i know which linux-source should i download and where can i find it ?

Result of `apt-get source linux-source` :

Picking 'linux-meta' as source package instead of 'linux-source'
NOTICE: 'linux-meta' packaging is maintained in the 'Git' version control system at:
http://kernel.ubuntu.com/git-repos/ubuntu/ubuntu-precise-meta.git
Skipping already downloaded file 'linux-meta_3.2.0.32.35.dsc'
Skipping already downloaded file 'linux-meta_3.2.0.32.35.tar.gz'
Need to get 0 B of source archives.
Skipping unpack of already unpacked source in linux-meta-3.2.0.32.35

Paolo Stivanin (polslinux) wrote :

@tomak: you're welcome :) (''prego'' in italian ;) )
@acemi: you have to install linux-source-3.5.0 if you're on Quantal

acemi (sadeceeray) wrote :

@Paolo Stivanin,

I got error.
I'm using 12.10 (quantal) ,

1) i just download [linux_3.5.0.orig.tar.gz] from http://packages.ubuntu.com/quantal/linux-source-3.5.0
2) And then extract to ~/linux-3.5
3) After this, i follow this commands : http://paste.ubuntu.com/1348676/

acemi maybe it would be a better idea to take that topic to Ubuntu Forums or AskUbuntu. This thread here should be used only to discuss this particular bug report, whereas installing Linux kernel is not related to it.

Tim Gardner (timg-tpi) on 2012-12-03
Changed in linux (Ubuntu Oneiric):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Raring):
status: Confirmed → Fix Released
Tim Gardner (timg-tpi) on 2012-12-03
Changed in linux (Ubuntu Oneiric):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem (3.0.0-29.46). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-35.55). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-20.31). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Paolo Stivanin (polslinux) wrote :

verification-done-quantal

tags: added: verification-done-precise verification-done-quantal
removed: verification-needed-precise verification-needed-quantal
Paolo Stivanin (polslinux) wrote :

verification-done-precise

I'm still getting the same problem. I'm able to connect my phone to the computer and send files from my computer to the phone. I am not able to send files from my phone to my computer, or browse my phone from Bluetooth > Browse Files on Device.

I have Acer AS5830TG-6614 running Ubuntu Precise 12.04 and my kernel is 3.2.0-35.55. I wonder now if I installed the kernel right...

Luis Henriques (henrix) wrote :

Since this is an upstream cherry-pick, has already been verified in Precise and Quantal, and the patch is trivial (just adds USB IDs), I'm tagging it as verified in Oneiric as well.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Launchpad Janitor (janitor) wrote :
Download full text (7.4 KiB)

This bug was fixed in the package linux - 3.2.0-35.55

---------------
linux (3.2.0-35.55) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1086856

  [ Andy Whitcroft ]

  * Revert "SAUCE: ata_piix: add a disable_driver option"
    - LP: #1079084
  * Revert "SAUCE: ata_piix: defer disks to the Hyper-V drivers by default"
    - LP: #1079084
  * SAUCE: ata_piix: add a disable_driver option
    - LP: #1079084, #994870

  [ Upstream Kernel Changes ]

  * libata: add a host flag to ignore detected ATA devices
    - LP: #1079084
  * ata_piix: defer disks to the Hyper-V drivers by default
    - LP: #1079084, #929545, #942316

linux (3.2.0-35.54) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1086349

  [ Kees Cook ]

  * Revert "SAUCE: SECCOMP: audit: always report seccomp violations"
    - LP: #1079469

  [ Luis Henriques ]

  * SAUCE: SECCOMP: audit: fix build on archs without CONFIG_AUDITSYSCALL
    - LP: #1079469

  [ Upstream Kernel Changes ]

  * seccomp: forcing auditing of kill condition
    - LP: #1079469
  * Bluetooth: Avoid calling undefined smp_conn_security()
    - LP: #1081676
  * x86: Remove the ancient and deprecated disable_hlt() and enable_hlt()
    facility
    - LP: #1081676
  * drm/nouveau: silence modesetting spam on pre-gf8 chipsets
    - LP: #1081676
  * drm/nouveau: fix suspend/resume when in headless mode
    - LP: #1081676
  * drm/nouveau: headless mode by default if pci class != vga display
    - LP: #1081676
  * nfsd: add get_uint for u32's
    - LP: #1081676
  * ALSA: PCM: Fix some races at disconnection
    - LP: #1081676
  * ALSA: usb-audio: Fix races at disconnection
    - LP: #1081676
  * ALSA: usb-audio: Use rwsem for disconnect protection
    - LP: #1081676
  * ALSA: usb-audio: Fix races at disconnection in mixer_quirks.c
    - LP: #1081676
  * ALSA: Add a reference counter to card instance
    - LP: #1081676
  * ALSA: Avoid endless sleep after disconnect
    - LP: #1081676
  * drm/radeon: fix typo in evergreen_mc_resume()
    - LP: #1081676
  * USB: mos7840: remove unused variable
    - LP: #1081676
  * rtnetlink: Fix problem with buffer allocation
    - LP: #1081676
  * rtnetlink: fix rtnl_calcit() and rtnl_dump_ifinfo()
    - LP: #1081676
  * gpio-timberdale: fix a potential wrapping issue
    - LP: #1081676
  * cfg80211: fix antenna gain handling
    - LP: #1081676
  * drm/i915: fix overlay on i830M
    - LP: #1081676
  * drm/i915: fixup infoframe support for sdvo
    - LP: #1081676
  * drm/i915: clear the entire sdvo infoframe buffer
    - LP: #1081676
  * crypto: cryptd - disable softirqs in cryptd_queue_worker to prevent
    data corruption
    - LP: #1081676
  * ARM: at91: at91sam9g10: fix SOC type detection
    - LP: #1081676
  * ARM: at91/i2c: change id to let i2c-gpio work
    - LP: #1081676
  * mac80211: Only process mesh config header on frames that RA_MATCH
    - LP: #1081676
  * mac80211: don't inspect Sequence Control field on control frames
    - LP: #1081676
  * mac80211: fix SSID copy on IBSS JOIN
    - LP: #1081676
  * wireless: drop invalid mesh address extension frames
    - LP: #1081676
  * mac80211: check managem...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (24.2 KiB)

This bug was fixed in the package linux - 3.5.0-21.32

---------------
linux (3.5.0-21.32) quantal-proposed; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1088979
  * SAUCE: i915_hsw: move i915_hsw_enabled symbol to intel_ips
    - LP: #1087622

linux (3.5.0-20.31) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1086759

  [ Ben Widawsky ]

  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_WAIT_TIMEOUT
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define DRM_I915_GEM_CONTEXT_[CREATE,DESTROY]
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: add register read IOCTL
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define i915_execbuffer2_[set,get]_context_id
    - LP: #1085245

  [ Chris Wilson ]

  * SAUCE: i915_hsw: Include #define I915_GEM_PARAM_HAS_SEMAPHORES
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_SECURE_BATCHES
    - LP: #1085245

  [ Daniel Vetter ]

  * SAUCE: i915_hsw: drm/i915: call intel_enable_gtt
    - LP: #1085245
  * SAUCE: i915_hsw: drm: add helper to sort panels to the head of the
    connector list
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract dp link bw helpers
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract drm_dp_max_lane_count helper
    - LP: #1085245
  * SAUCE: i915_hsw: drm: dp helper: extract drm_dp_channel_eq_ok
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract helpers to compute new training values
    from sink request
    - LP: #1085245
  * SAUCE: i915_hsw: drm: dp helper: extract drm_dp_clock_recovery_ok
    - LP: #1085245

  [ Dave Airlie ]

  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_PRIME_VMAP_FLUSH
    - LP: #1085245

  [ Leann Ogasawara ]

  * SAUCE: i915_hsw: Provide an ubuntu/i915 driver for Haswell graphics
    - LP: #1085245
  * SAUCE: i915_hsw: Revert "drm: Make the .mode_fixup() operations mode
    argument a const pointer" for ubuntu/i915 driver
    - LP: #1085245
  * SAUCE: i915_hsw: Rename ubuntu/i915 driver i915_hsw
    - LP: #1085245
  * SAUCE: i915_hsw: Only support Haswell with ubuntu/i915 driver
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define DRM_I915_GEM_WAIT
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract dp link train delay functions from radeon
    - LP: #1085245
  * SAUCE: i915_hsw: drm/dp: Update DPCD defines
    - LP: #1085245
  * SAUCE: i915_hsw: Update intel_ips.h file location
    - LP: #1085245
  * SAUCE: i915_hsw: Provide updated drm_mm.h and drm_mm.c for ubuntu/i915
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Replace the array of pages with a
    scatterlist
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Replace the array of pages with a
    scatterlist
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Stop using AGP layer for GEN6+
    - LP: #1085245
  * SAUCE: i915_hsw: Add i915_hsw_gpu_*() calls for ubuntu/i915
    - LP: #1085245
  * i915_hsw: [Config] Enable CONFIG_DRM_I915_HSW=m
    - LP: #1085245

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: fix hsw_fdi_link_train "retry" code
    - LP: #1085245
  * SAUCE: drm/i915: reject modes the LPT FDI receiver can't handle
    - LP: #1085245
  * SAUCE: drm/i915: add support for mPHY destination on i...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package linux - 3.0.0-29.46

---------------
linux (3.0.0-29.46) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1086305

  [ Upstream Kernel Changes ]

  * ath9k: fix stale pointers potentially causing access to free'd skbs
    - LP: #1081645
  * rt2800: validate step value for temperature compensation
    - LP: #1081645
  * target: Don't return success from module_init() if setup fails
    - LP: #1081645
  * cfg80211: fix antenna gain handling
    - LP: #1081645
  * wireless: drop invalid mesh address extension frames
    - LP: #1081645
  * mac80211: don't inspect Sequence Control field on control frames
    - LP: #1081645
  * DRM/Radeon: Fix Load Detection on legacy primary DAC.
    - LP: #1081645
  * mac80211: check management frame header length
    - LP: #1081645
  * mac80211: fix SSID copy on IBSS JOIN
    - LP: #1081645
  * nfsv3: Make v3 mounts fail with ETIMEDOUTs instead EIO on mountd
    timeouts
    - LP: #1081645
  * nfs: Show original device name verbatim in /proc/*/mount{s,info}
    - LP: #1081645
  * NFSv4: nfs4_locku_done must release the sequence id
    - LP: #1081645
  * nfsd: add get_uint for u32's
    - LP: #1081645
  * NFS: fix bug in legacy DNS resolver.
    - LP: #1081645
  * NFS: Fix Oopses in nfs_lookup_revalidate and nfs4_lookup_revalidate
    - LP: #1081645
  * drm: restore open_count if drm_setup fails
    - LP: #1081645
  * hwmon: (w83627ehf) Force initial bank selection
    - LP: #1081645
  * ALSA: PCM: Fix some races at disconnection
    - LP: #1081645
  * ALSA: usb-audio: Fix races at disconnection
    - LP: #1081645
  * ALSA: usb-audio: Use rwsem for disconnect protection
    - LP: #1081645
  * ALSA: usb-audio: Fix races at disconnection in mixer_quirks.c
    - LP: #1081645
  * ALSA: Add a reference counter to card instance
    - LP: #1081645
  * ALSA: Avoid endless sleep after disconnect
    - LP: #1081645
  * sctp: fix call to SCTP_CMD_PROCESS_SACK in sctp_cmd_interpreter()
    - LP: #1081645
  * netlink: use kfree_rcu() in netlink_release()
    - LP: #1081645
  * tcp: fix FIONREAD/SIOCINQ
    - LP: #1081645
  * ipv6: Set default hoplimit as zero.
    - LP: #1081645
  * net: usb: Fix memory leak on Tx data path
    - LP: #1081645
  * l2tp: fix oops in l2tp_eth_create() error path
    - LP: #1081645
  * ipv6: send unsolicited neighbour advertisements to all-nodes
    - LP: #1081645
  * futex: Handle futex_pi OWNER_DIED take over correctly
    - LP: #1081645
  * drm/vmwgfx: Fix hibernation device reset
    - LP: #1081645
  * drm/i915: fixup infoframe support for sdvo
    - LP: #1081645
  * drm/i915: clear the entire sdvo infoframe buffer
    - LP: #1081645
  * USB: mos7840: remove unused variable
    - LP: #1081645
  * xfs: fix reading of wrapped log data
    - LP: #1081645
  * intel-iommu: Fix AB-BA lockdep report
    - LP: #1081645
  * ALSA: Fix card refcount unbalance
    - LP: #1081645
  * ALSA: usb-audio: Fix mutex deadlock at disconnection
    - LP: #1081645
  * Linux 3.0.52
    - LP: #1081645
  * mm: bugfix: set current->reclaim_state to NULL while returning from
    kswapd()
    - LP: #1083318
  * fanotify: fix missing break
    - LP: #...

Read more...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
ID (q-w-e-r-t545) wrote :

Not working.

lsusb
Bus 001 Device 004: ID 0489:e027 Foxconn / Hon Hai

uname -a
Linux eagle 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

hciconfig dev
Can't get device info: No such device

Paulo Costa (bonowax) wrote :

Hello all;

No game here either...

Sony Vaio VPCEH2Q1E

Bus 001 Device 004: ID 0489:e027 Foxconn / Hon Hai

Linux rapyuta 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:44:52 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux (but I have this idea that the previous kernel had this fixed)

dmesg : [ 24.127190] ath3k: probe of 1-1.5:1.0 failed with error -110

Pep (pepsi-farkas-peter) wrote :

For me it works now (Sony VPCEH 1Z1E). Thanks for the good job!

To post a comment you must log in.