ThinkPad Mini Dock Series 3 problem with Audio output

Bug #893611 reported by cdecker on 2011-11-22
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I'm having a rather strange problem with the audio jack on the docking station. Using the headphone jack the external speakers work fine. When no speakers are plugged in the integrated speakers work. But when I plug in the speakers into the docking jack the integrated speakers get muted, but no sound comes from the external speakers.

WORKAROUND: Add the line:
options snd-hda-intel model=thinkpad

to the end of:
/etc/modprobe.d/alsa-base.conf

then reboot.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-12-generic-pae 2.6.38-12.51
ProcVersionSignature: Ubuntu 2.6.38-12.51-generic-pae 2.6.38.8
Uname: Linux 2.6.38-12-generic-pae i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: cdecker 1921 F.... pulseaudio
 /dev/snd/pcmC0D0p: cdecker 1921 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf5220000 irq 43'
   Mixer name : 'Conexant CX20590'
   Components : 'HDA:14f1506e,17aa21ce,00100002 HDA:14f12c06,17aa2122,00100000'
   Controls : 8
   Simple ctrls : 5
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xf3000000 irq 17'
   Mixer name : 'Nvidia GPU 1c HDMI/DP'
   Components : 'HDA:10de001c,17aa21ce,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Nov 22 15:28:28 2011
HibernationDevice: RESUME=UUID=5389edd4-875d-4a10-ba2b-044dd1d0de0b
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: LENOVO 4180P39
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-12-generic-pae root=UUID=5b8b6cd8-211c-44fa-b9da-c40f9b888df4 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-12-generic-pae N/A
 linux-backports-modules-2.6.38-12-generic-pae N/A
 linux-firmware 1.52
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/29/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 83ET63WW (1.33 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4180P39
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr83ET63WW(1.33):bd07/29/2011:svnLENOVO:pn4180P39:pvrThinkPadT420:rvnLENOVO:rn4180P39:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4180P39
dmi.product.version: ThinkPad T420
dmi.sys.vendor: LENOVO

cdecker (cdecker) wrote :
affects: ubuntu → linux (Ubuntu)
Brad Figg (brad-figg) on 2011-11-22
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Do you know if this issue happened in previous version of Ubuntu, or is this a new issue?

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest v3.2-rcN kernel (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the others). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.2-rc1 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.2-rc1'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'. If you believe this bug does not require upstream testing, please add the tag: 'kernel-upstream-testing-not-needed'.

Thanks in advance.

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
cdecker (cdecker) wrote :

I have not tested this setup with another version of Ubuntu, so I don't know if it's a new bug.

This being natty I was also unable to test the 3.2 release candidates (I tried anyway but got into trouble for doing so...) so I have to flag this one as kernel-unable-to-test-upstream.

Will upgrade to oneiric to see if problem persists.

tags: added: kernel-unable-to-test-upstream
cdecker (cdecker) wrote :

Upgraded to oneiric, problem persists with new 3.2-rc2 kernel.

Had to downgrade again, so we're back to the status of the original bug post.

Same problem here (Thinkpad T420s; Oneiric; MiniDock 3). I can hear laptop-related buzz through the miniport jack, but no actual audio. Headphone jack on the laptop works fine.

Brian Powell (cbpmsu) wrote :

Had same problem on Thinkpad W520, Oneiric 64-bit, MiniDock 3 and found this post:
http://ubuntuforums.org/showthread.php?t=1043568

Adding the line 'options snd-hda-intel model=thinkpad' to the end of /etc/modprobe.d/alsa-base.conf then rebooting seemed to fix the problem for me.

cdecker (cdecker) wrote :

Worked like a charm. Is there a way to include thinkpad detection during installation and add the line if a thinkpad is detected? Would solve it for all future installs :-)

Syrus (syrus-nn+launchpad) wrote :

Thanks for pointing us to the workaround with 'options snd-hda-intel model=thinkpad'. Works perfectly for me too.

tags: added: kernel-sound
removed: audio
tags: added: oneiric
description: updated
Donjan Rodic (bryonak) wrote :

Same symptoms here, not sure if I should open a new report because I'm using a different dock.

OS: Ubuntu 12.04 amd64, 3.2.0-20
Hardware: Thinkpad X230 and Ultrabase Series 3

Plugging the headphone into the Thinkpad itself works, pulling it out has music coming from the Thinkpad's speakers, but plugging it into the Ultrabase correctly mutes the Thinkpad yet leads to no output (very slight static noises).

Adding the model=thinkpad line and rebooting doesn't change the situation. alsamixer offers two devices: HDA Intel PCH and ThinPad Console Audio Control. Changes on the former correspond to real audio changes, but the Console Audio Control only has one muted unchangeable "Console" mixer.

Donjan Rodic (bryonak) wrote :

Mistyped my kernel version there, it should be -30 of course.

Here's the report dealing with my particular problem:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1026953
So I guess my bug is unrelated here.

Stefan Freyr (stefan-freyr) wrote :

I'm having this same problem on my Lenovo T430 and Ultrabase Series 3.

OS: Kubuntu 12.10 beta 1 (also tested on 12.04 and it behaves the same).

The workaround mentioned above (adding the model=thinkpad line to alsa-base.conf) does _not_ work in this case.

Should there be a new bug or is this related enough to this one to keep it going?

David Henningsson (diwic) wrote :

@Stefan - and others,

This is something that needs to be fixed once per type of laptop, so this is essentially one bug per machine. Essentially, for every laptop, we need to add its ID to a table to support the docking station.

Looking at the upstream code, below are the machines currently supported, with ID number and well known name. If you have one of these, and it does not currently work, you can probably make it work by following this procedure: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

If it is not listed, please file a new bug (using the "ubuntu-bug alsa-driver" command, as this will automatically attach the relevant ID), then write a comment in this bug with a pointer to the new one. Thanks.

(conexant codec chip - old style)
 SND_PCI_QUIRK(0x17aa, 0x20f2, "Lenovo T400s", CXT5066_THINKPAD),
 SND_PCI_QUIRK(0x17aa, 0x21c5, "Thinkpad Edge 13", CXT5066_THINKPAD),
 SND_PCI_QUIRK(0x17aa, 0x21da, "Lenovo X220", CXT5066_THINKPAD),
 SND_PCI_QUIRK(0x17aa, 0x21db, "Lenovo X220-tablet", CXT5066_THINKPAD),

(conexant codec chip - new style)
 SND_PCI_QUIRK(0x17aa, 0x20f2, "Lenovo T400", CXT_PINCFG_LENOVO_TP410),
 SND_PCI_QUIRK(0x17aa, 0x215e, "Lenovo T410", CXT_PINCFG_LENOVO_TP410),
 SND_PCI_QUIRK(0x17aa, 0x215f, "Lenovo T510", CXT_PINCFG_LENOVO_TP410),
 SND_PCI_QUIRK(0x17aa, 0x21ce, "Lenovo T420", CXT_PINCFG_LENOVO_TP410),
 SND_PCI_QUIRK(0x17aa, 0x21cf, "Lenovo T520", CXT_PINCFG_LENOVO_TP410),

(realtek chip)
 SND_PCI_QUIRK(0x17aa, 0x21f6, "Thinkpad T530", ALC269_FIXUP_LENOVO_DOCK),
 SND_PCI_QUIRK(0x17aa, 0x21fa, "Thinkpad X230", ALC269_FIXUP_LENOVO_DOCK),
 SND_PCI_QUIRK(0x17aa, 0x21fb, "Thinkpad T430s", ALC269_FIXUP_LENOVO_DOCK),
 SND_PCI_QUIRK(0x17aa, 0x2203, "Thinkpad X230 Tablet", ALC269_FIXUP_LENOVO_DOCK),

Stefan Freyr (stefan-freyr) wrote :

Ok thanks.

Just one question. There are no packages for Quantal (12.10) on that download page that the wiki page points to. Any idea when to expect one or whether I should request that one be created (and if so, where do I do that then)?

Kind regards and thanks for your great work!
Stefan Freyr.

uo (uo-li) wrote :

Same as Stefan, I've filed the following bug:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1064497

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers