hpacucli does not find controllers on precise

Bug #890768 reported by Ralf Spenneberg on 2011-11-15
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

hpacucli is a HP commandline tool to configure hp smart array controllers online.
A amd64 package using i386 libraries can be found here http://downloads.linux.hp.com/SDR/psp/pool/non-free/

This binary works fine on 2.6 kernels but not on 3.1. Apparently the tool determines the kernel version and cannot cope with the 3.1 version.

Here you may find more information:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644362:#45
We might need some setarch functionality.

I can confirm that the process is looking for /dev/cciss/c0d0/cciss when stracing:
 strace -f hpacucli 2> log
Although I am not convinced that this is the problem.

Without this tool any changes to the array configuration requires a reboot and entering the bios !
---
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Nov 14 08:21 seq
 crw-rw---- 1 root audio 116, 33 Nov 14 08:21 timer
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 1.26-0ubuntu1
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=4c16ce47-6821-43ff-b03a-fefe6be857a0
IwConfig: Error: [Errno 2] No such file or directory
MachineType: HP ProLiant DL585 G2
Package: linux (not installed)
PciMultimedia:

ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.1.0-2-generic root=UUID=2701cb46-51c3-466e-bba3-91e90f2e6d3d ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
RelatedPackageVersions:
 linux-restricted-modules-3.1.0-2-generic N/A
 linux-backports-modules-3.1.0-2-generic N/A
 linux-firmware 1.61
RfKill: Error: [Errno 2] No such file or directory
Tags: precise
Uname: Linux 3.1.0-2-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 04/30/2010
dmi.bios.vendor: HP
dmi.bios.version: A07
dmi.chassis.type: 23
dmi.chassis.vendor: HP
dmi.modalias: dmi:bvnHP:bvrA07:bd04/30/2010:svnHP:pnProLiantDL585G2:pvr:cvnHP:ct23:cvr:
dmi.product.name: ProLiant DL585 G2
dmi.sys.vendor: HP

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 890768

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Ralf Spenneberg (ralq) wrote :

There is no crashdump to collect. The tools runs but does not find a controller.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . If possible, please test the latest v3.2-rcN kernel (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the others). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed by the mainline kernel, please add the following tag 'kernel-fixed-upstream-KERNEL-VERSION'. For example, if kernel version 3.2-rc1 fixed and issue, the tag would be: 'kernel-fixed-upstream-v3.2-rc1'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'. If you believe this bug does not require upstream testing, please add the tag: 'kernel-upstream-testing-not-needed'.

Thanks in advance.

tags: added: needs-upstream-testing precise regression-release
Joseph Salisbury (jsalisbury) wrote :

Can you run the following, which will provide us additional details about your hardware:

apport-collect 890768

Changed in linux (Ubuntu):
importance: Undecided → Medium

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.1.0-2.3

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Ralf Spenneberg (ralq) wrote :

Tried 3.2.0-030200rc2-generic as suggested by Joseph. It does not change anything.

Still no controllers found.

tags: added: bot-stop-nagging kernel-bug-exists-upstream
removed: needs-upstream-testing
tags: removed: kernel-request-3.1.0-2.3
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

The bugzilla.kernel.org site may still be unavailable due to the recent break-in. If that is the case, please add the tag: kernel-needs-upstream-bug-report

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Ralf Spenneberg (ralq) on 2011-11-17
tags: added: kernel-needs- upstream-bug-report
Joseph Salisbury (jsalisbury) wrote :

Do you happen to know if this issue happens on Oneiric?

Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: kernel-needs-upstream-bug-report
removed: kernel-needs- upstream-bug-report
Ralf Spenneberg (ralq) wrote :

Apparently this is a 2.6/3.0 Kernel thing. Using the command uname26 from http://mirror.anl.gov/pub/linux/kernel/people/ak/uname26/ it works:

Without uname26:
# hpacucli ctrl all show
Error: No controllers detected.

With uname26:
# ./uname26 hpacucli ctrl all show

Smart Array P400 in Slot 9 (sn: PA5360J9STP1GM)

Please add uname26 to the distribution.

Ralf Heiringhoff (frosty-geek) wrote :

I can confirm that we get the "Error: no controllers detected." with Oneiric

-----------cut---------
root@d01-spi-1:~# dpkg -l linux-image-server hpacucli
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-===============================================-===============================================-==============================================================================================================
ii hpacucli 8.70-8.0.2-2 HP Command Line Array Configuration Utility
ii linux-image-server 3.0.0.14.16 Linux kernel image on Server Equipment.

root@d01-spi-1:~# dmidecode -s system-product-name
ProLiant DL385 G2

root@d01-spi-1:~# hpacucli controller all show

Error: No controllers detected.

root@d01-spi-1:~# uname26 hpacucli controller all show

Smart Array P400 in Slot 1 (sn: P61620F9xxxxxx)
-----------cut---------

Ralf

I can confirm this bug on Ubuntu Server 10.04.4 running with the Oneiric backport kernel 3.0.0-17.

cat /etc/issue
Ubuntu 10.04.4 LTS

uname -a
Linux hostname 3.0.0-17-server #30~lucid1-Ubuntu SMP Fri Mar 9 15:44:12 UTC 2012 x86_64 GNU/Linux

hpacucli ctrl all show
Error: No controllers detected.

Using uname26 makes it work:
./uname26 hpacucli ctrl all show
Smart Array P410i in Slot 0 (Embedded) (sn: )

When the machine boots with the default kernel 2.6.32, the hpacucli also runs fine.

The link to uname26 mentioned above seems to be down, here is another mirror:
http://mirror.linux.org.au/linux/kernel/people/ak/uname26/

Frank

Graham Inggs (ginggs) wrote :

Since util-linux 2.20-1-1, and included in Precise, setarch has a --uname-2.6 switch which enables the UNAME26 personality.

See:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=639690

Usage:
setarch x86_64 --uname-2.6 [[program] [program arguments]]

Example:
setarch x86_64 --uname-2.6 hpacucli ctrl all show

Graham Inggs (ginggs) wrote :

This seems to have been fixed since hpacucli version 9.0.
See first comment on this blog post:
http://blog.wpkg.org/2012/03/15/hpacucli-error-no-controllers-detected-with-hpsa-module-in-use/

Christian says:
July 4, 2012 at 9:38 am

Hi there,

I had the same problem some weeks ago with Debian 6.0.5 running hpsa driver on a G8 blade server. The method you describe was not working for me so I used a different approch.

The problem with not finding any controllers does not persist in Version >= 9.0 of hpacucli which unfortunatly does is not available for debian or ubuntu right now. You can “backport” it from SuSE with alien though.

http://downloads.linux.hp.com/SDR/downloads/proliantsupportpack/SuSE/11.2/x86_64/9.10/hpacucli-9.10-22.0.x86_64.rpm

BR,
Christian

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.