Ubuntu

[Thinkpad R61] Headphones don't work due to "headphone" volume control missing

Reported by jolo on 2011-07-29
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
ubuntuaudiobug

Bug Description

In oneiric the built in speakers do work, but the headphones don't work.
(The headphones do work in Ubuntu 11.04.)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: pulseaudio 1:0.9.23-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-7.8-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jolo 1386 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe100000 irq 48'
   Mixer name : 'Conexant CX20549 (Venice)'
   Components : 'HDA:14f15045,17aa20db,00100100'
   Controls : 19
   Simple ctrls : 10
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7KHT24WW-1.08'
   Mixer name : 'ThinkPad EC 7KHT24WW-1.08'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri Jul 29 11:05:19 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110727)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/09/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 7OETC4WW (2.24 )
dmi.board.name: 8932GMG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7OETC4WW(2.24):bd04/09/2010:svnLENOVO:pn8932GMG:pvrThinkPadR61:rvnLENOVO:rn8932GMG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 8932GMG
dmi.product.version: ThinkPad R61
dmi.sys.vendor: LENOVO

jolo (joop-loep) wrote :
jolo (joop-loep) wrote :
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
David Henningsson (diwic) wrote :

Hi Jolo and thanks for testing Oneiric!

Looking at the codec it seems like there is no volume control created for the headphones, so PulseAudio can't control it.

summary: - Headphones don't work
+ [Thinkpad R61] Headphones don't work due to "headphone" volume control
+ missing
David Henningsson (diwic) wrote :

Hi Jolo and thanks for testing the new version of Ubuntu! Could you please

affects: pulseaudio (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: Confirmed → Triaged
David Henningsson (diwic) wrote :

Ok, I have now sent a patch to upstream, let's hope they accept it.

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Triaged → In Progress
David Henningsson (diwic) wrote :

Upstream accepted patch.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Download full text (14.9 KiB)

Output from my Lebovo R61i:

engineer@engineer-ThinkPad-R61e:~$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
engineer@engineer-ThinkPad-R61e:~$ lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
 Subsystem: Lenovo ThinkPad T61
 Flags: bus master, fast devsel, latency 0, IRQ 45
 Memory at fe100000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

engineer@engineer-ThinkPad-R61e:~$ find /lib/modules/`uname -r` | grep snd
/lib/modules/3.0.0-13-generic/kernel/sound/core/snd-hrtimer.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/snd-hwdep.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/snd.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/snd-rawmidi.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/snd-pcm.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/snd-timer.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/snd-page-alloc.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/seq/snd-seq.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/seq/snd-seq-midi.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/seq/snd-seq-midi-emul.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/seq/snd-seq-device.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/seq/snd-seq-dummy.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/seq/snd-seq-virmidi.ko
/lib/modules/3.0.0-13-generic/kernel/sound/core/seq/snd-seq-midi-event.ko
/lib/modules/3.0.0-13-generic/kernel/sound/usb/misc/snd-ua101.ko
/lib/modules/3.0.0-13-generic/kernel/sound/usb/usx2y/snd-usb-us122l.ko
/lib/modules/3.0.0-13-generic/kernel/sound/usb/usx2y/snd-usb-usx2y.ko
/lib/modules/3.0.0-13-generic/kernel/sound/usb/snd-usb-audio.ko
/lib/modules/3.0.0-13-generic/kernel/sound/usb/caiaq/snd-usb-caiaq.ko
/lib/modules/3.0.0-13-generic/kernel/sound/usb/snd-usbmidi-lib.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/ctxfi/snd-ctxfi.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-indigoiox.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-gina20.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-darla24.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-layla24.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-darla20.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-indigo.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-echo3g.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-layla20.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-indigodj.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-gina24.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-indigoio.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-indigodjx.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-mona.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/echoaudio/snd-mia.ko
/lib/modules/3.0.0-13-generic/kernel/sound/pci/cs46xx/snd-cs46xx.ko
/lib/modules/3.0.0-13-generic/ker...

Changed in linux (Ubuntu):
status: Fix Committed → In Progress
status: In Progress → Fix Committed

It looks like this bug is the culprit for bug #911331 and maybe for bug #909348.

Vianney

jolo (joop-loep) wrote :

I wonder what happened with David Henningsson' patch.
In oneiric the headphones still did not work out of the box.

However I did find a workaround in
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/218817
comment #19
options snd-hda-intel model=laptop-micsense
in /etc/modprobe/alsa-base.conf
also works for me.

This workaround worked for me: https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules

In some similar bug reports, other people solved their problem with this: https://help.ubuntu.com/community/HdaIntelSoundHowto

I have to say this was really painful for me: I had to search for a dozen hours before finally being able to use my headphones on a very common computer (Asus N73S).

How come this bug is still not resolved in Oneiric?

Vianney

Andy Whitcroft (apw) on 2012-01-16
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
ubuntuaudiobug (b600407) on 2013-01-04
Changed in linux (Ubuntu):
assignee: David Henningsson (diwic) → ubuntuaudiobug (b600407)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers