Ubuntu

Atheros AR5001 wireless card "wireless is disabled by hardware switch"

Reported by Denva Joshua Ingram on 2011-07-25
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
Seth Forshee

Bug Description

I have tried several things that I found in forums with no success (i.e. rfkill), I have also tried ndiswrapper and this didn't help either (recognized the drivers, but wouldn't switch it on). It just seems to be this type of laptop which is an Compaq Presario CQ50-110EM.

Ubuntu knows its there:

lspci -
00:00.0 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation Device 075e (rev a2)
00:01.1 SMBus: nVidia Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.3 Co-processor: nVidia Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: nVidia Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] SATA Controller (non-AHCI mode) (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation MCP77 Ethernet (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:14.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 11h Processor HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 11h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 11h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 11h Processor Link Control
02:00.0 VGA compatible controller: nVidia Corporation C77 [GeForce 8200M G] (rev a2)
07:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

lsusb -
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04f2:b091 Chicony Electronics Co., Ltd Webcam
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
denvaingram@ubuntu:~$

The laptop does have a wireless button, but this has no effect on weather the wireless works or not (the colours are normally orange with wifi off or blue for wifi on if this helps anyone)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-11-generic 2.6.38-11.47
ProcVersionSignature: Ubuntu 2.6.38-11.47-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: denvaingram 1210 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xc0000000 irq 20'
   Mixer name : 'Nvidia MCP77/78 HDMI'
   Components : 'HDA:14f15051,103c360a,00100000 HDA:10de0002,10de0101,00100000'
   Controls : 20
   Simple ctrls : 9
CurrentDmesg:

Date: Mon Jul 25 22:41:21 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: Hewlett-Packard Compaq Presario CQ50 Notebook PC
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-11-generic root=UUID=7C8056B68056771C loop=/hostname/disks/root.disk ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-11-generic N/A
 linux-backports-modules-2.6.38-11-generic N/A
 linux-firmware 1.52.1
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/23/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.3E
dmi.board.name: 360A
dmi.board.vendor: Wistron
dmi.board.version: 08.60
dmi.chassis.type: 10
dmi.chassis.vendor: Wistron
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.3E:bd06/23/2009:svnHewlett-Packard:pnCompaqPresarioCQ50NotebookPC:pvrF.3E:rvnWistron:rn360A:rvr08.60:cvnWistron:ct10:cvrN/A:
dmi.product.name: Compaq Presario CQ50 Notebook PC
dmi.product.version: F.3E
dmi.sys.vendor: Hewlett-Packard

Brad Figg (brad-figg) on 2011-07-25
Changed in linux (Ubuntu):
status: New → Confirmed
Roy Jamison (xteejx) wrote :

I'll add to this that this specific laptop was my own, and worked back in an old version of Ubuntu, possibly 7.10-8.04 or thereabouts. I'm thinking this may be related to NetworkManager, and will work through https://wiki.ubuntu.com/DebuggingNetworkManager to rule it in or out.

Sorry I also forgot that in Windows 7, they state this wireless card as an Atheros AR5007 (I dunno if this helps at all)
Thanks guys

network-manager start/stop and kernel driver load/unload tested (syslog)
hardware button tested (syslog1)
rfkill checked (command 1)
Also, tried full instructions at Hotkeys/Troubleshooting in case it was the Hardware button itself. It was tested with udev and acpi_listen and there is no event for the button, so could be that the kernel is not initiating an event to NetworkManager or X to kick the wifi in.

Could try wpa_supplicant but need instructions on how to do this - any simple instructions welcome (WEP 64 hex key), i.e. how to kick it to connect manually, although I don't know the commands.

udev tested as per Hotkeys/Troubleshooting - no events for button

Mainline kernel amd64 v3.0-rc7 tested too, no change in the situation.

~~~~~~~~~~~~~~~~~~~~~~~~~
Tested by xteejx directly

Roy Jamison (xteejx) wrote :

I have sent this bug upstream directly to the kernel developers, considering the regression nature of this bug report, and that there is a lot of information here, and many things tried and tested.
https://bugzilla.kernel.org/show_bug.cgi?id=40102 < kernel bug report can be seen here and commented on
Please keep an eye on the kernel bug report and check in on it from time to time to see how it is progressing, or if there is any more information needed by them. Give as much as info you can when you reply as you have here. More information is better than no information.

tags: added: regression-release
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Roy Jamison (xteejx) wrote :

Ok, so the problem is definitely not the mainline kernel, but could still be our patches.
The laptop has been tested with a live DVD of Sabayon linux with kernel 2.6.31-sabayon #1 on i686 arch, it is based on gentoo 2.0.1, and uses GNOME 2.28.0.
Will try to test other distros to narrow down the issue.

Changed in linux (Ubuntu):
status: Triaged → Confirmed
Seth Forshee (sforshee) wrote :

It looks like the rfkilli s the problem. I see Matthew Garrett already suggested you try unblocking it. Am I understanding correctly that when you unblock both 0 and 1 it works temporarily, but a short time later it stops working again and displays a soft block on the hp-wifi device? It might be best if you just pasted in the output from 'rfkill list' after it stops working again.

Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
importance: High → Medium
status: Confirmed → Incomplete

Hello Seth,

I will try this a bit later on when I am at home and can connect it to the internet via wire :D

Roy Jamison (xteejx) wrote :

Hi Seth, thanks for looking at this.
It appears that rfkill may indeed be the problem, but the situation is that rfkill works first time only if the laptop was rebooted from windows.
After that, rfkill unblock {0,1} works, but yes, temporarily, as the local APs are displayed in network-manager, but then rfkill HARD blocks/kills the wireless button (hp-wifi) after about 10-30 seconds.
No amount of messing around with the rfkill options works.

Roy Jamison (xteejx) wrote :

And I can answer the above question (forgive the syntax it's from memory, but the text is correct). After it stops working again (after the unblock suggested by M Garrett), rfkill list shows something like this:

0: hp-wifi Hard blocked: yes
                   Soft blocked: no

1: phy0 Hard blocked: no
                   Soft blocked: no

And yes, the device number shown for phy0 changes from 4 to 1 after working, it is not a typing error.

Hello again, I though I would try and use a USB wireless dongle. It was a ralink RT2070 (device ID - 148f:2070), but for some strange reason it came up with "device is disabled by hardware switch". So I decided to do "rfkill unblock all" and sure enough my laptop wireless was unblocked and the usb dongle was unblocked, so I tried to use my laptop wireless and it connect and disconnect 3 or 4 times, then went back to hardblock.

I will attach some log files just in case you need them, but I think that it may not be any wireless card problem but the laptop itself as ubuntu says that the ralink dongle is disabled by hardware switch, which isn't possible

Thanks guys

Seth Forshee (sforshee) wrote :

Denva: Can you give the output of 'rfkill list' when you get the situation with the USB adapter?

Teej: It would be most helpful to have the rfkill list output pasted in rather than typed from memory, just to ensure that there aren't any mistakes.

What it looks like at this point is that hp_wmi receives events from the BIOS that it thinks are telling it that some kind of blocks have been applied to the wireless. Exactly why that is happening is unclear at this point.

Seth Forshee (sforshee) wrote :

Oh, and if you want to work around the problem temporarily the easiest thing to do is to unload the hp_wmi module (sudo rmmod hp_wmi). You can make it persist across reboots by adding the line 'blacklist hp_wmi' to /etc/modprobe.d/blacklist.conf. You will loose some functionality however, probably most noticeable is support for hotkeys.

Hello and thanks Seth, I can't uoad the rfkill as my laptop overheated and am currently writing this on my blackberry. But when I did do the rfkill it said the same thing as last time (stated above).

I also tried the work around and after following your instructions my wireless card was picking up networks but wouldn't connect to them. Then we done disabled the network and turned it back on and it came up with "disabled by hardware switch". And haven't been able to get it to search for networks again.

One last thing I did blacklist hp_wmi, but I think I have undone all of it again

Thanks again for your help, this problem is getting annoying lol

anthropornis (anthropornis) wrote :

This affects me too.

When I woke up this morning, heard my laptop fan running because of a dialog box that needed attention, which in itself to me is a bug.

Even though I had my ethernet cable plugged into the laptop, it was still trying to reconnect to a wifi network in the house, and there is no telling how long this dialog box had been up, causing my cpu to run hotter.

So I pressed the physical wifi button on my laptop (which I never use, because I've always perceived it as not working in Ubuntu), as an attempt to turn off the wifi card temporarily, until I was actually away from my wired connection at home.

Then I did today's system updates (via Synaptic), which seemed to include a new kernel (?), and shut off the laptop, since it needed to be rebooted for the update, and I was leaving for work anyway.

Once at work, I started the laptop again, and now I have the "wireless is disabled by a hardware switch" issue.

Ubuntu 11.04 amd64 is the only OS on my machine, can't do anything with Windows. Don't know if this situation is related to running the updates this morning, or solely from pressing the physical wifi button on my Compaq Presario CQ60-215DX laptop.

sudo rfkill unblock all doesn't fix anything
sudo rrmod hp_wmi doesn't seem to fix anything either, though the module is now unloaded
forcing my grub2 menu and booting with an older kernel doesn't seem to do anything either

Seth Forshee (sforshee) wrote :

Denva: Will you run the following commands in a terminal and attache the *.dsl files that are generated?

  sudo apt-get install fwts
  sudo fwts --disassemble-aml

Anthropornis: I can't tell whether your problem is really the same. I'd assume you've tried this, but since you didn't mention it specifically -- pressing the wifi button doesn't unblock your wireless? Can you provide the output of 'rfkill list' before and after pressing the button?

anthropornis (anthropornis) wrote :

Sorry for the delay, yes I had tried to just press the physical wifi button but it did not work (it worked quite well to start this whole mess though).

I had actually managed to remove, I think the HP driver, from the kernel, and that was a decent workaround. Then I received my new laptop, and I've not been using the affected the laptop lately. If I get a chance I will try to retrace my steps and put the (driver?) back into the kernel and test rfkill list.

eof (eric-odier-fink) wrote :

Solution from: http://ubuntuforums.org/showthread.php?t=1805960

sudo rfkill unblock all

Speaking to the OP, this does not work, as explained above.
This was tried way back when with "sudo rfkill unblock all" and it worked
for
about 5 minutes until the user tried to connect to an AP, but then the
hp-wifi
(I can only assume) kicked back in and hard blocked everything.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.