Ubuntu

Realtek rtl8187b wireless chipset slow speed

Reported by Mike on 2011-06-28
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, I have ubuntu 11.04, all updates, wifi chipset rtl8187B, kernel 2.6.38-10, and 14mbit/s internet connection.
When I try to download something, for example from torrents, I see ping up (up to 500-800ms), slow speed (<1mbit/s) and packets lost.
In windows its works fine, ping didnt up, download speed 14mbit/s.
So if I want to download something, I need to reboot from ubuntu to windows, or wait for download at low speed in ubuntu. And it's not good=(
Thanks, and sorry my bad english.

laptop:~$ uname -a
Linux mike-laptop 2.6.38-10-generic #44-Ubuntu SMP Thu Jun 2 21:32:22 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

laptop:~$ modprobe --show-depends rtl8187
insmod /lib/modules/2.6.38-10-generic/updates/drivers/misc/eeprom/eeprom_93cx6.ko
insmod /lib/modules/2.6.38-10-generic/updates/net/wireless/cfg80211.ko
insmod /lib/modules/2.6.38-10-generic/updates/net/mac80211/mac80211.ko
insmod /lib/modules/2.6.38-10-generic/updates/drivers/net/wireless/rtl818x/rtl8187/rtl8187.ko

laptop:~$ sudo lsusb -d 0bda:8187
Bus 001 Device 004: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-10-generic 2.6.38-10.44
ProcVersionSignature: Ubuntu 2.6.38-10.44-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mike 2412 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfcb00000 irq 43'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,144dc06a,00100004'
   Controls : 13
   Simple ctrls : 8
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xddefc000 irq 16'
   Mixer name : 'Nvidia GPU 0b HDMI/DP'
   Components : 'HDA:10de000b,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Tue Jun 28 13:24:48 2011
HibernationDevice: RESUME=UUID=339679fe-6015-48a0-b9f5-9bdecde05562
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110405)
MachineType: SAMSUNG ELECTRONICS CO., LTD. R530/R730/P530
ProcEnviron:
 LANGUAGE=ru_RU:en
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=eae27d1a-6cca-45bb-8c38-d8cdd238b079 ro quiet splash nomodeset video=uvesafb:mode_option=1377x768-24,mtrr=3,scroll=ywrap vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-10-generic N/A
 linux-backports-modules-2.6.38-10-generic N/A
 linux-firmware 1.52.1
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-05-04 (54 days ago)
dmi.bios.date: 06/21/2010
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 04KQ.M007.20100621.KSJ
dmi.board.asset.tag: Tag 12345
dmi.board.name: R530/R730/P530
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr04KQ.M007.20100621.KSJ:bd06/21/2010:svnSAMSUNGELECTRONICSCO.,LTD.:pnR530/R730/P530:pvrNotApplicable:rvnSAMSUNGELECTRONICSCO.,LTD.:rnR530/R730/P530:rvrNotApplicable:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: R530/R730/P530
dmi.product.version: Not Applicable
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Mike (joke99) wrote :
Mike (joke99) on 2011-06-28
summary: - Realtek rtl8187b slow speed
+ Realtek rtl8187b wireless chipset slow speed
RedSingularity (redsingularity) wrote :

Assigning to linux kernel.

affects: ubuntu → linux (Ubuntu)
Brad Figg (brad-figg) on 2011-07-19
Changed in linux (Ubuntu):
status: New → Confirmed

As a workaround please put into your

/etc/rc.local

this row

iwconfig wlan0 rate 5.5M

before the

exit 0

and reboot the system

Mike (joke99) wrote :

marcobra,
I have already tried it, and tried right now, but it's didn't change anything:(
Thanks.

VPablo (villumar) wrote :

If it is like RTL8187L you need to install drivers because Linux takes the 8187 generic driver and it does not work properly. Please, download the driver from here:

http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=1&PFid=1&Level=6&Conn=5&DownTypeID=3&GetDown=false&Downloads=true#RTL8187B

Unpack the archiver and install it by:
$ sudo make
$ sudo make install

And reboot.

It works for the RTL8187L (that it is not the same card).

Mike (joke99) wrote :

Vpablo,
But there is no official realtek linux drivers for 8187B.
Thanks.

VPablo (villumar) wrote :

Yes, you are right, it seems there is no Linux driver or they removed it (I don't remember).

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Dany K (dny-k21) wrote :

Still not working in Ubuntu 12.04 Beta 2.

Dany K, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug linux

Thanks!

Ringelkrat (ringelkrat) wrote :

You may find a solution in ubuntuforums: http://ubuntuforums.org/showthread.php?p=11582134#post11582134 I did not test it though.

Mike (joke99) wrote :

Okay, I just returned from the army, where I was last year (I'm from Russia).
So, I install Elementary OS 0.2 Luna 64bit, and rtl8187b chipset works great, on full speed, without any lag!

uname -a:
Linux laptop 3.2.0-51-generic #77-Ubuntu SMP Wed Jul 24 20:18:19 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

tags: added: needs-full-computer-model
Mike (joke99) wrote :

Computer Samsung R530 jt-03. But I use usb wifi adapter WiFiSKY (china) with rtl8187b chipset.

Mike, could you please provide the full computer model as noted on the sticker (ex. Samsung NP-R530-JT03US)?

Mike (joke99) wrote :

Samsung NP-R530-JT03RU

Mike, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: removed: needs-full-computer-model
tags: added: bios-outdated-07jd
Mike (joke99) on 2013-09-02
tags: added: kernel-fixed-upstream-v3.11-rc7
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Mike (joke99) wrote :

Okay, I tested it on daily ubuntu Saucy build with v3.11-rc7 kernel, and everything works fine. Thanks for fixing this bug!

Changed in linux:
status: New → Invalid

looks like some router and adapter uncompability.

router zyxel P-2812HNU-F3
http://www.zyxel.com/no/no/products_services/p_2812hnu_fx_series.shtml?t=p

and statement in router wireless specifications "Backward compatible to 802.11b/g" is not 100% correct ...

adapter
lsusb:
Bus 001 Device 003: ID 0846:4260 NetGear, Inc. WG111v3 54 Mbps Wireless [realtek RTL8187B]

Symptoms:
ping to router
 ping 10.0.0.138
PING 10.0.0.138 (10.0.0.138) 56(84) bytes of data.
^C
--- 10.0.0.138 ping statistics ---
26 packets transmitted, 0 received, 100% packet loss, time 25000ms

uname -na :
Linux irmute 3.11.0-2-lowlatency #1-Ubuntu SMP PREEMPT Fri Aug 16 22:06:58 UTC 2013 i686 i686 i686 GNU/Linux

modprobe --show-depends rtl8187:
insmod /lib/modules/3.11.0-2-lowlatency/kernel/drivers/misc/eeprom/eeprom_93cx6.ko
insmod /lib/modules/3.11.0-2-lowlatency/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/3.11.0-2-lowlatency/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/3.11.0-2-lowlatency/kernel/drivers/net/wireless/rtl818x/rtl8187/rtl8187.ko

iwconfig wlan1:
wlan1 IEEE 802.11bg ESSID:"XXXXXXXXXX"
          Mode:Managed Frequency:2.412 GHz Access Point: CC:5D:4E:1B:46:44
          Bit Rate=1 Mb/s Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=39/70 Signal level=-71 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:1 Invalid misc:0 Missed beacon:0

Another build in laptop wlan adapter:

Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

iwconfig wlan0
wlan0 IEEE 802.11abg ESSID:"xxxxxxxxxxxxxx"
          Mode:Managed Frequency:2.412 GHz Access Point: CC:5D:4E:1B:46:44
          Bit Rate=54 Mb/s Tx-Power=15 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=44/70 Signal level=-66 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:46 Missed beacon:0

 ping 10.0.0.138
PING 10.0.0.138 (10.0.0.138) 56(84) bytes of data.
64 bytes from 10.0.0.138: icmp_seq=1 ttl=64 time=0.911 ms
64 bytes from 10.0.0.138: icmp_seq=2 ttl=64 time=0.873 ms
64 bytes from 10.0.0.138: icmp_seq=3 ttl=64 time=0.869 ms
64 bytes from 10.0.0.138: icmp_seq=4 ttl=64 time=0.868 ms
^C
--- 10.0.0.138 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 0.868/0.880/0.911/0.027 ms

All diference that i can see is only wirelees standarts that is suported by adapters:
netgear IEEE 802.11bg and intel IEEE 802.11abg.

and some dependences:
modprobe --show-depends iwl3945
insmod /lib/modules/3.11.0-2-lowlatency/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/3.11.0-2-lowlatency/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/3.11.0-2-lowlatency/kernel/drivers/net/wireless/iwlegacy/iwlegacy.ko
insmod /lib/modules/3.11.0-2-lowlatency/kernel/drivers/net/wireless/iwlegacy/iwl3945.ko

 mabe this module eeprom_93cx6.ko makes problem with rtl8187, but to check it is out of my qualification...

Mike (joke99) wrote :

Hi! It seems that you have another problem, because in my case, when I didnt download anything, ping to router whas <1ms, whitout packets lost, and connection rate 54mb/s in iwconfig (you have 1mb/s and all packets lost). But when I try to download something, download speed where <100kb/s (<1Mbit/s), 50/50 packets lost, and ping up to 500-1000ms.
You should try to get closer to router because I see that "Link Quality=39/70" and "Bit Rate=1 Mb/s".
If it doesnt help, then I think that you should search or open another bug. Thx!

reportXubuntu, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Thanks Mike for quick answer. It is nice to find out that there is some body alive in this bug :D

It was only in this example with that
new kernel (3.11.0-2-lowlatency #1-Ubuntu SMP PREEMPT Fri Aug 16 22:06:58 UTC 2013 i686)
when Netgear usb adapter give 100% lost,
with older kernel (3.8.0-30-lowlatency #22-Ubuntu SMP PREEMPT Mon Aug 26 22:31:40 UTC 2013 x86_64 x86_64 x86_64) adapter was working, but so so slugish like hell.... and average pakage lost was up til 50% or
60%, and sometimes up til 20%.
The router was just in average 10 m distance with the wooden wall. So it is nothing to do with signal strenght
because another adapter with intel chip with all most the same signal quality gives 0% of pakage lost when pinging to router.
And a bit rate, i think, i set it it to auto or something, but if i want i can set it up til to 54mb/s
with sudo iwconfig wlan1 rate 54M fixed but there is no point set rate to 54mb/s with internet speed i have . It is the same like when your car
can go on road max 200km/h and put 400km/h on speedometer. the car will not became faster just for that ;)

And on athe laptop with 13.04 ubuntustudio with
kernel (3.8.0-30-lowlatency #22-Ubuntu SMP PREEMPT Mon Aug 26 22:31:40 UTC 2013 x86_64 x86_64 x86_64)
with setings
sudo iwconfig wlan1 rate 5.5M fixed
sudo iwconfig wlan1 frag 2346
and laptop about 15m distance from router

pinging to router gives
ping 10.0.0.138
PING 10.0.0.138 (10.0.0.138) 56(84) bytes of data.
64 bytes from 10.0.0.138: icmp_req=9 ttl=64 time=1.67 ms
64 bytes from 10.0.0.138: icmp_req=10 ttl=64 time=3.45 ms
64 bytes from 10.0.0.138: icmp_req=12 ttl=64 time=2.04 ms
64 bytes from 10.0.0.138: icmp_req=13 ttl=64 time=2.60 ms
^C
--- 10.0.0.138 ping statistics ---
15 packets transmitted, 4 received, 73% packet loss, time 14005ms
rtt min/avg/max/mdev = 1.677/2.445/3.452/0.671 ms

and with sudo iwconfig wlan1 txpower 15

ping 10.0.0.138
PING 10.0.0.138 (10.0.0.138) 56(84) bytes of data.
64 bytes from 10.0.0.138: icmp_req=4 ttl=64 time=1.71 ms
64 bytes from 10.0.0.138: icmp_req=6 ttl=64 time=1.45 ms
64 bytes from 10.0.0.138: icmp_req=7 ttl=64 time=3.05 ms
64 bytes from 10.0.0.138: icmp_req=8 ttl=64 time=1.58 ms
64 bytes from 10.0.0.138: icmp_req=9 ttl=64 time=1.75 ms
64 bytes from 10.0.0.138: icmp_req=10 ttl=64 time=1.27 ms
^C
--- 10.0.0.138 ping statistics ---
10 packets transmitted, 6 received, 40% packet loss, time 9008ms
rtt min/avg/max/mdev = 1.273/1.805/3.054/0.582 ms

So i think it is the same or allmost the same like yours situation,
because with this % of packet lost i also shall get slow download speed.

Actualy adapter in 2012 up till august was working fine. Then router was changed
and i began to have connection problems with this adpter. I don't remember what kernel was at that momem in use.
Now i began to remember that maybe i made experiment with another router dlink some have year ago,
and adapter was pinging fine, but now can not verify it 100% if I remember it 100% exactly.

Mike what is router name that your adapter is connecting ?

In this router-modem zyxel P-2812HNU-F3
 that i am connected now , i have tried to set up ant to use

only 802.11b, and only 802.11b/g, and defaoult that was standing and is in use now 802.11abgn (or somethinglike that)

the situation was the same: very poor, unstable connection and slow like hell .......

and only with this netgear WG111v3 54 Mbps Wireless [realtek RTL8187B] adapter.

Intels adapters Network controller: Intel Corporation PRO/Wireless 3945ABG works fine.

decided to make a test with new kernel
 3.11.0-999-generic #201309140405 SMP Sat Sep 14 08:06:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

with settings

sudo iwconfig wlan1 frag 2346
sudo iwconfig wlan1 txpower 15
sudo iwconfig wlan1 rate 5.5M fixed

i get this pinging situation to router

--- 10.0.0.138 ping statistics ---
26 packets transmitted, 22 received, 15% packet loss, time 25039ms
rtt min/avg/max/mdev = 1.237/1.602/3.742/0.511 ms

not so bad but also and not so good ...

Mike (joke99) wrote :

reportXubuntu, Hi!
I use Dlink DIR-615, also I've use it with 2-3 different free hot-spot in my town, and all works fine.
Yes, now it seems that you have the same problem, but then I didnt undestood why my rtl8187b work perfect? Maybe because I use china noname wifi adapter (something like clone of a Alfa AWUS036H 1000mW), and you have NetGear, maybe we have different revision of wireless chipset? But I didnt see that it have several revision.
Did you try it in Windows with official drivers?
Yes, by default bit rate set to auto, and when system see, that signal is too slow, it try to slow down bit rate, because on low bitrate it can transmit data to larger distance.. and 15m I think not good distance, especially if you neighbor have another working wifi on this (or nearby) channel (they make interference). And I saw that you wifi WG111v3 adapter doesnt have external antenna.
So I think you need to try to get closer to router, or/and try to use it from Windows (maybe livecd or vmware) with official drivers.
Thx! And sorry for my english, I learn it in school about 7 years ago :D

reportXubuntu, please see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/802902/comments/21 . As this report is closed as Fix Released, no further triaging or development would be occuring from this report.

Hi Mike, my english also not from the top of championship mountain ;D

oh yes, i have tried yesterday, on winxp sp3. And yes, official drivers WG111v3 Version 1.5.0 from Netgear website,
was working. I used windows wireless manager for connecting. And in the same 15m distance signal was good,
and no packet loss while pinging to router.
So now it is clear, that there is nothing bad with router or usb adapter circuits itself.
All thing is with driver or some settings in ubuntu (or kernel).

Than i found out that there was WG111v3 Version 2.0.0 for windows. Tried and this. Wireless application, that was included with driver ver.2 , failed connect to wireless network. It automatically chose WEP encryptions, but the password was not working no with 64bit neither 128 bit passphrase. Result was a message that connection is not working or limited or something like that - in another words: adapter can not obtain information from dhcp and set some default,not working, TCP/IP values . But if i use windows wireless manager then adapter connects to router and obtains dhcp values for TCP/IP.

Than i decided to go with ndiswrapper on ubuntu, and test windows drivers. First impression was that it looks promising: driver installed, device recognized...and nothing more. It was not working. Then i tried few other drivers, but result was the same.
 Result in dmesg was : can not load drivers or something like that. I tried i386 and amd64. no luck.
So i think that maybe
there is some additional stuff in driver installation for windows, that helps adapter to function correctly.

Christopher M. Penalver (penalvch) where do you think is better to opening
 up the new report or bug (launchpad, bugzilla) and what kernel to use for the report?

At last found where the two beasts are.
one is little one and other is a big one :D

The little beast - device was to hot.

I have disassemble plastic cover, and was using usb adapter
without plastic cover. When i decided to change usb port and to use usb cable (1,5 m in length ),
i find out that chip (rtl8187b; 74307S1; G716D TAIWAN)
is quite hot (betwen53C and 60C).

The big beast - device was directly connected to laptop usb port
(and maybe pick up some nice interference from build in intel wireless card or from another electric circuit ).

I tested few positions with usb cable and find out that it really matter adapter orientation,
and how far away adapter is from laptop (in my situation about 70cm was enough to get good results ).

Test results:

without cooling (chip rtl8187b up to ~59C)
and with usb cable about 70cm from laptop, adapter is hanging down with led pointing to router.

--- 10.0.0.138 ping statistics ---
208 packets transmitted, 127 received, 38% packet loss, time 207181ms
rtt min/avg/max/mdev = 0.806/3.346/148.845/13.007 ms

with cooling (chip temperature up to 34C)
and other things are all the same

starting cooling:
--- 10.0.0.138 ping statistics ---
204 packets transmitted, 181 received, 11% packet loss, time 203239ms
rtt min/avg/max/mdev = 0.752/3.685/174.709/17.437 ms

hand get tired and i put ventilator on the table

--- 10.0.0.138 ping statistics ---
111 packets transmitted, 110 received, 0% packet loss, time 110108ms
rtt min/avg/max/mdev = 0.695/5.633/228.638/26.297 ms

while downloading gimp windows install (86,0 MB) and still cooling

--- 10.0.0.138 ping statistics ---
194 packets transmitted, 193 received, 0% packet loss, time 193214ms
rtt min/avg/max/mdev = 0.727/14.372/749.374/72.800 ms

still cooling :D
--- 10.0.0.138 ping statistics ---
225 packets transmitted, 225 received, 0% packet loss, time 224268ms
rtt min/avg/max/mdev = 0.721/3.329/193.260/17.353 ms

So i am not an expert on electric circuit, neither on usb wireless adapters electronics,
but it is really something to do with drivers and maybe power management or
power consumption for some routines.
Maybe windows drivers use smarter algorithms to do the same job than linux drivers,
and that's why chip in linux has more job, use more power and gets over hot and starts malfunction?
Or maybe it is usb power management?
But to answer exactly man need to have knowledge and understanding about this device (chipset), or
in another words need team assistance which crated this device (chipset).

So problem solution is to put cooler and use usb cable :D

But still annoying why in windows it works ok even when adapter is hot and on linux need to be cooled down to 30C ?

reportXubuntu, regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/802902/comments/27 :
>"...where do you think is better to opening up the new report or bug (launchpad, bugzilla)"

Launchpad in a new report, as previously noted to you in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/802902/comments/21 .

>" and what kernel to use for the report?"

The one that comes with Ubuntu, as already advised to you in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/802902/comments/21 .

Christopher M. Penalver,
i would like to ask you, how to call or address problem (if you take a look at comment 28 and this comment below)?

* Power consumption for wg111v3 with current linux driver rtl8187 is inefficient ?

* Need more inefficient power consumption for device wg111v3 ?

* TX Power problem or wrong voltage? (of course it's just fun to think about this: and how to verify it ? :D ..... )

* And usb cable ...... uninterference algorith is wrong or driver (kernel, OS) lacks of it at all?

* Or usb power control in OS is wrong ?

So how to look at situation, which direction to go?

All i can say, that this problem ( chip rtl8187b overheating ) can lead to :

* connection degrades after few minutes or after 30 min
  (all depends how device is dissipating heat at it depends on each situation and moment differently
   and additional cooling really solves problem)

* OS can reports it's "Excellently" connected - but in reality it can't move a byte;

* or connection rate and stability can vary from time to time .

I like this comment from:
http://www.tomshardware.co.uk/forum/347032-28-enabling-power-adjustment-rtl8187-chipset

Although it has the same chipset, it's the adapter manufacturer who decides which chipset features are actually available to the end user. In any event, leaving TX Power at the default is always the recommended action since increasing it can have negative effects such as:

* overheating of the power amplifier chip and the card which will cause lower efficiency and more data errors;

* overdriving the amplifier which will cause more data errors;

* excessive power usage for the card and this may overload the 3.3V power supply of the board that the card is located on resulting in voltage drop and reboot or excessive temperatures for the board.

* Life-expectancy of the adapter is greatly reduced.

Maybe address bug with wg111v3 to linux driver rtl8187 (or kernel) implementation of AGC?

"The RTL8187B supports fast receiver Automatic Gain Control (AGC) and antenna diversity functions, and an adaptive transmit power control function to obtain better performance in the analog portions of the transceiver. It also has on-chip digital-to-analog converters and analog-to-digital converters for analog I and Q inputs and outputs, transmit TSSI and receiver RSSI inputs, and transmit and receiver AGC outputs. "

quote is taken from the link
http://www.realtek.com.tw/products/productsView.aspx?Langid=1&PNid=24&PFid=1&Level=6&Conn=5&ProdID=143

This part "adaptive transmit power control function to obtain better performance"
i want to paraphrase "adaptive transmit power control function to make more trouble for linux users" :D

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers