Invisible pointer (Regression in kernel from 2.6.39.4 to 3.0.0-0300rc1)

Bug #793486 reported by Fabio Marconi on 2011-06-06
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Canonical Kernel Team
Oneiric
High
Canonical Kernel Team

Bug Description

Binary package hint: xorg

Is here again
On installed updated Oneiric the system was going into suspend but I recall it pressing a key, but the pointer now is invisible.
everythings is working
fabio

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+4ubuntu3
Uname: Linux 3.0.0-0300rc1-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1280x1024 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAebY1Dnm0DAAgOAQNuIht46i7lpFdKnCURUFSla4AxT0VPYU+BgAEBAQEBAQEBMCoAmFEAKkAwcBMAUg4RAAAeAAAA/QA4Sx5TDgAKICAgICAgAAAA/ABMMTczMFMKICAgICAgAAAA/AAgCiAgICAgICAgICAgAN0=
Date: Mon Jun 6 14:20:36 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 nVidia Corporation C51G [GeForce 6100] [10de:0242] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASRock Incorporation Device [1849:0242]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110531.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-0300rc1-generic root=UUID=e92839e8-9ed6-448c-930f-f0c8674d0780 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/03/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.asset.tag: 00000000
dmi.board.name: K8NF4G-SATA2
dmi.board.version: 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd11/03/2005:svn:pnK8NF4G-SATA2:pvr1.00:rvn:rnK8NF4G-SATA2:rvr1.00:
dmi.product.name: K8NF4G-SATA2
dmi.product.version: 1.00
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.25-2ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 7.10.2-0ubuntu2
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: njin 1292 F.... pulseaudio
CRDA: Error: [Errno 2] File o directory non esistente
Card0.Amixer.info:
 Card hw:0 'ICH'/'Intel ICH with ALC850 at irq 23'
   Mixer name : 'Realtek ALC850 rev 0'
   Components : 'AC97a:414c4790'
   Controls : 42
   Simple ctrls : 27
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=120d0277-b3be-4bab-b6f0-4e82ddde3620
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 0718:0628 Imation Corp.
 Bus 002 Device 002: ID 046d:c050 Logitech, Inc. RX 250 Optical Mouse
 Bus 002 Device 003: ID 046d:c313 Logitech, Inc.
Package: linux (not installed)
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-8-generic root=UUID=d71a6edb-65f2-4ee3-ac9d-dea092ff3d24 ro drm.debug=0xe
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-8-generic N/A
 linux-backports-modules-3.0.0-8-generic N/A
 linux-firmware 1.57
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: oneiric running-unity
Uname: Linux 3.0.0-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/03/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.asset.tag: 00000000
dmi.board.name: K8NF4G-SATA2
dmi.board.version: 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd11/03/2005:svn:pnK8NF4G-SATA2:pvr1.00:rvn:rnK8NF4G-SATA2:rvr1.00:
dmi.product.name: K8NF4G-SATA2
dmi.product.version: 1.00

Fabio Marconi (fabiomarconi) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Moving to xserver-xorg-video-nouveau since it's the video driver in use. I noticed that you're using kernel version 3.0.0-0300rc1-generic

Are you able to reproduce the problem with 2.6.39.3.4 ?

affects: xorg (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)
Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

Hello
Actually i cannot reproduce it in linux 3, but looking at kern.log at the time of it happens i found:

Jun 6 14:30:34 njin kernel: [20483.330968] [drm] nouveau 0000:00:05.0: PGRAPH - ERROR nsource: (unknown bits 0x00800000) nstatus: PROTECTION_FAULT

Kern.log attached

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → New
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Alive and kicking in Oneiric 20110803.1

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

Reproduceable everytime with default kernel
Tried with 2.6.39.4/oneiric from ppa and it is no more reproduceable.
Thanks
fabio

Fabio Marconi (fabiomarconi) wrote :

Hello
Another strange thing.
After installing 2.6.39.4/Oneiric-all.deb, & -headers & -image if I boot the system in the default 3.0 kernel I cannot reproduce this bug

Fabio Marconi (fabiomarconi) wrote :

ehm, misspoken earlier, reproducible again so #6 not valid, sorry

Bryce Harrington (bryce) wrote :

From the comments, it sounds like this is a regression in the kernel between versions 2.6.39.4 to 3.0.0-0300rc1. A git bisection search can be utilized to narrow in on where the regression occurred. Please see https://wiki.ubuntu.com/Kernel/KernelBisection

Reassigning to the kernel team for further follow up, since they'll need to ensure the faulty patch is backed out or replaced.

summary: - Invisible pointer
+ Invisible pointer (Regression in kernel from 2.6.39.4 to 3.0.0-0300rc1)
affects: xserver-xorg-video-nouveau (Ubuntu) → linux (Ubuntu)
tags: added: kernel-needs-reviewkernel-handoff-graphics
Jean-Baptiste Lallement (jibel) wrote :

Setting importance to high because it is a regression.

tags: added: regression-release
Changed in linux (Ubuntu Oneiric):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
importance: Medium → High

The kernels being used/tested here appear to be the mainline kernel builds. The mainline kernels builds are produced for debugging purposes and therefore come with no support. Use them at your own risk. It additionally appears you are using the v3.0-rc1 kernel (ie an early v3.0 release candidate)

So, please test with the most recent 3.0.0-8.10 Ubuntu kernel. It was most recently rebased onto upstream stable v3.0.1.

Changed in linux (Ubuntu Oneiric):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Fabio Marconi (fabiomarconi) wrote :

Hello
apport-collect executed in linux 3.0.8-10 with the bug in action.
Thanks
Fabio

Changed in linux (Ubuntu Oneiric):
status: Incomplete → Confirmed
Fabio Marconi (fabiomarconi) wrote :
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Fabio Marconi (fabiomarconi) wrote :

Hello
Actually is fixed starting from linux 3.0.9 and 3.0.10.
Just some days of testing before closing this report.
Fabio

Closing per comment #31. Fabio, feel free to re-open if this reappears. Thanks.

Changed in linux (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers