wlan (AR928X, ath9k) slow since upgrade to natty

Bug #761176 reported by decker on 2011-04-14
150
This bug affects 30 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Seth Forshee

Bug Description

***Fixed in 2.6.39 (oneiric)***

Since upgrade to natty (from lucid) the network connection with my wlan card (AR928X) is awfully slow. The wlan was ok under lucid and reaches full speed when I boot into windows. The LAN-Connection (eth0) in contrast is ok.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
Regression: Yes
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: decker 1750 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf0880000 irq 17'
   Mixer name : 'Nvidia MCP79/7A HDMI'
   Components : 'HDA:111d7675,10280271,00100103 HDA:10de0007,10280271,00100100'
   Controls : 20
   Simple ctrls : 11
Date: Thu Apr 14 23:36:04 2011
Frequency: I don't know.
HibernationDevice: RESUME=UUID=45b7e75f-fc12-4186-9c51-5589de3b6665
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MachineType: Dell Inc. Studio XPS 1340
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_GB.utf8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=55b69878-b4c9-4599-8c93-eabb936b49e6 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.50
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-04-03 (11 days ago)
dmi.bios.date: 03/25/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.vendor: Dell Inc.
dmi.board.version: A14
dmi.chassis.asset.tag: 1234567890
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A14
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd03/25/2010:svnDellInc.:pnStudioXPS1340:pvrA14:rvnDellInc.:rn:rvrA14:cvnDellInc.:ct8:cvrA14:
dmi.product.name: Studio XPS 1340
dmi.product.version: A14
dmi.sys.vendor: Dell Inc.

decker (schnoerkellos) wrote :
decker (schnoerkellos) wrote :

seems to be a problem with mixed WPA/WPA2 mode on the ath9k driver, the following work-around solves the problem:

sudo rmmod -f ath5k
sudo modprobe ath5k nohwcrypt=1

see also http://ubuntuforums.org/showthread.php?t=1682388

summary: - wlan card (AR928X) slow since upgrade to natty
+ wlan (AR928X, ath9k) slow since upgrade to natty

I have a 0b:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)
and unfortunately that workaround didn't work for me.

C Pirnat (histoplasmosis) wrote :

While the hwcrypt option seem sto help a little I'm still receiving some packet loss. That appears to be the "slow down" problem.

C Pirnat (histoplasmosis) wrote :

Correction. That does workaround does not seem to work it just started experiencing the slow downs again. I will try building compat-wireless to see if that helps.

The workaround does work for me though, of course, one must correct the typo and replace the two instances of "ath5k" with "ath9k".

As stated in the ubuntuforums entry cited above you can make the workaround permanent by adding a file ath9k.conf containing the line "options ath9k nohwcrypt=1" to /etc/modprobe.d.

darkanry (richard-andrysek) wrote :

By me it hangs by >sudo ifup wlan0:(
What can be wrong, with 10.04 were no problem?

I can confirm that bug was fixed on kernel 2.6.39.

To solve it on Natty:

sudo add-apt-repository ppa:kernel-ppa/ppa
sudo apt-get update && sudo apt-get dist-upgrade -y

Changed in linux (Ubuntu):
status: New → Confirmed
description: updated
darkanry (richard-andrysek) wrote :

Hi Tiago,

I've tried your package. This is a part from an installation:
...
 * dkms: running auto installation service for kernel 2.6.39-0-generic
 * fglrx (8.840)... [fail]
...

Hi darkanry,

You first need to uninstall fglrx restricted driver because it is not compatible with the new kernel.

Cheers

darkanry (richard-andrysek) wrote :

Hi Tiago,

without fglrx does not run natty GUI. I hope it will be soon somehow solved.

Roberto Marin (robertomarin) wrote :

Tiago, I love you! :)

Dàrent (animaletdesequia) wrote :

I tried the kernel and the nohwcrypt solutions but didn't work for me, so i've downloaded and installed the madwifi drivers (sorry i can't pont the website, but there's a lot of how-to's about the procedure). It was my last choice since i don't like to mess with the modules and blacklisted modules... but maybe somebody will need this workarround. Thank you all for your comments anyway. :)

Han He (upwell) wrote :

Tiago's new kernel does fix the slow problem. However, I got a new problem with the new kernel.

System hang for a while when login, and I got the following error messages in the syslog. It looks like a bug in the new kernel. Once I roll back to the old kernel, it disappeared.

kernel: [ 75.020013] ata1.00: exception Emask 0x0 SAct 0x3 SErr 0x40000 action 0x6 frozen
kernel: [ 75.020089] ata1: SError: { CommWake }
kernel: [ 75.020129] ata1.00: failed command: READ FPDMA QUEUED
kernel: [ 75.020168] ata1.00: cmd 60/08:00:20:bc:f1/00:00:36:00:00/40 tag 0 ncq 4096 in
kernel: [ 75.020168] res 40/00:01:00:00:00/00:00:00:00:00/40 Emask 0x4 (timeout)
kernel: [ 75.020227] ata1.00: status: { DRDY }
kernel: [ 75.020245] ata1.00: failed command: READ FPDMA QUEUED
kernel: [ 75.020269] ata1.00: cmd 60/08:08:88:bb:f1/00:00:37:00:00/40 tag 1 ncq 4096 in
kernel: [ 75.020270] res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
kernel: [ 75.020326] ata1.00: status: { DRDY }
kernel: [ 75.020347] ata1: hard resetting link
kernel: [ 75.369277] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
kernel: [ 75.681488] ata1.00: both IDENTIFYs aborted, assuming NODEV
kernel: [ 75.681492] ata1.00: revalidation failed (errno=-2)
kernel: [ 80.359207] ata1: hard resetting link
kernel: [ 80.708571] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
kernel: [ 80.711202] ata1.00: configured for UDMA/133
kernel: [ 80.711453] ata1.00: device reported invalid CHS sector 0
kernel: [ 80.711458] ata1.00: device reported invalid CHS sector 0
kernel: [ 80.711469] ata1: EH complete
kernel: [ 80.781582] ppdev: user-space parallel port driver
kernel: [ 80.790844] type=1400 audit(1305127912.864:18): apparmor="STATUS"

Tatyana Volkova (wolf39) wrote :

Tiago, thank you! I upgraded the kernel and everything worked!

I had a problem with fglrx though (the same as darkanry), but I used this script:
http://home.comcast.net/~ibladesi/fixfglrx.sh
from ibladesi to install ati drivers. It helped!

Ryan (ubuntu-draziw) wrote :

I added a comment in 735171.. Right now with my ath9k I'm getting ~60kb/sec. with 10.04 and 10.10 I was getting ~2-5MB/sec. I'm now download the ppa kernel (via wired connection since Natty/11.04 has crushed my wireless functionality)

Seth Forshee (sforshee) wrote :

There have been quite a few atheros bug fixes in the .38 stable kernels, so it would be good to check the most recent stable kernel to see if the bug is already fixed there. This is available at:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.38.8-natty/

Please post your results here. If it's not fixed in .38.8 then we may have to do a bisection to find out which commit fixes the issue so that it can be backported to natty.

Thanks!

Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: Confirmed → Incomplete
Robert (roband) wrote :

I tried linux-image-2.6.38-02063808-generic_2.6.38-02063808.201106040910_amd64.deb and this seems to have fixed the problem for me.

Seth Forshee (sforshee) wrote :

@Robert, great, thanks for testing. Those fixes will be included in a future natty kernel update.

Everyone else, please go ahead and test the kernel linked to in comment #17 even though Robert's results were good. It is frequently the case that there are several different issues at play, so what fixes one person's wireless may not fix everyone's.

Rob Parker (rfdparker) wrote :

I've tried the kernel from comment #17 but I'm still having the issue (connection unusably slow and most often 'dies' after a short while... but still appearing the be connected from NetworkManager's perspective - requests just sit there waiting) - I've also tried the .39 kernels from the PPA in comment #8 (and of course the normal Natty kernel).

This is on an Acer Aspire 5742G; lspci reports the wireless chipset as "03:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)". I also tried the workaround described in comments #1 and #6 with all three aforementioned kernel versions and this also appeared to have no effect. If there's any logs/reports that'd be helpful for me to provide, please let me know.

Seth Forshee (sforshee) wrote :

@Rob: If you'll attach the output of dmesg and /var/log/syslog I'll take a look at them. Make sure to collect these logs after you've been experiencing the issue.

Mark (1aunchpad-nct) wrote :

I am running 2.6.38.8 on Natty (11.04). I did nothing special to get this kernel installed. The problem is NOT fixed there. I have very slow downloads and > 10% packet loss to my router.

I tried the commands in comment #8 but apt-get dist-upgrade reports:

Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

so my kernel was not updated to 2.6.39.

I had big problems with W-LAN support in Lucid with the RT drivers so I bought a new D-LINK/Atheros card, which worked well. Then I upgraded to Maverick/Natty and wireless is broken again. Wireless support seems to be a major weak point of Linux/Ubuntu.

Seth Forshee (sforshee) wrote :

Mark: Do you have the proposed archive enabled? If not, and if you haven't done anything else special to install a kernel, then you aren't running 2.6.38.8. If you paste the output of 'uname -a' I can tell you exactly what you're running. Note that running Ubuntu kernel version 2.6.38-8.42 does not imply you are running 2.6.38.8 -- the components of the version number after the dash are specific to Ubuntu and have no direct relationship to the upstream stable version number.

Mark (1aunchpad-nct) wrote :

A kernel update came through the Ubuntu Update Manager today which has fixed the problem. I am now running, according to 'uname -a'

$ uname -a
Linux NeurosLINK 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:07:17 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

The System Monitor reports the kernel as 2.6.38-10-generic. It reported my previous kernel as 2.6.38-8-generic which I reported as 2.6.38.8 in comment #22. That kernel definitely did not fix the problem.

The changes in the 2.6.38-10 kernel include fixes to (something like) the wireless compatibility module. I am happy to report that I can now ping my router without packet loss and one test with speedtest.net gave a result of 45Mbps, the closest I have ever got to my ISP's advertised 50Mbps, though the average speed is around 32 Mbps.

I want to say a big thank you to the people who fixed this bug and enabled my HTPC to work properly again.

Seth Forshee (sforshee) wrote :

Thanks for the update, Mark.

decker: Could you please test with natty kernel version 2.6.38-10.46 that was just released to see whether your problem is fixed? Thanks!

Mark (1aunchpad-nct) wrote :

I expect it has fixed decker's problem. I have my router set in mixed WPA/WPA2 mode and I have not disabled h/w encryption via the commands decker suggested.

Seth Forshee (sforshee) wrote :

Okay, I'm just going to go ahead and set the status to fixed then. decker, if you still see problems please reopen.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
decker (schnoerkellos) wrote :

fixed in kernel 2.6.38-10.46

Brian Merkel (merkelbk) wrote :

I am running kernel 2.6.38-11-generic #48 and I am still having the slow connection error. Is there a way to downgrade to 2.6.38-10?

Evgeny Remizov (ram3ai) wrote :

For me it was almost certainly the 802.11n problem. If you have access to the router, disable it there.
If you don't, then the situation is worse. Unfortunately, ath9k hasn't got an easy way to disable it on the device (11n_disable option as some other drivers do). You may compile your own one, though: start with http://askubuntu.com/questions/18897/enable-only-802-11b-g-in-a-802-11n-in-atheros-wireless-card .

The symptoms match and the workaround at the top works. When I use the nohwcrypt option I go straight from:
an unstable connection and file transfer bars which hang randomly and then come back to life to:
a continuous 9MB wireless n connection. My wireless security model is WPA2 AES

However the kernel 2.6.38-11-generic did not fix the problem for me. I am running this kernel on 10.10 - so I'm not sure if that makes me ineligible to report.

I have AR5008 run with ath9k driver. This is a Thinkpad laptop on the AR5008 is a connected via cardbus.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers