musb driver doesn't attach on omap3

Bug #759913 reported by Paolo Pisati on 2011-04-13
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Paolo Pisati
Natty
Medium
Paolo Pisati

Bug Description

the musb device is not added to the platform bus, and thus the driver cannot attach to a non-existent device:

[flag@newluxor canonical]$ grep musb dmesg-2.6.38.txt
[ 0.332000] bus_add_driver::636 bus: 'platform': add driver musb-tusb
[ 0.382751] musb_init::2434
[ 0.382751] musb-hdrc: version 6.0, tusb-omap-dma, otg (peripheral+host), debug=0
[ 0.382781] bus_add_driver::636 bus: 'platform': add driver musb-hdrc
[ 0.382934] musb_init::2463 ret: -19

#define ENODEV 19 /* No such device */

flag@omap:~$ ls -la /sys/devices/platform/musb*
ls: cannot access /sys/devices/platform/musb*: No such file or directory

Previously it was working fine:

[flag@newluxor canonical]$ grep musb dmesg-2.6.37.txt
[ 0.000000] bus_add_device::457 bus: 'platform': add device musb_hdrc
[ 0.048736] musb_init::2488
[ 0.048767] musb_hdrc: version 6.0, musb-dma, otg (peripheral+host), debug=0
[ 0.048797] bus_add_driver::637 bus: 'platform': add driver musb_hdrc
[ 0.048919] musb_hdrc: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx, HB-ISO Tx, SoftConn)
[ 0.048919] musb_hdrc: MHDRC RTL version 1.800
[ 0.048950] musb_hdrc: setup fifo_mode 4
[ 0.048950] musb_hdrc: 28/31 max ep, 16384/16384 memory
[ 0.049133] musb_hdrc musb_hdrc: USB OTG mode controller at fa0ab000 using DMA, IRQ 92
[ 0.049224] musb_init::2517 ret: 0

flag@omap:~$ ls -la /sys/devices/platform/musb_hdrc/
total 0
drwxr-xr-x 4 root root 0 2011-04-14 12:28 .
drwxr-xr-x 40 root root 0 2011-04-14 12:28 ..
lrwxrwxrwx 1 root root 0 2011-04-14 12:29 driver -> ../../../bus/platform/drivers/musb_hdrc
drwxr-xr-x 3 root root 0 2011-04-14 12:29 gadget
-r--r--r-- 1 root root 4096 2011-04-14 12:29 modalias
-rw-r--r-- 1 root root 4096 2011-04-14 12:29 mode
drwxr-xr-x 2 root root 0 2011-04-14 12:29 power
-rw-r--r-- 1 root root 4096 2011-04-14 12:29 srp
lrwxrwxrwx 1 root root 0 2011-04-14 12:28 subsystem -> ../../../bus/platform
-rw-r--r-- 1 root root 4096 2011-04-14 12:28 uevent
-rw-r--r-- 1 root root 4096 2011-04-14 12:29 vbus

it's simply a config difference introduced in 5bfc8061 (while rebasing on 2.6.38-rc1), when USB_MUSB_TUSB6010 was picked instead of USB_MUSB_OMAP2PLUS.

With the attached patch we get musb back on omap3:

flag@omap:~$ uname -a
Linux omap 2.6.38-8-omap #42 Thu Apr 14 12:39:06 CEST 2011 armv7l GNU/Linux

flag@omap:~$ dmesg | grep musb
[ 0.360717] musb-hdrc: version 6.0, musb-dma, otg (peripheral+host), debug=0
[ 0.360870] musb-hdrc: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx, HB-ISO Tx, SoftConn)
[ 0.360870] musb-hdrc: MHDRC RTL version 1.800
[ 0.360900] musb-hdrc: setup fifo_mode 4
[ 0.360900] musb-hdrc: 28/31 max ep, 16384/16384 memory
[ 0.361083] musb-hdrc musb-hdrc: USB OTG mode controller at fa0ab000 using DMA, IRQ 92

flag@omap:~$ ls -la /sys/devices/platform/musb-omap2430/
total 0
drwxr-xr-x 4 root root 0 2011-04-14 13:03 .
drwxr-xr-x 37 root root 0 2011-04-14 13:03 ..
lrwxrwxrwx 1 root root 0 2011-04-14 13:05 driver -> ../../../bus/platform/drivers/musb-omap2430
-r--r--r-- 1 root root 4096 2011-04-14 13:05 modalias
drwxr-xr-x 4 root root 0 2011-04-14 13:03 musb-hdrc
drwxr-xr-x 2 root root 0 2011-04-14 13:05 power
lrwxrwxrwx 1 root root 0 2011-04-14 13:03 subsystem -> ../../../bus/platform
-rw-r--r-- 1 root root 4096 2011-04-14 13:03 uevent

Paolo Pisati (p-pisati) wrote :
tags: added: armel kconfig natty
Changed in linux (Ubuntu):
assignee: nobody → Paolo Pisati (p-pisati)
status: New → In Progress
Paolo Pisati (p-pisati) on 2011-04-14
description: updated
Changed in linux (Ubuntu Natty):
importance: Undecided → Medium
Tim Gardner (timg-tpi) on 2011-04-27
Changed in linux (Ubuntu Natty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.39-0.5

---------------
linux (2.6.39-0.5) oneiric; urgency=low

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: Revert "x86, hibernate: Initialize mmu_cr4_features during boot"
    - LP: #764758

  [ Leann Ogasawara ]

  * rebase to v2.6.39-rc5
  * [Config] updateconfigs following rebase to v2.6.39-rc5

  [ Paolo Pisati ]

  * [Config] s/USB_MUSB_TUSB6010/USB_MUSB_OMAP2PLUS/ on omap3 to get musb
    - LP: #759913

  [ Stefan Bader ]

  * Include nls_iso8859-1 for virtual images
    - LP: #732046

  [ Major Kernel Changes ]

  * rebase from v2.6.39-rc4 to v2.6.39-rc5
 -- Leann Ogasawara <email address hidden> Wed, 27 Apr 2011 06:39:42 -0700

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

Accepted linux into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Brad Figg (brad-figg) on 2011-05-10
tags: added: verification-needed-natty
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Paolo Pisati (p-pisati) on 2011-05-11
tags: added: verification-done
removed: verification-needed-natty
Launchpad Janitor (janitor) wrote :
Download full text (26.1 KiB)

This bug was fixed in the package linux - 2.6.38-10.46

---------------
linux (2.6.38-10.46) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #802464

  [ Upstream Kernel Changes ]

  * Revert "put stricter guards on queue dead checks"
  * Revert "fix oops in scsi_run_queue()"

linux (2.6.38-10.45) natty-proposed; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "af_unix: Only allow recv on connected seqpacket sockets."

linux (2.6.38-10.44) natty-proposed; urgency=low

  [ Steve Conklin ]

  * Release Tracking Bug
    - LP: #792013

  [ Robert Nelson ]

  * SAUCE: omap3: beagle: detect new xM revision B
    - LP: #770679
  * SAUCE: omap3: beagle: detect new xM revision C
    - LP: #770679
  * SAUCE: omap3: beagle: if rev unknown, assume xM revision C
    - LP: #770679

  [ Stefan Bader ]

  * Include nls_iso8859-1 for virtual images
    - LP: #732046

  [ Thomas Schlichter ]

  * SAUCE: vesafb: mtrr module parameter is uint, not bool
    - LP: #778043

  [ Tim Gardner ]

  * Revert "SAUCE: acpi battery -- move first lookup asynchronous"
    - LP: #775809
  * updateconfigs after update to v2.6.38.6

  [ Upstream Kernel Changes ]

  * Revert "ALSA: hda - Fix pin-config of Gigabyte mobo"
    - LP: #780546
  * Revert "[SCSI] Retrieve the Caching mode page"
    - LP: #788691
  * Revert "USB: xhci - fix unsafe macro definitions"
  * Revert "USB: xhci - fix math in xhci_get_endpoint_interval()"
  * Revert "USB: xhci - also free streams when resetting devices"
  * ath9k_hw: fix stopping rx DMA during resets
    - LP: #775809
  * netxen: limit skb frags for non tso packet
    - LP: #775809
  * ath: add missing regdomain pair 0x5c mapping
    - LP: #775809
  * block, blk-sysfs: Fix an err return path in blk_register_queue()
    - LP: #775809
  * p54: Initialize extra_len in p54_tx_80211
    - LP: #775809
  * qlcnic: limit skb frags for non tso packet
    - LP: #775809
  * nfsd4: fix struct file leak on delegation
    - LP: #775809
  * nfsd4: Fix filp leak
    - LP: #775809
  * virtio: Decrement avail idx on buffer detach
    - LP: #775809
  * x86, gart: Set DISTLBWALKPRB bit always
    - LP: #775809
  * x86, gart: Make sure GART does not map physmem above 1TB
    - LP: #775809
  * intel-iommu: Fix use after release during device attach
    - LP: #775809
  * intel-iommu: Unlink domain from iommu
    - LP: #775809
  * intel-iommu: Fix get_domain_for_dev() error path
    - LP: #775809
  * drm/radeon/kms: pll tweaks for r7xx
    - LP: #775809
  * drm/nouveau: fix notifier memory corruption bug
    - LP: #775809
  * drm/radeon/kms: fix bad shift in atom iio table parser
    - LP: #775809
  * drm/i915/tv: Remember the detected TV type
    - LP: #775809
  * tty/n_gsm: fix bug in CRC calculation for gsm1 mode
    - LP: #775809
  * serial/imx: read cts state only after acking cts change irq
    - LP: #775809
  * ASoC: Fix output PGA enabling in wm_hubs CODECs
    - LP: #775809
  * ASoC: codecs: JZ4740: Fix OOPS
    - LP: #775809
  * ALSA: hda - Add a fix-up for Acer dmic with ALC271x codec
    - LP: #775809
  * ahci: don't enable port irq before handler is registered
    - LP: #775809
  * libata: Implement ATA_FLAG_NO_...

Changed in linux (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers