[natty] plymouth on r600 drops back to text even though KMS seems to function

Bug #751615 reported by Toby Smithe on 2011-04-05
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: plymouth

It looks like grub2 sets the display mode to 1024x768, despite the panel's native resolution being 1280x800. The kernel is then loaded, and initially uses a display mode of 80x25 text rather than 1024x768 or 1280x800.

[ 0.000000] vt handoff: transparent VT on vt#7
[ 0.000000] Console: colour VGA+ 80x25
[ 0.000000] console [tty0] enabled

Subsequently, drm/radeondrmfb is initialised, and the console switches to 160x50 text:

[ 3.000866] [drm] fb mappable at 0xD0141000
[ 3.000870] [drm] vram apper at 0xD0000000
[ 3.000872] [drm] size 4096000
[ 3.000873] [drm] fb depth is 24
[ 3.000875] [drm] pitch is 5120
[ 3.473151] Console: switching to colour frame buffer device 160x50
[ 3.476071] fb0: radeondrmfb frame buffer device
[ 3.476073] drm: registered panic notifier
[ 3.476085] [drm] Initialized radeon 2.8.0 20080528 for 0000:01:00.0 on minor 0

For some reason, the mode isn't properly set to 1280x800, and so the plymouth log contains entries like those below (I've attached the full debug log). This is especially annoying, as when the console switches to 160x50 from 80x25, because the screen geometry is now effectively four times larger, the plymouth text splash is reduced to the upper left quarter of the console.

This is a regression, because plymouth worked beautifully in maverick, and also worked at the beginning of this cycle for a while; I cannot remember the software versions/packages that caused the regression.

[main.c] check_for_consoles:checking for consoles and adding displays
[main.c] check_for_consoles:There are currently 0 text displays
[main.c] add_default_displays_and_keyboard:adding default displays and keyboard
[ply-utils.c] ply_open_module:Could not load module "/lib/plymouth/renderers/x11.so": /lib/plymouth/renderers/x11.so: cannot open shared object file: No such file or directory

[./plugin.c] create_backend:creating renderer backend for device /dev/dri/card0
[./plugin.c] load_driver:Attempting to load driver '(null)'
[./plugin.c] load_driver:drmOpen failed
[ply-renderer.c] ply_renderer_open:could not open rendering device for plugin /lib/plymouth/renderers/drm.so
[./plugin.c] create_backend:creating renderer backend for device /dev/fb0
[./plugin.c] open_device:could not open '/dev/fb0': No such file or directory
[ply-renderer.c] ply_renderer_open:could not open rendering device for plugin /lib/plymouth/renderers/frame-buffer.so
[./plugin.c] open_device:could not open '/dev/fb0': No such file or directory
[ply-renderer.c] ply_renderer_open:could not open rendering device for plugin /lib/plymouth/renderers/vga16fb.so
[ply-renderer.c] ply_renderer_open:could not find suitable rendering plugin
[main.c] add_default_displays_and_keyboard:could not open renderer /dev/fb
[main.c] add_display_and_keyboard_for_terminal:adding display and keyboard for /dev/tty7
[ply-terminal.c] ply_terminal_open:trying to open terminal '/dev/tty7'
[ply-terminal.c] ply_terminal_look_up_geometry:looking up terminal text geometry
[ply-terminal.c] ply_terminal_look_up_geometry:terminal is now 80x25 text cells

Cheers

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: plymouth 0.8.2-2ubuntu21
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
CheckboxSubmission: cb8560608953d46833a1bf646e78598a
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Tue Apr 5 17:10:40 2011
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
EcryptfsInUse: Yes
MachineType: Dell Inc. Studio 1537
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-7-generic root=UUID=f5cadb34-d259-4135-a92d-f4bad690bcfc ro quiet splash vt.handoff=7 plymouth:debug
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/27/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0P132H
dmi.board.vendor: Dell Inc.
dmi.board.version: A09
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A09
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd05/27/2009:svnDellInc.:pnStudio1537:pvrA09:rvnDellInc.:rn0P132H:rvrA09:cvnDellInc.:ct8:cvrA09:
dmi.product.name: Studio 1537
dmi.product.version: A09
dmi.sys.vendor: Dell Inc.

Toby Smithe (tsmithe) wrote :
description: updated
Toby Smithe (tsmithe) wrote :

I just checked the current natty daily live cd image for amd64, and it occurs there, too.

affects: plymouth (Ubuntu) → linux (Ubuntu)
Toby Smithe (tsmithe) on 2011-04-15
tags: added: regression-release
Scott Palmer (skewty) wrote :

Similar issue with Dell E6510

/etec/default/grub contains (along with usual stuff):

GRUB_CMDLINE_LINUX_DEFAULT="drm.debug=0x4 plymouth:debug"
GRUB_GFXMODE=854x480

I also found this in my plymouth log entry in /var/log

[ply-utils.c] ply_open_module:Could not load module "/lib/plymouth/renderers/x11.so": /lib/plymouth/renderers/x11.so: cannot open shared object file: No such file or directory

Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
Peter Wu (lekensteyn) wrote :

This bug seems to be related to https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/770371 (actually, that bug is related to a kernel bug)
In that case, the intel driver (i915) wasn't loaded before plymouth, here, it looks like the radeon (?) driver wasn't loaded before.

The message in post #3 by skewty is harmless and also occurs on machines with a working plymouth splash. The problematic line is:

[./plugin.c] load_driver:Attempting to load driver '(null)'

See also https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/770371/comments/3

Toby Smithe (tsmithe) wrote :

Hi everyone,

I've just upgraded to oneiric, and this is still presenting as a problem. What Lekensteyn says is interesting, and the driver still doesn't seem to be loaded even if the radeon driver is explicitly included in the initramfs modules.

Toby Smithe, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

tags: added: needs-upstream-testing
tags: added: oneiric
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/751615

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers