Ubuntu

SATA 3.0 port&IDE mode: Cannot Detect DVD Drive

Reported by etnba on 2011-03-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hi All,

 I meet a problem in Ubuntu 10.10(Marevrick). This problem exists on Ubuntu 11.4(Natty), too.
Ubuntu can't detected DVD drive when I plug a DVD drive to SATA 3.0 port and set SATA controlloer to IDE mode.
If I plug the DVD drive to SATA 2.0 port and set SATA controlloer to IDE mode, the DVD drive can be detected.
If I plug the DVD drive to SATA 3.0 port and set SATA controlloer to AHCI mode, the DVD drive can be detected, too.

If I use the setting to install Ubuntu, I will get the message 'no common cd-rom drive was detecte'.

I use live usb to collect some logs. Of course, When I ues live usb, the DVD drive can't be detected, too.

I use the same setting to install RHEL 6.0 and it works fine. This bug doesn't exist in RHEL6.0

Any ideas to fix it?

Thanks

etnba (g9417717) wrote :
etnba (g9417717) wrote :
etnba (g9417717) wrote :
etnba (g9417717) wrote :
etnba (g9417717) wrote :

Can I remove the attachment #1 and #2? I upload the wrong files.

description: updated
etnba (g9417717) wrote :

the correct dmesg.log

etnba (g9417717) wrote :

the correct lspci-vnvn.log

etnba (g9417717) wrote :

the major messages form dmesg.log

[ 1.739662] ata_piix 0000:00:1f.2: version 2.13
[ 1.739692] ata_piix 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[ 1.739813] ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
[ 1.894822] ata_piix 0000:00:1f.2: setting latency timer to 64
[ 1.894900] scsi0 : ata_piix
[ 1.895093] scsi1 : ata_piix
[ 1.896558] ata1: SATA max UDMA/133 cmd 0x3098 ctl 0x30ac bmdma 0x3070 irq 19
[ 1.896679] ata2: SATA max UDMA/133 cmd 0x3090 ctl 0x30a8 bmdma 0x3078 irq 19
[ 1.896836] ata_piix 0000:00:1f.5: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 1.896968] ata_piix 0000:00:1f.5: MAP [ P0 -- P1 -- ]
[ 2.050371] ata_piix 0000:00:1f.5: setting latency timer to 64
[ 2.050450] scsi2 : ata_piix
[ 2.050619] scsi3 : ata_piix
[ 2.051460] ata3: SATA max UDMA/133 cmd 0x3088 ctl 0x30a4 bmdma 0x3050 irq 21
[ 2.051579] ata4: SATA max UDMA/133 cmd 0x3080 ctl 0x30a0 bmdma 0x3058 irq 21
[ 2.411524] ata3: SATA link down (SStatus 0 SControl 300)
[ 2.959887] ata2.00: failed to resume link (SControl 0)
[ 3.119805] ata4: failed to resume link (SControl 0)
[ 3.131304] ata4: SATA link down (SStatus 4 SControl 0)
[ 3.299715] ata1.01: failed to resume link (SControl 0)
[ 3.321094] ata2.00: SATA link down (SStatus 4 SControl 0)
[ 3.321227] ata2.01: SATA link down (SStatus 0 SControl 300)
[ 3.459693] ata1.00: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 3.459834] ata1.01: SATA link down (SStatus 4 SControl 0)
[ 3.459971] ata1.01: link offline, clearing class 3 to NONE
[ 3.479771] ata1.00: ATAPI: HL-DT-ST DVDRAM GH22NS40, NL02, max UDMA/100
[ 3.519751] ata1.00: configured for UDMA/100
[ 8.517024] ata1.00: qc timeout (cmd 0xa0)
[ 8.517125] ata1.00: TEST_UNIT_READY failed (err_mask=0x4)
[ 9.936295] ata1.01: failed to resume link (SControl 0)
[ 10.096289] ata1.00: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 10.096410] ata1.01: SATA link down (SStatus 4 SControl 0)
[ 10.096524] ata1.01: link offline, clearing class 3 to NONE
[ 10.127758] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x2)
[ 10.127866] ata1.00: revalidation failed (errno=-5)
[ 10.127970] ata1.00: limiting SATA link speed to 1.5 Gbps
[ 16.512919] ata1.01: failed to resume link (SControl 0)
[ 16.672899] ata1.00: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[ 16.673020] ata1.01: SATA link down (SStatus 4 SControl 0)
[ 16.674733] ata1.01: link offline, clearing class 3 to NONE
[ 16.732949] ata1.00: configured for UDMA/100
[ 21.730244] ata1.00: qc timeout (cmd 0xa0)
[ 21.730353] ata1.00: TEST_UNIT_READY failed (err_mask=0x4)
[ 21.730457] ata1.00: disabled
[ 21.730567] ata1.00: hard resetting link
[ 22.080061] ata1.01: hard resetting link
[ 23.149510] ata1.01: failed to resume link (SControl 0)
[ 23.309488] ata1.00: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[ 23.309608] ata1.01: SATA link down (SStatus 4 SControl 0)
[ 23.309722] ata1.01: link offline, clearing class 3 to NONE
[ 23.309725] ata1: EH complete
[ 23.310136] Write protecting the kernel read-only data: 10240k

Phillip Susi (psusi) wrote :

Is that a log of Ubuntu with the controller in IDE mode? Can you get a log where IDE mode works in RHEL?

As for how to fix it, well, you already found it: use AHCI mode. This is the preferred, native mode.

Changed in linux (Ubuntu):
status: New → Incomplete
etnba (g9417717) wrote :

For my work, I must use the SATA 3.0 port in IDE mode so I should try to fix it.

Attachment #1 and #2 are not in IDE mode. Please use attachment #8 and #9.

I set many boot option to fix this but it is in vain.

The RHEL_lspc.logi is the lspci log under RHEL 6.0 (Kernel: 2.6.32)
The RHEL_dmesg.logi is the dmesg log under RHEL 6.0 (Kernel: 2.6.32)

etnba (g9417717) wrote :
Phillip Susi (psusi) wrote :

Please attach the COMPLETE logs of rhel and ubuntu booting in ide mode. That one it looks like it is still driving it in SATA mode. Also why do you have to use it in IDE mode? That mode is for compatibility with old operating systems without AHCI drivers.

Phillip Susi (psusi) wrote :

Also could you try adding this to your kernel command line:

libata.force=1:nohrst

etnba (g9417717) wrote :

I add this to the kernel commane line:

file=/cdrom/preseed/ubuntu-server.seed vga=788 initrd=/install/initrd.gz libata.force=1:nohrst

The DVD drive still can't be detected.

You can double confirm that I set SATA controller to IDE mode via ub_lspci.log.

00:1f.2 IDE interface [0101]: Intel Corporation Cougar Point 4 port SATA IDE Controller [8086:1c00] (rev 04) (prog-if 8f [Master SecP SecO PriP PriO])

Thanks for your help.

etnba (g9417717) wrote :
etnba (g9417717) wrote :
etnba (g9417717) wrote :
etnba (g9417717) wrote :

The logs of Ubuntu: Ub_lspci.log and Ub_dmesg.log
The logs of RHEL6.0: RHEL60_dmesg.log and RHEL60_lspci.log

I should make sure the integrity of our product so that we can tell our customer that we can install ubuntu in any mode.

Thanks

etnba (g9417717) on 2011-03-23
description: updated
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Ming Lei (tom-leiming) wrote :

Please try the patch[1] to see if it can fix your problem:

[1], https://bugzilla.kernel.org/attachment.cgi?id=69612
[2], https://bugs.launchpad.net/bugs/794642

Launchpad Janitor (janitor) wrote :
Download full text (10.3 KiB)

This bug was fixed in the package linux - 3.1.0-1.1

---------------
linux (3.1.0-1.1) precise; urgency=low

  [ Andiry Xu ]

  * SAUCE: (drop during 3.2 merge) xHCI: AMD isoc link TRB chain bit quirk
    - LP: #872811

  [ Andy Whitcroft ]

  * Revert "ubuntu: compcache -- follow changes to bd_claim/bd_release"
    - LP: #832694
  * Revert "ubuntu: compcache -- version 0.5.3"
    - LP: #832694
  * [Config] standardise CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP=m
  * [Config] Enable CONFIG_MACVTAP=m
    - LP: #822601
  * record the compiler in the ABI and check for inconsistant builds
  * [Config] move ECRYPT_FS back to =y for all architectures
    - LP: #827197
  * [Config] enable CONFIG_DRM_VMWGFX=m
    - LP: #698009
  * [Config] re-fix ECRYPT_FS=y
    - LP: #827197
  * enforcer -- ensure we have CONFIG_ECRYPT_FS=y
    - LP: #827197
  * [Config] dropping compcache configuration options
  * [Config] standardise on HZ=250
  * SAUCE: headers_install: fix #include "..." usage for userspace
    - LP: #824377
  * make module-inclusion selection retain the left overs
  * add a new linux-image-extras package for virtual

  [ Colin Watson ]

  * Deliver more Atheros, Ralink, and iwlagn NIC drivers to d-i

  [ edwin_rong ]

  * SAUCE: Staging: add driver for Realtek RTS5139 cardreader
    - LP: #824273

  [ Greg Kroah-Hartman ]

  * SAUCE: staging: rts5139: add vmalloc.h to some files to fix the build.
    - LP: #824273

  [ Jesse Sung ]

  * SAUCE: Unregister input device only if it is registered
    - LP: #839238

  [ Jiri Kosina ]

  * SAUCE: HID: add MacBookAir4, 2 to hid_have_special_driver[]

  [ Joshua V. Dillon ]

  * SAUCE: HID: add support for MacBookAir4,2 keyboard.

  [ Kees Cook ]

  * [Config] enable and enforce SECCOMP_FILTER on x86

  [ Keng-Yu Lin ]

  * [Config] Enable CONFIG_RTS5139=m on i386/amd64
    - LP: #824273

  [ Leann Ogasawara ]

  * Revert "ubuntu: overlayfs -- ovl: make lower mount read-only"
  * Revert "ubuntu: overlayfs -- fs: limit filesystem stacking depth"
  * Revert "ubuntu: overlayfs -- ovl: improve stack use of lookup and
    readdir"
  * Revert "ubuntu: overlayfs -- ovl: fix overlayfs over overlayfs"
  * Revert "ubuntu: overlayfs -- overlayfs: implement show_options"
  * Revert "ubuntu: overlayfs -- overlayfs: add statfs support"
  * Revert "ubuntu: overlayfs -- overlay filesystem"
  * Revert "ubuntu: overlayfs -- overlay: overlay filesystem documentation"
  * Revert "SAUCE: ARM: OMAP: Add macros for comparing silicon revision"
  * Revert "SAUCE: OMAP: DSS2: check for both cpu type and revision, rather
    than just revision"
  * Revert "SAUCE: OMAP: DSS2: enable hsclk in dsi_pll_init for OMAP36XX"
  * Revert "ubuntu: fsam7400 disable driver"
    - LP: #876030
  * rebase to v3.1-rc1
  * [Config] updateconfigs after rebase to v3.1-rc1
  * rebase to v3.1-rc2
  * [Config] Updateconfigs after rebase to v3.1-rc2
  * ubuntu: Yama - update calls to generic_permission() and
    inode->i_op->permission()
  * ubuntu: ndiswrapper -- remove netdev_priv macro
  * ubuntu: aufs -- Temporarily disable due to build failure
  * [Config] Diable INTEL_MID_PTI on armel
  * [Config] Temporarily disable CONFIG_FTMAC100 on armel
  * [Conf...

Changed in linux (Ubuntu):
status: Expired → Fix Released
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel 3.0.0-13.21 for oneiric in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Herton R. Krzesinski (herton) wrote :

This bug was not verified, but the patch which fixes this issue is verified on two other reports (bugs 782386, 794642). Thus the patch will not be reverted, and I'll mark this bug as verified. In case this bug isn't fixed by kernel 3.0.0-13.21, please report here.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel for Natty in -proposed solves the problem (2.6.38-13.53). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-natty' to 'verification-done-natty'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-natty
Herton R. Krzesinski (herton) wrote :

This bug was not verified on Natty, but the patch which also fixes this issue is verified on two other reports on Natty already (bugs 782389, 794642). Thus the patch will not be reverted, and I'll mark this bug as verified. In case this bug isn't fixed by kernel 2.6.38-13.53, please report here.

tags: added: verification-done-natty
removed: verification-needed-natty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers