Ubuntu

[Lenovo G550] Alps touchpad detected, but scrolling not working

Reported by Frantique on 2011-03-17
420
This bug affects 83 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Before the 2.6.38 kernel the touchpad was not detected at all. Now it is, but the vertical scrolling still not working.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-generic-pae 2.6.38.7.21
Regression: Yes
Reproducible: No
ProcVersionSignature: Ubuntu 2.6.38-7.35-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: attila 1359 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf4700000 irq 47'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aac001,00100000'
   Controls : 16
   Simple ctrls : 8
CheckboxSubmission: ecd19ca3a26f16a98d11e3f4a3b2e429
CheckboxSystem: 3e53d3ea5811723345f19eff5070f9ab
Date: Thu Mar 17 19:52:02 2011
Frequency: Once a day.
HibernationDevice: RESUME=UUID=d1872416-3a66-4ee3-b334-8f13a3d46fe5
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: LENOVO 20023
ProcEnviron:
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic-pae root=UUID=0a3a6dbd-b652-474e-83f6-d4d1a022b8a3 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-7-generic-pae N/A
 linux-backports-modules-2.6.38-7-generic-pae N/A
 linux-firmware 1.48
SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-02-21 (23 days ago)
dmi.bios.date: 05/21/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 18CN46WW(V2.55)
dmi.board.name: NITU1
dmi.board.vendor: LENOVO
dmi.board.version: REFERENCE
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLENOVO:bvr18CN46WW(V2.55):bd05/21/2010:svnLENOVO:pn20023:pvrLenovoG550:rvnLENOVO:rnNITU1:rvrREFERENCE:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: 20023
dmi.product.version: Lenovo G550
dmi.sys.vendor: LENOVO

Frantique (undernetangel) wrote :
Bram Bonné (brambonne) on 2011-04-03
Changed in linux (Ubuntu):
status: New → Confirmed
Chris Villa (chrisvxd) wrote :

Using the below command, you can tell Ubuntu to treat it as a PS/2 mouse with a scroll wheel:

echo "options psmouse proto=imps"|sudo tee -a /etc/modprobe.d/psmouse.conf; sudo modprobe -r psmouse; sudo modprobe psmouse

(Thank you help.ubuntu.com)

Frantique (undernetangel) wrote :

@Chris Villa: Tried that already, but it has no effect. (None of the proto options, tested all of them.)

Same on HP mini 311 with ALPS touchpad. In 10.10 it wasn't detected as touchpad, but scrolling worked.

Davide (dspinell) wrote :

Same on acer aspire 1830t. I have ALPS touchpad that is correctly detected. The Touchpad tab exists in System Settings > Mouse, but vertical and horizontal scrolling do not work

Davide (dspinell) wrote :

To complete post #5: I am running ubuntu 11.04 beta 2

pittipatti (pittipatti) wrote :

I'm seeing the same issues on a Dell E4300 using Kubuntu 11.04.
All settings have no effect on the touchpad behaviour.
Interesingly after awaking from suspend to ram the settings get set and e.g. vertical scrolling works.

Davide (dspinell) wrote :

In my case vertical scrolling does not work after awaking from suspend

Marking as regression since this used to work on older Ubuntu versions.

summary: - Alps touchpad detected, but scrolling not working
+ [regression] Alps touchpad detected, but scrolling not working

Two-finger scrolling and middle button emulation isn't working too.

gescheit (gescheit) wrote :

On Dell latitude e4200 scrolling dont work after suspend. After rmmod and modprobe psmouse - scroll start working. Twofinger scroll and middle button emulation not work.

Frantique (undernetangel) wrote :

@gescheit: Cannot confirm this for Lenovo G550. Still stucked on detecting the Alps, but not working as it should.

We need more info on this issue. Gescheit, can you post some more info, eventually about what processes ran after the wake up?

Peter M. Clausen (pclausen) wrote :

On my very old Dell Lattitude D505 I do have scrolling in the beginning, but kind of like gescheit, after a while (my laptop is often on a very long time, say more days) it looses the ability to scroll and more importantly middle button (right and left simultaneously).

I'm running Natty 11.04 (32-bit), everything default. Before (from 8.04 - 10.10) I had no problems.

The only thing I found strange is the massive amount of errors in Xorg.0.log:

[ 46965.116] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

$ cat /var/log/Xorg.0.log | grep FBIOPUTCMAP | wc -l
287039

gescheit (gescheit) wrote :

Scroll dont work after getting(or putting) notebok from(to) dockstation.
dmesg only show this:
[15327.810147] usb 1-3: USB disconnect, address 11
[15327.810653] usb 1-4: USB disconnect, address 12

Peter M. Clausen (pclausen) wrote :

@gescheit: I cant reproduce the log that you've inserted but I can confirm the problem could arise from the docking station, which I am also using (because recharging with cable only does not work anymore - as I said; it's an old, but good laptop).

Peter M. Clausen (pclausen) wrote :

I'm not sure if it helps, but I now found this in /var/log/syslog

May 2 01:23:40 laptop1104 kernel: [ 9122.079634] psmouse.c: GlidePoint at isa0060/serio1/input0 lost sync at byte 1
May 2 01:23:40 laptop1104 kernel: [ 9122.080465] psmouse.c: GlidePoint at isa0060/serio1/input0 lost sync at byte 1
May 2 01:23:40 laptop1104 kernel: [ 9122.081724] psmouse.c: GlidePoint at isa0060/serio1/input0 lost sync at byte 1
May 2 01:23:40 laptop1104 kernel: [ 9122.137656] psmouse.c: GlidePoint at isa0060/serio1/input0 lost sync at byte 1
May 2 01:23:40 laptop1104 kernel: [ 9122.138686] psmouse.c: GlidePoint at isa0060/serio1/input0 lost sync at byte 1
May 2 01:23:40 laptop1104 kernel: [ 9122.138693] psmouse.c: issuing reconnect request

Ubuntuser (ubuntuser1404) wrote :

Scrolling is not working on Netbook Acer aspire one D260 ...

This bug seems to be related to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550625 . Its description says the patch was reverted but actually for me the upgrade to natty broke scrolling and middle mouse button emulation. Is this bug an upstream issue?

David Burrows (snadge) wrote :

Aspire One D260, also no vertical scrolling or middle click. :/

Scrolling works with workaround from #2(but it recognized as mouse, like in 10.10), middle button emulation can be enabled in gpointing-device-settings.

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
funicorn (funicorn) wrote :

echo "options psmouse proto=imps"|sudo tee -a /etc/modprobe.d/psmouse.conf;
sudo modprobe -r psmouse; sudo modprobe psmouse

works like a charm !

funicorn (funicorn) wrote :

well, the bad news is, the touchpad menu in the "gnome-mouse-properties" is gone.
And I lost the support of syndaemon, which means touchpad restarts to make trouble
when typing. The same nightmare in Ubuntu 10.10 is back.

Frantique (undernetangel) wrote :

@funicorn: Cannot confirm this. After modprobing with proto=imps the input device identifies as PS/2 Generic Mouse, but still no scrolling.

Thiago Lopes (th-slopes) wrote :

Same on HP Pavilion DV5. My touchpad that is correctly detected. The touchpad tab exists in System Settings > Mouse, but vertical and horizontal scrolling do not work.

Simbav (simbav) wrote :

Same problem.
Before the 2.6.38 kernel the touchpad was not detected at all. Now it is, but the vertical scrolling still not working.
Sony vpceb4joe Alps touchpad

Luca Pireddu (pireddu) wrote :

I'm experiencing this problem on a Sony Vaio vpcsb, which has a "AlpsPS/2 ALPS GlidePoint".

What I've understood so far is that the kernel creates two input devices for the touchpad. In `/proc/bus/input/devices` I have two devices with the same Bus, Vendor, an Product: a PS/2 mouse and the touchpad.

 I: Bus=0011 Vendor=0002 Product=0008 Version=0000
 N: Name="PS/2 Mouse"
 P: Phys=isa0060/serio1/input1
 S: Sysfs=/devices/platform/i8042/serio1/input/input8
 U: Uniq=
 H: Handlers=mouse1 event8
 B: PROP=0
 B: EV=7
 B: KEY=70000 0 0 0 0
 B: REL=3

 I: Bus=0011 Vendor=0002 Product=0008 Version=7326
 N: Name="AlpsPS/2 ALPS GlidePoint"
 P: Phys=isa0060/serio1/input0
 S: Sysfs=/devices/platform/i8042/serio1/input/input9
 U: Uniq=
 H: Handlers=mouse2 event9
 B: PROP=0
 B: EV=b
 B: KEY=420 70000 0 0 0 0
 B: ABS=1000003

Xorg sees both of them. `xinput -list` gives:

 ⎡ Virtual core pointer id=2 [master pointer (3)]
 ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
 ⎜ ↳ PS/2 Mouse id=12 [slave pointer (2)]
 ⎜ ↳ AlpsPS/2 ALPS GlidePoint id=13 [slave pointer (2)]

*But*, and herein lies the problem, only the PS/2 mouse generates events. Using `xinput -test` with device 12

 motion a[0]=326 a[1]=224
 motion a[0]=322 a[1]=219
 motion a[0]=314 a[1]=205

Device 13 (the touchpad) on the other hand doesn't generate any events.

Xorg loads the synaptics module, I can configure its properties with synclient, the KDE synaptiks application shows me that it sees the touchpad and can configured it. Its events however get re-routed to the mouse device.

BrokenKingpin (brokenkingpin) wrote :

I have the same issue with my Acer 532h. On the old Ubuntu release it was treated as a PS2 mouse with no touchpad options, and now it is treated as a touchpad with no scrolling. The fix to set it as IMPS is horrible because you do not get the touchpad features like disabling touchpad will typing (which is a must have feature).

Lee Walsh (lee-walsh) wrote :

scroll doesn't work on Acer Aspire One 533 when Ubuntu 11.04 is installed or when running live cd.

the ps/2 comment allows me to scroll, but I'm unable to deactivate the touchpad while typing, which is a most have.

naught101 (naught101) wrote :

Funicorn's workaround also works for me (although it's technically a regression). But it appears to make external usb mice very jerky - eg. 3-4 fps or something, basically unusable. This basically means I have to choose between being able to scroll on my trackpad, or use an external mouse, but not both.

jmilhomens (joao-milhomens) wrote :

I'm on a Compaq mini 311, and also lost touchpad scroll and middle button emulation when upgrading from Maverick.

Lee Walsh (lee-walsh) wrote :

synaptic update installed today 16 June 2011 --- xserver-xorg-input-synaptics (1.3.99+git200110116.0e27ce3a-0ubuntu12).

This has still not solved the scroll bar or disable pad while typing issues.

Any ideas anyone?

Luca Pireddu (pireddu) wrote :

The last entry in the changelog says:
  * Drop libxtst-dev build dependency so syndaemon does not use XRecord,
    preventing a wide range of crashes in _CallCallbacks. (LP: #774978)

So it doesn't look like the change was addressing this issue.

arsenix (arsenix) wrote :

Another user commented that he fixed this issue on his machine by recompiling the psmouse module without two finger scrolling support.

Post #224: http://ubuntuforums.org/showthread.php?t=1388164&page=23

Have not had a chance to test this yet, worth a shot for users experiencing this problem though.

Luca Pireddu (pireddu) wrote :

I just tried the patched module posted on that thread. It doesn't solve the problem on my system (Vaio vpcsb) :-( The result seems comparable to loading the default psmouse module with the option "proto=exps" or "proto=imps". The touchpad is detected as a simple mouse and the vertical scrolling works, but none of the other features work.

Tymur Lavreniuk (tml605) wrote :

Acer Aspire One 753, Ubuntu 11.04 x64, kernel 2.6.39. AlpsPS/2 ALPS GlidePoint
Same problem, no touchpad acts as mouse.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
psymole (a-apitz) wrote :

Funicorn Any ideas on How to reverse the changes from post 23 if need.
Any other posts on how to try and fix it, my company is deploying 57 Acer aspire One mod 532h ubuntu 11.04 laptops with the same problem

Davide (dspinell) wrote :

any update/temporary work around?

shark (weltepe) wrote :

Same problem on the Acer Aspire One D255 netbook. Workaround in comment #2 works (vertical scrolling enabled now), but as noted in another comment this means that gnome-mouse-properties no longer shows the tab for touchpad settings.

jpcote (jp-cotegraphiste) wrote :

On a Acer Aspire One ZG5 with Ubuntu 11.04. I had the touch pad not working first. This make it work :
gconftool-2 --set --type boolean /desktop/gnome/peripherals/touchpad/touchpad_enable true (after boot)
But then the vertical scolling wasn't working until, this is strange, but I report what happen, after i installed Chromium. Can't see anything else! Maybe it's something else... it should be, but, if someone get the same result I am not crazy. Hopefully someone will confirm.

Archimedes (8-ich) wrote :

jpcote: Are you referring to chromium-bsu or chromium-browser? Though installing a specific application not related to the input system shouldn't change anything at all. And that is what I observed (logged in, opened terminal, changed touchpad_enable to true and did an apt-get install chromium-browser -- after this it didn't work).
Maybe you did something else which wasn't applied until the package management performed some configuration updates?

Archi (who has a hard time not rantig about such an annoying bug not being fixed for several months -.-')

Davide (dspinell) wrote :

It is more than annoying: for example I use ipe (vector graphics) and without scrolling I cannot zoom which makes the app pretty much unusable. Also the active cursor while typing is a nightmare.

To be honest I would expect a bug like this to be fixed a bit faster

Luca Pireddu (pireddu) wrote :

+1

This bug affects my Sony Vaio E Series Laptop VPC-EH14FM running ubuntu 11.04 64-bit (Natty Narwhal)

Please let me know what I can do to assist. Thank you!

The same is true for ubuntu oneiric 64bit on a sony vaio e-series, eb4c.
if any logs are needed, i can provide them.

MikeRich (bigmeanmikerich) wrote :

ALPS device is also partially broken on HP dm4-2070us with Ubuntu 11.04, 32-bit, latest kernel. Vertical and Horizontal Scroll do not work, and there is no way to disable tap-clicking. Will provide any logs that will be helpful.

Kyle Meier (kyle-honda-rider) wrote :

My Sony Vaio VPCEE3WFX is having this issue. The ALPS touchpad is recognized in the xlist and the touchpad tab shows up in the mouse options. There is no vertical or horizontal scrolling, and the two finger scroll is not functioning either. The proto=imps does not work. I´m looking forward to a solution.

This problem is the same in Google Chromium OS, Linux Mint, Ubuntu 11.04, and Ubuntu 11.10

Andrés Silva (andres-silva-m) wrote :

Same for me. I am using Xubuntu 11.04 64 bits in Acer Aspire 5542-1072 and the vertical scrolling doesn't work.

Hemanti (henrikmarcel) wrote :

I'm experiencing the same issue using a HP dm4-2000sg. Neither in Natty nor Oneiric does scrolling work while in gpointing-devices both the touchpad (called "AlpsPS/2 ALPS GlidePoint") and a PS/2 mouse show up, but no settings in the touchpad section work. Not even disabling it. The workaround found in comment #2 doesn't work for me, unfortunately.

mdbarton (mrmdbarton) wrote :

@funicorn: Acer D260 - fixed - thank you!

Frantique (undernetangel) wrote :

Still not fixed. The situation remained unchanged in my case.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for someone affected by this to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

Leon van der Ree (lvanderree) wrote :

I installed the latest upstream kernel on 11.10.

I don't need the options psmouse proto=imps anymore to make scrolling work.

However the control panel still does not show multi-touch (two-finger scrolling) and it does not recognize handpalms yet.

tags: removed: needs-upstream-testing

lvanderree, may be touchpad doesn't support multitouch?

Leon van der Ree (lvanderree) wrote :

Jep it does, I am now using the patch from here: http://people.canonical.com/~sforshee/alps-touchpad/ and even though it isn't pefrect yet, multitouch scrolling is working now!

Oleg German (oleg-german) wrote :

using this packege
http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.10/psmouse-alps-dkms_0.10_all.deb
multitouch scrolling- works
acceleration setting - works
sensitivity setting - doesn't work

R Wankar (rwankar) wrote :

I too can confirm that this works on 11.04 and 11.10. One thing I'd like to add is that the touchpad is not disabled while typing. It'd be great if this was fixed.

Michael Berg (jaykaycgn) wrote :

The Patch from #56 does not work on Lenovo Ideapad Z360.
Scrolling is not working at all. Also, this Patch removed my Alps-Device from the xinput-list.

All Touchpad actions come from the PS2-Mouse Thing

Input driver version is 1.0.1
Input device ID: bus 0x11 vendor 0x2 product 0x1 version 0x0
Input device name: "PS/2 Generic Mouse"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
Testing ... (interrupt to exit)
Event: time 1320162124.624633, type 2 (Relative), code 0 (X), value 1
Event: time 1320162124.624634, type 2 (Relative), code 1 (Y), value 1
Event: time 1320162124.624635, -------------- Report Sync ------------
Event: time 1320162124.701168, type 2 (Relative), code 0 (X), value 1
Event: time 1320162124.701170, type 2 (Relative), code 1 (Y), value -1
Event: time 1320162124.701171, -------------- Report Sync ------------
Event: time 1320162124.740889, type 2 (Relative), code 0 (X), value 1
Event: time 1320162124.740891, -------------- Report Sync ------------
Event: time 1320162124.780508, type 2 (Relative), code 0 (X), value 1
Event: time 1320162124.780510, -------------- Report Sync ------------
Event: time 1320162124.818391, type 2 (Relative), code 0 (X), value 1
Event: time 1320162124.818393, -------------- Report Sync ------------
Event: time 1320162124.859271, type 2 (Relative), code 0 (X), value 1
Event: time 1320162124.859273, -------------- Report Sync ------------

Michael Berg (jaykaycgn) wrote :

How can i get the device back in the output of `xinput list`?
uninstalling of this package from #56 didn't work

Installed the deb from #57 and I can confirm that both two finger and edge scrolling is now working. Thanks a lot for this! Didn't try any other settings.

sir4taye (sir4taye-gmail) wrote :

Found this bug through ubuntuforums and post #57's link fixed my alps touchpad no scroll issue. Thanks
Lenovo G550 Ubuntu 11.10 fresh install

Davide (dspinell) wrote :

The fix from #57 fixed my alps touchpad on Ubuntu 11.10 64bit

I can also confirm that solution mentioned in #56 or #57 worked for me (HP dv5).

Jeroen Ost (jeroen-ost-8) wrote :

Me too I confirm that the patch from #57 works on Sony Vaio VPC-F13M1E.
Contrary to what is written in #58 "Disable touchpad while typing" works as well. Also 3 button emulation, all scrolling options - perfect.
Been waiting a long time for this, thanks a lot.

Frantique (undernetangel) wrote :

I can confirm as well. The patch should be included in the next official update of Ubuntu.

Rand Brittain (randbrittain) wrote :

The driver from #57 fixes most of my problems on my VAIO, but it still occasionally gets into a mood where it acts strangely, sending my pointer in the opposite direction from where I was going when I move my finger or being otherwise weird. In general this driver is an improvement, though.

Diska (discardi-nicola) wrote :

installing the .deb enable the edge but not two finger .

 Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Mouse id=11 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]

Parameter settings:
    LeftEdge = 300
    RightEdge = 1700
    TopEdge = 210
    BottomEdge = 1190
    FingerLow = 12
    FingerHigh = 14
    FingerPress = 127
    MaxTapTime = 180
    MaxTapMove = 107
    MaxDoubleTapTime = 180
    SingleTapTimeout = 180
    ClickTime = 100
    FastTaps = 0
    EmulateMidButtonTime = 75
    EmulateTwoFingerMinZ = 139
    EmulateTwoFingerMinW = 7
    VertScrollDelta = 48
    HorizScrollDelta = 48
    VertEdgeScroll = 0
    HorizEdgeScroll = 0
    CornerCoasting = 0
    VertTwoFingerScroll = 1
    HorizTwoFingerScroll = 1
    MinSpeed = 1
    MaxSpeed = 1.75
    AccelFactor = 0.0819336
    TrackstickSpeed = 40
    EdgeMotionMinZ = 14
    EdgeMotionMaxZ = 79
    EdgeMotionMinSpeed = 1
    EdgeMotionMaxSpeed = 195
    EdgeMotionUseAlways = 0
    TouchpadOff = 0
    LockedDrags = 0
    LockedDragTimeout = 5000
    RTCornerButton = 2
    RBCornerButton = 3
    LTCornerButton = 0
    LBCornerButton = 0
    TapButton1 = 1
    TapButton2 = 3
    TapButton3 = 2
    ClickFinger1 = 1
    ClickFinger2 = 1
    ClickFinger3 = 1
    CircularScrolling = 0
    CircScrollDelta = 0.1
    CircScrollTrigger = 0
    CircularPad = 0
    PalmDetect = 0
    PalmMinWidth = 10
    PalmMinZ = 99
    CoastingSpeed = 20
    CoastingFriction = 50
    PressureMotionMinZ = 14
    PressureMotionMaxZ = 79
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    ResolutionDetect = 1
    GrabEventDevice = 1
    TapAndDragGesture = 1
    AreaLeftEdge = 0
    AreaRightEdge = 0
    AreaTopEdge = 0
    AreaBottomEdge = 0

sony vaio VPCEB1Z1E. touchpad is multitouch

Diska (discardi-nicola) wrote :

sorry ubuntu 11.10 64 bit

Peter Schachte (schachte) wrote :

I installed the .deb from comment #57, but it disabled the trackpad altogether, leaving the touchpoint as the only functioning mouse device. Before installing the .deb, and after uninstalling it, the trackpad is treated like a PS/2 mouse. With the .deb installed, xinput recognized the device as a "AlpsPS/2 ALPS DualPoint TouchPad", but showed its status as disabled. Using xinput set-prop to enable it was just ignored (no error message, but it stayed disabled). I'm attaching the output of xinput list-props.

This is on a Dell Latitude E6420, on Ubuntu 11.10 64-bit, kernel 3.0.0-15-generic.

Peter Schachte (schachte) wrote :

Further to comment #70, I'm attaching the output of the alps-reg-dump program from the site referred by comment #56 for my Dell Latitude E6420. I just ran the program for a while, and killed it after it had just produced 0s for a while. I hope it's helpful. I'm happy to run other tests or try other experiments if it will help.

luigi massa (info-luigi-massa) wrote :

After installation of patch .deb, alps is recognized.
But Vertical scrolling doesn't work, Horizontal ok.

My pc is:
Dell Latitude E6510 with ubuntu 11.10 64bit.

Like comment #70, the .deb didn't work on Ubuntu 11.10 64-bit, kernel 3.0.0-15-generic. It did work when using the 3.0.0-14 kernel.

HP DM4-2191US

Sorry, disregard my comment on #73. I forgot to install the header files that time. After installing, it works like in 3.0.0-14 (but without the backlight-off problem when the screen fades when locked)!

John Felso (felso) wrote :

The .deb (psmouse-alps-dkms_0.10_all.deb) worked on my Dell E6510 with the exception of the Pointer Speed settings. I don't care much about those settings anyway. The fact that I can now type without accidentially tapping the touchpad is a HUGE relief.

Thank you, thank you, thank you!

John Felso (felso) wrote :

Actually, the pointer speed settings work too! (At least accelleration does.) Awesome.

Error (tomasz-wiszkowski) wrote :

** Before you post your comment **

1) Please read the following statement, if you have problems with ALPS touchpad:

http://pj.freefaculty.org/blog/alps-touchpad-linux-final-statement-now

2) Please remember this is a bug tracking system and it's meant for bug reporting and tracking; please consider sending thank you notes directly to the maintainers rather than everyone subscribed to the bug.

Thank you.

David Gamino (dfreemind) wrote :

Thanks to https://launchpad.net/~funicorn on answer #23

It works well now on a Compaq Mini 311

Great :)

goniomdq (jose-goni) wrote :

Fix on comment #57 also works for me (at least for the 2-finger and edge scrolling).
AlpsPS/2 ALPS DualPoint TouchPad / AlpsPS/2 ALPS GlidePoint
Toshhiba Tecra R850
Ubuntu 11.10
Thanks Duke!!

piou13 (mihelakis-nikitas) wrote :

Fix on comment #57 it maked my touchpad working only not working is pointer speed and accelaration.
Sony Vaio VPCEH Ubuntu 11.10

thanks

Changed in linux:
status: Confirmed → Fix Released
Dave Turvene (dturvene) wrote :

I installed the psmouse with ALPS support from #57 and it works better but is still buggy. I still get occasional spurious refocus actions even when typing and xinput watch-props says "Synaptics Off" is set. I'm using 12.04 LTS on a Dell I15R.

Current issue:

* syndaemon must be running in the background. I messed around with the -i <val> times, while using xinput watch-props ID (the ALPS device id from xinput --list and it seems like it works. The higher the <val> times, the longer "Synaptics Off" property is disabled after typing. However, I still seem to get spurious pointer refocus actions even when the "Synaptics Off" is set.

* I tried to disable tap-to-click using xinput set-prop on various ALPS Tap properties. Another post said xinput set-prop 14 546 0 (set the prop id for "Synaptics Tap Time" to 0) will disable tap-to-click, but I saw no change.

* I can disable the ALPS touchpad by doing xinput set-prop 12 132 0 (On the psmouse device id, set prop id for "Device Enabled" to 0) but this has no effect on the ALPS device.

* I messed around with different values in /etc/modprobe.d/psmouse.conf for "options proto" but all were worse than the built driver.

* I put some printk debug in the driver but it just confirmed what I was seeing. Tap-to-click and the buttons generate the same codes to the driver. alps_tap_mode defaults to enable tap, but when I set it to disable tap, the tap is still enabled. I sent a request to ALPS with a specific request for the tap disable sequence, but (as expected) no response.

* I added known values to /etc/X11/xorg.conf.d/50-synaptics and verified they were set using xinput list-props 14, but that did not seem to affect anything.

* I do Fn-F3 while monitoring the ALPS device (14) and it shows a bunch of changes with no visible result (e.g. "Device Enabled" toggles but does not enable/disable the touchpad. I monitor the psmouse device and see no changes. This is consistent with disabling the touch pad using xinput set-prop on the psmouse device.

I'll continue to investigate because it bugs (no pun) me that I can't groom this to my liking. I suspect the control protocol to my version of the ALPS touchpad may be different than previous AND that 12.04 does not accurately recognize the ALPS touchpad.

Frantique, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

no longer affects: linux (Ubuntu)
affects: linux → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Medium → Undecided
status: Fix Released → New
importance: Undecided → Low
status: New → Incomplete
summary: - [regression] Alps touchpad detected, but scrolling not working
+ [Lenovo G550] Alps touchpad detected, but scrolling not working
tags: added: latest-bios-v2.55
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.