hp dm1z ALPS touchpad not detected, scroll doesn't work

Bug #616605 reported by Mike M on 2010-08-12
106
This bug affects 22 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

I have a HP dm1z-2000 laptop, and the touchpad is detected as a generic device, not ALPS/Synaptic as it should (I believe on this machine it is an ALPS touchpad). As a result, functions like vertical scroll do not work. In the System -> Preferences -> Mouse settings, Touchpad does not appear.

After reading https://wiki.ubuntu.com/DebuggingTouchpadDetection and https://help.ubuntu.com/community/SynapticsTouchpad, I decided to open this bug because it seems like a real issue. Also noticed that others were having similar problems on different laptops, but according to the Ubuntu Wiki, it said to open a new bug report anyway.

I am on Ubuntu 10.04, and the xserver-xorg-input-synaptics driver is at 1.2.2-1ubuntu4, and the linux kernel is 2.6.32-24.39.

I have attached all the outputs recommended by the Wiki and Launchpad.

Thanks.

Mike M (mikemalo) wrote :
Mike M (mikemalo) wrote :
Mike M (mikemalo) wrote :
Mike M (mikemalo) wrote :
Mike M (mikemalo) wrote :
Mike M (mikemalo) wrote :
Mike M (mikemalo) wrote :
tags: added: kj-triage
creepingmee (creepingmee) wrote :

I have the exact same problem, same computer, problem still exists in the 10.10 beta 64bit which is what i am runnning.

Anyone know of a way around this problem for now?

Gursimran singh (simar) wrote :

Hi Mike M,

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. If you could test the current Ubuntu stable release(maverick ubuntu 10.10), this would help us a lot. If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect <bug #>, and any other logs that are relevant for this particular issue.

Changed in linux (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Alvaro (joe--) wrote :

Hi,
I'm currently running the latest update of Maverick Ubuntu 10.10. 64 bit on the same hp listed above (dm1z-2000). I just updated to kernel headers 2.

Alvaro (joe--) wrote :

I'm sorry for the incomplete post (touchpad fault). I just updated to kernel headers 2.6.35-22.35. This issue still persists, attached are the outputs updated for this version.

Alvaro (joe--) wrote :
Alvaro (joe--) wrote :
Alvaro (joe--) wrote :
Alvaro (joe--) wrote :
Alvaro (joe--) wrote :
Alvaro (joe--) wrote :

Same happening here. HP dm1z, ubuntu 10.10 64bits. The touchpad is detected as a generic PS2 mouse.

Here's my Xorg.0.log

xinput --list

lspci -vvn

dmesg

cat /proc/devices

plus...
uname -a: Linux fid-laptop 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 11:55:36 UTC 2010 x86_64 GNU/Linux

cat /proc/version_signature
Ubuntu 2.6.35-23.41-generic 2.6.35.7

creepingmee (creepingmee) wrote :

I can confirm this bug also, DM1Z touchpad not recognised as a touchpad, comes up as a generic usb mouse. Seems although there is plenty of information on this bug, little interest in it!!
If you need more info, let me know what further outputs you would require to get this bug moved up. Ubuntu 10.10 amd64bit HP DM1Z. Ubuntu 2.6.35-24.42-generic 2.6.35.8

If this bug interests/affects you, please click on the green link: "this bug affects X people" under the title. This bug is unassigned and set to expire. If you have a dm1z or your alps multi touch mouse is not detected, please click that link.

Let's move the bug up a notch and at least get it assigned to someone in the ubuntu team.

Mike M (mikemalo) wrote :

Still not working for me either, 10.10 live usb. Would really like to use Ubuntu on this machine but can't justify it without all touchpad features since its my primary form of navigation. This can't be the only laptop using this touchpad. Are there any other bugs dealing with the same touchpad (but possibly on a different laptop) we can "combine" with this one so that it won't expire or will be noticed more by the developers?

So, my main problem is not scrolling or multitouch, but the fact that the mouse gets in the way of my writing. I wrote a quick workaround tutorial. The workaround is VERY LAME, but works for me until the drivers are available.
It is a key combination that toggles between mouse enabled and mouse disabled. So, when I write, I disable it. Otherwise I enable it.

I posted my tutorial (8 simple steps) here:
http://www.iacobelli.cl/blog/?p=111

Bryan Verduzco (rustycannibal) wrote :

just installed ubuntu 10.10, and im experiencing this exact same bug, same model as reported before, hp dm1z-2000

Sampo Saarela (sopsaare-gmail) wrote :

Hey ppl!

HP dm3-2130so here and exactly the same thing with touchpad being recognized as PS2 mouse without any extra functionality.

Though I'm just wondering if this is duplicate of the https://bugs.launchpad.net/ubuntu/+source/linux/+bug/565543
?

Tom (t-linsky) wrote :

Any chance the patch applied to the kenel in bug 632884 could also be applied to the HP dm1z? It would address this bug. I commented out the model number checking in alps.c in kernel 2.6.38-8-generic so that the quirks are always enabled, and tested the module on my dm1z. No synaptics stuff, but at least the scrolling works with the dell quirks enabled, which makes using the computer MUCH less frustrating. However, I'm not very experienced at this so I'm not sure how to extract the model number of the touchpad to post it so that the dell quirks can be enabled for the dm1z specifically to allow scrolling on this model for everyone. Please let me know what additional information I can provide to help.

Ketil Malde (ketil-ii) wrote :

Scrolling is a matter of protocol, by using 'modprobe psmouse proto=imps' you will get edge scrolling back. Or, at least, I did.
See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/737051/comments/2

Ketil Malde (ketil-ii) wrote :

Why is this "Incomplete"? The brokenness of ALPS is amply documented, and there are a set of similar bugs reported. It should probably be marked "duplicate", but I'm unsure which ones to merge.

(Anyway - my solution is to order a new laptop with a touchpad from Synaptics. This was my first and last HP.)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Tom (tlinsky) wrote :

Hi, the solution on comment 32 still did not enable edge scrolling for me running the current Ubuntu Natty kernel (2.6.38-10-generic) on my HP dm1z-2100. I tried both of the following:

modprobe psmouse proto=imps

and then
echo "options psmouse proto=imps"|sudo tee -a /etc/modprobe.d/psmouse.conf; sudo modprobe -r psmouse; sudo modprobe psmouse

keith kuslak (keith-kuslak) wrote :

Why is this such low priority? The bug was reported and described over a year ago and it is just now being marked as confirmed? I tried some of the methods of changing the alps.c file found elsewhere, but that just made options visible in the settings but they didn't work. If I knew more I'd work on it, but I'm not a kernel programmer.

Tom (tlinsky) wrote :

Seth Forshee is actively developing a kernel patch that fixes this issue on my dm1z (and apparently also numerous other laptops that have the same ALPS touchpad). Using the dkms deb package he has provided in bug 550625, two-finger scrolling and edge scrolling both work on my dm1z, as does the feature to disable the touchpad while typing.

I suggest you try his patch at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550625

Mike M, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

tags: added: lucid needs-upstream-testing
removed: alps dm1z
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.