Internal Microphone on Dell Lattitude e6410 does not work

Bug #605047 reported by Walter Garcia-Fontes on 2010-07-13
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
linux (Ubuntu)
Medium
David Henningsson
Lucid
Medium
David Henningsson
Maverick
Medium
David Henningsson
linux-backports-modules-2.6.32 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

The internal microphone does not seem to work. I don't get any input from either Micro 1 or Micro 2 from the gnome mixer. Plugging in an external micro works.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: wgarcia 1606 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6960000 irq 22'
   Mixer name : 'Intel G45 DEVIBX'
   Components : 'HDA:111d76d5,1028040a,00100104 HDA:80862804,80860101,00100000'
   Controls : 22
   Simple ctrls : 13
Date: Tue Jul 13 17:01:29 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/tcsh
SourcePackage: alsa-driver
dmi.bios.date: 05/28/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0667CC
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd05/28/2010:svnDellInc.:pnLatitudeE6410:pvr0001:rvnDellInc.:rn0667CC:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6410
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.

I tried the solution suggested in :

http://ubuntuforums.org/showthread.php?t=1504774

and it did not work for me.

Sorry, the solution in #2 DOES work, it seems I forgot to restart after applying it. But if it is just a workaround I guess the bug stands.

There are several posts with several things to try in that thread, as well as several people asking about their different hardware models. Could you plesae point me to the post that fixes your issue?

Thanks.

Fabio Gori (igor-fobia) wrote :

I have a similar problem with my Dell Latitude E4300. I read that the internal microphone it is a digital microphone
http://forums.opensuse.org/english/get-help-here/multimedia/440083-skype-mic-problems.html

So I began to tune my alsamixer setting. I still have some quality problem, but I had no time to try all the options properly.

A snapshot of my alsamixer config is included.

Ameet Paranjape (ameetp) on 2010-09-02
Changed in alsa-driver (Ubuntu):
status: New → Confirmed
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: pcert
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium

Since the package is set to alsa-driver, the relevant people will see this bug.

 affects ubuntu/alsa-driver
 assignee nobody

Changed in alsa-driver (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
David Henningsson (diwic) wrote :

So this is basically the same three-mics-problem as bug #519066 .

Takashi fixed it a few days ago, so according to my own simulations https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules would solve this problem. Can you verify?

Hankyone (hankyone) wrote :

I can confirm, problem solved.

Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
importance: Undecided → High
Jerone Young (jerone) on 2010-09-04
Changed in oem-priority:
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :
Changed in oem-priority:
assignee: Canonical Platform QA Team (canonical-platform-qa) → nobody
Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Confirmed → Triaged
Changed in alsa-driver (Ubuntu):
status: Triaged → In Progress
Changed in oem-priority:
status: Confirmed → In Progress
assignee: nobody → David Henningsson (diwic)

This is fixed in Maverick as of 2.6.35-22.32. Thanks.

https://launchpad.net/ubuntu/+source/linux/2.6.35-22.32

affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu Maverick):
status: In Progress → Fix Released

Accepted linux-backports-modules-2.6.32 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Hankyone (hankyone) wrote :

Confirming linux-backports-modules-2.6.32, works great.

Martin Pitt (pitti) on 2010-09-17
Changed in linux (Ubuntu Lucid):
status: New → Fix Committed
Changed in linux-backports-modules-2.6.32 (Ubuntu Maverick):
status: New → Invalid
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: New → Fix Committed
Changed in linux (Ubuntu Lucid):
status: Fix Committed → Invalid
Changed in oem-priority:
status: In Progress → Fix Committed
Changed in linux (Ubuntu Lucid):
status: Invalid → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.32 - 2.6.32-25.23

---------------
linux-backports-modules-2.6.32 (2.6.32-25.23) lucid-proposed; urgency=low

  [ Brad Figg ]

  * SAUCE: ALSA: HDA: Enable internal mic on Dell E6410 and Dell E6510
    - LP: #605047, #628961

linux-backports-modules-2.6.32 (2.6.32-25.22) lucid-proposed; urgency=low

  [ Stefan Bader ]

  * Bump ABI to -25 for proposed upload.

linux-backports-modules-2.6.32 (2.6.32-24.21) lucid-proposed; urgency=low

  [ Tim Gardner ]

  * Add Conflicts/Replaces for compat-wireless
    - LP: #621185

linux-backports-modules-2.6.32 (2.6.32-24.20) lucid-proposed; urgency=low

  [ Tim Gardner ]

  * Added patch infrastructure
    - LP: #621185
  * Update atl1c to 1.0.1.0-NAPI from 2.6.36-rc2
    - LP: #621185

linux-backports-modules-2.6.32 (2.6.32-24.19) lucid-proposed; urgency=low

  [ Stefan Bader ]

  * Add WWAN sub-package and backported qcserial
    - LP: #554099

  [ Tim Gardner ]

  * Make udev firmware helper file name unique by ABI and flavour
    - LP: #535132
  * Added compat-wireless-2.6.35-1
    - LP: #621185
  * Package multiple versions of compat-wireless
    - LP: #621185
  * Update to compat-wireless-2.6.34.1
    - LP: #618578
  * Use POCKET in flavour stub to correctly reference meta files
    - LP: #621185
 -- Brad Figg <email address hidden> Thu, 09 Sep 2010 10:44:36 -0700

Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Committed → Fix Released

Just installed Maverick release candidate:
Linux delle6410 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux

The internal microphone works perfectly without the workaround in #2 and #3. Great job everybody!

Martin Pitt (pitti) wrote :

Accepted linux into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by Thursday, November 11, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

My systems right now are all updated to Maverick. Is there a kernel that I can test in Maverick? Otherwise somebody still with Lucid should test.

Steve Conklin (sconklin) wrote :

Due to national holidays, the deadline for verification of fixes for the -proposed kernel has been extended thru Monday, November 15th.

If verification that this bug is fixed by the -proposed kernel has not occurred by that date, the change will be reverted and this bug will be set to incomplete.

If you have tested the kernel in -proposed and found that it fixes the bug on the original hardware, please change the bug tag "verification-needed" to "verification-done".

The new stable kernel release process under which these actions are being taken is still being refined, and is documented here:

https://wiki.ubuntu.com/Kernel/StableReleaseCadence

Discussions about the new process tend to take place in #ubuntu-kernel on IRC, so please contribute to the discussion there if you would like.

Thank you!

Marc Tardif (cr3) wrote :

I have a Dell Lattitude e6410 with 10.04.1 and the proposed kernel, 2.6.32-26-generic i686. There is no input device listed under the sound preferences, so microphone doesn't work. For completeness, I tried to report a bug with the command "ubuntu-bug audio" but this raises an exception when attempting to read /proc/asound/cards which doesn't exist.

Marc: if you could try the kernel suggested by Steve in
https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/605047/comments/20
it would be great, otherwise I will have to install Lucid again in a partition of my E6410 laptop just to try it, since I have updated already to Maverick.

Marc Tardif (cr3) wrote :

I have the latest kernel from the lucid-proposed repository, please let me know which kernel version you are referring to.

To the one that you can see if you follow the instructions in https://wiki.ubuntu.com/Testing/EnableProposed (changing Maverick to Lucid). I may try to test it anyway this weekend setting up a special partition for Lucid in my E6410.

Steve Conklin (sconklin) wrote :

Verification that this bug is fixed has not been completed by the deadline for the current stable kernel release cycle.
The change will be reverted and this bug is being set to incomplete.

In order to have this fix considered for reapplication to the kernel, please follow the process documented here:

https://wiki.ubuntu.com/Kernel/StableReleaseCadence

Discussions about the new process tend to take place in #ubuntu-kernel on IRC, so please contribute to the discussion there if you would like.

Thank you!

tags: added: stable-reverted-lucid
Changed in linux (Ubuntu Lucid):
status: Fix Committed → Incomplete
Steve Conklin (sconklin) on 2010-11-16
tags: removed: verification-needed
David Henningsson (diwic) wrote :

@Marc, I don't really know how your system managed to screw up so badly that you don't even have a /proc/asound/cards file - perhaps you installed a non-working ALSA driver override? Switched to OSS? Perhaps there are some hints in dmesg of what can have happened?
Thanks for the report of ubuntu-bug audio not working - I'll try to fix that up, at least for Natty.

Øyvind Stegard (oyvinst) wrote :

Fix worked fine before it was reverted (Dell E6510). What do you need besides "It works for me and does not break anything else on my machine" to get it through the verification process ?

Øyvind Stegard (oyvinst) wrote :

I cannot confirm that it fixes it on original hardware, since I don't own a Dell E6410. However, like I just stated, at least it worked for the Dell E6510.

Øyvind Stegard (oyvinst) wrote :

Setting stable-reapply-lucid, as instructions on https://wiki.ubuntu.com/Kernel/StableReleaseCadence say.
Will verify fix for next update.

tags: added: stable-reapply-lucid
removed: stable-reverted-lucid
Chris Van Hoof (vanhoof) on 2010-11-29
tags: added: hwe-blocker
Chris Van Hoof (vanhoof) on 2010-11-29
Changed in oem-priority:
status: Fix Committed → In Progress
assignee: David Henningsson (diwic) → Chris Van Hoof (vanhoof)
Chris Van Hoof (vanhoof) on 2010-12-20
Changed in linux (Ubuntu Lucid):
assignee: nobody → David Henningsson (diwic)
Chris Van Hoof (vanhoof) on 2011-05-06
Changed in oem-priority:
assignee: Chris Van Hoof (vanhoof) → nobody
Changed in linux (Ubuntu Lucid):
importance: Undecided → Medium
Changed in linux (Ubuntu Lucid):
status: Incomplete → Invalid
Chris Van Hoof (vanhoof) on 2011-06-20
Changed in oem-priority:
status: In Progress → Fix Released
Andy Whitcroft (apw) on 2015-05-21
Changed in linux (Ubuntu Lucid):
status: Invalid → Fix Committed
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in linux (Ubuntu Lucid):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers