Ubuntu 10.04 hangs/locks up often

Bug #576352 reported by Nicholas Allen on 2010-05-06
104
This bug affects 20 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I get random lock ups after freshly installing Ubuntu 10.04 on a Thinkpad W510 laptop. Ubuntu 9.10 did not have this problem. The lock ups happen at random times (sometime after 10 seconds of use and sometimes after a few hours of use). It seems to happen less often when wired network connection than when using wireless so perhaps this could be a problem with the wireless driver.

When the computer locks up it is not possible to do anything. Ctrl-Atl-Fn keys do not switch to virtual terminals. However, sometimes the mouse can still be moved.

I have tried with both the NVIDIA proprietry driver and the open source one but this made no difference so seems unlikely to be due to the graphics driver I would guess.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-generic 2.6.32.22.23
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: nick 2077 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf2620000 irq 17'
   Mixer name : 'Conexant ID 5069'
   Components : 'HDA:14f15069,17aa218b,00100301'
   Controls : 6
   Simple ctrls : 4
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xcdefc000 irq 16'
   Mixer name : 'Nvidia ID a'
   Components : 'HDA:10de000a,10de0101,00100100'
   Controls : 0
   Simple ctrls : 0
Card1.Amixer.values:

Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6MHT32WW-1.07'
   Mixer name : 'ThinkPad EC 6MHT32WW-1.07'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Thu May 6 13:32:23 2010
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=0e950b0d-9df5-444e-b0ce-ce2f192468c6
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: LENOVO 431929G
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-22-generic root=UUID=1337a29e-bfe1-4de3-8339-a35d5ff11018 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34
SourcePackage: linux
dmi.bios.date: 01/20/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6NET46WW (1.09 )
dmi.board.name: 431929G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6NET46WW(1.09):bd01/20/2010:svnLENOVO:pn431929G:pvrThinkPadW510:rvnLENOVO:rn431929G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 431929G
dmi.product.version: ThinkPad W510
dmi.sys.vendor: LENOVO

Nicholas Allen (nick-allen) wrote :
Nicholas Allen (nick-allen) wrote :

I've installed the mainline kernel 2.6.34-999-generic and so far I haven't had a lock up. I can't vouch that it's fixed yet but so far it's the longest that Ubuntu has stayed up on my laptop (now over 2 hours). I'll let you know in a few days/weeks if it still seems to be working ok. As an added bonus the usb 3 ports now seem to work as well. Seems 2.6.33 is not a good choice of kernel for this laptop at all.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Nicholas,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Nicholas Allen (nick-allen) wrote :

I have installed the latest kernel and things look good so far but need to wait a little bit before I feel confident enough to say that it is fixed.

chriz (christian-seipel) wrote :

I have the same problems on an Asus Eeepc 1000H with kernel 2.6.32-21 installed.

ltmon (lukemonahan) wrote :

Using a new W510 here, current uptime 3.5 days giving it a good workout, including large file transfers on wireless. I'm also running 64-bit, stock generic kernel.

I have the same model, but a lower spec (i7 720, HD+ monitor, 6-cell battery, 4GB ram).

Nicholas Allen (nick-allen) wrote :

Unfortunately, the latest mainline kernel made no difference. I just got a complete lock up after only a few hours use. It seems to last longer than the kernel that ships with Ubuntu 10.04 but still completely unusable. The kernel I tried was:

Linux version 2.6.34-999-generic (root@zinc) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #201005061008 SMP Thu May 6 09:09:42 UTC 2010

tags: removed: needs-upstream-testing
Nicholas Allen (nick-allen) wrote :

Seems a number of people are experiencing something similar to this with kernel versions introduced with 10.04 but on different hardware (see http://ubuntuforums.org/showthread.php?t=1478787&page=11).

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Nicholas Allen (nick-allen) wrote :

After googling on the web it seems this is happenning on all kinds of hardware so removed the W510 from bug description.

summary: - Ubuntu 10.04 hangs/locks up often with Thinkpad W510
+ Ubuntu 10.04 hangs/locks up often
Nicholas Allen (nick-allen) wrote :

Could this be related to bug 577183?

Nicholas Allen (nick-allen) wrote :

I've installed the 2.6.34-020634rc7-generic version of the mainline kernel and it seems to be fixed now. I've been using it all day and haven't had a single lock up. If it works for the next few weeks then I think we will be able to close this bug....

Nicholas Allen (nick-allen) wrote :

Just experienced a lock up with this kernel too so that didn't fix it ;-( It locks up almost every time at the login screen if I start running on battery. I still haven't had a lock up when running on mains though. Maybe it is something to do with power management?

Nicholas Allen (nick-allen) wrote :

Lots of people experiencing this problem on the Ubuntu forums: see http://ubuntuforums.org/showthread.php?t=1478787&page=20

Jeremy Foshee (jeremyfoshee) wrote :

Nicholas,
    Unfortunately, if they don't have bugs opened for their specific issues, then I can't help them. Even bugs that appear to be the same hardware or the same error need to be filed separately due to the nature of the kernel and the fact that similar issues could be caused by completely different issues. if you'd like to encourage them to open new bugs, then that is fine. Unfortunately the level of work on the Team as a whole precludes them or me from participating in the forums, so we don't get to see those issues like we would like to.

Thanks!

~JFo

Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: kernel-net
removed: networking
Nicholas Allen (nick-allen) wrote :

I've tried everything with newer mainline kernels and nothing fixes the problem. I have also seen this happen on Eee Pc as well which is completely different hardware (not to mention thousands of posts on the forums and elsewhere seeing the same problem). It seems there is a major bug in more recent versions of the Linux kernel.

But I need to use my computer to do something useful so have now reinstalled 9.10 as this is at least a stable usable release for me. This means I'm no longer easily able to offer any more information on this bug now that I've downgraded. Hopefully, others will be able to stick with it longer than I did and can offer more information when required....

ntupel (ntupel) wrote :

I had exactly the same problems as described here and only by downgrading to 9.10 could I avoid those nasty freezes. Upgrading to 2.6.34 did *not* help. Reading the forums this problem seems to affect quite a few people.

Kris Logan (krisloganm) wrote :

I have exactly the same problem on the below machine:-

AMD 64 Quad Phenom 2.2Ghz
4GB Dual Channel RAM
nVidia GeFore 9800 GT 512MB RAM

Ubuntu 10.04 running Kernel 2.6.32-22-generic

ntupel (ntupel) wrote :

Another remark - I didn't experience this problem with 10.04 originally only after some weeks of usage (and updates). To test this I have yesterday re-installed 10.04 and accepted all updates except the following packages which I have locked:

linux-generic 2.6.32.21.22
linux-headers-generic 2.6.32.21.22
linux-image-generic 2.6.32.21.22
xserver-common 2:1.7.6-2ubuntu7
xserver-xorg-core 2:1.7.6-2ubuntu7

My system runs stable with this configuration whereas I suffered from random freezes before with a fully up-to-date 10.04. My configuration is a Thinkpad W510 with the nVidia graphics chipset (using Nouveau driver). Maybe it helps to have a closer look into what changed between those packages and their latest versions.

ntupel (ntupel) wrote :

Apologies. Ignore my last comment. It happened again after several hours of use. Same symptoms as before. I could ping the machine for a while, but using ssh to get a remote login didn't work. After some minutes the host was unreachable.

FD (francois-dessart) wrote :

To be confirmed, but in my case (W510 with 32-bit ubuntu 10.04) it seems the hangs/locks occur only when using the PAE enabled kernel (needed for 4Gb RAM). I am now running with the non-PAE kernel (2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 07:54:58 UTC 2010 i686 GNU/Linux) for several hours without hang.

FD (francois-dessart) wrote :

Still hanging around once a day with non-PAE kernel unfortunately.

FD (francois-dessart) wrote :

It is so much impacting for me that I looked a bit further...

Symptoms:
-GUI completely frozen, except mouse is still moving (always)
-no response to keyboard: switch to console, kill X,... not working
-background processes still running (music player, virtualbox,...)

I connected remotely via SSH (session was established prior to the hang, I didn't verify whether new connections were still possible). A "top" shows "Xorg" process at 100% CPU.

Kill signal 15 on Xorg: no effect.
Kill signal 9 on Xorg: a new Xorg process is immediately recreated, still at 100% CPU, but screen is still in frozen state.

My knowledge of X is low, so I didn't really know what else to look at/capture. Feel free to guide me further...

This is so impacting that I would do anything to solve this.

Thanks for your help.

Feng Yang (feng-yang) wrote :

This is just to provide some more information on the problem. Hope it helps to resolve it.

I have two thinkpad laptops: w510 and t500.

On w510, lucid 64 bit was installed freshly. On t500, it was upgraded to lucid 32 bit from karmic. The file system is ext4 on w510, and ext3 on t500. T500 works just fine with PAE kernel while w510 occasionally frozen with the same problem described by other users.

orGSD (orgsd) wrote :

I just purchased one of these laptops and found this bug report prior to install. Seeing as there has been little activity I thought I would try 10.10 Maverick Alpha 3 to see if by chance in the months since it has been opened, something silently got fixed.
Unfortunately the laptop is not usable. With a fresh install of 10.10 Maverick Alpha 3, it freezes randomly and often. This happens with the Nouveau driver (I have not tried the nVidia driver yet) with and without Desktop Effects enabled in KDE.
I am running 64bit, and the only non stock thing configuration wise on the laptop is 12GB of RAM.
When the machine freezes/hangs/locks up it is the same as the op. Keyboard is 100% unresponsive, no caps lock, mouse movement does continue however. Only solution is a holding down the power button.
So the bug is still present and makes this rather nice machine a complete paperweight, at least with (K)ubuntu. I am sympathetic towards the op and dread the thought of having to downgrade to make it run.
I am happy to run tests or provide any information that could be useful for anyone interested in helping resolve this bug. Heck I would even be happy to bounty this if it helped!

FD (francois-dessart) wrote :

after various testing, it appears to be stable after I uninstalled package named "xserver-xorg-video-nouveau".

Strangely it is still able to find a "nouveau" module somewhere (I see it in lsmod).

orGSD (orgsd) wrote :

Thanks FD! A couple of quick questions to see if I can replicate your success under 10.10.
Are you using the nVidia driver instead, or are you using the "somehow leftover" nouveau module resulting from after xserver-xorg-video-nouveau removal?
Are you successfully running stable after the removal of that package under 10.04 or newer or is this still after your downgrade?
Thank you for all your help, I now have a glimmer of hope that I may be able to finally migrate to my new machine!

FD (francois-dessart) wrote :

>Are you using the nVidia driver instead, or are you using the "somehow leftover"
>nouveau module resulting from after xserver-xorg-video-nouveau removal?

Indeed, that's my understanding (I played so much with those that I might have missed something but...):
-Nvidia drivers are not installed (have been removed)
-"somehow leftover" nouveau module is what I use.

>Are you successfully running stable after the removal of that package under 10.04
>or newer or is this still after your downgrade?

I am running 10.04.
At some point, I installed a PPA to get more recent xorg:
http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu

After installing the (automatically) proposed xorg related package, freeze/hangs disappeared.
But one day a new upgrade was proposed, containing that "xserver-xorg-video-nouveau" package...and hangs came back. So I only uninstalled that package and it is running fine again.

charlie (s887131) wrote :

Hi, FD:

I am a rookie in ubuntu...
I also confused in w510 hangs bug...
May I ask you some question about

> -Nvidia drivers are not installed (have been removed)
 how to removed the Nvidia drivers? not install it? from the installation of ubuntu?

>-"somehow leftover" nouveau module is what I use.
 how to install this module?

>At some point, I installed a PPA to get more recent xorg:
>http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu
 how to install this? can you write detail typing command to me?

Thank you very much...
and sorry for my poor english...

Andrew Brown (abrown-gcpna) wrote :

Simply deleting the xserver-xorg-video-nouveau seems to be working here. I am running ATI card and this was loaded?? This seems to be the fix everyone has been looking for...no more locking up. Thanks!!!!

Martin Spacek (mspacek) wrote :

I have to say, since upgrading to Maverick, I haven't had any lock up problems (other than on suspend), although I haven't yet left it running for a great many hours at a time. I'm using the nvidia driver (latest from repo is 256.44), on 64 bit ubuntu. This is on my W510 with 8GB ram.

Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
status: Confirmed → New
status: New → Confirmed
Jeff Burns (admiraljkb) wrote :

While I was running 10.04, this ceased being a *consistent* issue after the 256.xx.xx drivers were added to the SWAT repository. It appeared to me like the GPU clock throttling started working more consistently. (http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu).

After upgrading to 10.10 Beta 1, (and keeping the swat repo active), I continued to enjoy stability *overall*... I finally found the workaround for complete stability, which was to just throttle the clock on the GPU to the minimum using information I found here: http://linux.aldeby.org/nvidia-powermizer-powersaving.html. My graphics performance for work related apps doesn't appear to have been impacted really. (and frankly do I really need a 1.2Ghz clock on my Laptop's GPU???)

I updated /etc/X11/xorg.conf with the following:
Section "Device"
 Identifier "Default Device"
 Option "Coolbits" "1"
"RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2223; PowerMizerLevel=0x3; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3"
 Driver "nvidia"
EndSection

My teammate running Windows 7 on his W510 had the same but much worse problem initially. Using my driver experience on Ubuntu, I had him upgrade to the 256 beta drivers, which stabilized him for a month. However, his onboard Nvidia card finally burned out and his systemboard was replaced last Friday. From my experience and watching his, it seems to indicate that this could be a combination hardware/driver defect rather than a Linux/Ubuntu defect.

Greg Wilkins (gregw-wiltel) wrote :

I've had similar problems with my W510. Initially on 10.04 I got lockups with binary and nouveau drivers. I then switched to the x-swat nouveau and was stable for a few months.

Last week it started happening again and this week I upgraded to 10.10. Now it happens about 5 times per day.

I know this is not very helpful. If there is specific information that I can get to help, please ask.

Jon Seymour (jon-seymour) wrote :

Greg,

I've been using nvidia-current from the SWAT repo which includes 260.19.06 of the NVIDIA drivers on top of 10.04.

Since I have installed those, the lockup problems I was having with nouveua drivers have gone.

The remaining issue is that the splash and virtual terminal are in a very low resolution and none of the workarounds I have tried have fixed that.

jon.

Nicholas Allen (nick-allen) wrote :

This bug seems to happen even more often in 10.10 than it did in 10.04. The live cd locks up at random points after the X server is started. Sadly, 9.10 is still the only stable release I can use.

Mary Margaret (otterjet) wrote :

This bug needs to be addressed and done so now. This bug report shows only a few users compared to what is out on the Internet forums. This screw up affects thousands of users. Just Google it, you'll figure it out.

I'm disgusted that Canonical is abandoning every release they churn out. They don't even bother making Ubuntu better anymore. They squirt out a new release; don't fix a damn thing and then move on and begin working on the next one.

Then they have the audacity to solicit my company for servers and support? The salesman on the phone didn't have the slightest clue when I said "you've had over half a decade and you guys can't even stabilize your own OS, why should we trust you with our nationwide network?"

Maybe Shuttleworth and Bacon think people are going buy bugs from them?

Nicholas Allen (nick-allen) wrote :

I'm surprised this bug is only marked as of medium importance. I can't think of anything more serious than an entire malfunction and lock up of the operating system (and hence all programs the user is running).

avlas (avlas) wrote :

I completely agree with the last comment. I had to abandon the nouveau driver in favor of nvidia just because of this usual hangs, even if nouveau was working even better than nvidia otherwise. It's a shame and should be attended as far as possible IMHO

Nicholas Allen, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.