Comment 64 for bug 565543

@Brian : The scrolling has always worked for me even with the generic
PS/2 driver. It must be that the firmware inside the ALPS works with
generic PS/2 multi-button mice so the touchpad firmware is
pre-programmed to set the right edge of the touchpad to buttons 4 and
5, ie. scroll wheel up and down.

@Bill : Your narrow is the best we've got. Now where in the kernel
should I look for differences in code?

@Chris Roggers : The TOUCHPAD variable? Are you talking about the
kernel drivers?

@Gursimran : Oops... my bad again. :S

On Wed, Aug 25, 2010 at 9:49 PM, Brian McNicholas
<email address hidden> wrote:
> Well the scroll feature just randomly started working. Still not showing
> a touchpad, still says generic PS/2 wheel mouse, and no touchpad tab
> under mouse settings. But the vertical scrolling works! I'm so confused!
>
> --
> Alps touchpad detected as ImPS/2 Generic Wheel Mouse(in VAIO E series) after the kernel upgrade
> https://bugs.launchpad.net/bugs/565543
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Triaged
>
> Bug description:
> Initially the ALPS touchpad was detected by the kernel but does not support horizontal and vertical support but after the kernel upgrade to 10.04 vertical scroll is working but horizontal scroll is not working. And the kernel is not detecting the ALPS touchpad and the cat /proc/bus/input/devices says it is a  PS2 mouse ..
>
> This is seen in sony vaio E series in particular ...
>
> Also Bill in Comment #52 says
> Acer Aspire One 532h (Alps touchpad).
> I booted the distribution from a thumb drive, but once I installed from the thumb drive and updated Ubuntu (10.04), I lost the touchpad (works as a mouse) ..
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/565543/+subscribe
>