Comment 50 for bug 565543

It looks to me like udev is the problem (I read udev is slowly being
integrated into DeviceKit).
Looking at /lib/udev/rules.d/66-xorg-synaptics.rules I see:

ACTION!="add|change", GOTO="xorg_synaptics_end"
KERNEL!="event*", GOTO="xorg_synaptics_end"

ENV{ID_INPUT_TOUCHPAD}!="1", GOTO="xorg_synaptics_end"

# Placeholder for platform specific quirks needing
# ID_INPUT.tags to be set.
ATTR{[dmi/id]product_name}=="Inspiron 1011", ENV{ID_INPUT.tags}="inspiron_1011"
ATTR{[dmi/id]product_name}=="Inspiron 1012", ENV{ID_INPUT.tags}="inspiron_1012"
ATTR{[dmi/id]product_name}=="Inspiron 1120", ENV{ID_INPUT.tags}="inspiron_1120"
ATTR{[dmi/id]product_name}=="HP MiniNote 1000", ENV{ID_INPUT.tags}="mininote_100

LABEL="xorg_synaptics_end"

I don't know what the tagging is for but I tried adding:
ATTR{[dmi/id]product_name}=="VPCEB2S1E", ENV{ID_INPUT.tags}="VPCEB2S1E"

and after a reboot, no change.

But if udev reads DMI data to detect the hardware, by looking at the
output of dmidecode, I couldn't see any touchpad device on my system,
so maybe the DMI data is missing or dmidecode can't read it.

Hope this helps.

On Wed, Aug 18, 2010 at 1:59 AM, Paul-Sebastian Manole
<email address hidden> wrote:
> Call me stupid, but why does this bug's status change this often?
>
> PS - Anyone tried my suggestions yet?
>
> On Tue, Aug 17, 2010 at 10:25 PM, Gursimran singh Mohar
> <email address hidden> wrote:
>> ** Changed in: linux (Ubuntu)
>>       Status: Incomplete => Triaged
>>
>> --
>> Alps touchpad detected as ImPS/2 Generic Wheel Mouse(in VAIO E series) after the kernel upgrade
>> https://bugs.launchpad.net/bugs/565543
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in “linux” package in Ubuntu: Triaged
>>
>> Bug description:
>> Initially the ALPS touchpad was detected by the kernel but does not support horizontal and vertical support but after the kernel upgrade to 10.04 vertical scroll is working but horizontal scroll is not working. And the kernel is not detecting the ALPS touchpad and the cat /proc/bus/input/devices says it is a  PS2 mouse ..
>>
>> This is seen in sony vaio E series in particular ...
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/565543/+subscribe
>>
>