2.6.32.30 reproducible oops at startup in acpi_ex_read_data_from_field

Bug #561151 reported by Martin Pool
366
This bug affects 115 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
Nominated for Lucid by Rasmus Nielsen

Bug Description

I have Lucid running on an Thinkpad X61s. I've just installed this mornings updates, and the current kernel 2.6.32-20-generic oopses at startup in acpi_ex_read_data_from_field as shown in the attachment. 2.6.32-19-generic works correctly. Booting in recovery mode doesn't help. I haven't tried noacpi yet but I might do that now.

I can't page up to get the rest of the traceback and sysrq doesn't work. I have to hard-power-cycle the machine.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-20-generic 2.6.32-20.29
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mbp 3785 F.... pulseaudio
 /dev/snd/pcmC0D0p: mbp 3785 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe020000 irq 17'
   Mixer name : 'Analog Devices AD1984'
   Components : 'HDA:11d41984,17aa20d6,00100400'
   Controls : 30
   Simple ctrls : 19
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7MHT24WW-1.02'
   Mixer name : 'ThinkPad EC 7MHT24WW-1.02'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Apr 12 12:43:05 2010
MachineType: LENOVO 76697DM
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-19-generic root=/dev/mapper/hostname_ssd-root ro single
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/zsh
RelatedPackageVersions: linux-firmware 1.33
SourcePackage: linux
dmi.bios.date: 09/19/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 7NET27WW (1.08 )
dmi.board.name: 76697DM
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7NET27WW(1.08):bd09/19/2007:svnLENOVO:pn76697DM:pvrThinkPadX61s:rvnLENOVO:rn76697DM:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 76697DM
dmi.product.version: ThinkPad X61s
dmi.sys.vendor: LENOVO

Revision history for this message
Martin Pool (mbp) wrote :
Revision history for this message
Martin Pool (mbp) wrote :
Revision history for this message
Roland Dreier (roland.dreier) wrote :

Same here on an X31 -- crash looks identical, happens every time on 2.6.32-20, while 2.6.32-19 works fine. I just took a picture of the oops with an 80x50 console, so I got a bit more of it. Haven't looked at the kernel to figure out what changed yet.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Same here.

Revision history for this message
Erwin van Rijsewijk (erijsewijk) wrote :

IBM Thinkpad R60 (LEnovo) Same problem overhere.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Booting a recent upstream kernel 2.6.34 worked.

Andy Whitcroft (apw)
Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → High
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

T42 is affected as well. -19 works fine.

Revision history for this message
Roland Dreier (roland.dreier) wrote :

Looking at
http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-lucid.git;a=commitdiff;h=3f80f9e8e30f4759ad0e29d23856126edbfc7b41
which I believe is the only commit between -19 and -20 that actually touches ACPI, I see one thing that is a bit bogus. In the chunk below (launchpad may mangle the formatting but I hope not):

+ /* allow full data read from EC address space */
+ if (obj_desc->field.region_obj->region.space_id ==
+ ACPI_ADR_SPACE_EC) {
+ if (obj_desc->common_field.bit_length > 8)
+ obj_desc->common_field.access_bit_width =
+ ACPI_ROUND_UP(obj_desc->common_field.
+ bit_length, 8);
+ obj_desc->common_field.access_byte_width =
+ ACPI_DIV_8(obj_desc->common_field.
+ access_bit_width);
+ }

This is a nested if, and the two assignments of rounded things are indented as if they were supposed to both be consequences of the inner if. But the brace is placed after the first if, so the assignment of ACPI_DIV_8 to the access_byte_width will happen even if bit_length is not > 8.

I haven't tried building a kernel with that fixed, and I don't know how this would cause the problem but it does look suspicious.

Revision history for this message
Roland Dreier (roland.dreier) wrote :

Oh well, launchpad killed the indentation -- follow the link to gitweb that I posted and look at the first chunk of the patch to see what I mean.

Revision history for this message
Fabián Rodríguez (magicfab) wrote :

As Jamie indicates, a valid workaround for now is to boot into the GRUB menu (by pressing SHIFT) then booting into a previous kernel version.

Revision history for this message
Liviu Beraru (beraru-liviu) wrote :

Same here on a Toshiba Satellite L-40. The last line on the screen is
"usb 6-2: configuration #1 chosen from 1 choice "
Then it wont move anymore so I have to press Ctrl-Alt-Del to restart the system and chose another Kernel.

2.6.32-19 works fine.

Revision history for this message
Andy Whitcroft (apw) wrote :

This is looking like fall out from an EC fix. Building some test kernels to confirm this diagnosis. For now the -19 kernel should be a good fallback and can be reached by holding SHIFT as the BIOS fades out and then selecting the -19 kernel from the boot menu.

Revision history for this message
Jeroen Hoek (mail-jeroenhoek) wrote :

I am not sure if this is the same bug, but it looks similar.

Asus M51SN laptop (x86_64).

When I boot into -20 from after rebooting from a working kernel (-19) it hangs on photo 1. If I then do a shutdown using the power button and boot into -20 again, I always get photo 2.

Revision history for this message
Jeroen Hoek (mail-jeroenhoek) wrote :
Revision history for this message
Gama Franco (gama-franco) wrote :

ASUS UL 30

summary: - reproducible oops at startup on thinkpad x61s in
- acpi_ex_read_data_from_field
+ 2.6.32.30 reproducible oops at startup in acpi_ex_read_data_from_field
Revision history for this message
Marco Lackovic (marco-lackovic) wrote :

Same here on an Asus X53S (F3Sa): crash looks identical, happens every time on 2.6.32-20, while 2.6.32-19 works fine.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.32-20.30

---------------
linux (2.6.32-20.30) lucid; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) ACPI: EC: Allow multibyte access to EC"
    - LP: #561151
 -- Andy Whitcroft <email address hidden> Mon, 12 Apr 2010 15:46:31 +0100

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Endy Muhardin (endy-muhardin) wrote :
Revision history for this message
gilson585 (gilson585) wrote :

2.6.32-20.30 fixed the issue here thx

Revision history for this message
HughDaniel (hugh-toad) wrote :

I can report that 2.6.32-20.30 fixed the issue on my T43 Lucid test host.

Revision history for this message
sujivet (sujivet-gmail) wrote : Re: [Bug 561151] Re: 2.6.32.30 reproducible oops at startup in acpi_ex_read_data_from_field
Download full text (3.4 KiB)

Thanks. 2.6.32-20.30 now works on my MacBook 4.1. Thanks

Suresh

Sent from my iPod

On Apr 12, 2010, at 7:40 PM, HughDaniel <email address hidden> wrote:

> I can report that 2.6.32-20.30 fixed the issue on my T43 Lucid test
> host.
>
> --
> 2.6.32.30 reproducible oops at startup in acpi_ex_read_data_from_field
> https://bugs.launchpad.net/bugs/561151
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Fix Released
>
> Bug description:
> I have Lucid running on an Thinkpad X61s. I've just installed this
> mornings updates, and the current kernel 2.6.32-20-generic oopses at
> startup in acpi_ex_read_data_from_field as shown in the attachment.
> 2.6.32-19-generic works correctly. Booting in recovery mode doesn't
> help. I haven't tried noacpi yet but I might do that now.
>
> I can't page up to get the rest of the traceback and sysrq doesn't
> work. I have to hard-power-cycle the machine.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: linux-image-2.6.32-20-generic 2.6.32-20.29
> Regression: Yes
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-19-generic i686
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mbp 3785 F.... pulseaudio
> /dev/snd/pcmC0D0p: mbp 3785 F...m pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xfe020000 irq 17'
> Mixer name : 'Analog Devices AD1984'
> Components : 'HDA:11d41984,17aa20d6,00100400'
> Controls : 30
> Simple ctrls : 19
> Card29.Amixer.info:
> Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg
> 0x30, fw 7MHT24WW-1.02'
> Mixer name : 'ThinkPad EC 7MHT24WW-1.02'
> Components : ''
> Controls : 1
> Simple ctrls : 1
> Card29.Amixer.values:
> Simple mixer control 'Console',0
> Capabilities: pswitch pswitch-joined penum
> Playback channels: Mono
> Mono: Playback [on]
> Date: Mon Apr 12 12:43:05 2010
> MachineType: LENOVO 76697DM
> PccardctlIdent:
> Socket 0:
> no product info available
> PccardctlStatus:
> Socket 0:
> no card
> ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-19-generic root=/dev/mapper/
> hostname_ssd-root ro single
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_AU.UTF-8
> SHELL=/bin/zsh
> RelatedPackageVersions: linux-firmware 1.33
> SourcePackage: linux
> dmi.bios.date: 09/19/2007
> dmi.bios.vendor: LENOVO
> dmi.bios.version: 7NET27WW (1.08 )
> dmi.board.name: 76697DM
> dmi.board.vendor: LENOVO
> dmi.board.version: Not Available
> dmi.chassis.asset.tag: No Asset Information
> dmi.chassis.type: 10
> dmi.chassis.vendor: LENOVO
> dmi.chassis.version: Not Available
> dmi.modalias: dmi:bvnLENOVO:bvr7NET27WW
> (1.08)
> :bd09/
> 19/
> 2007:
> svnLENOVO:pn76697DM:pvrThin...

Read more...

Revision history for this message
John Mark (johnmark) wrote : Re: [Bug 561151] Re: 2.6.32.30 reproducible oops at startup in acpi_ex_read_data_from_field
Download full text (3.9 KiB)

The fix (2.6.32-20.30) works for me as well on my T400 and T500.

On Mon, Apr 12, 2010 at 6:20 PM, sujivet <email address hidden> wrote:

> Thanks. 2.6.32-20.30 now works on my MacBook 4.1. Thanks
>
> Suresh
>
> Sent from my iPod
>
> On Apr 12, 2010, at 7:40 PM, HughDaniel <email address hidden> wrote:
>
> > I can report that 2.6.32-20.30 fixed the issue on my T43 Lucid test
> > host.
> >
> > --
> > 2.6.32.30 reproducible oops at startup in acpi_ex_read_data_from_field
> > https://bugs.launchpad.net/bugs/561151
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in “linux” package in Ubuntu: Fix Released
> >
> > Bug description:
> > I have Lucid running on an Thinkpad X61s. I've just installed this
> > mornings updates, and the current kernel 2.6.32-20-generic oopses at
> > startup in acpi_ex_read_data_from_field as shown in the attachment.
> > 2.6.32-19-generic works correctly. Booting in recovery mode doesn't
> > help. I haven't tried noacpi yet but I might do that now.
> >
> > I can't page up to get the rest of the traceback and sysrq doesn't
> > work. I have to hard-power-cycle the machine.
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 10.04
> > Package: linux-image-2.6.32-20-generic 2.6.32-20.29
> > Regression: Yes
> > Reproducible: Yes
> > ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
> > Uname: Linux 2.6.32-19-generic i686
> > AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
> > Architecture: i386
> > ArecordDevices:
> > **** List of CAPTURE Hardware Devices ****
> > card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
> > Subdevices: 2/2
> > Subdevice #0: subdevice #0
> > Subdevice #1: subdevice #1
> > AudioDevicesInUse:
> > USER PID ACCESS COMMAND
> > /dev/snd/controlC0: mbp 3785 F.... pulseaudio
> > /dev/snd/pcmC0D0p: mbp 3785 F...m pulseaudio
> > CRDA: Error: [Errno 2] No such file or directory
> > Card0.Amixer.info:
> > Card hw:0 'Intel'/'HDA Intel at 0xfe020000 irq 17'
> > Mixer name : 'Analog Devices AD1984'
> > Components : 'HDA:11d41984,17aa20d6,00100400'
> > Controls : 30
> > Simple ctrls : 19
> > Card29.Amixer.info:
> > Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg
> > 0x30, fw 7MHT24WW-1.02'
> > Mixer name : 'ThinkPad EC 7MHT24WW-1.02'
> > Components : ''
> > Controls : 1
> > Simple ctrls : 1
> > Card29.Amixer.values:
> > Simple mixer control 'Console',0
> > Capabilities: pswitch pswitch-joined penum
> > Playback channels: Mono
> > Mono: Playback [on]
> > Date: Mon Apr 12 12:43:05 2010
> > MachineType: LENOVO 76697DM
> > PccardctlIdent:
> > Socket 0:
> > no product info available
> > PccardctlStatus:
> > Socket 0:
> > no card
> > ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-19-generic root=/dev/mapper/
> > hostname_ssd-root ro single
> > ProcEnviron:
> > PATH=(custom, user)
> > LANG=en_AU.UTF-8
> > SHELL=/bin/zsh
> > RelatedPackageVersions: linux-firmware 1.33
> > SourcePackage: linux
> > dmi.bios.date: 09/19/2007
> > dmi.bios.vendor: LENOVO
> > dmi.bios.version: 7NET27WW (1.08 )
> > dmi.board.name: 76697DM
> > dmi.board.ve...

Read more...

Revision history for this message
BenNewton (ben-m-newton) wrote :

Affects my T61 too. Booting in an old kernel is no bother, but it would be good to get a new up up for release.
Cheers, B

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Here's the link of the upstream bug: https://bugzilla.kernel.org/show_bug.cgi?id=15749

At comment #7 you can check the proposed fix, but it's still outside Linus' tree.

Revision history for this message
Sebastian Bergmann (sb-sebastian-bergmann) wrote :

2.6.32-20.30 now works on my ThinkPad X60s, thanks!

Revision history for this message
Tomas Šiaulys (tosi) wrote :

Just another "works for me now". Asus Z35F. Thank you!

Revision history for this message
Eric Hartmann (hartmann-eric) wrote :

Works for me also on UL30VT and M70vm. Thanks

Revision history for this message
Mark Weaver (mark-weaver) wrote :

2.6.32-20.30 also works for me on my Lenovo T43.

Revision history for this message
Cory Flick (flicck) wrote :
Download full text (3.3 KiB)

2.6.32-20.30 also now works fine for me on my Asus K60.

On Tue, Apr 13, 2010 at 5:34 AM, Mark Weaver <email address hidden>wrote:

> 2.6.32-20.30 also works for me on my Lenovo T43.
>
> --
> 2.6.32.30 reproducible oops at startup in acpi_ex_read_data_from_field
> https://bugs.launchpad.net/bugs/561151
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “linux” package in Ubuntu: Fix Released
>
> Bug description:
> I have Lucid running on an Thinkpad X61s. I've just installed this
> mornings updates, and the current kernel 2.6.32-20-generic oopses at startup
> in acpi_ex_read_data_from_field as shown in the attachment.
> 2.6.32-19-generic works correctly. Booting in recovery mode doesn't help.
> I haven't tried noacpi yet but I might do that now.
>
> I can't page up to get the rest of the traceback and sysrq doesn't work. I
> have to hard-power-cycle the machine.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: linux-image-2.6.32-20-generic 2.6.32-20.29
> Regression: Yes
> Reproducible: Yes
> ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-19-generic i686
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
> Architecture: i386
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
> Subdevices: 2/2
> Subdevice #0: subdevice #0
> Subdevice #1: subdevice #1
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: mbp 3785 F.... pulseaudio
> /dev/snd/pcmC0D0p: mbp 3785 F...m pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> Card0.Amixer.info:
> Card hw:0 'Intel'/'HDA Intel at 0xfe020000 irq 17'
> Mixer name : 'Analog Devices AD1984'
> Components : 'HDA:11d41984,17aa20d6,00100400'
> Controls : 30
> Simple ctrls : 19
> Card29.Amixer.info:
> Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw
> 7MHT24WW-1.02'
> Mixer name : 'ThinkPad EC 7MHT24WW-1.02'
> Components : ''
> Controls : 1
> Simple ctrls : 1
> Card29.Amixer.values:
> Simple mixer control 'Console',0
> Capabilities: pswitch pswitch-joined penum
> Playback channels: Mono
> Mono: Playback [on]
> Date: Mon Apr 12 12:43:05 2010
> MachineType: LENOVO 76697DM
> PccardctlIdent:
> Socket 0:
> no product info available
> PccardctlStatus:
> Socket 0:
> no card
> ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-19-generic
> root=/dev/mapper/hostname_ssd-root ro single
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_AU.UTF-8
> SHELL=/bin/zsh
> RelatedPackageVersions: linux-firmware 1.33
> SourcePackage: linux
> dmi.bios.date: 09/19/2007
> dmi.bios.vendor: LENOVO
> dmi.bios.version: 7NET27WW (1.08 )
> dmi.board.name: 76697DM
> dmi.board.vendor: LENOVO
> dmi.board.version: Not Available
> dmi.chassis.asset.tag: No Asset Information
> dmi.chassis.type: 10
> dmi.chassis.vendor: LENOVO
> dmi.chassis.version: Not Available
> dmi.modalias:
> dmi:bvnLENOVO:bvr7NET27WW(1.08):bd09/19/2007:svnLENOVO:pn76697DM:pvrThinkPadX61s:rvnLENOVO:rn76697DM:rvrNotAvailable:cvnLENOVO:ct1...

Read more...

Revision history for this message
nuneko1 (nunbarnfhb) wrote :

asus f3j also affected

Revision history for this message
Liviu Beraru (beraru-liviu) wrote :

After the update 2.6.32-20 is working on Toshiba Satellite L-40. Thanks!

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

The proper patch to apply on top of the stable one that caused this bug just got mainline, and the hash is 2060c44576c79086ff24718878d7edaa7384a985.

Revision history for this message
tuxedo0801 (alex-root1-deactivatedaccount) wrote :

2.6.31-19-generic (64bit) was the last working kernel image.

The following versions did not work on my 64bit system:
2.6.32-19-generic
2.6.32-20-generic
2.6.32-21-generic

Will now try 2.6.32-20.30 ...

Revision history for this message
tuxedo0801 (alex-root1-deactivatedaccount) wrote :

Oh, damn, 2.6.32-20.30 I already tried. Did not work too.

So. 2.6.32-19-generic (2.6.31-19.56) is still the last working kernel image :-(

Revision history for this message
miegiel (nix-miegiel) wrote : Re: [Bug 561151] Re: 2.6.32.30 reproducible oops at startup in acpi_ex_read_data_from_field

On 04/18/2010 11:00 AM, Alexander Ch. wrote:
> Oh, damn, 2.6.32-20.30 I already tried. Did not work too.
>
> So. 2.6.32-19-generic (2.6.31-19.56) is still the last working kernel
> image :-(
>
>
Are you sure it's (still) this ACPI bug that's causing your trouble?
It's been fixed for everyone else for almost a week now.

Booting with 'acpi=off' in my kernel line in grub was the only way I
could boot the bugged kernel, you might want to try that for testing,
though falling back to 2.6.32-19 is more sane for using lucid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.