Ubuntu

Boot hangs after update to kernel 2.6.32-20

Reported by miegiel on 2010-04-12
294
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Bug reported while running 2.6.32-19 which runs fine.

For a screenshot where the boot hangs see : http://ubuntuforums.org/showthread.php?p=9109496#post9109496
It's not identical but verry similar to my screen which ends with :
...] usb 1-2: configuration #1 chosen from 1 choice

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-19-generic-pae 2.6.32-19.28 < = = this kernel does work 2.6.32-20 doesn't
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic-pae 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: x139137 2573 F.... xfce4-volumed
                      x139137 2607 F.... pulseaudio
 /dev/snd/pcmC0D0p: x139137 2607 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xe4500000 irq 22'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:10ec0269,10250229,00100004 HDA:80862802,80860101,00100000'
   Controls : 22
   Simple ctrls : 11
Date: Mon Apr 12 04:04:16 2010
HibernationDevice: RESUME=UUID=ac479525-2163-4f04-b3a1-2cbe20ee89f8
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
MachineType: Acer Aspire 3810T
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic-pae root=UUID=f37872a4-b819-410f-ae4f-d601d947c4af ro i8042.reset=1 quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.33
SourcePackage: linux
WifiSyslog:

dmi.bios.date: 03/04/2010
dmi.bios.vendor: Acer
dmi.bios.version: V1.24
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 3810T
dmi.board.vendor: Acer
dmi.board.version: PSMBOU-1234567
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: None
dmi.modalias: dmi:bvnAcer:bvrV1.24:bd03/04/2010:svnAcer:pnAspire3810T:pvrV1.24:rvnAcer:rnAspire3810T:rvrPSMBOU-1234567:cvnAcer:ct10:cvrNone:
dmi.product.name: Aspire 3810T
dmi.product.version: V1.24
dmi.sys.vendor: Acer

See also bug 561462, bug 561437, bug 561409, and bug 561429.

miegiel (nix-miegiel) wrote :
miegiel (nix-miegiel) on 2010-04-12
description: updated

Also running an Acer timeline with slightly different hardware 5810t and have the same problem after updating kernels.

The posted screenshot is from my machine. Running -19 fine.

gilson585 (gilson585) wrote :

IBM Thinkpad A31 here doing the same thing

miegiel (nix-miegiel) wrote :

On the ubuntu forum someone with a Compaq Pesario CQ60 had the bug too, while someone else had no problem at all. Maybe it's laptops (or some laptops) with the "82801I (ICH9 Family)" chipset.

'sudo lshw -short' should tell you what you have.

I also received a kernel freeze, on USB driver recognition. I am using a MBP (5,4), under Lucid Beta 2, and received the following in dmesg:

==
[ 0.830105] usb 1-4: new high speed USB device using ehci_hcd and address 2
[ 0.871329] forcedeth 0000:00:0a.0: ifname eth0, PHY OUI 0x732 @ 1, addr 00:26:4a:02:b8:22
[ 0.871332] forcedeth 0000:00:0a.0: highdma csum pwrctl gbit lnktim msi desc-v3
[ 0.986042] usb 1-4: config index 0 descriptor too short (expected 642, got 624)
[ 0.986046] usb 1-4: invalid descriptor for config index 0: type = 0x2, length = 3
[ 0.986049] usb 1-4: can't read configurations, error -22
[ 1.110095] usb 1-4: new high speed USB device using ehci_hcd and address 3
[ 1.266018] usb 1-4: config index 0 descriptor too short (expected 642, got 578)
[ 1.266022] usb 1-4: invalid descriptor for config index 0: type = 0x2, length = 3
[ 1.266025] usb 1-4: can't read configurations, error -22
==

Regarding bridge type/chipset, I'm running the Nvidia MCP79.

gilson585 (gilson585) wrote :

This machine is quite old and is only 32bit. It uses the Intel 845 chipset + I do not have the pae kernel just the generic kernel.

I can confirm this as well. My machine (Asus k50ij Laptop) hangs while booting the .20 kernel. .19 works fine, using it right now. I could not find anything relevant in the system logs.

Cory Flick (flicck) wrote :
Download full text (3.2 KiB)

I can also confirm this. I'm running 64 bit Lucid Beta 2, fresh install and just updated. Kernel 2.6.32-20 hangs during boot, rebooting and selecting 2.6.32-19 kernel brings up the system just fine. Machine is an Asus K60 notebook.

Output of sudo lshw -short :

flick@lil-spooky:~$ sudo lshw -short
[sudo] password for flick:
H/W path Device Class Description
======================================================
                               system K60IJ
/0 bus K60IJ
/0/0 memory 64KiB BIOS
/0/4 processor Pentium(R) Dual-Core CPU T4400
/0/4/5 memory 64KiB L1 cache
/0/4/7 memory 1MiB L2 cache
/0/6 memory 64KiB L1 cache
/0/1d memory 4GiB System Memory
/0/1d/0 memory 2GiB SODIMM DDR2 Synchronous 667 MHz
/0/1d/1 memory 2GiB SODIMM DDR2 Synchronous 667 MHz
/0/100 bridge Mobile 4 Series Chipset Memory Contro
/0/100/2 display Mobile 4 Series Chipset Integrated Gr
/0/100/2.1 display Mobile 4 Series Chipset Integrated Gr
/0/100/1a bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1a.1 bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1a.2 bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1a.7 bus 82801I (ICH9 Family) USB2 EHCI Contro
/0/100/1b multimedia 82801I (ICH9 Family) HD Audio Control
/0/100/1c bridge 82801I (ICH9 Family) PCI Express Port
/0/100/1c.1 bridge 82801I (ICH9 Family) PCI Express Port
/0/100/1c.1/0 wlan0 network AR9285 Wireless Network Adapter (PCI-
/0/100/1c.5 bridge 82801I (ICH9 Family) PCI Express Port
/0/100/1c.5/0 eth0 network Atheros AR8121/AR8113/AR8114 PCI-E Et
/0/100/1d bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1d.1 bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1d.2 bus 82801I (ICH9 Family) USB UHCI Control
/0/100/1d.7 bus 82801I (ICH9 Family) USB2 EHCI Contro
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1f bridge ICH9M LPC Interface Controller
/0/100/1f.2 scsi0 storage ICH9M/M-E SATA AHCI Controller
/0/100/1f.2/0 /dev/sda disk 500GB ST9500325AS
/0/100/1f.2/0/1 /dev/sda1 volume 14GiB Windows FAT volume
/0/100/1f.2/0/2 /dev/sda2 volume 97GiB Windows NTFS volume
/0/100/1f.2/0/3 /dev/sda3 volume 353GiB Extended partition
/0/100/1f.2/0/3/5 /dev/sda5 volume 46GiB Linux filesystem partition
/0/100/1f.2/0/3/6 /dev/sda6 volume 3812MiB Linux swap / Solaris partitio
/0/100/1f.2/0/3/7 /dev/sda7 volume 303GiB Linux filesystem partition
/0/100/1f.2/1 /dev/cdrom disk ...

Read more...

azwan ali (novatech) wrote :

2.6.32-20-generic wont boot. it give this message and just hang up there

[ 0.474607] scsi0 : ata_piix
[ 0.518285] scsi1 : ata_piix
[ 0.779830] scsi 0:0:0:0: Direct-Access ATA TOSHIBA MK6034GA AC10 PQ: 0 ANSI: 5
[ 0.779977] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 0.784400] scsi 0:0:1:0: CD-ROM HL-DT-ST RW/DVD GCC-4244N 1.00 PQ: 0 ANSI: 5
[ 0.795394] sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
[ 0.795498] sr 0:0:1:0: Attached scsi CD-ROM sr0
[ 0.795550] sr 0:0:1:0: Attached scsi generic sg1 type 5

Crunchy the Headcrab (m-greb) wrote :

I have the same problem on an ASUS G50Vt-X1 Laptop. I don't know what logs you need me to pull but if you need more information I'd be more than willing to give it.

Brett Jackson (bjackson128) wrote :

Same problem with a MacBook Pro 2,1.

Output of "lshw -short" attached.

timosha (timosha) wrote :

Ditto here on a Thinkpad R51 - 2887 with Intel 855GM graphic chip.

Ryan Rushton (ryancr) wrote :

Same problem on a Asus UL80A

Roger (rogeralexanderdean) wrote :

Also on Thinkpad X60s

Michael (mstrelan) wrote :

Same problem on Asus F8SA. Attached is the output from lshw -short

hangyu (xcywhy) wrote :

Same problem on Asus Z99JN

Roger (rogeralexanderdean) wrote :

...but it doesn't happen for a 32-bit install within VirtualBox. guess this means it's hardware-dependant?

Luke Ashe-Browne (lukeab) wrote :

Same Problem Dell D630 - 64 bit but i can't safe mode or boot with the 2.6.31-19.

Greg Eden (grege) wrote :

I have same problem with my Dell 11z - similar chipset to the Acer notebooks above - Intel ULV, GMA4500 and Broadcom WiFi.

I reinstalled beta 2 as a clean install and updated and got back to the same problem. Same using Kubuntu. Switch back to 19 and all runs fine.

I have three other desktops that are using 2.6.32-20 without problem.

Oren_B (oren.barnea) wrote :

Same problem, Dell Mini 10v.

phsommer (phsommer) wrote :

Same problem on Thinkpad T400.

Gang Cheng (tvpanda) wrote :

Same problem on Asus A8sr. I'm on kernel 19 for now.

Same problem on Thinkpad T60 with Lucid Beta 2

G Mc.Pherson (diggmc) wrote :

Same problem on Asus UL20A

JoeWheeler (josephwheeler64) wrote :

Same problem on ibm x40 thinkpad

Jan K. Mikalsen (jkm-dips) wrote :

Same problem on IBM ThinkPad R50:

[ 0.824537] scsi 0:0:0:0: Direct-Access ATA HTS726060M9AT00 MH40 PQ: 0 ANSI: 5
[ 0.824849] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 0.825133] sd 0:0:0:0: [sda] 117210240 512-byte logical blocks: (60.0 GB/55.8 GiB)
[ 0.825240] sd 0:0:0:0: [sda] Write Protect is off
[ 0.825278] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 0.825343] sd 0:0:0:0: [sda] Write Cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 0.825587] sda:
[ 0.830071] scsi 1:0:0:0: CD-ROM HL-DT-ST RW/DVD GCC-4241N 0202 PQ: 0 ANSI: 5
[ 0.840384] sda1 sda2 <sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
[ 0.843006] Uniform CD-ROM driver Revision: 3.20
[ 0.843175] sr 1:0:0:0: Attached scsi CD-ROM sr0
[ 0.843279] sr 1:0:0:0: Attached scsi generic sg1 type 5
[ 0.864511] sda5 >
[ 0.864896] sd 0:0:0:0: [sda] Attached SCSI disk

Hangs after this.

Mark Fraser (launchpad-mfraz) wrote :

Getting this too with Toshiba NB100 netbook. Couldn't even get the grub menu to choose another kernel.
Is getting stuck where it detects USB devices.

Susan Cragin (susancragin) wrote :

FWIW -- I compiled the latest linux kernel from yesterday's git, 2.6.34 something, without Ubuntu patches, and the problem persists there.
I have an ASUS G1S.

hiptrop (lilo5011) wrote :

Same Problem with Lenovo R61

Same problem on IBM ThinkPad R50:

[ 0.824537] scsi 0:0:0:0: Direct-Access ATA HTS726060M9AT00 MH40 PQ: 0 ANSI: 5
[ 0.824849] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 0.825133] sd 0:0:0:0: [sda] 117210240 512-byte logical blocks: (60.0 GB/55.8 GiB)
[ 0.825240] sd 0:0:0:0: [sda] Write Protect is off
[ 0.825278] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 0.825343] sd 0:0:0:0: [sda] Write Cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 0.825587] sda:
[ 0.830071] scsi 1:0:0:0: CD-ROM HL-DT-ST RW/DVD GCC-4241N 0202 PQ: 0 ANSI: 5
[ 0.840384] sda1 sda2 <sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda tray
[ 0.843006] Uniform CD-ROM driver Revision: 3.20
[ 0.843175] sr 1:0:0:0: Attached scsi CD-ROM sr0
[ 0.843279] sr 1:0:0:0: Attached scsi generic sg1 type 5
[ 0.864511] sda5 >
[ 0.864896] sd 0:0:0:0: [sda] Attached SCSI disk

Hangs after this.

mkis62 (mihaikx62) wrote :

Same problem on Acer TravelMate 2410...

Garron Stevenson (garron) wrote :

Same problem with T61 Thinkpad. Hangs with .20 kernel after/during disk initialisation. Pretty similar to the other Thinkpad logs posted here. Boots fine with .19 kernel.

chiffre (sebibad) wrote :

Same problem with Acer TravelMate 8371. Hangs with .20 kernel but .19 runs just fine.

Mark Weaver (mark-weaver) wrote :

Same problem with IBM T43.

Mark Weaver (mark-weaver) wrote :

I should add that with the generic kernel, I just have a blank screen. The recovery kernel last line states no Plug and Play devices found. 2.6.32-19 runs fine

Eric Hartmann (hartmann-eric) wrote :

Same problem with Asus M70vm and Asus UL30VT

Märt Suga (mart-suga) wrote :

Same here:
Macbook pro 5.5

Aliaksandr Dzeshchanka (lazy) wrote :

Same with IBM T40, back to 2.6.32-19.

Same problem, ACER 5740 (core i3). Works fine with .19 kernel.

Michael Tinsay (tinsami1) wrote :

Similar problem with #27 above. I have an Acer Aspire 4315 laptop. Boot hangs for a while at detecting partitions in /dev/sda -- some times it sees sda1, some times not, but it cannot see sda2 everytime which is my root partition. After a while, I get dropped into a busybox session. I've had 10.04 installed in this laptop since Alpha 2 and this is the first time I have encountered such a problem.

Artem Popov (artfwo) on 2010-04-12
Changed in linux (Ubuntu):
status: New → Confirmed
Dean (morningching) wrote :

Acer aspire 4710 doesn't boot with kernel 2.6.32-20.

Lio (ekinox) wrote :

Same on a Macbook 5.1, roll back to 32-19

Eugene San (eugenesan) on 2010-04-12
Changed in linux:
status: New → Confirmed
description: updated
Eugene San (eugenesan) wrote :

Linux actually panics and print trace and never reaches root mount.

Previous observation might be incorrect since Linux continues to handle events (as SCSI and USB insertions) while scrollling trace output.

I can observe only tail of trace:
EIP: is at acpi_ex_read_data_from_field+0x131/0x168 SS:ESP 0068:f70ddd70

With acpi=off there is no trace or panic, boot progress a little more but dies later, maybe because I I boot from USB :-(

miegiel (nix-miegiel) wrote :

I just managed to boot with acpi=off. Though, if you can, booting the old kernel is a better option.

I really would like to know what more info I can give, since the bug was reported while running 2.6.32-19 and I assume not all the relevant stuff is in the report.

Last point; I think we have enough "me too" comments ;-) It seems, though it doesn't affect everyone, it is pretty wide spread. just hit the "This bug affects XX persons. Does this bug affect you?" link at the top.

jferguson (jferg977) wrote :

Toshiba Satellite L45-S7243 hangs at "usb 1-2: configuration #1 chosen from 1 choice" BIOS setting to boot from network disabled to no avail. 2.6.32-19 works fine.

lyon (r-steiger) wrote :

Same problem on Lenovo S12 with nVidia ION. After kernel oops some USB related messages appear but nothing more.
2.6.32-19 works OK.

Fevzi Kivanc (fckivanc) wrote :

Same problem on Asus U6V

jotape99 (jotape99) wrote :

+1 -20 don't boot, -19 all ok. Medion P6612.

jolo (joop-loep) wrote :

Same Problem with Lenovo R61i 8932GMG and kernel 2.6.32-20

[ 0.559499] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.559501] EDD information not available.
[ 0.608672] ata1.00: ATAPI: MATSHITADVD-RAM UJ-860, RB01, max UDMA/33
[ 0.624351] ata1.00: configured for UDMA/33
[ 0.732867] isapnp: No Plug & Play device found
[ 0.735167] scsi 0:0:0:0: CD-ROM MATSHITA DVD-RAM UJ-860 RB01 PQ: 0 ANSI: 5
[ 0.740468] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[ 0.740471] Uniform CD-ROM driver Revision: 3.20
[ 0.740567] sr 0:0:0:0: Attached scsi CD-ROM sr0
[ 0.740615] sr 0:0:0:0: Attached scsi generic sg0 type 5

Hangs after this.

miegiel (nix-miegiel) wrote :

From bug #561151 :

Launchpad Janitor wrote 1 hour ago: #17
This bug was fixed in the package linux - 2.6.32-20.30

---------------
linux (2.6.32-20.30) lucid; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) ACPI: EC: Allow multibyte access to EC"
    - LP: #561151
 -- Andy Whitcroft <email address hidden> Mon, 12 Apr 2010 15:46:31 +0100

Changed in linux (Ubuntu):
status: In Progress → Fix Released

Michael (starkpc) wrote :

Same Problem with Lenovo SL500

Hangs after this:
usb 1-2: configuration #1 chosen from 1 choice

jolo (joop-loep) wrote :

The fix 2.6.32-20.30 works for me on my Lenovo R61i 8932GMG.

To post a comment you must log in.