Ubuntu

Computer freezes during boot and during viafb loading

Reported by Leo on 2010-03-15
This bug report is a duplicate of:  Bug #558569: Unable start as live cd Lucid Beta 2. Edit Remove
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
DeviceMatic
Invalid
Undecided
Unassigned
Linux
Confirmed
Undecided
Unassigned
base-installer
Invalid
Undecided
Unassigned
initramfs-tools
Undecided
Unassigned
ubiquity
Invalid
Undecided
Unassigned
xsplash
Undecided
Unassigned
linux (Ubuntu)
High
Leann Ogasawara
Nominated for Lucid by Leo
module-init-tools (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Leo

Bug Description

Starting a Lucid Live Session, or trying to load viafb module from a Karmic Session, both make the computer completely freeze:

- The screen goes black, but not off.
- The cooler turns on indefinitely (suggesting strong cpu activity).
- The keyboard locks (the user can't even turn on/off capslock or numlock).

It seems that there won't be a fix for this kernel module any soon.

So far there are two possible workarounds for this:

* With a Live CD, remove "quiet splash" and add "viafb.modeset=0" to the boot options.
* Create a Live USB with persisten memory, boot it on another computer and add viafb to the kernel module blacklist.

It is a regression from Karmic. (Not that viafb works on Karmic, but it is not loaded there by default.)

Leo (leorolla) on 2010-03-15
description: updated
Leo (leorolla) on 2010-03-15
description: updated
Leo (leorolla) on 2010-03-15
affects: ubuntu → gworkspace (Ubuntu)
Leo (leorolla) on 2010-03-15
summary: - Lucid Alpha 3 Live session gives blank screen and freezes
+ Lucid Alpha 3 installation CD gives blank screen and freezes

Please do not just click "Also affects" on a bunch of random projects. I'm going to mark them all invalid and reassign to (guessing) the kernel in Ubuntu, although it may be an X bug instead.

Changed in linux:
status: New → Invalid
Changed in ubiquity:
status: New → Invalid
Changed in xsplash:
status: New → Invalid
Changed in gdm:
status: New → Invalid
Changed in base-installer:
status: New → Invalid
affects: gworkspace (Ubuntu) → linux (Ubuntu)
Leo (leorolla) wrote :

Sorry. I coundn't find bug report instructions for when the LiveCD halts.

But I did see similar bugs reported for the workspace and xsplash.

Thanks for the help.

tags: added: kernel-series-unknown
Leo (leorolla) wrote :

I removed quiet slpash from the boot line and chose option noacpi.

It seems fine for a moment, then starts giving an error to handle USB devices, complained about a live file system not accepting address 10, error -110, unable to enumerate USB device on port 5.... etc...

Finally it shows a line saying

(initramfs)

It is locked here. When I press enter it just repeats the same line.

Changed in xsplash:
status: Invalid → New
affects: linux → initramfs-tools
Changed in initramfs-tools:
status: Invalid → New
Leo (leorolla) on 2010-03-16
tags: added: default-application regression-potential
Leo (leorolla) wrote :

$ lspci -nn
00:00.0 Host bridge [0600]: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge [1106:0364] (rev 80)
00:00.1 Host bridge [0600]: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge [1106:1364]
00:00.2 Host bridge [0600]: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge [1106:2364]
00:00.3 Host bridge [0600]: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge [1106:3364]
00:00.4 Host bridge [0600]: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge [1106:4364]
00:00.5 PIC [0800]: VIA Technologies, Inc. CN896/VN896/P4M900 I/O APIC Interrupt Controller [1106:5364]
00:00.6 Host bridge [0600]: VIA Technologies, Inc. CN896/VN896/P4M900 Security Device [1106:6364]
00:00.7 Host bridge [0600]: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge [1106:7364]
00:01.0 PCI bridge [0604]: VIA Technologies, Inc. VT8237/VX700 PCI Bridge [1106:b198]
00:02.0 PCI bridge [0604]: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller [1106:a364]
00:03.0 PCI bridge [0604]: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller [1106:c364] (rev 80)
00:0f.0 IDE interface [0101]: VIA Technologies, Inc. VT8237A SATA 2-Port Controller [1106:0591] (rev 80)
00:0f.1 IDE interface [0101]: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE [1106:0571] (rev 07)
00:10.0 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev a0)
00:10.1 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev a0)
00:10.2 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev a0)
00:10.4 USB Controller [0c03]: VIA Technologies, Inc. USB 2.0 [1106:3104] (rev 86)
00:11.0 ISA bridge [0601]: VIA Technologies, Inc. VT8237A PCI to ISA Bridge [1106:3337]
00:11.7 Host bridge [0600]: VIA Technologies, Inc. VT8251 Ultra VLINK Controller [1106:287e]
00:12.0 Ethernet controller [0200]: VIA Technologies, Inc. VT6102 [Rhine-II] [1106:3065] (rev 7c)
00:13.0 PCI bridge [0604]: VIA Technologies, Inc. VT8237A Host Bridge [1106:337b]
00:13.1 PCI bridge [0604]: VIA Technologies, Inc. VT8237A PCI to PCI Bridge [1106:337a]
01:00.0 VGA compatible controller [0300]: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] [1106:3371] (rev 01)
06:01.0 Audio device [0403]: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) [1106:3288] (rev 10)
$

Colin Watson (cjwatson) wrote :

It is not sensible to use the upstream projects for filing bugs in Ubuntu. Their purpose is to handle forwarded bugs, or bugs from people working directly with the upstream code.

Bugs that result in falling through to an initramfs prompt are usually kernel bugs in hardware detection, so the bug task there should be just fine as it is.

Changed in initramfs-tools:
status: New → Invalid
Changed in xsplash:
status: New → Invalid
Leo (leorolla) wrote :

Sorry. How can I file a bug that seems to be at initramfs without using the upstream?

Like I say, this one *doesn't* seem to be in the initramfs. The
initramfs is just the messenger.

But to answer the question as asked, you would file it as a bug in the
Ubuntu distribution, and when asked for a source package name, say
'initramfs-tools'.

Leo,
   Would you mind testing this with the current live CD image? It is located at: http://cdimage.ubuntu.com/daily-live/current/

Thanks,

~JFo

Changed in linux (Ubuntu):
status: New → Incomplete
Leo (leorolla) wrote :

Sure!

What I see:

SYSLINUX etc...
Ubuntu written in poor graphical mode, in the middle of the screen, with a keyboard and a man at the bottom.
It disappears.
Blank screen with "Ubuntu 10.04" in a strange font, still graphical-looking mode.
4 dots below it that change color from white to read, suggesting that some process is going on.
Pressing arrows alternates between this screen and a totally blank screen.
After some time the screen is black (but not off), the cooler starts and it seems frozen:
capslock, numlock, turning off wireless or even unplugin power cable don't result any of the indicator LEDs to change state.
CtrlAltDel gives nothing, Power key gives nothing. Only way out is to keep Power key pressed until the computer does a hard power off.

It never showed the "Select Language in 30 seconds" screen.

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: VT82xx [HDA VIA VT82xx], device 0: ALC260 Analog [ALC260 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: VT82xx [HDA VIA VT82xx], device 0: ALC260 Analog [ALC260 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: leorolla 1629 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'VT82xx'/'HDA VIA VT82xx at 0xcb000000 irq 17'
   Mixer name : 'Realtek ALC260'
   Components : 'HDA:10ec0260,10710205,00100400'
   Controls : 13
   Simple ctrls : 7
CheckboxSubmission: 8dd9676589cd4ff8931b9c579ef790e3
CheckboxSystem: 83075ebc7d90de701d72276e79eb150c
CurrentDmesg:
 [ 26.895298] ppdev: user-space parallel port driver
 [ 28.044355] [drm] Initialized drm 1.1.0 20060810
 [ 31.078071] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
 [ 36.780019] eth0: no IPv6 routers present
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=9ae379e0-92dd-4c39-b3cf-8990b5e93bae
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Notebook MIM2310
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-20-generic root=UUID=b684fad8-1534-4cd8-87c3-a22b98a74f84 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-20-generic N/A
 linux-firmware 1.26
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1648): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1648): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1681): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1706): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1678): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
dmi.bios.date: 07/16/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: M1.01
dmi.board.asset.tag: Tag 12345
dmi.board.name: MIM2310
dmi.board.vendor: Notebook
dmi.board.version: VT6363A
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Notebook
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrM1.01:bd07/16/2007:svnNotebook:pnMIM2310:pvrVT6363A:rvnNotebook:rnMIM2310:rvrVT6363A:cvnNotebook:ct1:cvrN/A:
dmi.product.name: MIM2310
dmi.product.version: VT6363A
dmi.sys.vendor: Notebook

Leo (leorolla) wrote : BootDmesg.txt
Leo (leorolla) wrote : IwConfig.txt
Leo (leorolla) wrote : Lspci.txt
Leo (leorolla) wrote : Lsusb.txt
Leo (leorolla) wrote : UdevDb.txt
Leo (leorolla) wrote : UdevLog.txt
Leo (leorolla) wrote : WifiSyslog.gz
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

At

http://kmuto.jp/debian/hcl/index.rhtmlx

they say that

01:00.0 VGA compatible controller [0300]: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] [1106:3371] (rev 01)

only works with the 2.6.32 kernel, and uses module viafb. Trying the Lucid kernel on my Karmic install also resulted in crash. The crash looks similar to the crash I had when I tried to run

sudo modprobe viafb

on Karmic.

I am attaching the log of my recent attempt to boot Karmic with the Lucid kernel.

Leo (leorolla) wrote :
  • syslog Edit (327.7 KiB, application/octet-stream)

At

http://kmuto.jp/debian/hcl/index.rhtmlx

they say that

01:00.0 VGA compatible controller [0300]: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] [1106:3371] (rev 01)

only works with the 2.6.32 kernel, and uses module viafb. Trying the Lucid kernel on my Karmic install also resulted in crash. The crash looks similar to the crash I had when I tried to run

sudo modprobe viafb

on Karmic.

I am attaching the log of my recent attempt to boot Karmic with the Lucid kernel.

tags: added: karmic
tags: removed: kernel-series-unknown

Exactly same problems with the Beta 1 release.

Nomodeset doesn't help.

Is it possible to recover log information from the persistent memory file?

summary: - Lucid Alpha 3 installation CD gives blank screen and freezes
+ Lucid Beta 1 installation CD gives blank screen and freezes
description: updated
Jeremy Foshee (jeremyfoshee) wrote :

fixed the release tag that I mistakenly put to karmic instead of lucid.

~JFo

tags: added: lucid
removed: karmic
Leo (leorolla) on 2010-03-22
description: updated
Andrew Bolster (bolster) wrote :

I've been experiencing this bug also with the release beta, and the past 3 daily builds.

It seems that the only place that this bug can originate from is xsplash, so can I ask why this is not tied to that project? I saw there was discussion about the inappropriate 'affects', but surely when the problem occurs with the splash boot option but doesnt without the splash, it must be a xsplash issue?

(new to bug reporting, any information that would make it easier, let me know)

Leo (leorolla) wrote :

Hi!

Thanks for helping.

When I disable splash I get the same problem. In my case I suspect the problem is related to the viafb module that is present on kernel 2.6.32 but not on 2.6.31.

If you can boot disabling splash, I guess your problem is different.

In this case you should file a different bug.
If someone else will decide it is the same and then mark one of them as duplicated, and the other as confirmed.

You can see if your hardware is the same as mine by looking at the attached files (such as lspci.txt).

Firstly, projects are for use once a bug has been identified by a
developer and is being passed upstream. They are not for use for users
reporting bugs against a distribution, unless those users are explicitly
testing upstream code. That's the difference between "Also affects
project" and "Also affects distribution" near the top of Launchpad bug
pages.

Secondly, the main splash screen (the one with "Ubuntu 10.04" and the
dots) is plymouth, but the freeze seems to happen upon entering X. That
could be in any of several places: plymouth (on the way out), xorg (on
the way in), linux (for some kind of hardware-related trouble in
between). The reason I assigned it to "linux (Ubuntu)" was because that
was my best guess. Where it's *least* likely to be is xsplash, because
xsplash is just an ordinary userspace application that drew some stuff
on top of X, and if that hangs the system, it's probably X's fault, not
xsplash's. In any case, more recent daily builds no longer contain
xsplash at all.

This is all moving very quickly, and it would be helpful to track daily
builds to see how they're doing.

It's even less likely to be xsplash than Colin suggests, because Lucid does not have xsplash enabled currently. So that should reduce the likelihood to about 0. :)

Leo (leorolla) wrote :

Please, see my post 25 above.

It may be the viafb module in the 2.6.32 kernel

Leo (leorolla) wrote :

1. Lucid kernel (2.6.32-18) on a Karmic install.

I have blacklisted viafb and now it boots and opens gdm.
Without blacklisting viafb it freezes with intense processor and HD activity.

2. Lucid Beta 1 (2.6.32-16) Live Session

I have blacklisted viafb (on another computer, with persistent filesystem on a pendrive) and now it boots and opens gdm.
Without blacklisting viafb it freezes with intense processor and HD activity.

Just a word from the viafb maintainer:
This sounds like a known problem, fixed by
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=97922b5462fa543484831d42ab0fe4562b9373fc
(or alternatively by disabling hardware acceleration in viafb via the module parameter viafb_accel=0)
some other (less critical) hardware acceleration issues are
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=8a3a95c32f612068be8dae74fa5fc4cf2db1592e
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=0b94190e1e60f96962b82d35729d7d44cf298ef8

Sorry for the trouble but viafb is currently undergoing heavy changes and as only a few people test -mm (resulting in only a very limited variety of VIA boards getting tested) and the datasheets are not as good as they could be these issues can't be avoided at the moment.

Leo (leorolla) wrote :

Thanks for the feedback.

For Ubuntu bugtrack I guess that these patches on the git tree mean that this is a confirmed bug.

For the linux kernel, I could help testing.

Installing the .deb from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc3-karmic/ is enough?
How do I provide you with the important data afterwards?

Hi Leo,

I've spoken with Florian and I'll build a test kernel with the patches he's pointed out backported. Please stay tuned.

Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → High
status: New → In Progress

Hi Leo,

So I've made two test kernels. I'd appreciate your feedback on both. If you'd be able to test these kernels within a Lucid install that'd be even better.

========

The first test kernel only has the first patch applied which Florian suggested might resolve the issue you are facing:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=97922b5462fa543484831d42ab0fe4562b9373fc

http://people.canonical.com/~ogasawara/lp539020/i386/v1/

=========

The second test kernel has all three patches applied which Florian suggested:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=97922b5462fa543484831d42ab0fe4562b9373fc
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=8a3a95c32f612068be8dae74fa5fc4cf2db1592e
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=0b94190e1e60f96962b82d35729d7d44cf298ef8

http://people.canonical.com/~ogasawara/lp539020/i386/v2/

========

We'd definitely appreciate your feedback on both kernels as soon as possible. We're cutting it close to the final kernel upload for Lucid so we'd like to get in as many fixes as possible. Thanks in advance!

Thanks.

I will try to do these tests as soon as possible.

Normally I wouldn't be able to use this laptop for long periods in the
next couple of days.

I should certainly test it with Karmic.

Will try to install Lucid to an HD partition too, but I don't know if
I will make it. Can also try first to install the kernels inside Live
Sessions of USBs, but it made the USB unbootable last time I tried.

Anyway, the symptoms so far were the same for both releases.

With Karmic, neither one worked:
2.6.32-19
2.6.32-19 (v1)
2.6.32-19 (v2)

They all halt during boot, preety much the same way as with Lucid CD and
2.6.32-16

I will try to test with a Lucid install today. Will also try
2.6.34-rc3-karmic/

That's bad, I really thought it would work.
Well if everything fails could you please also try the latest kernel you suggested last time
http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc3-karmic/
This would at last reveal whether this is a known/fixed bug or a completly new one.

Hi,

perhaps I should have added that my main objective is to fix the freeze. That viafb sometimes requires a bunch of parameters for correct operation as described in viafb.txt is a known issue I'm trying to fix on the long term (but that proves quite difficult without much support from VIA)
I just dug in my inbox and found the relevant bug report where the VGA hardware looks identical to yours:
http://marc.info/?l=linux-fbdev&m=126131088208675&w=2
Sadly the thread was interupted (reply-all problem) and the potential freeze was reported later as a sidenote.

Leo (leorolla) wrote :

I can test upstream, no problem.

Adding the nomodeset flag during Lucid CD boot didn't help.

For Lucid release, is it reasonable to have viafb blacklisted in the
ISO image, as a compromise solution so that it boots on computers like
mine? Os is it too severe?

If you want something that helps during boot try (not sure whether it works, but might worth a try)
video=viafb:off
or (if it's just a hardware acceleration problem)
video=viafb:viafb_accel=0

Blacklisting, well I could live with it as it still allows to use viafb if wanted (so better than what Fedora is doing who make the module completly unusable as far as I know)

Leo (leorolla) wrote :

===

Ubuntu

Right now it just does not boot.

Maybe video=viafb:off or video=viafb:viafb_accel=0 will solve it.

Persistent memory and blacklisting from another computer solve it persistently.

But for an incoming user more newbie than me, there are no such things.

====

Upstream

How can I provide useful information when I test the latest kernel?
Can it be done here at LP, running all those automated ubuntu bug filing tools?

I fully agree that we shouldn't welcome a new user (or any user) with a non-booting linux.

Upstream
Well I don't need that much info at all:
Does it work? (or in what way does it not work)
If yes, are there any remaining issues?
What's the kernel version you're trying?
What module/boot parameters do you use? (if any)
And the hardware you have (VN896).
That's all. Framebuffer drivers are pretty standalone.
For communication do what you like:
Either here (if nobody objects) or mail the results to me or (as the module shouldn't have any grave modifications) to <email address hidden>

Leo (leorolla) wrote :

I tested with Lucid.

Without blacklisting viafb it halts the same way:
2.6.32-19
2.6.32-19 (v2)
2.6.34-rc3-lucid/

I added video=viafb:off to the second last line of booting before the "quiet splash" and it didn't work either.

However the latter was not completely installed:

leorolla@leorolla-laptop:~/Desktop/lucid$ ls
linux-headers-2.6.34-020634rc3-generic_2.6.34-020634rc3_i386.deb
linux-image-2.6.34-020634rc3-generic_2.6.34-020634rc3_i386.deb
leorolla@leorolla-laptop:~/Desktop/lucid$ sudo dpkg -i *
Selecting previously deselected package linux-headers-2.6.34-020634rc3-generic.
(Reading database ... 125434 files and directories currently installed.)
Unpacking linux-headers-2.6.34-020634rc3-generic (from linux-headers-2.6.34-020634rc3-generic_2.6.34-020634rc3_i386.deb) ...
Selecting previously deselected package linux-image-2.6.34-020634rc3-generic.
Unpacking linux-image-2.6.34-020634rc3-generic (from linux-image-2.6.34-020634rc3-generic_2.6.34-020634rc3_i386.deb) ...
Done.
dpkg: dependency problems prevent configuration of linux-headers-2.6.34-020634rc3-generic:
 linux-headers-2.6.34-020634rc3-generic depends on linux-headers-2.6.34-020634rc3; however:
  Package linux-headers-2.6.34-020634rc3 is not installed.
dpkg: error processing linux-headers-2.6.34-020634rc3-generic (--install):
 dependency problems - leaving unconfigured
Setting up linux-image-2.6.34-020634rc3-generic (2.6.34-020634rc3) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.34-020634rc3-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.34-020634rc3-generic /boot/vmlinuz-2.6.34-020634rc3-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.34-020634rc3-generic /boot/vmlinuz-2.6.34-020634rc3-generic

Errors were encountered while processing:
 linux-headers-2.6.34-020634rc3-generic

Leo (leorolla) wrote :

> Does it work? (or in what way does it not work)

No. They all halt the in apparently the same way.

> What's the kernel version you're trying?

2.6.32 from Ubuntu Lucid repositories
A patched version of it (v2 by Leann Ogasawara, see the post 38 on LP539020)
i386 files from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc3-lucid/

> What module/boot parameters do you use?

Standard Lucid Beta parameters.

> And the hardware you have (VN896).

I can't get any more detail than those attached files on LP539020.

Hi Leo,

thanks a lot for your work. So this
1. seems to be a completly new issue that was not known before
2. there is not even a way (to my knowledge) to prevent this as the boot options don't get propagated until module load time
so blacklisting it for the release looks like the best option.

Okay as I don't see a way to propagate the boot options to viafb could you please blacklist it for now and test whether
sudo modprobe viafb viafb_accel=0
behaves different? This will tell us whether this is a hardware acceleration problem (most likely) or not. I need only the result for one of those 2.6.32 or later kernels. Sorry but I need to locate the problem somehow. Thanks.

I tested with 2.6.33 no acceleration and freezed the same way

Thanks. It's odd to hear that it breaks totally for you but works for another with the same IGP. I'm nearing despair. However I just found something suspicious in the syslog you attached:
[ 32.198735] VIA Graphics Intergration Chipset framebuffer 2.4 initializing
[ 32.255733] __ratelimit: 3 callbacks suppressed
[ 32.255737] vmap allocation for size 134221824 failed: use vmalloc=<size> to increase size.
[ 32.255742] ioremap failed
[ 32.255770] viafb: probe of 0000:01:00.0 failed with error -12
This means that viafb itself refuses to work as it can't map the framebuffer (128MB, is this correct?). I'm really puzzled how a module that itself refuses to do anything can cause any harm to (escpecially freeze) your machine.
So the best I can suggest as the next step would be to add the boot option "vmalloc=268435456" to reserve 256MB for remapping and see whether the behaviour of 2.6.33 changes, meaning
(a) whether the warning in the syslog vanishes (the different kernel version shouldn't make a difference but you can check if you like)
(b) whether viafb still freezes your PC

Leo (leorolla) wrote :

This laptop has 1GiB RAM and at BIOS setup I can choose how much of this 1GB I want to give to the video card.

I was giving 128MB.

Tried adding vmalloc=268435456 to the second last line (before quitet splash) of the boot options. Is it the right place to add it?

Tried adding ... to a new line between the second last line and the last line.

Tried changing the BIOS setting to 256MB.

They all freezed, but nothing appeared at the syslog (attached).

Leo (leorolla) on 2010-04-13
summary: - Lucid Beta 1 installation CD gives blank screen and freezes
+ Computer freezes during boot and during viafb loading
Jane Atkinson (irihapeti) wrote :

It looks like this bug is affecting me too. I have the same graphics chip. I've tried Leann Ogasawara's v1 kernel with no change. (and various other things, chronicled in bug 499399.)

Blacklisting viafb means I can now boot with a Lucid kernel (after 3 1/2 months of frustration).

Many thanks to whoever discovered the blacklist viafb option. I thought I was going to have to find another distro, which I didn't actually want to do.

tags: added: iso-testing
Leo (leorolla) on 2010-04-14
description: updated
affects: gdm → devicematic
Leo (leorolla) on 2010-04-14
Changed in linux:
status: New → Confirmed
Leo (leorolla) wrote :

According to the Lucid Schedule I find it unlikely that a solution (even the simple blacklist solution) will be there for the Lucid LTS Release.

Jane Atkinson (irihapeti) wrote :

Output of lspci -nn on my computer:
01:00.0 VGA compatible controller [0300]: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] [1106:3371] (rev 01)

Jane Atkinson (irihapeti) wrote :

@Leo
See bug 558569, comments 17 and 18.
I've just installed the updated module-init-tools (and other updates) and commented out the "blacklist viafb" in blacklist.conf.

The computer boots normally.

We'll see what happens with the live CD in a day or so.

Leo (leorolla) wrote :

Thanks for the good news.

kajo (work-jka) wrote :

This problem remain.. I tryed install latest (16.4.) alternate ubuntu 10.04 (http://cdimage.ubuntu.com/daily/current/lucid-alternate-i386.iso), but not success. First screen after booting install CD is OK, next (Install Ubuntu) is blank screen and no activity..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers