Ubuntu

Comment 13 for bug 446146

The attached patch should make it work again, though it's a bit of a hack and probably not
what the final solution will be. In case you really don't want to stick to 2.6.31.1 :-)