Several Huawei USB dongle don't work with kernel 2.6.31-12.40 (2.6.31.1 update related)

Bug #446146 reported by Dominique Eckert on 2009-10-08
952
This bug affects 182 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Andy Whitcroft
Declined for Dapper by Jeremy Foshee
Declined for Hardy by Jeremy Foshee
Declined for Intrepid by Jeremy Foshee
Declined for Jaunty by Jeremy Foshee
Declined for Lucid by Jeremy Foshee
Karmic
High
Unassigned

Bug Description

SRU Justification:

Impact: The Huawei modem (with a certain firmware it seems) claims to support a certain sense data format, but does not do so.

Fix: Change to USB storage, which lets the device fallback to a shorter sense format. This patch went into 2.6.31.5 ("usb-storage: Workaround devices with bogus sense size").

---

I'm using a Huawei E169 USB dongle to connect to a GSM mobile broadband network. It used to work out-of-the-box with Jaunty and previous versions of Karmic (kernel 2.6.31-11 and previous). However the device doesn't work any more with the latest kernel.

Dmesg gives me repatedly this message:

dmesg:
option: option_instat_callback: error -108

lsusb:
Bus 005 Device 005: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem

My system: Dell XPS M1530, see attached result of "lshw"

This bug apparently affects other people as well: http://ubuntuforums.org/showthread.php?p=8070873#post8070873

NB: Remaining bug with Huawei E220/E270 is bug #449394, not this bug

Dominique Eckert (dom-eckert) wrote :

Affects me also with Huawei E169 and eeePC 1000H

Ubuntu 9.10 beta updated today
kernel: 2.6.31-12-generic #41
network-manager: 0.8~a~git.20091005t192303.1d28ad1-0ubuntu2
modemmanager: 0.2.git.20091003t063318.aa78b5f-0ubuntu1

Russell Faull (rfaull) wrote :

Exactly the same issue on two machines after upgrading to 2.6.31-12.40/41 generic. Retaining kernel 2.6.31-11 as workaround and hoping later updates solve this problem.

Kernel is seeing dongle as a usb drive and not a modem. I'm sure its the kernel upgrade because NM and modem manager are the same versions.

BTW karmic alpha/beta is working very well for me, apart from this problem.

Problem exists on 2.6.31-13-generic #42

AND on Ubuntu Netbook Remix daily live (.iso) of 9-Oct-09 where Huawei E169 cannot be used at all as there is no previous kernel to boot!

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: regression-potential
Russell Faull (rfaull) wrote :

Confirming problem remains with latest kernel 2.6.31-13.42.

Russell Faull (rfaull) wrote :

Updating to 2.6.31-13#43 makes no difference

Download full text (4.9 KiB)

Below is part of dmesg (2.6.31-13#43) showing the 'loop':

g@KKsep22:~$ dmesg
[ 1261.396207] usb 2-2: new full speed USB device using uhci_hcd and address 4
[ 1261.616651] usb 2-2: configuration #1 chosen from 1 choice
[ 1261.634400] scsi86 : SCSI emulation for USB Mass Storage devices
[ 1261.637423] usb-storage: device found at 4
[ 1261.637438] usb-storage: waiting for device to settle before scanning
[ 1261.744264] usb 2-2: USB disconnect, address 4
[ 1262.480201] usb 2-2: new full speed USB device using uhci_hcd and address 5
[ 1262.645650] usb 2-2: configuration #1 chosen from 1 choice
[ 1262.653302] option 2-2:1.0: GSM modem (1-port) converter detected
[ 1262.653695] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB0
[ 1262.656890] option 2-2:1.1: GSM modem (1-port) converter detected
[ 1262.657342] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB1
[ 1262.666827] option 2-2:1.2: GSM modem (1-port) converter detected
[ 1262.667166] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB2
[ 1262.672207] scsi90 : SCSI emulation for USB Mass Storage devices
[ 1262.678576] usb-storage: device found at 5
[ 1262.678585] usb-storage: waiting for device to settle before scanning
[ 1267.678453] usb-storage: device scan complete
[ 1267.681422] scsi 90:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
[ 1267.684423] scsi 90:0:0:1: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2
[ 1267.715350] sr0: scsi-1 drive
[ 1267.715798] sr 90:0:0:0: Attached scsi CD-ROM sr0
[ 1267.716193] sr 90:0:0:0: Attached scsi generic sg2 type 5
[ 1267.716944] sd 90:0:0:1: Attached scsi generic sg3 type 0
[ 1267.749246] option: option_instat_callback: error -108
[ 1267.749530] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 1267.749596] option 2-2:1.0: device disconnected
[ 1267.752224] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 1267.752271] option 2-2:1.1: device disconnected
[ 1267.755231] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[ 1267.755279] option 2-2:1.2: device disconnected
[ 1267.864140] usb 2-2: reset full speed USB device using uhci_hcd and address 5
[ 1268.011659] option 2-2:1.2: GSM modem (1-port) converter detected
[ 1268.011950] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB0
[ 1268.012354] option 2-2:1.1: GSM modem (1-port) converter detected
[ 1268.012698] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB1
[ 1268.013127] option 2-2:1.0: GSM modem (1-port) converter detected
[ 1268.013513] usb 2-2: GSM modem (1-port) converter now attached to ttyUSB2
[ 1268.091233] option: option_instat_callback: error -108
[ 1268.099009] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[ 1268.099071] option 2-2:1.0: device disconnected
[ 1268.099265] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 1268.099322] option 2-2:1.1: device disconnected
[ 1268.099495] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 1268.099547] option 2-2:1.2: device disconnected
[ 1268.212136] usb 2-2: reset full speed USB dev...

Read more...

p3car (peter-carlsson50) wrote :

Affects me to. Seems like the USB modem is mounted as an USB-memory stick. I can actually open the disk in Nautilus and browse the content. I tried to download http://www.greenhughes.com/files/e169g-switch_0.3_all.deb which resolved the issue for me in earlier versions of Ubuntu. The modem has been working flawless up until last week when I upgraded to 2.6.31-12 and today I upgraded to 2.6.31-13 and the modem is still being seen as usb-disk.

When inserting the usb-modem I get the following error message:

Unable to mount Tele2 3G-modem

Error mounting: mount exited with exit code 32: Mount: block
device /dev/sr1 is write protected, mounting read-only
mount: /dev/sr1 already mounted or /media/Tele2 3G-
modem busy

Changed in linux:
status: Unknown → Confirmed

We identified the bug upstream, it's a 2.6.31.1 - >2.6.31.2 regression. Still looking for a proper fix (yeah, I have one of these critters too).

Discussion is mostly happening on lkml but we'll keep http://bugzilla.kernel.org/show_bug.cgi?id=14355 updated when a solution is found, hopefully in the next couple of days.

Russell Faull (rfaull) wrote :

Thanks, Benjamin. Good luck with the fix. I have retained 2.6.31-11 and I am updating other kernels as they appear in repos.

Andrea Chiavazza (andrea-c7a) wrote :

2.6.31-13.44 doesn't fix the bug for me

We now know what the problem is, still debating how to properly fix it

The attached patch should make it work again, though it's a bit of a hack and probably not
what the final solution will be. In case you really don't want to stick to 2.6.31.1 :-)

Hi Benjamin, I do not want to 'gain' from your knowledge but if possible can you take a look to bug:
https://bugs.launchpad.net/bugs/408555
that has a similar 'looping' on creating/disconnecting ttyUSBx with ZTE MF636? The difference there is that ttyUSBx is advanced (+1) at a time reaching ttyUSB8-9-... and finally the system gets frozen.
Thanks in advance,
George

Andy Whitcroft (apw) on 2009-10-12
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

Ok I have taken the dirty fix benh referenced above and applied it to the karmic kernel and built some kernels for testing. Could those of you affected by this issue please try these kernels and report back here. The kernels can be found at the URL below:

     http://people.canonical.com/~apw/lp446146-karmic/

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Andrea Chiavazza (andrea-c7a) wrote :

Andy's #44lp446146apw1 fixes the problem for me.

Dominique Eckert (dom-eckert) wrote :

The problem is also solved for me using Andy's kernel.

Same good results for my E169 with 2.6.31-13-generic #44lp446146apw1

My problem is fixed with this Andy's #44lp446146apw1. Thank you!

Russell Faull (rfaull) wrote :

Works for me too, except the E169 also loads as a USB drive.

Thanks

Helder Fraga (whise) wrote :

i got this to with my E220 usb modem using kernel 2.31.13 , hope this gets fixed in the future

Hi Russell Faull,
my opinion is that USB drive (virtual CDROM/ZeroCD) must exist but possibly not mounted automatically. It is not good to reject it as in the future a manufacturer may want to include any Linux (open source better) application program to control/update their modem (ex. like betavine s/w). The user can add a rule to eject/unmount it automatically. The same and more important is to get access on microSD card reader.
Regards,
George

Russell Faull (rfaull) wrote :

Hi George

Good point about future Linux software, I hope more manufacturers adopt open source.

Perhaps not for this thread, but how do I control mount / unmount automatically, as you suggest?

Regards and thanks
Russell

FraGe (fragebuntu) wrote :

Hi all,

I can confirm the issues with E220 and E270, although I haven't tested the fixes yet. Will try to update my box today/tomorrow ...

regards,
FraGe

Note that 2.6.31-13-generic #44lp446146apw1 is just '2.6.31-13' for grub.
A newer update will force 2.6.31-13-generic #45 to be used instead of the patched and the problem will come back!

@Russell Faull, post anything at http://ubuntuforums.org/showthread.php?t=1202430 to discuss.

Keith Drummond (victor9098) wrote :

I have an E220 and get the following whenever I attempt to use it;

Unable to mount Mobile_Connect
Error mounting: mount exited with exit code 32: mount: block device /dev/sr0 is write-protected, mounting read-only mount: /dev/sr0: can't read superblock

Russell Faull (rfaull) wrote :

Bug remains with 2.6.31-14 #46 (Change log not available to the time of writing this post).

Thanks to GeorgeVita for warning about *31-13, which is now 'pinned'.

Here's the "final" patch that unless major problem or end of the world,
Greg will send to Linus and apply to -stable tomorrow:

http://marc.info/?l=linux-kernel&m=125540979118722&w=2

Andy Whitcroft (apw) on 2009-10-14
Changed in linux (Ubuntu):
milestone: none → karmic-updates
Keith Drummond (victor9098) wrote :

Just got latest kernal update and the problem still persists. Have to go back to -11 to use the USB dongle!

Andrea Chiavazza (andrea-c7a) wrote :

2.6.31-14.46 is still affected by the bug, and today it's kernel freeze time...
Does milestone -> karmic-updates mean that a fix for this bug will be released as a kernel update after the release of 9.10 ?
If the dongle is your only Internet connection you will have to save the kernel update packages on a flash disk and use them to upgrade after you installed 9.10.

1 comments hidden view all 478 comments

This is indeed a concern. Those dongles are quite common, at least here in .au

My latest patch was accepted and is now in gregkh tree, it should hit the next stable release and Linus soon now, might be worth making sure it's in the released kernel

Jyrki Luoma (hoikkam73) wrote :

Loaded just new updates from main server.
still doesn't work.

It gives this error:
Error mounting: mount exited with exit code 32: mount: block device /dev/sr1 is write-protected, mounting read-only
mount: /dev/sr1 already mounted or /media/Mobile Partner busy

Without any updates only cd-install of karmic it works good.

leviathan (fl4me) wrote :

It's a big problem, Those dongles are very common in Italy too

Patch now upstream ID b8430e1b82b7e514d76a88eb70a7d8831d50df1e and queued for next -stable

Russell Faull (rfaull) wrote :

Ben, does this mean the patch is likely to be 2.6.31-14.48? And thanks for solving this annoying bug.

I have no idea in what ubuntu kernel it will show up :-) All I know is the upstream status :-)

Blake Munro (blake-munro) wrote :

This bug was also affecting me, thanks to Andy's .13 Kernel I am now online.
Look forward to a fix before the final release.

Andy Whitcroft (apw) wrote :

The patch is now pulled into our tree. It is most likely to release as an SRU immediatly after release.

Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Russell Faull (rfaull) wrote :

Andy, do I understand you correctly that the fix for this problem will only be available in a kernel upgrade sometime after Karmic is available to the general public as a final release on 27 October?

If so, there will be many disappointed users of e169 modems. I expected the Ubuntu will also suffer pretty negative publicity. I hope I am misunderstanding your post..

BTW I am using the kernel with Ben's 'hack' patch you posted at #15. It works fine. Is there a chance of a new kernel complied with the final patch for testing through this forum?

Regards and thanks

leviathan (fl4me) on 2009-10-17
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
clariwee (clariwee) on 2009-10-18
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
darhma (darhma) on 2009-10-24
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
james83 (j4mes-83) on 2009-10-24
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Daniel (daniel-raspone) on 2009-10-28
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Antofka (antofka) on 2009-10-31
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
summary: - Huawei E169 USB dongle not working with kernel 2.6.31-12.40
+ Several Huawei USB dongle don't work with kernel 2.6.31-12.40
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) on 2009-11-04
summary: - Several Huawei USB dongle don't work with kernel 2.6.31-12.40
+ Several Huawei USB dongle don't work with kernel 2.6.31-12.40 (2.6.31.1
+ update related)
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in linux (Ubuntu):
importance: Medium → High
Andy Whitcroft (apw) on 2009-11-06
Changed in linux (Ubuntu Karmic):
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → High
milestone: none → karmic-updates
status: New → Fix Committed
Andy Whitcroft (apw) on 2009-11-06
Changed in linux (Ubuntu):
milestone: karmic-updates → lucid-alpha-1
Martin Pitt (pitti) on 2009-11-06
tags: added: verification-needed
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Tommitel (scavenger80) on 2009-11-08
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Martin Pitt (pitti) on 2009-11-09
tags: added: verification-done
removed: verification-needed
Stefan Bader (smb) on 2009-11-12
description: updated
Tony Wood (twood) on 2009-11-17
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Karmic):
status: Fix Released → Fix Committed
Changed in linux:
status: Confirmed → Fix Released
Lars (home-lbm) on 2009-11-18
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → New
Changed in linux (Ubuntu):
status: New → Fix Committed
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
tags: added: karmic
jugpole (jugpole) on 2009-12-10
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2009-12-10
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Martin Pitt (pitti) on 2009-12-10
Changed in linux (Ubuntu Karmic):
status: Fix Released → In Progress
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
ANIMESH (animeshmeher) on 2009-12-18
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Incomplete
Changed in linux (Ubuntu Karmic):
status: Incomplete → Fix Committed
tags: added: regression-release
removed: regression-potential
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
mahela007 (mahela007) on 2010-01-12
Changed in linux (Ubuntu Karmic):
status: Fix Released → Fix Committed
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Karmic):
status: Fix Released → Confirmed
398 comments hidden view all 478 comments
madbiologist (me-again) wrote :

@David Fraser - The launchpad bug report for the E220 is at bug #449394 and is probably a better place to work on this. Bug 446146 became too long and confusing a long time ago, even before the fix for the E169 (E620) was released.

The E220 bug report contains a link to an E220 firmware in comment 10. After upgrading their modem's firmware to the version available at this link, many people reported their E220s were now working. If you have a Vodafone branded modem you may want to use the firmware linked to in comment 24 of that bug instead. You may also need a 2.6.31-15 or later kernel, but you mentioned you are using 2.6.31-17 so you should be fine in that regard. There a few other workarounds/tricks among the various comments too. Also see comment 31 in that bug.

Unfortunately the upstream bug at http://bugzilla.kernel.org/show_bug.cgi?id=14499 which you referred to seems to have stalled, although perhaps that is due to the success of the firmware updates. It seems that Huawei's original firmware was not fully compliant with the USB specification set by the USB Implementers Forum (USB-IF). There is short page on the USB-IF at http://en.wikipedia.org/wiki/USB_Implementers_Forum if you interested.

>Also of interest is that the same modem works successfully on a friend's machine with the same kernel on karmic (2.6.31.17.30)

That is very interesting. When you say "the same modem", do you mean your E220, or does your friend also have an E220? The answer to that question should probably go into bug #449394. If it's your E220 behaving differently on the two different E220 machines, please include the output of dmesg from both machines along with your answer.

David Fraser (davidf) wrote :

@madbiologist: Brilliant, thanks for pointing me to the other bug. I've delinked this from the E220 upstream bug and added a comment to the description saying this bug does not apply to E220.
And yes, it was exactly the same modem (but I'll address that in the other bug)

description: updated
SP (samipp) wrote :

Updated my Huawei E220 FW to 11.117.10.02.00, now my 9.10 with kernel 2.6.31-17 shows modem first as a USB-drive. Ejected drive (not unmount) and it started to show as a modem like it should. Then just chose from NetworkManager Enable Mobile Network and opened my connection. "Zadamn" I am on internet with my Karmic. Just took me three months to get correct info to get on line. Thanks for everybody for their input. I highly recommend to upgrade FW to latest one you can find.

Big Thanks to madbiologist! You understood to write right instructions enabling me to solve this issue.

SP (samipp) wrote :

Works the same way with 2.6.31-18

Startup->
Eject Vodafone USB-drive
NetworkManager->Choose Network provider

Connection made!

madbiologist (me-again) wrote :

@Richard Wikberg - I'm sorry to hear that you are still having problems with your Huawei E169 (E620).

Could you please post the contents of your dmesg file here, along with the kernel version you are now using?

Please also include the output of lsusb, so that we don't have to scroll back to find it.

Does the sudo modprobe usbserial vendor=0x12d1 product=0x1001 workaround work for you? Note that after applying this workaround you may also need to manually set the DNS addresses.

Jeremy Foshee (jeremyfoshee) wrote :

Richard Wikberg,
       Additionally I am interested in whether or not you see your Huawei showing up as a usb drive. There have been reports that unmounting this enabled usage in the network manager.

I'd be interested in your testing in this regard.

-JFo

Ruben (rubenseclipse) wrote :

What is the official workaround if one installs from the Ubuntu 9.10 CD?

I have found so many different approaches on the net and it becomes overwhelmingly confusing. Worse still after trying a few of the recommendations that don't work one cannot know what is original in the config and what is old etc. if one is a new user.

This would be helpful for people who don't have access to other connections where something like running online updates becomes impossible without getting the E220 to work.

Having an official workaround would be great for users who can implement it and run update to get the latest fix.
Also if the official workaround is published here at least one can direct others with the same problem correctly.

David Fraser (davidf) wrote :

@Ruben (re #445) - The remaining bug with Huawei E220/E270 is bug #449394, not this bug, although your question is relevant to both

sly (slyboots1) wrote :

After upgrade to new kernel 2.6.31-19-generic problem still exist with my Huawei E220.

madbiologist (me-again) wrote :

@sly - That information would be more relevant and more useful to bug #449394. In that bug you will find some links to E220 firmware which have worked for many people - see my comment #439 in this (446146) bug.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Karmic):
status: Confirmed → Fix Released
Martin Pitt (pitti) on 2010-02-08
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Changed in linux (Ubuntu Karmic):
status: Fix Released → Fix Committed
Bruno Cunha (brunoscunha) wrote :

With the latest kernel I still have to use sudo rmmod usb-storage to make the E220 work. This time I connected it, after 30 secs it shows up on the network devices. I try to connect, it connects, the connection drops and the E220 disappears from network devices.

Jeremy Foshee (jeremyfoshee) wrote :

Declined for all releases. Changed to Fix Released as the commit to fix Huawei Technologies Co., Ltd. E620 USB Modem from upstream is in the code for Lucid.

-JFo

Jeremy Foshee (jeremyfoshee) wrote :

Also, If your hardware is not the same as the model mentioned above, it is likely that you are encountering a problem that is different from the one reported here. Please open a new bug and collect all apport logs for that particular issue.

Thanks!

-JFo

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Reopening karmic task. It's only in -proposed and needs verification. It'll be closed when it goes to -updates.

Changed in linux (Ubuntu Karmic):
status: Fix Released → Fix Committed
madbiologist (me-again) wrote :

@SP - You might not need to eject the USB-drive anymore on Ubuntu 10.04 "Lucid Lynx". A new version (1.1.0-2) of usb-modeswitch was added to the Lucid repositories 5 days ago. I can't find the page anymore, but I read that this version has added support for several Huawei modems.

mahela007 (mahela007) wrote :

The issue doesn't seem to be their on the newest kernel version. 2.6.31-20. I successfully connected twice now.. I'll post back when I know more..

Suyog (suyog) wrote :

has this been fixed in latest Alpha release of 10.04? I am yet not able to connect to internet with Huawei EC1260 modem.
Really frustrating to see. why cant you just test and fix 3G modem issues? I am back on 9.04 where everything worked so well.
I am using Reliance Netconnect Broadband+ in India.

Suyog (suyog) wrote :

can you confirm if Huawei EC1260 works in latest Lucid Lynx build?

madbiologist (me-again) wrote :

@Suyog - You said "why can't you just test and fix 3G modem issues". The answer is that neither Canonical or the kernel developers at www.kernel.org have the money or time to purchase and test all of the different 3G modems on the market in all of the different countries in the world. However the good news is that Ubuntu is a community-based project. Ubuntu 10.04 "Lucid Lynx" is currently in it's testing phase, if you wish to participate you can download a Live CD of alpha 3 and try it with your EC1260 modem. If it does not work please open a new bug report and attach the contents of your dmesg file, and also include the output of lsusb and uname -srm

Roman Bolshakov (roolebo) wrote :

Yeah. I've tested e1550 just now and it's working. I can connect to MTS Russia successfully.

Martin Wildam (mwildam) wrote :

Just now means you tested with the most recent kernal update published a very few days ago?

mahela007 (mahela007) wrote :

The bug hasn't been fixed in kernel 2.6.31-20.

Roman Bolshakov (roolebo) wrote :

@Martin Wildam: Here is need explained answer, so let me describe my short story. I bought my first 3g modem in the last December. Network Manager detected it without any problems. Then I used it often for a couple of week.

It started to work anyhow after some time. Sometimes it was detected after reboot, sometimes on specific usb port. The modem even was not always detectable.

Then I didn't use it more than a month. I checked it recently, now the modem is detected from any USB port.

Carl Englund (englundc) wrote :

Using a fully updated Karmic (amd64) and kernel 2.6.31-20, I'm having lots of trouble getting my E169 to connect to the network, and often it only stays connected for a minute or two.

Martin Wildam (mwildam) wrote :

@Carl: Are you sure it is a E169? - Does it show up as such on the lsusb command?

@Roman:
I had no problems under 9.04 with my E160G. Then problems began with 9.10. However, I noticed that my E160G showed up as E220/E270 on the lsusb command. Some of them were similar to your problems. If varied for me depending on the kernel I tested. I also applied a firmware upgrade for my modem which improved the situation for me but not completely solve problems. However, with some of the last kernel updates officially released (I am currently using "2.6.31-20-generic #57-Ubuntu SMP Mon Feb 8 09:05:19 UTC 2010 i686 GNU/Linux") my problems seem to be completely gone even if I still can see the icon on the desktop (that never appeared on 9.04).

Well, my E1692 still doesn't work. It never gets switched to "modem mode", so the output of lsusb is:
Bus 001 Device 003: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552 (HSPA modem)

It should show 140C instead of 1446 if it had switched modes correctly. This on karmic x86_64, with kernel 2.6.31-20-generic. On my netbook, with 2.6.31-20-lpia, I put my own udev rules, and am using Huawei's HWActivator to switch it into modem mode. Like that it works.

Martin Wildam (mwildam) wrote :

@Jose:
Can you please file a separate bug (if you didn't already) for E1692 / E1552 with that description. And please post a link to the new bug for all those who want to follow that.

girts (girtsz) wrote :

Important!!!!!

People please update modem firmware and software on them. After I updated with latest HUAWEI E220 modem firmware and software from my provider all started working fine!!!!
I believe that I have found problem and this is modem firmware problem!!!!!!
Please check firmwares and software's in your provider home pages!!
I have downloaded my ISP LMT latest firmware and latest firmware added 7.2Mb/s bandwidth and solved problem which as all see is still but bug is not in Linux distributions, kernels!!!!

girts (girtsz) on 2010-03-18
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Invalid
Steve Langasek (vorlon) on 2010-03-18
Changed in linux (Ubuntu Karmic):
status: Invalid → Fix Committed

On Thu, Mar 18, 2010 at 19:58, girts <email address hidden> wrote:
> Important!!!!!
> People please update modem firmware and software on them. After I updated with latest HUAWEI
> E220 modem firmware and software from my provider all started working fine!!!!

I can confirm this - had the same experience - but:
1. I needed to get my modem and software installed on a Windows box.
No firmware update option from within Linux. So it took me a while to
get to a Windows box that I could install that stuff on.

2. The Windows driver Software seemed to work even with the old buggy
version. So somehow I guess that there must be a possibility for a
workaround.

Of course, updating the firmware should be the first choice.
--
Martin Wildam

Home: http://sites.google.com/site/mwildam/
Life Hack Blog: http://1-2-solved.blogspot.com
IT Blog: http://it-tactics.blogspot.com

Martin Wildam (mwildam) wrote :

I have extra bought a second different modem (besides for backup also to help testing) FYI: Again issues on 10.4 beta 2. While my E220 and (the new fresh bought) E620 (in lsusb, officially it's the E1552) work on 9.10, on 10.04 beta 2 the latter (E620 / E1552) does not work - see https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/561051 . This is getting annoying.

Get a Huawei E5, it doesn't need a driver, just a working WiFi connection.
That's what I did.

Nicholas Ipsen

girts (girtsz) wrote :

Martin Wildam wrote on 2010-04-11:

Martin ask your ISP to give you latest firmware and software updates for modems. I don't trust firmwares which are available for download under HUAWEI site.

If you upgrade firmware and software then under Vista and 7 you must see your modem and there must be possible to see all files under modem. If you cannot see files in Vista, 7 then filesystem is broken and there will be problems in Ubuntu 9.10 and other distributions where was seen problem with HUAWEI modems.

Martin Wildam (mwildam) wrote :

@girts: I can try that (if the support member I get is able to do so - I have faced really stupid people there already). - Anyway, both modems I have (different providers and different modem) work on Ubuntu 9.10. So that they don't work on 10.04 is definitely a regression. And BTW: Do you assume that the normal user will upgrade firmwares? BTW: In VirtualBox it does not work (even the USB enabled version can't cope with the Huawei-Modem) and I need to get to a real Windows PC where I can install on - possible but not in near reach.

Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Martin Pitt (pitti) on 2010-04-30
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

This bug is alive.

Upgraded from Jaunty.
Modem: E1750, Italy, 3 (H3G)
Kernel: 2.6.31-21-generic
Network-manager: vanilla Karmic (0.799...) and 0.8 from PPA

lsusb returns:
Bus 001 Device 004: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem

I omit the dmesg for brevity.

Martin Wildam (mwildam) wrote :

@effetto: Do you have usb-modeswitch installed?
Lucid + all updates + usb-modeswitch (although fresh installation) solved the problem for me in a 1552 case. Please see also Bug #561051

Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu Karmic):
assignee: Andy Whitcroft (apw) → nobody
panoet (panoet-h) wrote :

I'm running Ubuntu Lucid, and this bug still happens on my E220. Has Ubuntu going to fix this?

1 comments hidden view all 478 comments
madbiologist (me-again) wrote :

panoet - You've commented in the wrong bug. The bug for the Huawei E220 is bug #449394. In that bug you will find some links to E220 firmware which have worked for many people - see my comment #439 in this (446146) bug. Also see comments #466 and #467 this (446146) bug.

BDenis (borenko) on 2010-12-08
description: updated
Changed in linux:
importance: Unknown → Medium

This bug was nominated against a series that is no longer supported, ie karmic. The bug task representing the karmic nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Won't Fix
bing_bing13 (wonderful87643) wrote :

HUAWEI SD Storage USB Device driver manufacturer is (Standard disk drives) and developed by Microsoft in the database contains 20 versions of the HUAWEI SD Storage USB Device matches the hardware GenDisk.HUAWEI SD Storage USB Device compatible with 2 hardwares driver contains 1 binary files, You can Download the latest drivers for your HUAWEI SD Storage USB Device.http://www.binarydb.com/driver/HUAWEI-SD-Storage-USB-Device-635.html

Displaying first 40 and last 40 comments. View all 478 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.