[6.311772] ACPI: I/O resource piix4_smbus [0b00-0xb07] conflicts with region SOR1 [0xb00-0xb0f] on KUBUNTU Karmic boot

Bug #444235 reported by Shaved Wookie on 2009-10-06
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

On boot I get the message in the title just after GRUB and before the KDM login. I am on KUBUNTU Karmic 9.10 AMD64.

Mobo is an ASUS M3A78-T with an AMD Phenom II quad
core cpu and 4 gig of ram.

Everything else should be attached by apport.

I have no FDD attached to this computer. 1 IDE HDD and a DVD writer on
the IDE cable and a SATA drive. I deeply suspect this is related to the
DVD drive.

Let me know if there's any further info I can provide to help.

ProblemType: Bug
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe8f4000 irq 16'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,104382fe,00100101'
   Controls : 41
   Simple ctrls : 23
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfe9ec000 irq 19'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined
   Playback channels: Mono
   Mono: Playback [off]
Date: Mon Oct 5 23:42:58 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=c2040270-0c2a-42b1-b268-2b10201269cb
MachineType: System manufacturer System Product Name
NonfreeKernelModules: fglrx
Package: linux-image-2.6.31-11-generic 2.6.31-11.38
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=1fdc1c99-54d8-4df2-b618-749e5791b30e ro quiet splash
ProcEnviron:
 LANGUAGE=
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-11-generic N/A
 linux-firmware 1.20
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Uname: Linux 2.6.31-11-generic x86_64
dmi.bios.date: 10/30/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0502
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M3A78-T
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0502:bd10/30/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3A78-T:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Shaved Wookie (shavedwookie) wrote :
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Harry (harry33) wrote :

Corfirming I get exactly the same kernel message right after grub2.
Ubuntu Karmic 64-bit (fully updated clean install).
Mobo: Gigabyte GA-MA790XT-UD4P (with AMD chipset 790X / SB750)

Surbhi Palande (csurbhi) wrote :

@Shaved Wookie : Can you please attach the output of the following command as well:
sudo acpidump -o acpidump.txt
Thanks a lot !

Shaved Wookie (shavedwookie) wrote :

When I do that command, the console also outputs:
Wrong checksum for OEMB
Wrong checksum for OEMB!

Rocko (rockorequin) wrote :

I get this and also a bunch of other messages, shown in the screenshot in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/445966.

Harry (harry33) wrote :

OK now these kernel messages have been masket by elevating the trigger to the level 2 (only emergency messages will appear).
This does not, however, mean that the original cause for the messages are fixed now.

Harry (harry33) wrote :

Actually this is already fixed in linux kernel.
This address space collision is only a message.
You see, kernel finds that BIOS AML is accessing the same resources
and thus automatically disallowing the driver (i2c_piix4) to load.

Of cource if you blacklist this driver, kernel will not find space collision and thus the message is not shown during boot.
But the result is the same: the driver i2c_piix4 is not loaded anyway.

Toby Meehan (themeehans) wrote :

For what its worth, I get this same message on ASUS M4A78T-E mobo w/AMD 810 CPU.

Thanks for the kernel research report Harry.

Steve Nash (steve-nash) wrote :

Same message for me with new install of 9.10 on ASUS M4A78LT-M LE.
This has AMD 760G chipset.
Tried sudo acpidump but got command not found.

FYI This install is not finished yet. I also have Question #98093 ( network DISABLED)
Steve

Papamatti (matti-lx) wrote :

I have the same message during boot:
ACPI: I/O resource piix4_smbus [0xb00-0xb07] conflicts with ACPI region SOR1 [0xb00-0xb0f]

My board is a Gigabyte GA-MA790FXT-UD5P with an AMD Phenom II 955BE

Confirming, i try to blacklist the driver descibed in #7

floid (jkanowitz) wrote :

Aside from any more obvious lmsensors breakage, the inability to load piix4_smbus blocks the ability to use `decode-dimms` from i2ctools on these AMD systems, which is annoying.

MDS007 (mark-desousa) wrote :

Having the same error not sure if it is related to an issue I am having since an update as of May 16 of 9.10 that caused my box to become unresponsive after went into sleep. Decided to upgrade 10.04 fresh format/install and having the same issues after it goes to sleep stays unresponsive to network / keyboard access. Using an Asus M3A78-EM mobo Amd AthlonX2 5200+ CPU 2GB RAM, ATI HD3200 Integrated graphics with flgrx proprietary latest drivers as of this posting. Aside from that I have 1 320GB WD HDD Sata + 1 DVDRW Sata drive and a pci WIFI adapter. All were working well up to last week so I'm guessing something pushed recently may be the issue. Any help is appreciated.

tags: added: kernel-acpi
Jeremy Foshee (jeremyfoshee) wrote :

MDS007,
     Please open a new bug for your issue.

Thanks!

~JFo

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers