[ubuntu-boot-experience] nForce2_smbus conflicts with ACPI region SM00

Bug #440470 reported by Andreas Schildbach
262
This bug affects 55 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Low
linux (Ubuntu)
Low
Chase Douglas
Nominated for Lucid by argos
Karmic
Low
Unassigned

Bug Description

These messages flash up in text mode during boot:

[ 13.144298] ACPI: I/O resource nForce2_smbus [0x4c00-0x4c3f] conflicts with ACPI region SM00 [0x4c00-0x4c05]
[ 13.144387] ACPI: Device needs an ACPI driver
[ 13.144390] nForce2_smbus 0000:00:0a.1: Error probing SMB1.

ProblemType: Bug
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: AD198x Analog [AD198x Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: aschildbach 1485 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xfe024000 irq 22'
   Mixer name : 'Analog Devices AD1986A'
   Components : 'HDA:11d41986,104381b3,00100500'
   Controls : 37
   Simple ctrls : 21
Date: Fri Oct 2 11:27:47 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=678f2ef6-04b0-4c21-8d7f-31f0692733f9
MachineType: System manufacturer System Product Name
Package: linux-image-2.6.31-11-generic 2.6.31-11.36
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=fef535a5-83f5-4337-8c79-324daea229a8 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-11-generic N/A
 linux-firmware 1.19
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
Uname: Linux 2.6.31-11-generic i686
dmi.bios.date: 02/05/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2NPV-VM ACPI BIOS Revision 1301
dmi.board.name: M2NPV-VM
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 1.xx
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2NPV-VMACPIBIOSRevision1301:bd02/05/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTekComputerINC.:rnM2NPV-VM:rvr1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Revision history for this message
Andreas Schildbach (schildbach) wrote :
tags: added: ubuntu-boot-experience
Revision history for this message
Andreas Schildbach (schildbach) wrote :

I don't see how this can be fixed in a generic way, as this is a specific error message. Unmarking duplicate.

Changed in linux (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in linux (Ubuntu Karmic):
status: Confirmed → Triaged
Revision history for this message
Andreas Schildbach (schildbach) wrote :

new kernel 2.6.31-12 does NOT fix this problem

Revision history for this message
Stefan Bader (smb) wrote :

Would "acpi_enforce_resources=lax" added as a boot parameter help your case?

Revision history for this message
Andreas Schildbach (schildbach) wrote :

Adding "acpi_enforce_resources=lax" as a linux kernel parameter (via grub2) suppresses the message.

Revision history for this message
Stefan Bader (smb) wrote :

What also would be interesting, as the lax setting should not only make the message disappear but also get the nforce2_smbus driver successfully loaded, do you see any other change (like sensors being available which were not before)?

Andy Whitcroft (apw)
Changed in linux (Ubuntu Karmic):
milestone: none → karmic-updates
Revision history for this message
Sense Egbert Hofstede (sense) wrote :

I'm marking bug #440780 as a duplicate of this bug. It has almost the same error message:
[ 6.618133] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
[ 6.629604] i2c-adapter i2c-0: nForce2 SMBus adapter at 0x600
[ 6.629610] ACPI: I/O resource nForce2_smbus [0x700-0x73f] conflicts with ACPI region SM00 [0x700-0x73f]
[ 6.629661] ACPI: Device needs an ACPI driver
[ 6.629663] nForce2_smbus 0000:00:01.1: Error probing SMB2.
[ 6.882066] EDAC amd64_edac: Ver: 3.2.0 Sep 25 2009
[ 6.887073] k8temp 0000:00:18.3: Temperature readouts might be wrong - check erratum #141

The only difference is that the Error probing message is about SMB2 rather than SMB1.

summary: - [ubuntu-boot-experience] nvidia boot messages
+ [ubuntu-boot-experience] nForce2_smbus conflicts with ACPI region SM00
Revision history for this message
Caleb Callaway (enlightened-despot) wrote :

The message does not appear in the boot log anymore after adding the "acpi_enforce_resources=lax" I'm using a ZOTAC ION ITX-B-E (Intel Atom N230) with up-to-date Karmic.

Revision history for this message
Greg Odero-Jowi (ojgreg) wrote :

Problem still exists in Kernel 2.6.31-15-generic. I'm running an Asus M2N32-SLI Deluxe motherboard.

Revision history for this message
Fredrik Bränström (branstrom) wrote :

Same here. Asus A6000 laptop (chipset is C51MV(C61)+MCP51 (NVidia) - got that from http://www.computerstock.be/index.html?lang=nl&target=d203.html&lmd=39945.914456 but it was really hard to find specs for this laptop... It has a 3200+ AMD processor and a GeForce 6100 GPU, in any case).

Revision history for this message
Fredrik Bränström (branstrom) wrote :
Download full text (5.0 KiB)

Seems to be fixed by the "acpi_enforce_resources=lax" option.

[ 11.309296] sdhci: Secure Digital Host Controller Interface driver
[ 11.309300] sdhci: Copyright(c) Pierre Ossman
[ 11.310106] ACPI: I/O resource nForce2_smbus [0x600-0x63f] conflicts with ACPI region SMRG [0x600-0x60f]
[ 11.310110] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 11.310114] nForce2_smbus 0000:00:0a.1: Error probing SMB1.
[ 11.310164] i2c-adapter i2c-0: nForce2 SMBus adapter at 0x700
[ 11.312551] k8temp 0000:00:18.3: Temperature readouts might be wrong - check erratum #141
[ 11.334617] EXT4-fs (sda3): barriers enabled
[ 11.355330] kjournald2 starting: pid 732, dev sda3:8, commit interval 5 seconds
[ 11.355668] EXT4-fs (sda3): internal journal on sda3:8
[ 11.355673] EXT4-fs (sda3): delayed allocation enabled
[ 11.355677] EXT4-fs: file extents enabled
[ 11.361511] EXT4-fs: mballoc enabled
[ 11.361530] EXT4-fs (sda3): mounted filesystem with ordered data mode
[ 11.559959] Linux agpgart interface v0.103
[ 12.401045] nvidia: module license 'NVIDIA' taints kernel.
[ 12.401051] Disabling lock debugging due to kernel taint
[ 12.672338] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 12.674597] ACPI: PCI Interrupt Link [LNEC] enabled at IRQ 16
[ 12.674605] alloc irq_desc for 16 on node -1
[ 12.674608] alloc kstat_irqs on node -1
[ 12.674621] nvidia 0000:00:05.0: PCI INT A -> Link[LNEC] -> GSI 16 (level, low) -> IRQ 16
[ 12.674628] nvidia 0000:00:05.0: setting latency timer to 64
[ 12.674922] NVRM: loading NVIDIA UNIX x86 Kernel Module 185.18.36 Fri Aug 14 17:18:04 PDT 2009
[ 13.130395] b43-phy0: Broadcom 4318 WLAN found (core revision 9)
[ 13.188676] yenta_cardbus 0000:04:01.0: CardBus bridge found [1043:1367]
[ 13.316814] yenta_cardbus 0000:04:01.0: ISA IRQ mask 0x0cb8, PCI irq 19
[ 13.316819] yenta_cardbus 0000:04:01.0: Socket status: 30000006
[ 13.316824] pci_bus 0000:04: Raising subordinate bus# of parent bus (#04) from #05 to #08
[ 13.316834] yenta_cardbus 0000:04:01.0: pcmcia: parent PCI bridge I/O window: 0xe000 - 0xefff
[ 13.316839] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xe000-0xefff: clean.
[ 13.317043] yenta_cardbus 0000:04:01.0: pcmcia: parent PCI bridge Memory window: 0xdf700000 - 0xdfffffff
[ 13.317048] yenta_cardbus 0000:04:01.0: pcmcia: parent PCI bridge Memory window: 0xdb000000 - 0xdcffffff
[ 13.318543] sdhci-pci 0000:04:01.2: SDHCI controller found [1180:0822] (rev 17)
[ 13.318958] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 19
[ 13.318965] sdhci-pci 0000:04:01.2: PCI INT C -> Link[LNKD] -> GSI 19 (level, low) -> IRQ 19
[ 13.321060] Registered led device: mmc0::
[ 13.322091] mmc0: SDHCI controller on PCI [0000:04:01.2] using PIO
[ 14.209170] phy0: Selected rate control algorithm 'minstrel'
[ 14.209967] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
[ 14.801779] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x100-0x3af: clean.
[ 14.802916] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x3e0-0x4ff: clean.
[ 14.803405] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x820-0x8ff: ex...

Read more...

Revision history for this message
Greg Odero-Jowi (ojgreg) wrote :

The "acpi_enforce_resources=lax" kernel boot option doesn't work for me. To be more specific, I have 3 LUKS encrypted partitions. I can unlock the first 2 but not the 3rd. I enter the passphrase and hit enter but nothing gives. I hit enter a second time and I get a message saying that "unlocking the partition failed".

Revision history for this message
Greg Odero-Jowi (ojgreg) wrote :

...I forgot to mention that kernel 2.6.28-16-generic works fine. Something has changed in the Ubuntu kernel packages since 2.6.28-16-generic that has broken my system.

Revision history for this message
Stefan Bader (smb) wrote :

@Greg, this problem does not sound like it would be related to the problem described in this bug. Please file a new one.

Revision history for this message
Zjemm (smitrix) wrote :

Hi I have an POV ION 330
when i install karmic latest version i have the nforce2 smbus conflict error
even with the GRUB_CMDLINE_LINUX="acpi_enforce_resources=lax" option in /etc/default/grub is does not work
any progress in fixxing this issue?

Revision history for this message
Stefan Bader (smb) wrote : Re: [Bug 440470] Re: [ubuntu-boot-experience] nForce2_smbus conflicts with ACPI region SM00

Zjemm wrote:
> Hi I have an POV ION 330
> when i install karmic latest version i have the nforce2 smbus conflict error
> even with the GRUB_CMDLINE_LINUX="acpi_enforce_resources=lax" option in /etc/default/grub is does not work
> any progress in fixxing this issue?

What does "does not work" mean exactly? The option will drop the
resource conflict message to a warning (so it does not show up on
the console) and allow the smbus driver to bind. You will still see
the warning in dmesg.
And for fixing this, I try to gather data from different systems
that are affected, to see whether there is a pattern to it.

Revision history for this message
Zjemm (smitrix) wrote :

Sorry, forgot to update grub after the change. it works, no error anymore

Revision history for this message
Csimbi (turbotalicska) wrote :
Download full text (14.2 KiB)

I have a Zotac GF9300-G-E, PCB version 4.
I use Ubuntu 9.10, amd64
I get this error message:
ACPI: I/O resource nForce2_smbus [0x1c80-0x1cbf] conflicts with ACPI region SM01 [0x1c80-0x1cbf]
nForce2_smbus 0000:00:03.2: Error probing SMB2.

Here's the output of "sudo dmidecode":

# dmidecode 2.9
SMBIOS 2.5 present.
40 structures occupying 1230 bytes.
Table at 0x000F0000.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: Phoenix Technologies, LTD
        Version: 6.00 PG
        Release Date: 10/09/2009
        Address: 0xE0000
        Runtime Size: 128 kB
        ROM Size: 1024 kB
        Characteristics:
                ISA is supported
                PCI is supported
                PNP is supported
                APM is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                BIOS ROM is socketed
                EDD is supported
                5.25"/360 KB floppy services are supported (int 13h)
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 KB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                CGA/mono video services are supported (int 10h)
                ACPI is supported
                USB legacy is supported
                LS-120 boot is supported
                ATAPI Zip drive boot is supported
                BIOS boot specification is supported
                Targeted content distribution is supported

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: NVIDIA
        Product Name: MCP7A
        Version: 2
        Serial Number: 1
        UUID: 00000000-0000-0000-0807-060504030201
        Wake-up Type: Power Switch
        SKU Number:
        Family:

Handle 0x0002, DMI type 2, 8 bytes
Base Board Information
        Manufacturer: NVIDIA
        Product Name: MCP7A
        Version: 2
        Serial Number: 1

Handle 0x0003, DMI type 3, 17 bytes
Chassis Information
        Manufacturer: NVIDIA
        Type: Desktop
        Lock: Not Present
        Version: MCP7A
        Serial Number:
        Asset Tag:
        Boot-up State: Unknown
        Power Supply State: Unknown
        Thermal State: Unknown
        Security Status: Unknown
        OEM Information: 0x00000000

Handle 0x0004, DMI type 4, 40 bytes
Processor Information
        Socket Designation: Socket 775
        Type: Central Processor
        Family: Other
        Manufacturer: Intel
        ID: 7A 06 01 00 FF FB EB BF
        Version: Intel(R) Celeron(R)
        Voltage: 1.2 V
        External Clock: 200 MHz
        Max Speed: 1200 MHz
        Current Speed: 1200 MHz
        Status: Populated, Enabled
        Upgrade: ZIF Socket
        L1 Cache Handle: 0x000A
        L2 Cache Handle: 0x000B
        L3 Cache Handle: Not Provided
        Serial...

Revision history for this message
mdalacu (mdalacu) wrote :

Same error on Asus EeePC 1201N. I'am using Karmic 2.6.31-17 x86. I think this bug affects my Lan and wifi card.

<i>[ 15.298203] ACPI: I/O resource nForce2_smbus [0x4e00-0x4e3f] conflicts with ACPI region SM00 [0x4e00-0x4e3f]
[ 15.298214] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 15.298222] nForce2_smbus 0000:00:03.2: Error probing SMB2. </i>

Revision history for this message
Fabian Riechsteiner (ruffy91-gmail) wrote :

Got the same problem on a ZOTAC ION ITX D 330 mainboard.

Revision history for this message
mdalacu (mdalacu) wrote :

I've tested "acpi_enforce_resources=lax" : same warning, no more error but again my laptop freezes when i try to copy a large file over LAN (smb mount) and my BIOS gets reseted ! So no luck here. I don't have other errors in dmesg.

Revision history for this message
Erhnam (piethein) wrote :

Same problem here on a ASROCK ION330-HT (Nvidia ION chipset). Using Karmic 2.6.31-17 x86.

Revision history for this message
Florian Dorn (florian-dorn) wrote :

I have the same issue on a Zotac ION ITX A, GeForce 9400 (dual PC2-6400U DDR2) with 2.6.31-16-generic x86

Revision history for this message
mkalbere (info-programmers) wrote :

Same issue on eeepc 1201 (ION) karmic with updated kernel 2.6.33-020633rc4-generic. ( I hoped it would help in some way).
I get
 ACPI: I/O resource nForce2_smbus [0x4e00-0x4e3f] conflicts with ACPI region SM00 [0x4e00-0x4e3f]

Problem: freeze on lan transfer, no log, no trace & bios reseted !

the wifi generate lost of log (every 2 minutes)
an 24 22:41:59 littleone wpa_supplicant[1005]: CTRL-EVENT-SCAN-RESULTS
Jan 24 22:41:59 littleone kernel: [ 5918.812581] ===========rtl8192se_update_ratr_table: ff5
Jan 24 22:41:59 littleone kernel: [ 5918.812588] ===>set to B/G mode
Jan 24 22:43:59 littleone wpa_supplicant[1005]: CTRL-EVENT-SCAN-RESULTS
Jan 24 22:43:59 littleone kernel: [ 6038.820075] ===========rtl8192se_update_ratr_table: ff5
Jan 24 22:43:59 littleone kernel: [ 6038.820082] ===>set to B/G mode

Revision history for this message
mythterious (samsara) wrote :

Same issue with an Asus A8N-LA (Compaq motherboard, no BIOS update available), kernels 2.6.31-16-generic and 2.6.31-17-generic. "acpi_enforce_resources=lax" doesn't make the boot symptom go away and I do experience random lockups.

[ 13.882321] ACPI: I/O resource nForce2_smbus [0x4c00-0x4c3f] conflicts with ACPI region SM00 [0x4c00-0x4c05]
[ 13.882324] ACPI: This conflict may cause random problems and system instability
[ 13.882326] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

Revision history for this message
X3 (x3lectric) wrote :

I have experienced same issue with all karmic kernels acpi laxing is not a real fix even if it suppresses the error, in some way the must be some IO probing being done by acpi and sensors banging IO ports which I understand can be harmful for hw. The asrock ION family has a hw monitoring/control chip with no drivers available in the wild from either Asrock or Linux communities. Asrock first line support say W83677HG-I (the chip in question) has linux drivers yet nowhere are they to be found.

I believe that this chip is also part of solving this issue properly lm-sensors project have a request for such driver but nothing so far is up.

Also noticed issues with kernels up to -18 karmic flavours have issues with supporting modules like coretemp for instance where the coretemp.ko must be compiled in order to work.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/485234

This is all related IMO.

Revision history for this message
chuck-dtol (chuck-colford) wrote :

I have the exact same error in my dmesg:
...
[ 17.069168] nvidia: module license 'NVIDIA' taints kernel.
[ 17.069173] Disabling lock debugging due to kernel taint
[ 17.102603] ACPI: I/O resource nForce2_smbus [0x4c00-0x4c3f] conflicts with ACPI region SM00 [0x4c00-0x4c05]
[ 17.102653] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 17.102657] nForce2_smbus 0000:00:0a.1: Error probing SMB1.
[ 17.102737] i2c-adapter i2c-0: nForce2 SMBus adapter at 0x4c40
[ 17.106484] k8temp 0000:00:18.3: Temperature readouts might be wrong - check erratum #141
...

My system is an Asus M2NPV-VM with a dual core AMD Athlon X2 and I'm running the 64 bit OS:
$ sudo uname -a
Linux Study 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 17:01:44 UTC 2009 x86_64 GNU/Linux

Attached is my dmidecode output in the hope it is helpful to those debugging.

Revision history for this message
Age Jan Kuperus (ajk-tt) wrote :

Same problem in lucid (Linux stil 2.6.32-12-generic #16-Ubuntu SMP Thu Jan 28 07:47:05 UTC 2010 x86_64 GNU/Linux)

Feb 4 08:41:00 stil kernel: [ 13.383187] ACPI: I/O resource nForce2_smbus [0x600-0x63f] conflicts with ACPI region SMRG [0x600-0x6ff]
Feb 4 08:41:00 stil kernel: [ 13.383248] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Feb 4 08:41:00 stil kernel: [ 13.383250] nForce2_smbus 0000:00:01.1: Error probing SMB1.
Feb 4 08:41:00 stil kernel: [ 13.383302] ACPI: I/O resource nForce2_smbus [0x700-0x73f] conflicts with ACPI region SM00 [0x700-0x73f]
Feb 4 08:41:00 stil kernel: [ 13.383359] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Feb 4 08:41:00 stil kernel: [ 13.383361] nForce2_smbus 0000:00:01.1: Error probing SMB2.

Revision history for this message
X3 (x3lectric) wrote :

This problem will exist for a long long time the proof of this as they say is in the pudding, priority low... (jokes) other ancient bugs still exist since forever up until even Lucid.

1st ALL ION platforms will and do exibit this error regardless of distro.

2nd Thers a lack of Linux drivers for a monitoring chipset which would very likely solve this.

3rd laxing kernel fixes this but borks all sorts.

Revision history for this message
justmad (edgar-cardeira) wrote :

just registered to say i have the some problem on a ion board.
I wish to say to those who say linux is the best, this sure demonstrates it. at least microsoft stuff boot.
This way linux will never ever have general public acceptance. It doesn't even boot my god.

Revision history for this message
argos (argos66) wrote :

Same problem with my motherboard :
ASUS M2N-SLI DELUXE

My kernel revision is from Lucid :
Linux argos-lnx 2.6.32-13-generic #18-Ubuntu SMP Wed Feb 10 21:32:38 UTC 2010 x86_64 GNU/Linux

Please let me know if this bug was open on kernel trackers ?

Thanks,

Revision history for this message
argos (argos66) wrote :

I have opened a bug on bugzilla kernel : http://bugzilla.kernel.org/show_bug.cgi?id=15361
Now it closed, because it's not a problem, only a resource conflict without incidence.

Revision history for this message
David Nielsen (davidnielsen-deactivatedaccount) wrote :

I am seeing this on Lucid, spewing error messages on boot is a tad scary to new users.

Changed in linux:
status: Unknown → Invalid
Revision history for this message
Csimbi (turbotalicska) wrote :

Invalid?
Care to explain why?

Revision history for this message
mdalacu (mdalacu) wrote :

Why this bug is invalid? At least we should have an explanation. Thanks.

Revision history for this message
Sense Egbert Hofstede (sense) wrote :

It was marked as Invalid upstream because upstream says it is harmless, as indicated in comment #32.

Revision history for this message
David Nielsen (davidnielsen-deactivatedaccount) wrote :

the invalid comes from the upstream kernel bugtracker, they closed the bug WONTFIX. The bugwatcher automatically pulls in that information.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

For a more complete explanation of the issues involved, see the FAQ entry here: http://www.lm-sensors.org/wiki/FAQ/Chapter3#Mysensorshavestoppedworkinginkernel2.6.31

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I have queried the upstream linux-acpi developers mailing list about the choice to make native hwmon drivers non-functional without adding the "acpi_enforce_resources=lax" cmdline parameter. You can follow the message thread at:

http://marc.info/?t=126747745400002&r=1&w=2

It appears to be the strong belief that the functionality in 2.6.31 and later kernels are the correct solution, and even a whitelist of hardware is unwise. Thus, the default for Ubuntu will remain consistent with upstream. If you want native hwmon driver support, you will need to manually override the protection by using the aforementioned cmdline parameter.

However, the boot error message does appear to be at too high of a log level. I have compiled a kernel that lowers the warning message. I need someone to test the kernel to ensure that:

1. The boot message no longer appears over the splash screen
2. The message still appears in dmesg

Please find the new kernel at http://people.canonical.com/~cndougla/440470/

Revision history for this message
Andreas Schildbach (schildbach) wrote :

1. and 2. confirmed, but the kernel totally screws up resolutions. It looks like it does not use KMS or something.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Andreas Schildbach:

Is the kernel acting differently than other lucid kernels?

Revision history for this message
Andreas Schildbach (schildbach) wrote :

@Chase: Compared to -14, it screws up resolutions but at least displays a picture. The official -15 kernel only displays garbage. Looks like -15 has serious problems.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Andreas Schildbach:

Ok. I will submit the patch upstream.

As for your graphics issues with -15, can you open a bug for it, and then try out a kernel in the "red" ppa: https://edge.launchpad.net/~apw/+archive/red/+packages. This is a time sensitive issue as we are in the midst of discussion on what to do with Lucid graphics drivers.

Thanks

Revision history for this message
Andreas Schildbach (schildbach) wrote :
Revision history for this message
mythterious (samsara) wrote :

If this symptom is harmless, then what is the reason for more random lockups with 2.6.31 than with 2.6.28 with nForce Ethernet?

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@mythterious:

The random lockups with nForce Ethernet are unrelated to this message. This message appears when you try to use the legacy hardware monitoring driver for your motherboard with a newer kernel. The newer kernel is guarding against instability by preventing two drivers from trying to talk to the same device. It's preventing a situation like having two bosses yelling at you to do two different things at the same time.

If you are experiencing lockups, you should look for another bug that is directed at that issue, or open a new bug if you can't find one.

Thanks

Revision history for this message
Chase Douglas (chasedouglas) wrote :

I've sent the patch to lower the log level to the kernel-team mailing list. An SRU justification for Lucid follows:

IMPACT: Users with native hwmon drivers will see a warning about ACPI resource conflicts over their boot splash screens. The log level of the message is KERN_ERR, which is too high for a notification/warning message.

ADDRESSED: The log level has been reduced to KERN_INFO as suggested upstream. Upstream also suggested cleaning up the formatting of the message, which has been included in the patch.

PATCH: See attached patch 0001-Reduce-ACPI-resource-conflict-message-to-KERN_INFO-p.patch

TEST CASE: Boot a system with a native hwmon for the hardware (i.e. an nForce 2 motherboard). Watch the screen for a ACPI resource conflict message to be displayed over the boot splash.

REGRESSION POTENTIAL: The change is highly unlikely to cause a regression because it is merely a message printout change.

Changed in linux (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Chase Douglas (chasedouglas)
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package linux - 2.6.32-19.28

---------------
linux (2.6.32-19.28) lucid; urgency=low

  [ Andy Whitcroft ]

  * [Config] enable various multitouch devices
    - LP: #541453

  [ Chase Douglas ]

  * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
    - LP: #545307
  * SAUCE: Disable function tracing after hitting __schedule_bug
  * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
    cleanup
    - LP: #440470

  [ Jesse Barnes ]

  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328

  [ John Johansen ]

  * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
    - LP: #539437
  * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
    load
    - LP: #458299
  * SAUCE: AppArmor: Return string len rather than the allocation size
    - LP: #551844
  * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
    fails.

  [ Luke Yelavich ]

  * [Config] Enable Nouveau DRM module on powerpc

  [ Stefan Bader ]

  * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
    - LP: #357673
  * [Config] Enable thinkpad-acpi ALSA volume control
    - LP: #357673

  [ Steve Conklin ]

  * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
    - LP: #492392, #539609

  [ Upstream Kernel Changes ]

  * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
    Dell Inspiron 700m"
    - LP: #515246
  * (pre-stable) softlockup: Stop spurious softlockup messages due to
    overflow
    - LP: #551068
  * backlight: mbp_nvidia_bl - add five more MacBook variants
    - LP: #511965
  * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
    - LP: #529130
  * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
    - LP: #544739
  * (pre-stable) USB: fix usbfs regression
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  * Input: add the ABS_MT_PRESSURE event
    - LP: #541453
  * HID: Support for 3M multitouch panel
    - LP: #541453
  * HID: make 3M PCT touchscreen driver standalone config option
    - LP: #541453
  * HID: add support for Stantum multitouch panel
    - LP: #541453
  * HID: make Stantum driver standalone config option
    - LP: #541453
  * HID: add support for Acer T230H multitouch
    - LP: #541453
  * HID: add support for Pixart Imaging Optical Touch Screen
    - LP: #541453
  * HID: fixed bug in single-touch emulation on the stantum panel
    - LP: #541453
  * HID: add pressure support for the Stantum multitouch panel
    - LP: #541453
  * HID: Support for MosArt multitouch panel
    - LP: #541453
  * HID: hid-ntrig add multi input quirk and clean up
    - LP: #541453
  * HID: n-trig: remove unnecessary tool switching
    - LP: #541453
  * HID: hid-ntrig: multitouch cleanup and fix
    - LP: #541453
  * HID: hid-ntrig: Single touch mode tap
    - LP: #541453
  * hid: ntrig touch events
    - LP: #541453
  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
    - LP: #531309
  * drm/i915: Part of: Add initial bits for VGA mode...

Read more...

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
tristan8276 (tristan8276) wrote :

I'm running Lucid Beta 2, with all updates, and I'm still getting:

[ 13.874283] nForce2_smbus 0000:00:01.1: Error probing SMB1

at boot.

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@tristan8276:

Do you see the error message over the boot splash screen or in your logs somewhere?

Thanks

Revision history for this message
eris23 (jdkatz23) wrote :

I see it flash before the splash screen and in the log (the plymouth splash only is on briefly before gdm on my nvidia binary system).

Revision history for this message
tristan8276 (tristan8276) wrote :

I see it both over the boot splash and in the logs. I don't see any other errors in the logs though, and I don't notice any problems with the OS after it boots.

Revision history for this message
mvisa (mikko-puolikuu) wrote :

I see it during boot, before the splash screen. It seems to me it prolongs the boot time by some time (maybe 3-5 sec).

Revision history for this message
Antonio Navarro (anavarrog) wrote :

After installing lucid beta 2 im experiencing the same problem: nForce2_smbus 0000:00:01.1: Error probing SMB1

Revision history for this message
Chase Douglas (chasedouglas) wrote :

It looks like we've solved half of this issue then. We got rid of the ACPI subsystem message, but now we need to fix the nforce message in the same way.

Because we like to keep one fix per bug report, can someone open a new bug for the nforce message specifically? Then note the new bug here. I'll work to get it fixed, though it's too late to get fixed for the Lucid cd image I think.

Thanks

Revision history for this message
tristan8276 (tristan8276) wrote :

Actually I had overlooked it, but in my logs I am still getting these two messages as well during boot:

[ 7.745964] ACPI: resource nForce2_smbus [0x5000-0x503f] conflicts with ACPI region SM00 [0x5000-0x5005]
[ 7.745974] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

Revision history for this message
Chase Douglas (chasedouglas) wrote :

@tristan8276:

Yes, you should continue to see these messages. The "fix" for this bug is that we made sure the priority of the messages doesn't force them to appear during boot, as they aren't terribly important unless you really want hwmon drivers to work. If you do, then you can override this manually through a cmdline interface, but that's just a hack. The real fix is to create a new ACPI aware hwmon driver for your device.

Revision history for this message
Jor (jlcigm) wrote :

I am experiencing the same problem at boot "nForce2_smbus 0000:00:01.1: Error probing SMB2" no matter if i disable the restricted drivers. Another thing is when i enable the nvidia restricted driver my xsplash resolution on boot and log off splash drops down to a low resolution like 800x600 but if i disable them it recognize the proper resolution of 1680x1050.

Jor (jlcigm)
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
Chase Douglas (chasedouglas) wrote :

@Jor:

Please don't change the status of a bug away from Fix Released unless you have a really good reason to. Please see comment #55 for more details.

Thanks

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Jor (jlcigm) wrote :

@Douglas Sorry! Didn't know what i was doing! I am new to this!

Revision history for this message
Marty Vowles (mvowles311) wrote :

I'm still getting this error message over the splash screen on the released Lucid. Using an M3N78-VM. Should the fix have prevented it in my case?

Revision history for this message
sanctimon (dj.martin) wrote :

This is not a fixed issue. I believe that this particular bug causes a 35-40 second delay to Lucid Lynx booting up on my NForce system. Once the error appears, only then does the splash screen also appear and the system boots up (there is distinct hd activity with the login screen soon to follow).

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

sanctimon,
    In that case, please open a new bug with apport collected data so that we can approach it fresh.

Thanks!

~JFo

Revision history for this message
sanctimon (dj.martin) wrote :

OK, thanks Jeremy. I will proceed to do so right away.

Revision history for this message
sanctimon (dj.martin) wrote :

OK, new bug opened: #575296.

Revision history for this message
stel (stel-onshore) wrote :

i get the error (console and dmesg) along with another symptom i suspect is related. i can't log into X. i get the session login screen and auth is accepted but then the screen goes blank and the display manager restarts. i get this error in the log file.

QFont::fromString: Invalid description 'Serif,20,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,50,0'
QFont::fromString: Invalid description 'Sans Serif,10,5,0,75,0'
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /tmp/0408003652/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon

my system

kubuntu lucid (w/ medibuntu source.list) dist-upgrade just now 2am 5-6-2010
kernel 2.6.32-22-generic #33-Ubuntu SMP
kdm
AMD Athlon(tm) Processor LE-1660
MCP78S [GeForce 8200] SMBus
asus M3N78-VM
using nvidia-current package = v 195.136.15

Revision history for this message
Nicodemus (white-shadow420) wrote :

i keep getting this error message when trying to boot up from the grub (dual booted), and linux will not boot up

nForce2_smbus 0000:00:0a.1: Error probing SMB1

i would give you more details but im new to linux and i dont know how to get a print out of the bug.

Revision history for this message
Ingo Fabbri (ingo-fabbri) wrote :

same here. getting the same error-message. @zotac gf9300-i-e

Revision history for this message
sanctimon (dj.martin) wrote :

Gentlemen, if this issue still affects you under 10.04 (Lucid Lynx), please say so at #530976.

Revision history for this message
sanctimon (dj.martin) wrote :

Apologies, disregard previous bug #. The correct one is: bug #575296.

Revision history for this message
ingo (ingo-steiner) wrote :

Same here observed in Lucid, but present also in Karmic on ASUS M2N-E:

Jun 5 20:14:05 pp kernel: [ 6.600915] k8temp 0000:00:18.3: Temperature readouts might be wrong - check erratum #141
Jun 5 20:14:05 pp kernel: [ 6.740961] ata8: port disabled. ignoring.
Jun 5 20:14:05 pp kernel: [ 6.903379] i2c i2c-0: nForce2 SMBus adapter at 0x1c00
Jun 5 20:14:05 pp kernel: [ 6.903387] ACPI: resource nForce2_smbus [0x1c40-0x1c7f] conflicts with ACPI region SM00 [0x1c40-0x1c45]
Jun 5 20:14:05 pp kernel: [ 6.903391] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Jun 5 20:14:05 pp kernel: [ 6.903393] nForce2_smbus 0000:00:01.1: Error probing SMB2.

Revision history for this message
rasos (rasos) wrote :

Tried with latest development kernel 2.6.35-999: The "Error probing SMB2" disappeared on the ASUS M3N78-VM.

cat syslog | grep 'nForce2'
Jun 21 23:08:27 media kernel: [ 0.488975] cpufreq-nforce2: No nForce2 chipset.
Jun 21 23:08:27 media kernel: [ 15.781071] i2c i2c-0: nForce2 SMBus adapter at 0x600
Jun 21 23:08:27 media kernel: [ 15.781080] ACPI: resource nForce2_smbus [io 0x0700-0x073f] conflicts with ACPI region SM00 [??? 0x00000700-0x0000073f flags 0x30]

However, I do not recommend to use that kernel for production use (see https://wiki.ubuntu.com/KernelTeam/MainlineBuilds ).

Revision history for this message
ingo (ingo-steiner) wrote :

On 21.06.2010 23:15, rasos wrote:
> Tried with latest development kernel 2.6.35-999: The "Error probing
> SMB2" disappeared on the ASUS M3N78-VM.

However the address conflict still persists, so they probably just
suppressed the error message ;-)

Revision history for this message
Chase Douglas (chasedouglas) wrote :

ingo,

Correct. The error message that everyone sees over the splash screen is now gone completely in the upstream kernels. No functionality has changed in the process.

Revision history for this message
ingo (ingo-steiner) wrote :

> No functionality has changed in the process.

That's a pity, suppressing just the message is cheating. You won't get
any further information to fix the real bug. And it definitely is a bug,
see here the "kern.log" from Hardy, where all works fine:

Jun 22 12:35:41 pp kernel: [ 54.573266] input: PC Speaker as
/devices/platform/pcspkr/input/input4
Jun 22 12:35:41 pp kernel: [ 54.589284] i2c-adapter i2c-0: nForce2
SMBus adapter at 0x1c00
Jun 22 12:35:41 pp kernel: [ 54.589302] i2c-adapter i2c-1: nForce2
SMBus adapter at 0x1c40
Jun 22 12:35:41 pp kernel: [ 54.665463] Linux video capture interface:
v2.00

and the second i2c port needs a module - probably it's the reason why
Lucid does not perform kernel-suspend correctly - as Hardy does!

While this is the error message in Lucid:

May 19 17:49:10 pp kernel: [ 16.013542] i2c i2c-0: nForce2 SMBus
adapter at 0x1c00
May 19 17:49:10 pp kernel: [ 16.013549] ACPI: resource nForce2_smbus
[0x1c40-0x1c7f] conflicts with ACPI region SM00 [0x1c40-0x1c45]
May 19 17:49:10 pp kernel: [ 16.013552] ACPI: If an ACPI driver is
available for this device, you should use it instead of the native driver

Revision history for this message
ingo (ingo-steiner) wrote :

Here the modinfo for the current/working module in Hardy:

~$ modinfo i2c_nforce2
filename: /lib/modules/2.6.24-28-generic/kernel/drivers/i2c/busses/i2c-nforce2.ko
description: nForce2/3/4/5xx SMBus driver
author: Hans-Frieder Vogt <email address hidden>
license: GPL
srcversion: EB7002ADFD3CBF38D5C15EF
alias: pci:v000010DEd00000446sv*sd*bc*sc*i*
alias: pci:v000010DEd000003EBsv*sd*bc*sc*i*
alias: pci:v000010DEd00000368sv*sd*bc*sc*i*
alias: pci:v000010DEd00000264sv*sd*bc*sc*i*
alias: pci:v000010DEd00000034sv*sd*bc*sc*i*
alias: pci:v000010DEd00000052sv*sd*bc*sc*i*
alias: pci:v000010DEd000000E4sv*sd*bc*sc*i*
alias: pci:v000010DEd000000D4sv*sd*bc*sc*i*
alias: pci:v000010DEd00000084sv*sd*bc*sc*i*
alias: pci:v000010DEd00000064sv*sd*bc*sc*i*
depends: i2c-core
vermagic: 2.6.24-28-generic SMP mod_unload

Revision history for this message
Chase Douglas (chasedouglas) wrote :

ingo,

You still have an error message, it is just in dmesg and /var/log/messages. However, it's not a big error. Remember, this driver is *only* to enable hardware monitoring of things like fans connected to the motherboard and extra thermometers. If you run with the boot option "acpi_enforce_resources=lax", you will have the same behavior as in hardy, but again this only affects the HW sensors driver.

That gets us back to the whole point of this bug. This bug is not about fixing functionality. This bug is about the boot experience. The message that gets printed over the splash screen is not only ugly, it makes people think that it's the primary cause of all their issues. It's not.

This should be fixed in the latest Maverick kernel, so I'm setting the bug state as appropriate.

Changed in linux (Ubuntu Karmic):
status: Triaged → Won't Fix
Revision history for this message
ingo (ingo-steiner) wrote :

> ** Changed in: linux (Ubuntu Karmic)
> Status: Triaged => Won't Fix

I am not talking about Karmic, but Lucid. There I have problems with
kernel-suspend and my suspicion is that it has something to do with that.

Here for comparison the modinfo obtained from Lucid:

modinfo i2c_nforce2
filename:
/lib/modules/2.6.32-22-generic/kernel/drivers/i2c/busses/i2c-nforce2.ko
description: nForce2/3/4/5xx SMBus driver
author: Hans-Frieder Vogt <email address hidden>
license: GPL
srcversion: F20A6E012E416B99979D5A1
alias: pci:v000010DEd00000AA2sv*sd*bc*sc*i*
alias: pci:v000010DEd00000752sv*sd*bc*sc*i*
alias: pci:v000010DEd000007D8sv*sd*bc*sc*i*
alias: pci:v000010DEd00000542sv*sd*bc*sc*i*
alias: pci:v000010DEd00000446sv*sd*bc*sc*i*
alias: pci:v000010DEd000003EBsv*sd*bc*sc*i*
alias: pci:v000010DEd00000368sv*sd*bc*sc*i*
alias: pci:v000010DEd00000264sv*sd*bc*sc*i*
alias: pci:v000010DEd00000034sv*sd*bc*sc*i*
alias: pci:v000010DEd00000052sv*sd*bc*sc*i*
alias: pci:v000010DEd000000E4sv*sd*bc*sc*i*
alias: pci:v000010DEd000000D4sv*sd*bc*sc*i*
alias: pci:v000010DEd00000084sv*sd*bc*sc*i*
alias: pci:v000010DEd00000064sv*sd*bc*sc*i*
depends:
vermagic: 2.6.32-22-generic SMP mod_unload modversions

And if you compare to Hardy, you notice that dependency on "i2c-core" is
missing. In fact such a module is not found in Lucis - missing???

This bug has been nominated for Lucid and there it should be confirmed +
triaged, isn't it?

Revision history for this message
ingo (ingo-steiner) wrote :

> If you run with the boot option "acpi_enforce_resources=lax", you will have the same behavior as in hardy

That's not true in my case, I did try to boot with "acpi_enforce_resources=lax" and it does not change anything. Same with 2.6.34 kernel.

See this bug report: https://bugs.launchpad.net/bugs/575296

Revision history for this message
Chase Douglas (chasedouglas) wrote :

ingo,

If the issues you are having did not change when you ran with "acpi_enforce_resources=lax", then that is an indication that this message is unrelated. That's the end point of all this. You have issues that are unrelated to this bug and the error message it squashed. Please continue to follow up in bug 575296 as you have been, but there's nothing more to say in this bug.

Revision history for this message
ingo (ingo-steiner) wrote :

Chase,

it is just hard to understand that fixing cosmetic things (this bug) has appearently priority over bug 575296 which addresses the root cause - it is even not yet triaged :-(

Revision history for this message
Chase Douglas (chasedouglas) wrote :

ingo,

I understand your frustration. It's not that this bug is really a higher priority, it's more that this bug has a known fix. We have so many bugs against the Ubuntu kernel that we have to try to fix bugs that we have a solution for, and then we have to work on finding solutions for bugs that are affecting lots of users and are very serious. To be fair, we don't just focus on cosmetic issues like the one in this bug. However, we do need to address simple bugs as well as we work on future releases.

Revision history for this message
jim weaver (lonewitch) wrote :

I have same trouble and I am a newby my bug is error probing smb1 if that matters pc works fine just hangs up a bit at boot with that error

Revision history for this message
DEVAJ (devaj-01) wrote :

SORRY FOR BEING IGNORANT,BUT WHERE IS THE FIX AS EVEN I AM SUFFERING FROM THE SAME BUG ON ASUS 1201N EEEPC

Revision history for this message
DEVAJ (devaj-01) wrote :

SORRY FOR BEING IGNORANT,BUT WHERE IS THE FIX AS EVEN I AM SUFFERING FROM THE SAME BUG ON ASUS 1201N EEEPC.I AM ON UBUNTU 10.4 NETBOOK REMIX

Revision history for this message
Jeremy Foshee (jeremyfoshee) wrote :

Those of you afected by similar bugs still, please file new bugs for your issues so that we can investigate them. Please also read the policy here: https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs.

Thanks!

~JFo

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
status: Confirmed → Fix Released
Revision history for this message
disto2 (disto2) wrote :

same problem with ASUS AT3N7A-I (ITX) Mainboard
and Kernel 2.6.32-24-generic (Mythbuntu)

Revision history for this message
disto2 (disto2) wrote :

i added the following line to /etc/default/grub

GRUB_CMDLINE_LINUX="acpi_enforce_resources=lax"

after that i did

sudo update-grub2

and restarted the system

now my problem seems to be solved.

Changed in linux:
status: Invalid → Fix Released
Changed in linux:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.