CompactFlash PCMCIA disk is not detected

Bug #43092 reported by Mark Shuttleworth on 2006-05-05
66
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Lee Jones
Nominated for Hardy by Niels Kristian Bech Jensen

Bug Description

Plugging in a compactflash card does not produce a mounted hard disk. Attached are logs of the PCMCIA events, as well as ioports and interrupts.

This shows the series of events logged by the kernel.

The results of cat /proc/iomem after the compactflash card has been inserted.

The results of cat /proc/ioports after the device is inserted.

The result of cat /proc/interrupts after the device is inserted.

David Tansey (djtansey) wrote :

I am also unable to mount my PCMCIA-loaded CompactFlash cards. I am using the latest Dapper Drake (installed before it was released, but now fully dist-upgraded.)

I filed another bug -- #47595. Though somehow I think that the one Mark Shuttleworth filed might get a higher priority.

Tim (cyboreal) wrote :

Is it possible to request that the urgency of this bug be elevated? Can we expect that it will be fixed in Dapper in later bugfixes?

Torrey Hoffman (thoffman) wrote :

This is still broken on an up-to-date Feisty, June 28th 2007. So a year has gone by with no progress?

When I plug my compact flash in to my IBM Thinkpad, I get kernel messages (dmesg):

pccard: {CMCIA card inserted into slot 1
pcmcia: registering new device pcmcia1.0
ata4: PATA max PIO0 cmd 0x00013100 ctl 0x0001310e bmdma 0x000000000 irq3
scsi3 : pata_pcmcia
ata4.00: qc timeout (cmd 0x91)
ata4.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)
ata4.00: qc timeout (cmd 0x91)
ata4.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)
ata4.00:limiting speed to UDMA7:PIO5
ata4.00: qc timeout (cmd 0x91)
ata4.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)

And no drive ever shows up (nothing in /proc/partitions, etc.)

Torrey Hoffman (thoffman) wrote :

Note for other people with this problem: It looks like upstream (the kernel developers) are getting close to a fix. See the thread which starts at: http://lkml.org/lkml/2007/5/15/231
As of June 25th, they have a workaround at least but are still investigating.

I am getting the exact same kernel messages on my ThinkPad X60s (Feisty, 2.6.20-16-generic) as Torrey:

[ 3218.348000] pccard: PCMCIA card inserted into slot 0
[ 3218.348000] pcmcia: registering new device pcmcia0.0
[ 3218.388000] ata11: PATA max PIO0 cmd 0x00019100 ctl 0x0001910e bmdma 0x00000000 irq 3
[ 3218.388000] scsi10 : pata_pcmcia
[ 3248.552000] ata11.00: qc timeout (cmd 0x91)
[ 3248.552000] ata11.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)
[ 3279.212000] ata11.00: qc timeout (cmd 0x91)
[ 3279.212000] ata11.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)
[ 3279.212000] ata11.00: limiting speed to UDMA7:PIO5
[ 3309.872000] ata11.00: qc timeout (cmd 0x91)
[ 3309.872000] ata11.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)

BUT it was working a few days ago. This is probably not the same problem as described by Mark back in 2006. I guess we should file a new bug for this Feisty issue.

I don't know if there is a new bug for this issue in Feisty, but I have been having it for a long time (I think that I filed a separate bug report but I can't find it at the moment) on my Thinkpad X31.

For what it's worth this bug is still present in Tribe 4.

MarkBrier (mark-brier) wrote :

This is down to the lack of the ide-cs module in the stock ubuntu kerrnel. Many bugs asking for this, no reason surfaced for why it isn't included. Totally irritating to say the least!

effell (effell) wrote :

I can confirm this problem using the stock 2.6.22-14.

Some time ago I built a 2.6.23 kernel in order to bypass ubuntu bug 147464 (a HARD LOCK on heavy internet traffic) and as luck would have it CF works great with that non-Ubuntu kernel. It does have the ide-cs module.

I congratulate the Ubuntu team on making me see the usefulness of building my own kernel. Great fun. Granted I use an obscure brand of laptop, the "Thinkpad X31".

Tomas 'tt' Krag (tt) wrote :

I can confirm this issue on a thinkpad x40 with DeLock PCMCIA to CF adapter.
This is with Hardy and 2.6.24-19-generic kernel.
-----------------------------------------------------------

[ 4074.065157] pccard: PCMCIA card inserted into slot 0
[ 4074.065410] pcmcia: registering new device pcmcia0.0
[ 4074.134990] scsi5 : pata_pcmcia
[ 4074.135836] ata6: PATA max PIO0 cmd 0x3100 ctl 0x310e irq 3
[ 4092.579759] ata6.00: qc timeout (cmd 0x91)
[ 4092.579773] ata6.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)
[ 4092.579782] ata6: failed to recover some devices, retrying in 5 secs
[ 4117.923009] ata6.00: qc timeout (cmd 0x91)
-----------------------------------------------------------

$ sudo pccardctl ident
Socket 0:
  no product info available
  manfid: 0x004f, 0x0000
  function: 4 (fixed disk)

---------------------------------------------------------------

Strangely enough it works sometimes, i.e. semingly at random, and then stops working again after reboot.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

I can confirm the bug on an Acer Extensa 5220 with a fully updated Hardy Heron. The CF card is inserted in a Sandisk Ultra PC Card Adapter.

BTW it works fine on Mandriva 2008.1.

Changed in linux:
status: New → Confirmed

It also seems to be fixed in the Intrepid Alpha 3 Desktop CD.

effell (effell) wrote :

Re this problem, for a thinkpad X31 running Ubuntu 7.10:
- stock kernel 2.6.22-15-generic is buggy.
- home-compiled kernel 2.6.23.9 is not buggy.

Ubuntu is a great OS, but it is weird that a kernel.org kernel works better than what they cook up.
What gives?

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Tomas 'tt' Krag (tt) wrote :

When you write that "the linux-image-2.6.27-* package is currently available for you to install and test.", is that referring to the intrepid kernel? I'm happy to test it out, but just want to make sure i'm downloading the right kernel, and the one in the intrepid repos is the only one i can find.

Hi Tomas,

Yup you are correct, linux-image-2.6.27-* is the latest Intrepid kernel available only in the Intrepid repos. Sorry for any confusion, but thanks for willing to test. It's definitely much appreciated. I'm hopeful for your results since Niels commented this appears to be fixed with Intrepid Alpha3 so hopefully the 2.6.27 kernel will yield the same successful results. Thanks.

Tomas 'tt' Krag (tt) wrote :

OK, I've run the first basic tests after installing

linux-image-2.6.27-1-generic
linux-restricted-modules-2.6.27-1-generic

from the intrepid repo, on a Thinkpad x40 running hardy, the CF card mounts correctly after boot, and seems to behave exactly as expected. There are a few other minor niggles with this kernel, but if it is otherwise stable, i'll keep it loaded next week and report back here if the CF card still acts the way it should.

Thanks for the update, now i can't wait for the intrepid final :-)

Thanks for the testing and the feedback everyone. Based on the positive reviews so far, I'm going to tentatively set this to "Fix Released" for Intrepid. Mark, since you are the original bug reporter, if this is not resolved for you please reopen this by setting the status back to "New". Also, if anyone who's confirmed this bug as fixed but sees any regressions prior to Intrepid's final release, please also reopen this report. Thanks.

Changed in linux:
status: Confirmed → Fix Released
yussef milburn (yussefmilburn) wrote :

Just updated to the 8.10 release, still having this problem. Running on a Thinkpad T61

$ uname -a
Linux tinker 2.6.27-7-generic #1 SMP Thu Oct 30 04:12:22 UTC 2008 x86_64 GNU/Linux

$ lspci |grep Card
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)

$ pccardctl ls
Socket 0 Bridge: [yenta_cardbus] (bus ID: 0000:15:00.0)

$ dmesg |tail
[12315.333084] cs: pcmcia_socket0: time out after reset.

Tomas 'tt' Krag (tt) wrote :

I can confirm that this isn't completely solved in 8.10 on my thinkpad x40
Now, the drive mounts correctly when i first insert it, but isn't mounted on boot or after suspend.

hex32 (cpaget) wrote :

Confirm this is still a problem in 8.10 release. Toshiba M30 Laptop.

root@laptop:~# uname -a
Linux laptop 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux
root@laptop:~# dmesg | tail
[ 283.736077] pccard: PCMCIA card inserted into slot 0
[ 283.738252] pcmcia: registering new device pcmcia0.0
[ 283.782673] scsi3 : pata_pcmcia
[ 283.784341] ata4: PATA max PIO0 cmd 0x3040 ctl 0x304e irq 4
[ 288.948083] ata4.00: qc timeout (cmd 0x91)
[ 288.948104] ata4.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)
[ 299.112210] ata4.00: qc timeout (cmd 0x91)
[ 299.112230] ata4.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)
[ 309.276082] ata4.00: qc timeout (cmd 0x91)
[ 309.276103] ata4.00: failed to IDENTIFY (INIT_DEV_PARAMS failed, err_mask=0x4)
root@laptop:~# pccardctl ident
Socket 0:
  product info: "SanDisk", "SDP", "5/3 0.6", ""
  manfid: 0x0045, 0x0401
  function: 4 (fixed disk)

Changed in linux:
status: Fix Released → Confirmed
Tomas 'tt' Krag (tt) wrote :

It seems to have gotten worse again after the latest set of kernel updates. It now doesn't work at all on my thinkpad x40 .

Allen (allenbt) wrote :

Have Ubuntu 8.10 installed - does not recognize the existence of a CF card (or SD card for that matter) in the pccard slot on a Thinkpad T60p. This is my primary way of transferring data so this is a big problem. Hardware works fine under Windows XP on the same machine.

Tomas 'tt' Krag (tt) wrote :

Informal testing indicates that this problem has gone away with the latest kernel updates. Now running 2.6.27-9-generic on my thinkpad x40 and the CF card gets mounted correctly after boot and suspend. I'll do more rigorous testing after christmas.

effell (effell) wrote :

As reported back in April 08:
on Ubuntu 7.10/Thinkpad X31
- no such bug using 2.6.23.9 from kernel.org
- yes such bug using 2.6.22.16 (current) from ubuntu reps.

effell (effell) wrote :

Found a workaround for this bug! A memory card in a PCMCIA->SD is also NOT recognized,
but somehow allows the CF card to be seen.
If you boot without an SD card in the adapter, then again the CF card is not recognized.
(Ubuntu 7.10 on a Thinkpad)

Lee Jones (lag) wrote :

What are the latest happenings with this bug?

No one has reported an issue since for over a year, can we finally put this bug to bed?

If this is still an issue, can someone provide me with a recent system log please?

Lee Jones (lag) on 2010-08-23
Changed in linux (Ubuntu):
assignee: nobody → Lee Jones (lag)
Lee Jones (lag) on 2010-08-23
Changed in linux (Ubuntu):
status: Confirmed → Triaged

Sorry I don't have the hardware any more, so can't test or repro. Anyone
else?

On Mon, Aug 23, 2010 at 5:40 AM, Lee Jones <email address hidden> wrote:

> What are the latest happenings with this bug?
>
> No one has reported an issue since for over a year, can we finally put
> this bug to bed?
>
> If this is still an issue, can someone provide me with a recent system
> log please?
>
> --
> CompactFlash PCMCIA disk is not detected
> https://bugs.launchpad.net/bugs/43092
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

Lee Jones (lag) wrote :

I think it's about time we put this one to bed.

If anyone has any major objections feel free to voice your concerns, either on here to with me directly.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
gcc (chris+ubuntu-qwirx) wrote :

I object! Please can we have a fix or workaround in Hardy? My X31 is too slow to run Lucid and I can't use the built-in CF card reader ever since I installed Hardy (I think it worked in Feisty).

gcc (chris+ubuntu-qwirx) wrote :

There's a one-line kernel patch here which apparently makes the device work, albeit in polling mode, which is much better than having a completely broken device:

http://lkml.org/lkml/2007/6/25/2

Lee Jones (lag) wrote :

Can you provide me with your dmesg whilst trying to use the card?

Which card is it that you own?

Lee Jones (lag) wrote :

And the results of "pccardctl ident" and "pccardctl info" if it's not too much trouble.

Lee Jones (lag) wrote :

With regards to #36:
  http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=1c20a493caa30c5d47a394f9dbd86e6282323db9

I can't put it back in, due to possible regressions.

If we want to solve this for Hardy, we'll have to figure out another way.

I'm fairly sure other people have Lucid running on their X31s - time to migrate?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers