Huawei E220 and E169 3G dongle do not work on karmic (major regression)

Bug #430011 reported by Paul Sladen on 2009-09-15
254
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
NetworkManager
New
Undecided
Unassigned
linux (Ubuntu)
High
Eric Miao
Declined for Karmic by Paul Sladen

Bug Description

uname -r:

  2.6.31-10-generic

lsusb:

  Bus 002 Device 004: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem

[ 2263.543848] usb 2-3: USB disconnect, address 2
[ 2263.543857] usb 2-3.4: USB disconnect, address 4
[ 2263.543875] option: option_instat_callback: error -108
[ 2263.544102] BUG: unable to handle kernel paging request at 0010378c
[ 2263.544113] IP: [<c0124478>] __ticket_spin_lock+0x8/0x20
[ 2263.544130] *pde = 00000000
[ 2263.544137] Oops: 0002 [#1] SMP
[ 2263.544145] last sysfs file: /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:03/PNP0C09:00/PNP0C0A:00/power_supply/BAT1/charge_full
[ 2263.544154] Modules linked in: ppp_deflate zlib_deflate bsd_comp ppp_async crc_ccitt binfmt_misc ppdev bridge stp bnep kvm_intel kvm lp parport option usb
[ 2263.544286]
[ 2263.544294] Pid: 273, comm: khubd Not tainted (2.6.31-10-generic #32-Ubuntu) MSI Notebook PR200
[ 2263.544301] EIP: 0060:[<c0124478>] EFLAGS: 00010092 CPU: 1
[ 2263.544309] EIP is at __ticket_spin_lock+0x8/0x20
[ 2263.544315] EAX: 0010378c EBX: 00000292 ECX: 0010378c EDX: 00000100
[ 2263.544321] ESI: 0010378c EDI: f66a73c0 EBP: f70f5d98 ESP: f70f5d98
[ 2263.544327] DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[ 2263.544334] Process khubd (pid: 273, ti=f70f4000 task=f72ecb60 task.ti=f70f4000)
[ 2263.544339] Stack:
[ 2263.544343] f70f5da0 c0124508 f70f5db4 c056af2a 00103784 0010378c f66a73c0 f70f5dc8
[ 2263.544361] <0> c0381ded 00103780 00000003 f66a73c0 f70f5df0 f8e9104b 00000003 f70f5df0
[ 2263.544379] <0> c040ca29 00000000 f70a0d00 f70a0d00 f70a0d1c f8ebf2e0 f70f5e0c c040fb19
[ 2263.544399] Call Trace:
[ 2263.544410] [<c0124508>] ? default_spin_lock_flags+0x8/0x10
[ 2263.544421] [<c056af2a>] ? _spin_lock_irqsave+0x2a/0x40
[ 2263.544431] [<c0381ded>] ? tty_port_tty_get+0x1d/0x50
[ 2263.544451] [<f8e9104b>] ? usb_serial_disconnect+0x6b/0x160 [usbserial]
[ 2263.544460] [<c040ca29>] ? usb_disable_interface+0x39/0x50
[ 2263.544470] [<c040fb19>] ? usb_unbind_interface+0xe9/0x120
[ 2263.544481] [<c039daee>] ? __device_release_driver+0x3e/0x90
[ 2263.544490] [<c039dc00>] ? device_release_driver+0x20/0x40
[ 2263.544499] [<c039cf43>] ? bus_remove_device+0x73/0x90
[ 2263.544507] [<c039b6af>] ? device_del+0xef/0x150
[ 2263.544517] [<c040c97d>] ? usb_disable_device+0x7d/0xf0
[ 2263.544527] [<c04075ce>] ? usb_disconnect+0x9e/0x110
[ 2263.544536] [<c04075ba>] ? usb_disconnect+0x8a/0x110
[ 2263.544546] [<c040797c>] ? hub_port_connect_change+0x7c/0x830
[ 2263.544554] [<c040d650>] ? usb_control_msg+0xd0/0x120
[ 2263.544563] [<c0400100>] ? init_cdrom_command+0x10/0x70
[ 2263.544573] [<c04091e5>] ? hub_events+0x1f5/0x500
[ 2263.544582] [<c05690cc>] ? schedule+0x40c/0x730
[ 2263.544592] [<c0133767>] ? finish_task_switch+0x57/0xe0
[ 2263.544601] [<c0157a8a>] ? finish_wait+0x4a/0x70
[ 2263.544611] [<c04094f0>] ? hub_thread+0x0/0x150
[ 2263.544619] [<c0409525>] ? hub_thread+0x35/0x150
[ 2263.544627] [<c0157930>] ? autoremove_wake_function+0x0/0x40
[ 2263.544636] [<c015763c>] ? kthread+0x7c/0x90
[ 2263.544644] [<c01575c0>] ? kthread+0x0/0x90
[ 2263.544653] [<c0103f17>] ? kernel_thread_helper+0x7/0x10
[ 2263.544657] Code: ff ff 90 b9 2a 43 12 c0 b8 2d 43 12 c0 e9 59 ff ff ff 90 b9 30 43 12 c0 b8 33 43 12 c0 e9 49 ff ff ff 90 55 ba 00 01 00 00 89 e5 <f0> 66
[ 2263.544765] EIP: [<c0124478>] __ticket_spin_lock+0x8/0x20 SS:ESP 0068:f70f5d98
[ 2263.544778] CR2: 000000000010378c
[ 2263.544786] ---[ end trace 015abc1379692bce ]---

Hi Paul,

Can you comment the most recent kernel where this does not happen. It'll help narrow window which the regression was introduced. Thanks.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: regression-potential
Paul Sladen (sladen) wrote :

When I catch Grub in time, booting into 2.6.28-11 is sufficient to avoid the dongle issues.

I'll try to bisect it a bit further when I get back to the boat, but it'll take some time as it takes between 6 to ~0 minutes for the serial stack to oops (after which a full reboot is required to get the dongle functional again).

Paul Sladen (sladen) wrote :

... 6 to ~30 minutes ...

I've been on for several hours at a time, but it always breaks down at some point.

Paul Sladen (sladen) wrote :

Bumping up based on popularity of this particular dongle.

Changed in linux (Ubuntu):
importance: Medium → High
Eric Miao (eric.y.miao) wrote :

Hey, can you just do a apport-collect to collect other information that is helpful?

For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies Thanks in advance!

Eric Miao (eric.y.miao) wrote :

I assume this has something to do with the recent changes to usb serial, bug has been submitted to kernel bugzilla on behalf of Paul.

Eric Miao (eric.y.miao) wrote :
Changed in linux (Ubuntu):
assignee: nobody → Eric Miao (eric.y.miao)
Eric Miao (eric.y.miao) wrote :

OK, here's a similar bug already reported: http://bugzilla.kernel.org/show_bug.cgi?id=13906.

Paul,

Could you please try the patch Alan mentioned: http://www.kernel.org/pub/linux/kernel/people/gregkh/gregkh-2.6/gregkh-05-tty/tty-usb-shutdown

Should you have any problem building the kernel, let me know, I'll try to build one for you.

Paul Sladen (sladen) wrote :

Eric: that patch link appears to be 404 (though if you have a pre-built test kernel I'll give it a spin for a couple of days and see if it gets oopsed.

Eric Miao (eric.y.miao) wrote :

It's actually merged by Linus in his tree at: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=4455e344959a217ffc28de2ab1af87541322b343, though not hitting stable yet.

Please try installing the kernel package within http://people.canonical.com/~ycmiao/lp430011/ to see if it solves you problem, thanks.

I reported a similiar bug a few days ago, but it was marked as
duplicate.
  However, I have never seen a kernel-oops (which also didn't show in
the log that I posted). Is it the same issue?

/ Faultygearbox

On Tue, 2009-09-22 at 13:44 +0000, Paul Sladen wrote:
> Bumping up based on popularity of this particular dongle.
>
> ** Changed in: linux (Ubuntu)
> Importance: Medium => High
>

Paul: any update on this? how has the test kernel been going?

Andy Whitcroft (apw) wrote :

The latest kernel stable updates 2.6.31.2 brought a major set of fixes for USB serial which is what this device is connected to. Could you retest with the latest kernel 2.6.31-12.39 or later and report back here. Thanks.

Cyril Jaquier (cyril-jaquier) wrote :

I also have a Huawei E220 and everything worked fine with 2.6.31-11.38 but since I upgraded to 2.6.31-12.39 the system freezes (even Magic SysRq don't work).

With 2.6.31-12.39, the modem seems to be recognized first as usb storage (nautilus pop-ups) and then (I guess) when switching to modem mode, the system freezes.

Here is a successful connection with 2.6.31-11.38:

[ 1513.712130] usb 3-1: USB disconnect, address 3
[ 1513.713290] option: option_instat_callback: error -108
[ 1513.713722] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 1513.713764] option 3-1:1.0: device disconnected
[ 1513.714049] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 1513.714099] option 3-1:1.1: device disconnected
[ 1527.832095] usb 3-1: new full speed USB device using uhci_hcd and address 4
[ 1527.995370] usb 3-1: configuration #1 chosen from 1 choice
[ 1528.002742] option 3-1:1.0: GSM modem (1-port) converter detected
[ 1528.002979] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB0
[ 1528.005410] option 3-1:1.1: GSM modem (1-port) converter detected
[ 1528.005624] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB1

Hugh Blemings (hughhalf) wrote :

Thanks for the additional information Cyril

Suspect it could be related to this thread;

http://lkml.org/lkml/2009/10/9/456

Cyril Jaquier (cyril-jaquier) wrote :

Hi Hugh,

Yes, this seems to be the problem we are facing. Hopefully, kernel devs are looking at it :-)

Andy Whitcroft (apw) wrote :

This may well be related to bug #446146, on that bug there is a suggested fix which I have applied to the karmic kernel and built some kernels for testing. Could those of you affected by this issue please try these kernels and report back here. The kernels can be found at the URL below:

     http://people.canonical.com/~apw/lp446146-karmic/

Changed in linux (Ubuntu):
assignee: Eric Miao (eric.y.miao) → Andy Whitcroft (apw)
status: Triaged → Incomplete
assignee: Andy Whitcroft (apw) → Eric Miao (eric.y.miao)
Eric Miao (eric.y.miao) wrote :

Paul, Seph, Cyril, and anyone please confirm that Andy's kernel solved this problem, it is reported to solve the similar issue by many others?

Cyril Jaquier (cyril-jaquier) wrote :

I think the patch has been included in the new kernel packages (as stated in bug #446146). I will test them with my Huawei E220 and report here.

I will also test them ASAP.

On Oct 16, 2009 5:45 p.m., "Cyril Jaquier" <email address hidden> wrote:

I think the patch has been included in the new kernel packages (as
stated in bug #446146). I will test them with my Huawei E220 and report
here.

-- Oops randomly with Huawei E220 3G dongle (regression)
https://bugs.launchpad.net/bugs/430011 Yo...

Download full text (7.7 KiB)

First test with the latest kernel in the official repositories.

ii linux-image-2.6.31-14-gen 2.6.31-14.48 Linux kernel image for version 2.6.31 on x86/x86_64

The modem is "visible" as a modem during one minute or two but then the device or the USB controller seems to trigger a reset. The device is then recognize as a USB mass storage for a few seconds. Kernel logs bellow. I will test now with the patch.

[ 943.870064] usb 5-1: new full speed USB device using uhci_hcd and address 6
[ 944.093222] usb 5-1: configuration #1 chosen from 1 choice
[ 944.097157] scsi21 : SCSI emulation for USB Mass Storage devices
[ 944.097605] usb-storage: device found at 6
[ 944.097607] usb-storage: waiting for device to settle before scanning
[ 944.472630] usb 5-1: USB disconnect, address 6
[ 944.752567] usb 5-1: new full speed USB device using uhci_hcd and address 7
[ 944.917223] usb 5-1: configuration #1 chosen from 1 choice
[ 944.922277] option 5-1:1.0: GSM modem (1-port) converter detected
[ 944.922360] usb 5-1: GSM modem (1-port) converter now attached to ttyUSB0
[ 944.924622] option 5-1:1.1: GSM modem (1-port) converter detected
[ 944.924689] usb 5-1: GSM modem (1-port) converter now attached to ttyUSB1
[ 944.925402] scsi24 : SCSI emulation for USB Mass Storage devices
[ 944.925521] usb-storage: device found at 7
[ 944.925523] usb-storage: waiting for device to settle before scanning
[ 949.924260] usb-storage: device scan complete
[ 949.927210] scsi 24:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
[ 949.949185] sr1: scsi-1 drive
[ 949.949297] sr 24:0:0:0: Attached scsi CD-ROM sr1
[ 949.949359] sr 24:0:0:0: Attached scsi generic sg2 type 5
[ 962.300289] sr1: CDROM (ioctl) error, command: Get configuration 46 00 00 00 00 00 00 00 20 00
[ 962.300300] sr: Sense Key : No Sense [current]
[ 962.300303] sr: Add. Sense: No additional sense information
[ 962.505311] sr1: CDROM (ioctl) error, command: Get configuration 46 00 00 00 00 00 00 00 20 00
[ 962.505322] sr: Sense Key : No Sense [current]
[ 962.505325] sr: Add. Sense: No additional sense information
[ 962.585238] option: option_instat_callback: error -108
[ 962.585386] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 962.585407] option 5-1:1.0: device disconnected
[ 962.585474] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 962.585490] option 5-1:1.1: device disconnected
[ 962.700078] usb 5-1: reset full speed USB device using uhci_hcd and address 7
[ 962.850462] option 5-1:1.1: GSM modem (1-port) converter detected
[ 962.850549] usb 5-1: GSM modem (1-port) converter now attached to ttyUSB0
[ 962.851334] option 5-1:1.0: GSM modem (1-port) converter detected
[ 962.851402] usb 5-1: GSM modem (1-port) converter now attached to ttyUSB1
[ 963.248269] option: option_instat_callback: error -108
[ 963.249521] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 963.249537] option 5-1:1.0: device disconnected
[ 963.249590] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 963.249604] option 5-1:1.1: device disconnected
[ 963.3...

Read more...

Cyril Jaquier (cyril-jaquier) wrote :
Download full text (5.1 KiB)

Second test with the patch.

$ uname -a
Linux cyril-laptop 2.6.31-13-generic #44lp446146apw1 SMP Mon Oct 12 09:13:02 UTC 2009 x86_64 GNU/Linux

Still does not work :-( Kernel logs below. The device is recognize as USB mass storage first but then disappear. network-manager recognizes the modem during a few seconds but disappear again.

[ 209.730068] usb 5-2: new full speed USB device using uhci_hcd and address 2
[ 209.893536] usb 5-2: configuration #1 chosen from 1 choice
[ 210.095042] Initializing USB Mass Storage driver...
[ 210.096516] scsi5 : SCSI emulation for USB Mass Storage devices
[ 210.096646] usbcore: registered new interface driver usb-storage
[ 210.096650] usb-storage: device found at 2
[ 210.096652] usb-storage: waiting for device to settle before scanning
[ 210.096655] USB Mass Storage support registered.
[ 210.470108] usb 5-2: USB disconnect, address 2
[ 210.750702] usb 5-2: new full speed USB device using uhci_hcd and address 3
[ 210.914533] usb 5-2: configuration #1 chosen from 1 choice
[ 210.927444] scsi8 : SCSI emulation for USB Mass Storage devices
[ 210.928538] usb-storage: device found at 3
[ 210.928540] usb-storage: waiting for device to settle before scanning
[ 210.980952] usbcore: registered new interface driver usbserial
[ 210.980964] USB Serial support registered for generic
[ 210.981018] usbcore: registered new interface driver usbserial_generic
[ 210.981019] usbserial: USB Serial Driver core
[ 211.028778] USB Serial support registered for GSM modem (1-port)
[ 211.028829] option 5-2:1.0: GSM modem (1-port) converter detected
[ 211.028914] usb 5-2: GSM modem (1-port) converter now attached to ttyUSB0
[ 211.028929] option 5-2:1.1: GSM modem (1-port) converter detected
[ 211.028971] usb 5-2: GSM modem (1-port) converter now attached to ttyUSB1
[ 211.028986] usbcore: registered new interface driver option
[ 211.028988] option: v0.7.2:USB Driver for GSM modems
[ 215.921573] usb-storage: device scan complete
[ 215.924501] scsi 8:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
[ 215.946494] sr1: scsi-1 drive
[ 215.946607] sr 8:0:0:0: Attached scsi CD-ROM sr1
[ 215.946670] sr 8:0:0:0: Attached scsi generic sg2 type 5
[ 228.378573] sr1: CDROM (ioctl) error, command: Get configuration 46 00 00 00 00 00 00 00 20 00
[ 228.378583] sr: Sense Key : No Sense [current]
[ 228.378587] sr: Add. Sense: No additional sense information
[ 228.580566] sr1: CDROM (ioctl) error, command: Get configuration 46 00 00 00 00 00 00 00 20 00
[ 228.580576] sr: Sense Key : No Sense [current]
[ 228.580580] sr: Add. Sense: No additional sense information
[ 228.647531] option: option_instat_callback: error -108
[ 228.647660] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 228.647679] option 5-2:1.0: device disconnected
[ 228.647739] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 228.647754] option 5-2:1.1: device disconnected
[ 228.762551] usb 5-2: reset full speed USB device using uhci_hcd and address 3
[ 228.923753] option 5-2:1.1: GSM modem (1-port) converter detected
[ 228.923840] usb 5-2: GSM modem (1-port) converter now ...

Read more...

These are exactly the symptoms I am experiencing.

I upgraded to 2.6.31-14 #48 to work around bug #406312. After the update, my modem would continuously reset.

As part of my testing, I blacklisted the option module. The modem still resets, and this is the log that always precedes the reset:

[ 228.378573] sr1: CDROM (ioctl) error, command: Get configuration 46 00 00 00 00 00 00 00 20 00

I did experience this problem before, when the E220 first came on the market. It was caused by hald firing off an application that probed the virtual CDROM device.

I worked around it initially by adding a blacklist to the hald rules (which I see is included in the default rules now, and in the installed Ubuntu, so it is not the problem now).

Since the device is still blacklisted, I have no idea where the probe is coming from now. I am also not sure why the kernel issues a device reset when the ioctl generates an error, but I think this is wrong.

There was also a patch at some stage that prevented usbstorage from detecting the Huawei device, which also solved the problem.

For now, the only way I have network access is to revert to the 2.6.31.11 kernel, and use usbserial, instead of the option driver.

Paul Sladen (sladen) wrote :

IIRC, initially the device powers exposing a profile that includes a USB cdrom (designed for storing MS Windows driver software not required for Linux). A kernel module then pokes the device into a mode that no longer shows the cdrom profile (and instead presents an additional serial port).

So perhaps it's a case of a serial driver implicitly hardcoded to presume that it's talking to a usb-serial endpoint, when in fact it might not be. I'm guessing that what we've had (working) for the last year is merely to blacklist and ignore the cdrom interface, whereas instead nothing *should bind* to it until it's been switched into another profile.

Download full text (7.5 KiB)

I have posted the bug 455493 and probably is a duplicate of this.
Posting more info:

uname -a
Linux in 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux

hardware; Huawey / Vodafone Mobile Connect k3520

lsusb
Bus 003 Device 007: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem

kernel log
 3580.280047] usb 3-1: new full speed USB device using uhci_hcd and address 2
 3580.462254] usb 3-1: configuration #1 chosen from 1 choice
 3580.503080] Initializing USB Mass Storage driver...
 3580.506116] scsi4 : SCSI emulation for USB Mass Storage devices
 3580.506313] usb-storage: device found at 2
 3580.506316] usb-storage: waiting for device to settle before scanning
 3580.506340] usbcore: registered new interface driver usb-storage
 3580.506344] USB Mass Storage support registered.
 3580.540097] usb 3-1: USB disconnect, address 2
 3581.320058] usb 3-1: new full speed USB device using uhci_hcd and address 3
 3581.492388] usb 3-1: configuration #1 chosen from 1 choice
 3581.517365] scsi8 : SCSI emulation for USB Mass Storage devices
 3581.520254] usb-storage: device found at 3
 3581.520260] usb-storage: waiting for device to settle before scanning
 3581.589949] usbcore: registered new interface driver usbserial
 3581.589987] USB Serial support registered for generic
 3581.590150] usbcore: registered new interface driver usbserial_generic
 3581.590157] usbserial: USB Serial Driver core
 3581.605032] USB Serial support registered for GSM modem (1-port)
 3581.605150] option 3-1:1.0: GSM modem (1-port) converter detected
 3581.605323] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB0
 3581.605349] option 3-1:1.1: GSM modem (1-port) converter detected
 3581.605462] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB1
 3581.605487] option 3-1:1.2: GSM modem (1-port) converter detected
 3581.605589] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB2
 3586.522951] usb-storage: device scan complete
 3586.525913] scsi 8:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
 3586.528895] scsi 8:0:0:1: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2
 3586.551077] sr0: scsi-1 drive
 3586.551088] Uniform CD-ROM driver Revision: 3.20
 3586.551373] sr 8:0:0:0: Attached scsi CD-ROM sr0
 3586.551538] sr 8:0:0:0: Attached scsi generic sg1 type 5
 3586.551799] sd 8:0:0:1: Attached scsi generic sg2 type 0
 3586.589868] option: option_instat_callback: error -108
 3586.593101] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
 3586.593124] option 3-1:1.0: device disconnected
 3586.593235] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
 3586.593263] option 3-1:1.1: device disconnected
 3586.593363] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
 3586.593383] option 3-1:1.2: device disconnected
 3586.710049] usb 3-1: reset full speed USB device using uhci_hcd and address 3
 3586.867119] option 3-1:1.2: GSM modem (1-port) converter detected
 3586.867309] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB0
 3586.868607] option 3-1:1.1: GSM modem (1-port) converter detected
 3586.868814...

Read more...

Graham Beneke (graham-beneke) wrote :

I am not sure that the original bug is still what we are experiencing here. There is no longer a kernel Oops - the kernel appears to repeatedly bring up and tear down the USB interface with the modem.

This makes the modem completely unusable by network-manager or any other app.

This actual bug here has been solved. What is left is a new regression discussed here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/446146

Kernel bug here:
http://bugzilla.kernel.org/show_bug.cgi?id=14355

It seems like the patch did not make it into the release kernel, so the majority of mobile Ubuntu users are stuffed until the first service release.

This is very annoying!

Imagine the frustration of many newbie and non expert users who only have a mobile internet connection and want upgrade or install 9.10!

Some questions to try help some users:
- There are any scheduled new ISO releases for 9.10 with this fixed?
- Can someone suggest an easy way to install an old kernel like 2.6.31-11 ?

Like this one ... i have waited for days for this version to fix graphics issues and now i cant net?

The fact that it was recognised prior to release and still released is weird ... not knowing how to patch ... or apply a .deb kernel instead ... do I just sit and wait

Paul Sladen (sladen) on 2009-10-29
summary: - Oops randomly with Huawei E220 3G dongle (regression)
+ Huawei E220 and E169 3G dongle do not work on karmic (major regression)

I volunteer to test kernel patch before release it.
Just contact me.

Paul Sladen (sladen) wrote :

Back in the UK; and 2.6.31-14.48 appears to be working.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Paul Sladen (sladen) wrote :

Oh perhaps not... but seconds later:

  15:07:01 pppd[3231]: Connect time 44.9 minutes.

Changed in linux (Ubuntu):
status: Fix Released → Incomplete
Bengt Grahn (bengt-vikingsw) wrote :

On my system, it worked the first time after upgrade to 9.10 (via the on-line upgrade). However, now it has reverted to the problem I found with the four Xubuntu and Ubuntu 9.10 CDs I've downloaded, namely a necessity to re-boot again after having booted once. There is no way of editing the network-manager setup, because before the authentication pop-up, a complaint dialog pops up, and when I close it after having authenticated, it closes the network manager editing window as well. The only way is to re-boot. Funny, though, it worked perfectly in 9.04!

Daniel (daniel-blaschke) wrote :

just wanted to mention, that I am experiencing the same problem: my e220 modem doesn't work with the new kernel 2.6.31-14.48 (amd64), but works fine with the old 2.6.28 (which I furtunately kept).

Daniel

As of today, with new proposed updates - this problem is sorted for me

Fábio Silva (fabiogsilva) wrote :

I still have no success with the new 2.6.31-15-generic kernel image on a fresh Karmic install. Still seeing the same symptoms: modem keeps being connected and disconnected all the time. I'm using the Huawei E220 dongle.

Fabio, have you set proposed updates on and done a refresh of package list? the new headers and image sorted this exact issue out for me this morning

oh - the version im using now is 2.6.31.15.28

Fábio Silva (fabiogsilva) wrote :

@Steven: Yes, I have. I'm using that version too.

Then i am not sure for your case, mine is working 100%

Which repository server has this new 2.6.31-15-generic kernel?
Currently using the "main server"...

I will try this:
https://launchpad.net/ubuntu/karmic/amd64/linux-image-2.6.31-15-generic/

Linux box 2.6.31-15-generic #49-Ubuntu SMP Fri Nov 6 09:52:03 UTC 2009 i686 GNU/Linux

Same problem with the Huawei E156B. It worked fine on Jaunty.

Linux 1101ha 2.6.31-15-lpia #50-Ubuntu SMP Tue Nov 10 14:53:03 UTC 2009 i686 GNU/Linux
Huawei E1692 TIM Italy
ID: 12d1:140c (sometimes the product id shows as 1446 instead of 140c)

Doesn't work on karmic (even the "cd" pseudo device), got it yesterday so never tested on jaunty. Gives almost the same syslog as the bug reporter.

e X t 7 3 (ext73) wrote :

hmm I thin this isn`t Kernel (only) proble. Now I testing kernel build by myself with Yours patch 15-50, and ... nothing new, modem doesn`t work properly ... sometimes work, sometims bugs like others wrote. Why I think this is not kernel bug ? Because I`m using Ubuntu 9.04 with my build of kernel 2.6.31.5 ... and there all is oki !!!!! ... and other question - off topic I know - Why Yours kernel are so slow ?... My build of kernel work very fast (vanila source without Your patch) under "pressure" -> http://www.youtube.com/watch?v=w5AO-YHV-RM

e X t 7 3 (ext73) wrote :

Hi now I`ve build new image of kernel 2.6.31.6 ... and on this one I have much less problems with hdspa modem (huawei 220) !
link to my kernel build -> http://forum.ubuntu.pl/showthread.php?t=109452&page=2

Mnemonic (bfk) wrote :

I have a LG X110 with a build in "Ericsson Business Mobile Networks BV" G3 Modem. USB attached.

Most of the time is does not recognize it, but sometimes it works. I was working in Ubuntu 9.04.

It seems to be more of a USB problem than a modem problem. When it is not working my other USB devices does not work too. Like my Webcam, and USB Sticks that I plug in. They are not detected.

e X t 7 3 (ext73) wrote :
Download full text (7.7 KiB)

hmm and this is no The end ;/

sometimes - firs connection, dmesg:

usb 1-2: new high speed USB device using ehci_hcd and address 6
usb 1-2: configuration #1 chosen from 1 choice
scsi5 : SCSI emulation for USB Mass Storage devices
usb 1-2: USB disconnect, address 6
usb-storage: device found at 6
usb-storage: waiting for device to settle before scanning
usb 1-2: new high speed USB device using ehci_hcd and address 7
usb 1-2: configuration #1 chosen from 1 choice
scsi8 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 7
usb-storage: waiting for device to settle before scanning
scsi9 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 7
usb-storage: waiting for device to settle before scanning
usb 1-5: reset high speed USB device using ehci_hcd and address 5
usb 1-5: device descriptor read/64, error -71
usb 1-5: device descriptor read/64, error -71
usb 1-5: reset high speed USB device using ehci_hcd and address 5
usb 1-5: device descriptor read/64, error -71
usb 1-5: device descriptor read/64, error -71
usb 1-5: reset high speed USB device using ehci_hcd and address 5
usb 1-5: device not accepting address 5, error -71
usb 1-5: reset high speed USB device using ehci_hcd and address 5
usb 1-5: device not accepting address 5, error -71
usb 1-5: USB disconnect, address 5
usb 1-5: new high speed USB device using ehci_hcd and address 8
usb 1-5: device descriptor read/64, error -71
usb 1-5: device descriptor read/64, error -71
usb 1-5: new high speed USB device using ehci_hcd and address 9
usb 1-5: device descriptor read/64, error -71
usb 1-5: device descriptor read/64, error -71
usb 1-5: new high speed USB device using ehci_hcd and address 10
usb 1-5: device not accepting address 10, error -71
usb 1-5: new high speed USB device using ehci_hcd and address 11
usb 1-5: device not accepting address 11, error -71
hub 1-0:1.0: unable to enumerate USB device on port 5
usb-storage: device scan complete
scsi 8:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
usb-storage: device scan complete
scsi 9:0:0:0: Direct-Access HUAWEI MMC Storage 2.31 PQ: 0 ANSI: 2
sr0: scsi-1 drive
Uniform CD-ROM driver Revision: 3.20
sr 8:0:0:0: Attached scsi CD-ROM sr0
sr 8:0:0:0: Attached scsi generic sg1 type 5
sd 9:0:0:0: Attached scsi generic sg2 type 0
sd 9:0:0:0: [sdb] Attached SCSI removable disk
usb 4-1: new full speed USB device using uhci_hcd and address 2
usb 4-1: not running at top speed; connect to a high speed hub
usb 4-1: configuration #1 chosen from 1 choice
scsi10 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 10:0:0:0: Direct-Access Generic- Multi-Card 1.00 PQ: 0 ANSI: 0 CCS
sd 10:0:0:0: Attached scsi generic sg3 type 0
sd 10:0:0:0: [sdc] Attached SCSI removable disk
ISO 9660 Extensions: Microsoft Joliet Level 1
ISOFS: changing to secondary root

second connection:

usb 1-2: new high speed USB device using ehci_hcd and address 6
usb 1-2: configuration #1 chosen from 1 choice
scsi5 : SCS...

Read more...

e X t 7 3 (ext73) wrote :

and I can connetcion with thsi tuttorial:

1. Cold boot with it unplugged.
2. sudo killall devkit-power-daemon
3. sudo killall devkit-disks-daemon
4. Plug in the E220
5. Wait for a while, when it shows up in Network Manager, connect.

but sometimes I`ve got something like below (all kernel wersuin - Yours 2.6.31-14.49 and .50, my 2.6.31.6)

e X t 7 3 (ext73) wrote :

aha this below on my last kernel: uname -a
Linux ext73-net-9 2.6.31.6-ext73-gtr-3.0 #1 SMP PREEMPT Wed Nov 18 10:32:27 CET 2009 i686 GNU/Linux

Same here, or rather at a friends house.

it connects but then it disconnects at random, it _sometimes_ works after some connects and disconnects and re-connects. it seems to be a problem with that it can not keep the connection with the network open.

$ lsusb
Bus 002 Device 003: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 03f0:7e04 Hewlett-Packard DeskJet F4100 Printer series
Bus 001 Device 002: ID 15d9:0a33 Unknown
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

$ uname -a
Linux larsolof 2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:54:29 UTC 2009 i686 GNU/Linux

tags: added: regression-release
removed: regression-potential

It seems to be fixed upstream:
http://bugzilla.kernel.org/show_bug.cgi?id=14355

Comment #10 From Rafael J. Wysocki 2009-11-16 23:10:05 -------

Fixed by commit b8430e1b82b7e514d76a88eb70a7d8831d50df1e .

tags: added: karmic
Changed in linux:
status: Unknown → Fix Released
DrPaulaner (dr-paulaner) wrote :

nop with the kernel 31.16 and the new 31.17 it is the same, this stick only does work with 31.15, who can this be? the error is known, was solved in the 15 kernel version and the new ones do forget this error and plug em in again.

so; if someone coul mark this as NOT SOLVED

viking777 (viking-f2s) wrote :

+1 for the above comment - it has not been fixed in the 31.16 kernel.

Joshia (joshia-setiawan) wrote :

I have an E220 also and i have reported this similar bug ( my bug is #417776 ) a month earlier than this bug (430011) but it seems that is has lack of updates, so I also decided to subscribe here.

The point is, even after 31.17 kernel in karmic, the problem is still unsolved in my computer.

Fix released means propably Lucid, not Karmic.

Rodolfo Pilas (rodolfo) wrote :

Huawei error SOLVED!

File /etc/udev/rules.d/usb_modeswitch.rules said:

########################################################
# Huawei E220 (aka "Vodafone EasyBox II", aka "T-Mobile wnw Box Micro")
# Huawei E230
# Huawei E270
# Huawei E870
# [...]
SUBSYSTEM=="usb", SYSFS{idVendor}=="12d1", SYSFS{idProduct}=="1003", RUN+="/usr/sbin/usb_modeswitch --default-vendor 0x12d1 --default-product 0x1003 --detach-storage-only "

and these options are DEPRECATED by usb_modeswitch

You must change it to:

SUBSYSTEM=="usb", SYSFS{idVendor}=="12d1", SYSFS{idProduct}=="1003", RUN+="/usr/sbin/usb_modeswitch --default-vendor 0x12d1 --default-product 0x1003 --huawei-mode "

and my Huawei E270 works like a charm.

Kernel: 2.6.31-16-generic
Ubuntu 9.10 Keramic

Ian Johnston (ian-orbister) wrote :

That would be a great solution, if my system actually had /etc/udev/rules.d/usb_modeswitch.rules ...

Ike Panhc (ikepanhc) wrote :

@Ian

Try installing usb-modeswitch first: sudo apt-get install usb-modeswitch

John Leach (johnleach) wrote :

Same here, flip-flops between a usb mass storage device and a gsm over and over. usb-modeswitch doesn't help, even with Rodolfo's changes. This is really a different bug to the one originally reported - there is no oops messages.

Ian Johnston (ian-orbister) wrote :

I've now tried installing usb-modeswitch. Both with without and with the --huawei-mode modification it fails to solve the problem.

I occasionally try to persuade colleagues to shift to Ubuntu. Situations like this - where most of the mobile broadband devices in use are disabled for months and the Ubuntu people don;t see this as any sort of a problem at all - make me despair. No wonder we still have bug #1.

Boniek (boniek12p) wrote :

Unfortunately it seems this bug is still an issue. Can you confirm this issue exists with the most recent Lucid Lynx 10.04 release - http://cdimage.ubuntu.com/releases/lucid/alpha-2/. If the issue remains in Lucid, please test the latest 2.6.32 upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . Let us know your results. Thank

Sebastian (slovdahl) wrote :

I'm also having problems with both my Huawei modems:
- E160E, Bus 001 Device 006: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
- E169, Bus 002 Device 003: ID 12d1:1001 Huawei Technologies Co., Ltd. E620 USB Modem

They both worked lika a charm 22 days ago according to network-manager. I've tried the latest upstream mainline kernel, linux-image-2.6.32-02063206-generic_2.6.32-02063206_i386.deb, with no luck. I'm currently using stock 2.6.31-18-generic, and I've also tried -14, -15 and -17.

aditirex (adi-tirex) wrote :

I tested too with the latest 2.6.32 from mainline and still no luck . in /var/log/messages stil shows it as mounted only as a CD-ROM Mass storage.
I subscribe to #61 , this is a really bad regression :(

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Sebastian (slovdahl) wrote :

I can actually get the modem to work using wvdial, however, network-manager doesn't detect it.

Tim Jones (tim-mr-dog) wrote :

To recognise that my E220 is plugged in, I often need to run: 'sudo restart network-manager'
I've even a panel button for it!

Stuart (stuart-ward) wrote :

The problems that people are continuing to have I believe relate to Network Manager and not to the original Kernel issues. I propose that this bug is closed and further issues are perused in a Network Manager bug.

Ian Johnston (ian-orbister) wrote :

According to lspci...

Before I installed usb-modeswitch, the E220 switches constantly (period about 5 seconds) between being mass storage and being a modem.

After I installed usb-modeswitch, the E220 switches constantly (period about 5 seconds) between being nothing at all and being a modem.

Sounds far more kernel than network-manager to me.

I have the same modem, 9.10 with all the updates, still the E220 is
detected as a mass storage unit, and dmesg reports a lots unknown
device errors. If I rmmod the usb-storage module then I can connect
from the network manager interface with no problems. So I'm pretty
sure it is a kernel issue

On Fri, Jan 29, 2010 at 10:35 AM, Stuart <email address hidden> wrote:
> The problems that people are continuing to have I believe relate to
> Network Manager and not to the original Kernel issues. I propose that
> this bug is closed and further issues are perused in a Network Manager
> bug.
>
> ** Also affects: network-manager
>   Importance: Undecided
>       Status: New
>
> --
> Huawei E220 and E169 3G dongle do not work on karmic (major regression)
> https://bugs.launchpad.net/bugs/430011
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Andrea

This still appears broken in 10.04 (with kernel 2.6.32-11-generic). The modem resets the moment that I try to go online and NetworkManager instantly tells that it has been disconnected. However, I can still get connected by retrying a few times (just as in 9.04).

SP (samipp) wrote :

Updated my Huawei E220 FW to 11.117.10.02.00, now my 9.10 with kernel 2.6.31-17 shows modem first as a USB-drive. Ejected drive (not unmount) and it started to show as a modem like it should. Then just chose from NetworkManager Enable Mobile Network and opened my connection. "Zadamn" I am on internet with my Karmic. Just took me three months to get correct info to get on line. Thanks for everybody for their input. I highly recommend to upgrade FW to latest one you can find.

SP (samipp) wrote :

Works the same way with 2.6.31-18

Startup->
Eject Vodafone USB-drive
NetworkManager->Choose Network provider

Connection made!

Johnathon (kirrus) wrote :

Upstream have patched. Is this one a serious enough bug that we can make a case for an SRU?

Ejecting the USB drive does not help. As soon as I try to connect, the modem resets and the USB drive appears again (still using lucid with 2.6.32-11 kernel). Retrying many times and possibly reconnecting the modem allows getting connected, but this takes a lot of attempt.

madbiologist (me-again) wrote :

There is a launchpad bug report for the E220 at bug #449394. It contains a link to an E220 firmware in comment 10. After upgrading their modem's firmware to the version available at this link, many people reported their E220s were now working. If you have a Vodafone branded modem you may want to use the firmware linked to in comment 24 of that bug instead. You may also need a 2.6.31-15 or later kernel, but you mentioned you are using 2.6.32-11 so you should be fine in that regard. There a few other workarounds/tricks among the various comments too. Also see comment 31 in that bug.

Unfortunately the upstream bug at http://bugzilla.kernel.org/show_bug.cgi?id=14499 seems to have stalled, although perhaps that is due to the success of the firmware updates. It seems that Huawei's original firmware was not fully compliant with the USB specification set by the USB Implementers Forum (USB-IF). There is short page on the USB-IF at http://en.wikipedia.org/wiki/USB_Implementers_Forum if you are interested.

If it doesn't work instantly after upgrading, _then_ follow SP's instructions in comments #71 and #72.

tags: added: patch

Same problem here. Cannot get a 3 UK Huawai e169 to work at all on Lucid Beta1. eee900. It worked flawlessly on Jaunty..

madbiologist (me-again) wrote :

The problem with the E169 should be fixed according to bug #446146 - you may also need to update the Huawei modem's firmware to a newer version. Try looking on your ISP's website for a newer version and instructions on how to apply it.

Cyril Jaquier (cyril-jaquier) wrote :

Hi guys,

Did you install usb-modeswitch? I have bought a Huawei E1692 the other day. My old E220 worked pretty out-of-the-box after a firmware upgrade but the E1692 only showed up as USB storage. Installing usb-modeswitch makes the device switch to modem automatically (triggered by udev).

Jeremy Foshee (jeremyfoshee) wrote :

Paul Sladen,
    Are you able to confirm if the information presented by madbiologist above resolves your issue?

Thanks!

~JFo

Changed in linux (Ubuntu):
status: Triaged → Incomplete

For the record, on Fedora 13 both my devices (E270 and E1820) work perfectly. Connection is established within seconds and on every attempt, unlike Ubuntu which may take a long time to connect and very often fails to connect at all, and E1820 also required installing usb_modeswitch to make it even get detected and I also had to disable PIN code request because NetworkManager connection status started flickering otherwise and the device wouldn't work. I had neither of these two problems on Fedora either.

Filippo Argiolas (fargiolas) wrote :

Same here E220 works flawlessly in Fedora 13 and doesn't even show up in Lucid's NetworkManager.

Changed in linux:
importance: Unknown → Medium
madbiologist (me-again) wrote :

@Filippo Argiolas - Did you update the firmware of your E220 as described in comment #75?

As this bug was originally reported against Karmic, and many other posters were also running Karmic, I propose closing this bug when support for Karmic officially ends at the end of this month - see https://help.ubuntu.com/9.10/about-ubuntu/C/
Users having a similar bug on Lucid would then be recommended to report a new bug.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.