ASUS 1101HA brightness hotkeys don't work, generate ACPI errors

Bug #429942 reported by Spock112 on 2009-09-15
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Rachid
Nominated for Jaunty by diogovieira
Nominated for Karmic by Spock112
Nominated for Lucid by Spock112
linux (Ubuntu)
Medium
Unassigned
Nominated for Jaunty by diogovieira
Nominated for Karmic by Spock112
Nominated for Lucid by Spock112

Bug Description

Hi,
some of the hotkeys don't work correct.
I'm using Ubuntu UNR 9.04. The keyboard layout is set to Asus-Laptop (the installer set it to Generic 105 (itel) I think) but ther is no change.

Correct are:
Fn+F1: Hibranate
Fn+F7: disable display backlight
Fn+F10,F11,F12: audio volume keys
Fn+Space: wake-up
Fn+Arrowkeys: Page up/down, end, pos1
Fn+Insert: Numlock

Wrong is:
Fn+F8: it should enable or disable the VGA output ... instead it increases audio volume (just like Fn+F12)

Nonefunctional are:
Fn+F2: Disable Wlan/Bluetooth
Fn+F3: Disable touthpad
Fn+F4: toggle fullscreen
Fn+F6,F7: Display brightnes/backlight control
Fn+F9: open taskmanager (in MS Win)

also nonefunctional is the extra buttom on the left above the keybord to disable touchpad.

--Fn+F2--Wlan--
for this key I get in 'xev':
xev | grep keycode
    request MappingKeyboard, first_keycode 8, count 247
    state 0x0, keycode 246 (keysym 0x1008ff95, XF86WLAN), same_screen YES,
    state 0x0, keycode 246 (keysym 0x1008ff95, XF86WLAN), same_screen YES,

and acpi_listen:
hotkey ATKD 00000010 00000024
----------------------

--Fn+F3/additional Touchpadkey--
nothing in xev but in acpi_listen:
hotkey ATKD 00000037 00000009
hotkey ATKD 00000037 0000000a
----------------------

--Fn+F4-toggle Fulscreen--
nothing in xev
acpi_listen:
hotkey ATKD 00000038 00000006
----------------------------------

--Fn+F5-decreas display-brightness/backlight--
nothing in xev and acpi_listen, but these messages in dmesg:
[ 2684.513714] ACPI Exception (exoparg2-0444): AE_AML_PACKAGE_LIMIT, Index (000000010) is beyond end of object [20080926]
[ 2684.513767] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_._Q0B] (Node f6c18900), AE_AML_PACKAGE_LIMIT
---------------------------------

--Fn+F6-increas display-brightness/backlight--
nothing in xev and acpi_listen, but these messages in dmesg:
[ 2844.889690] ACPI Exception (exoparg2-0444): AE_AML_PACKAGE_LIMIT, Index (000000010) is beyond end of object [20080926]
[ 2844.889743] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_._Q0D] (Node f6c18918), AE_AML_PACKAGE_LIMIT
--------------------------------

--Fn+F8-VGA-Output--
 xev | grep keycode
    request MappingKeyboard, first_keycode 8, count 247
    request MappingKeyboard, first_keycode 8, count 248
    request MappingKeyboard, first_keycode 8, count 247

sudo acpi_listen
hotkey ATKD 00000030 00000006
-----------------------------

--Fn+F9-Taskmanager--
xev | grep keycode
    request MappingKeyboard, first_keycode 8, count 247
    state 0x0, keycode 156 (keysym 0x1008ff41, XF86Launch1), same_screen YES,
    state 0x0, keycode 156 (keysym 0x1008ff41, XF86Launch1), same_screen YES,

sudo acpi_listen
hotkey ATKD 00000012 00000007
------------------------------

That's what I got. If you need anything else then tell me.

THX
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: MID [HDA Intel MID], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: MID [HDA Intel MID], device 0: ALC269 Analog [ALC269 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2824 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'MID'/'HDA Intel MID at 0xf3f38000 irq 23'
   Mixer name : 'Realtek ALC269'
   Components : 'HDA:10ec0269,104383ce,00100004'
   Controls : 12
   Simple ctrls : 7
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
MachineType: ASUSTeK Computer INC. 1101HA
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=de console-setup/layoutcode?=de
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.32
Reproducible: Yes
Tags: lucid needs-upstream-testing regression-potential
TestedUpstream: No
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/01/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0323
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1101HA
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0323:bd12/01/2009:svnASUSTeKComputerINC.:pn1101HA:pvrx.x:rvnASUSTeKComputerINC.:rn1101HA:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 1101HA
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Spock112 (spock112) wrote :

So ... I've done some research:

It seems that only user with the german version of the AUSUS EEE 1101HA have this problem.
Changing the keyboard-layout to any english/us one does nothing.

And eee-applet, eee-control don't work for this model.

Spock112 (spock112) wrote :

Hi again ....

so the wireless-switch works if you add "rfkill_input" to your "/etc/modules" ...

btw: like in bug #356335 eeepc-acpi-scripts is uninstallable. So I tried to load the eeepc_laptop module but this changes nothing (see bug #328989).

Still not working:
Taskmanager-Key -> sends Xev thats ok for me ...
Touchpad-Key(s) -> I don't really need them ...
Toggle-Fullscreen -> in UNR everything is fullscreen ^^

Display-Output and Brightness-Controll are verry important I think, the first one does something wrong and the last one has ACPI errors. So I think the BUG is in ACPI ... or wherever this Key-Events are maped.

Jose Bernardo (bernardo-bandos) wrote :

Hi, I managed to edit / hack a working version of eee-control 0.9.4, and it doesn't change anything, I still have the same errors as you with the FN keys. I have a portuguese keyboard on my 1101HA.

badook (kappamr) wrote :

The problem still exists in karmic beta (kernel 2.6.31-14-generic), the only exception is the wireless button which is working and fn+f8 doesn't change volume, but i couldn't test if it actually toggles on/off the vga out.
Kernel problems still exist for touch-pad keys not translating the ACPI event to an input event.

Spock112 (spock112) on 2009-10-23
affects: ubuntu → acpi-support (Ubuntu)
Steve Langasek (vorlon) wrote :

>i 'm using Ubuntu UNR 9.04. The keyboard layout is set to Asus-Laptop
> (the installer set it to Generic 105 (itel) I think) but ther is no change.

You shouldn't do that. In recent Linux distributions, the keyboard layout should be set to Evdev-managed keyboard.

badook, you mention that there are problems in karmic, but could you please also explicitly confirm that you have the same model?

There is no rfkill_input module in karmic; this should now work by default, yes.

Fn+F8/VGA - This key is trapped by gnome-settings-daemon, so you would never see output in xev anyway. But you should be able to run 'lshal -m' to get output like this:

$ lshal -m

Start monitoring devicelist:
-------------------------------------------------
06:33:05.168: computer_logicaldev_input_4 condition ButtonPressed = switch-videomode
^C
$

Please see https://wiki.ubuntu.com/Hotkeys/Troubleshooting for more information about this.

Do the brightness keys still cause ACPI errors in karmic?

Spock112 (spock112) wrote :

Hi again, after I get Karmic to work on my eee1101ha .... the news ...

so Fn+F8 works just well ...

And the brightnesskey still causes ACPI errors:

FN+F5:
[ 3771.188756] ACPI Exception: AE_AML_NO_RETURN_VALUE, Missing or null operand 20090521 dsutils-646
[ 3771.188779] ACPI Exception: AE_AML_NO_RETURN_VALUE, While creating Arg 0 20090521 dsutils-763
[ 3771.188807] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_._Q0B] (Node f7016900), AE_AML_NO_RETURN_VALUE

FN+F6:
[ 3808.344741] ACPI Error: Result stack is empty! State=f4506000 20090521 dswstate-98
[ 3808.344777] ACPI Exception: AE_AML_NO_RETURN_VALUE, Missing or null operand 20090521 dsutils-646
[ 3808.344800] ACPI Exception: AE_AML_NO_RETURN_VALUE, While creating Arg 0 20090521 dsutils-763
[ 3808.344828] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_._Q0D] (Node f7016918), AE_AML_NO_RETURN_VALUE

btw .... the backlightsettings from the gnome-powermanagement work fine .... also do xbacklight ....

Steve Langasek (vorlon) on 2009-10-30
summary: - ASUS 1101HA hotkeys wrong/don't work
+ ASUS 1101HA brightness hotkeys don't work, generate ACPI errors
Steve Langasek (vorlon) wrote :

Thanks, it sounds like the only outstanding issue is the ACPI error from the brightness hotkeys. Opening a bug on the linux package for this.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in acpi-support (Ubuntu):
status: New → Fix Released
splarz (dtm-marco) wrote :

I don't understand: has anybody fixed it? I don't think so, I still have problems with Fn+F5/F6. I think now it's obvious, but also "italian" eeepc 1101HA has this problem.

C. Reis (reic) wrote :

I don't think this can be regarded as fixed, too - I am still having trouble with the following keys:
Fn + F3 for disabling the touchpad does not work
Fn + F4 does nothing
Fn + F5 decreasing brightness does not work
Fn + F6 increasing brightness does not work
Fn + F7 does nothing
Fn + F8 does nothing
Fn + F9 does nothing
The Fn Button also should activate Numpad - funktions on the Keys 7, 8, 9, U, I, O, J, K, L and M.

A Button on the top left of the keyboard to disable the touchpad is also nonfunctional, as well as the multitouch - function of the touchpad itself.

I'll gladly submit any information that could be helpful to solve the problem - just give me a hint which files you could use.

Steve Langasek (vorlon) wrote :

Please file a new bug report, with information about what keys are not functioning correctly and what you expect them to do.

Spock112 (spock112) wrote :

with the new version of eee-controle (http://greg.geekmind.org/eee-control/deb/) the brightness control works fine. I haven't tested any other functions.

Jeremy Foshee (jeremyfoshee) wrote :

Hi Spock112,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/lucid . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 429942

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
jfestrada (jfestrada) wrote :

In my ASUS UL30A I have the same issue, the hotkeys are the as the computer of the bug description. When I start to monitoring the devicelist with "lshal -m" If I press fn+f6 I get the next output:

THE FIRST LINE IS GENERATED WITH FN+F5 THE REST IS GENERATED WITH ONLY ONE PRESS OF FN+F6

pexi@xxxxxx:~$ lshal -m

Start monitoring devicelist:
-------------------------------------------------
19:07:09.610: computer_logicaldev_input_0 condition ButtonPressed = brightness-down
19:07:16.016: computer_power_supply_battery_BAT0 property battery.remaining_time = 10540 (0x292c)
19:07:16.017: computer_power_supply_battery_BAT0 property battery.charge_level.rate = 13305 (0x33f9)
19:07:16.018: computer_power_supply_battery_BAT0 property battery.charge_level.current = 38955 (0x982b)
19:07:16.019: computer_power_supply_battery_BAT0 property battery.reporting.current = 38955 (0x982b)
19:07:16.020: computer_power_supply_battery_BAT0 property battery.reporting.rate = 13305 (0x33f9)
19:07:16.021: computer_power_supply_battery_BAT0 property battery.voltage.current = 15076 (0x3ae4)

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Spock112 (spock112) wrote :

So ...
I did collect the needed data ... using a 10.04 live system without psb-graphic (only vesa).
the brightness key do change the brightness ... but without displaying this nice notifyer window.
Also all other (wlan, audio, displayswith) exapt numlock and hibranate ceased functionalaty.
This is totaly not satisfactory!!!

Marcin (stepien1) wrote :

Okay all fixed, adding acpi_backlight=vendor to the kernel options fixed it, now it works just liked in 9.10.

@ Marcin...im a total n00b with linux....how do i do that?

MF (mmuruev) wrote :

I'm have brightness button problem too. It's not detect by xen programm. And of course no pop up in gnome then change brightness. Laptop Asus A6vm. In oldest version asus module this button work fine. About 3 years ago. But after change kernel module this key was lost.

Evgeny Kuznetsov (nekr0z) wrote :

Why is this bug marked "Incomplete". It looks like it's "Confirmed", if not even "Triaged" for Linux.

Note that nothing happende yet if i press Fn+F2/F3.....F9.

There's any solution available atm<'''??

If it's possible let me know

Regards

Ok, I found how the brightness can be adjusted by editing a text file:
1) Open a terminal and type sudo su to get root permissions
2) chmod 711 /sys/class/backlight/psb-bl/brightness to give permission to yourself to read/write the text file in question.
3)Use a text editor to open the text file, in the example it's leafpad: leafpad /sys/class/backlight/psb-bl/brightness
4) Choose a number from 1 - 100. You 'll probably want to set it somewhere inbetween (around 50 is ok). Save and you're done.

The above post helped me to set backlight dimmer on my Asus EEEPC 1101HA, running ubuntu 12.04.
But the commands have to be changed somewhat to actually change the file /sys/class/backlight/psb-bl/brightness

2) chmod 666 /sys/class/backlight/psb-bl/brightness
to give yourself permission to read/write (711 actually only gives execute permission)

3) Using a text editor (I use vi) gives Fsync errors (/sys is not a normal filesystem), so use the shell to write to the "file" instead:
First choose the number, for example 50. The command is:
echo 50 >| /sys/class/backlight/psb-bl/brightness

4) done.

Rachid (rachchood) on 2015-10-03
Changed in acpi-support (Ubuntu):
assignee: nobody → Rachid (rachchood)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers