Comment 0 for bug 367072

Allowed Xubuntu update manager to upgrade to 9.04
I left the machine running and came back this morning to an "Upgrade failed, please check internet connection, etc. and try again" message. I ran the update manager and again selected to upgrade to 9.04. This time it ran through all the steps up to the reboot.

On reboot, I let Grub select the new Kernel 2.6.28.11 and immediately get the following error:

BUG: Int 14: CR2 cl000000
          EDI cl000000 ESI 00000000 EBP c0731f50 ESP c0731f14
          EBX ff78f000 EDX 0000000e ECX 3fc04000 EAX 00000000
          err 00000002 EIP c073c30d CS 00000060 flg 00010016
Stack: ff78f000 ffffffff 00000001 00000002 00881000 00000000 ff78f000 ffffffff
          00000000 00000000 00000000 c0731fc4 c073ec52 00000000 c0731f76 00000004
          00000086 00000000 0000000f 000000a7 205b0000 30202020 c0731fd8

I get the same error if I select Kernel 2.6.28.11 (recovery mode)
If I select Kernel 2.6.27.11, I get a grey-blue screen (the background color of xubuntu login screen) which flashes a few times and locks up.
Only Kernel 2.6.27.11 (recovery mode) works correctly, but finds no package or other errors and only gets me to a console.