Int 14 error when booting into 9.04 after upgrade

Bug #367072 reported by Lance L on 2009-04-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Allowed Xubuntu update manager to upgrade to 9.04
I left the machine running and came back this morning to an "Upgrade failed, please check internet connection, etc. and try again" message. I ran the update manager and again selected to upgrade to 9.04. This time it ran through all the steps up to the reboot.

On reboot, I let Grub select the new Kernel 2.6.28.11 and immediately get the following error:

BUG: Int 14: CR2 cl000000
          EDI cl000000 ESI 00000000 EBP c0731f50 ESP c0731f14
          EBX ff78f000 EDX 0000000e ECX 3fc04000 EAX 00000000
          err 00000002 EIP c073c30d CS 00000060 flg 00010016
Stack: ff78f000 ffffffff 00000001 00000002 00881000 00000000 ff78f000 ffffffff
          00000000 00000000 00000000 c0731fc4 c073ec52 00000000 c0731f76 00000004
          00000086 00000000 0000000f 000000a7 205b0000 30202020 c0731fd8

I get the same error if I select Kernel 2.6.28.11 (recovery mode)
If I select Kernel 2.6.27.11, I get a grey-blue screen (the background color of xubuntu login screen) which flashes a few times and locks up.
Only Kernel 2.6.27.11 (recovery mode) works correctly, but finds no package or other errors and only gets me to a console.

ADDED INFORMATION: I reinstalled Intrepid from CD (which worked fine) and then tried to upgrade to 9.04 again and got the same error on the reboot. Then I tried using a 9.04 Alternate Install CD for a clean install and again get the same error, but this time immediately after telling the CD to install (after passing a disk integrity check). So definitely repeatable on my system and only an issue with 9.04. This machine is an old Compaq Presario 5868, w/ 600mhz Athlon processor, AMD751 chipset, & 3DFX Voodoo 3 AGP video card. It utilizes a dynamic drive overlay and a Highpoint IDE hard disk controller to allow it to read a 120 Gig HD, otherwise stock.

affects: ubuntu → linux (Ubuntu)
Lance L (mrlechner) on 2009-04-28
description: updated
Lance L (mrlechner) on 2009-04-29
description: updated
summary: - Fails to boot new kernel 2.6.28.11 after upgrade
+ Int 14 error when booting into 9.04 after upgrade
Morris Daniels (mdaniels2-nc) wrote :

I've had the same problem with upgrading on a Compaq 7000 from the prior Ubuntu version and it has the original hard disk drive. I reloaded from a CD with V9.04 and got the same error. Reinstall the prior version and it works fine.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates.

Any chance someone kept the upgrade logs from /var/log/dist-upgrade or the logs from a new install in /var/log/installer ? I know it has been a very long time, but sometimes... I am not able to reproduce this issue on my systems, installing 8.10, adding all the updates, then upgrading to 9.04 using update-manager.

Changed in linux (Ubuntu):
status: New → Incomplete
Charlie Kravetz (charlie-tca) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers