Ubuntu

HP Pavilion dv5: ATA exception on resume from suspend [FIXED]

Reported by Paul Swanson on 2008-11-23
290
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by adityaw

Bug Description

** This bug has been fixed by a BIOS update released from HP (Updated 2nd of June 2009) **

On resume from suspend in Ubuntu 8.10 (Intrepid Ibex) the ATA driver throws a series of exceptions, as a result the filesystems can not be accessed and the computer needs to be rebooted. Hibernate, however, does work and does not have this problem, suspend / resume only. The linux kernel version is the latest 2.6.27-7.

* Update 2nd of June * If you have a similar problem with model other than a dv5, dv4, dv6 or HDXx, please start a new bug report

* Update 16th of May 2009 * The problem remains unchanged under Ubuntu 9.04 (Jaunty Jackalope).

The initial error message on resume is:

btusb_intr_complete: hci0 urb f7d94a00 failed to resubmit (2)
ata2: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
ata2: irq_stat 0x00000040, connection status changed
ata1: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
ata1: irq_stat 0x00000040, connection status changed
sd 0:0:0:0: rejecting I/O to offline device
PM: Device 0:0:0:0; failed to resume: error 65536

Then, as nothing is able function properly, the most repeated error message is as follows:

ata1: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
ata1: SError: { DevExch }
ata2: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
ata2: irq_stat 0x00000040, connection status changed
ata2: SError: { DevExch }

There are a variety of other error messages thrown about ext3 file systems not being to be re-mounted, but I haven't been able to capture those yet.

I'm running a fresh copy of Ubuntu 8.10 (Intrepid Ibex), with the latest updates, on a reasonably new HP Pavilion dv5 (1075er) notebook.

Rationale:

Originally I posted my problem under bug #158050 but later I realised that this was for an older kernel version. Then I thought that bug #273323 would be a better fit, but that has since digressed into a KDE discussion, entirely irrelevant to my problem. I've looked at every Intrepid suspend / resume bug listed and none are specific to my distribution version, kernel version or hardware so I'm starting a new one.

* Update 16th of May 2009 * There has been a Kernel Bug Report open on this for some time now http://bugzilla.kernel.org/show_bug.cgi?id=12276

* Update 18th of May 2009 * There is also evidence, anecdotal and otherwise, to suggest that the same problem is present on HDX and some other models of HP laptop.

Paul Swanson (paul-swanson) wrote :
Paul Swanson (paul-swanson) wrote :

The dmesg output. I wish there were some way we could add multiple attachments on launchpad. zip / tar balls just don't cut it.

Paul Swanson (paul-swanson) wrote :

And for the magic ...

Magic number: 0:953:373
hash matches /build/buildd/linux-2.6.27/drivers/base/power/main.c:390

I will greatly appreciate any help that can be given. I've tried a lot of solutions out there and none have helped or changed the outcome in any way. As you can appreciate, suspend / resume is a really important feature on a laptop / notebook computer.

Thanks.

freak007 (freak-linux4freak) wrote :

I can confirm this problem.
I have a HP laptop (dv7-1050ef) and i have the same problem.

Maybe a problem with acpi bios ?

The problem still persist with kernel 2.6.28-rc6.
Hibernate works fine but suspend to ram not.

freak007 (freak-linux4freak) wrote :
freak007 (freak-linux4freak) wrote :
freak007 (freak-linux4freak) wrote :
freak007 (freak-linux4freak) wrote :
freak007 (freak-linux4freak) wrote :

I can notice some changes with kernel loading:
- if I use my system with software RAID
- if I use my system without software RAID (duplicate system)

The kernel loading is faster without software RAID, and there is the two lines if I boot with software RAID:
[ 5.030012] pci 0000:00:1a.7: EHCI: BIOS handoff failed (BIOS bug?) 01010001
[ 5.580012] pci 0000:00:1d.7: EHCI: BIOS handoff failed (BIOS bug?) 01010001

These lines don't exist in non-RAID boot.

freak007 (freak-linux4freak) wrote :

Adding libata.noacpi=1 at kernel command line for 2.6.28 kernel has no effect.
Adding pci=nomsi solve sound resume, but has no effect for the sata.

Paul Swanson (paul-swanson) wrote :

Thanks freak007 for contributing to this bug report. Have you had any luck with this bug yet? I'm quite convinced it's a kernel driver issue, which puts it out of my hands for an easy fix. I can't understand why so many laptops can have the same boring old Intel hardware yet everyone seems to have their unique problems. Is it, perhaps, the HP BIOS that is to blame?

Paul Swanson (paul-swanson) wrote :

Just tried updating my HP BIOS from F.09 to F.11 but resume from suspend is still broken; the latest kernel update (2.6.27-9.19) has had no effect either.

Paul Swanson (paul-swanson) wrote :

freak007 has confirmed the same problem. Please excuse me if I'm not doing the right thing by confirming this.

Changed in linux:
status: New → Confirmed
freak007 (freak-linux4freak) wrote :

A kernel bug has been opened about this problem:

http://bugzilla.kernel.org/show_bug.cgi?id=12113

freak007 (freak-linux4freak) wrote :

the last bios update from hp (F21) solves the problem !

freak007 (freak-linux4freak) wrote :

paul_swanson, your problem is fixed for you too ?

Paul Swanson (paul-swanson) wrote :

Well, unfortunately I don't have that BIOS update available for mine (even though the machine is practically identical to yours less a few inches of display) so I'm still at the mercy of HP or some philanthropic kernel boffins. So I'm a little sad. Suspend / Resume is really important on laptop computer. I must add that aside from this giant hole, the installation of Ubuntu was almost perfect (Wireless / Video / Hot keys etc..) and definitely FAR less painful than Vista was (which took a whole evening of downloading drivers).

So ... if you're out there and reading this with the same problem ... don't be shy, add your name to the list!

Bill Liming (bill-limings) wrote :

I can confirm this problem on my dv5t with BIOS fc11. Note that the kernel bug listed above has been closed since the problem was fixed on the dv7 with the BIOS update. I've contacted HP about whether we can expect the changes made for the dv7 BIOS to be implemented on the dv5t.

Bill Liming (bill-limings) wrote :

Also, in case it's of any use:

I get the problem with both 32-bit and 64-bit Ubuntu.

Booting from a USB flashdrive of either version of Ubuntu 8.1 resume "works", but generates the same errors and the HD in the system is no longer accessible.

Upgrading to just the Jaunty kernel doesn't fix anything. In the process of upgrading to the entire Jaunty install now to see if that makes a difference.

Paul Swanson (paul-swanson) wrote :

I'm planning to open a new kernel bug (or reopen that older one) in the near future. Although freak007 was able to fix theirs with a HP BIOS update it was not a dv5, and there is no such magic bullet available yet. Additionally, the dv5 suspend / resume works 100% under Vista so we know that it is not entirely the fault of HP, there is clearly a way of getting to work without a BIOS update.

I did notice the other day a difference in how Ubuntu and Vista deal with the Suspend / Resume feature:

Ubuntu puts the laptop into a suspend state that requires the power button to be pressed for resume to be triggered, whereas Vista only requires a keystroke to reactivate. Perhaps the suspend state that Ubuntu uses is just not the right one for a dv5.

Does anyone else find this to be so?

Bill Liming (bill-limings) wrote :

That's an interesting note. My mom has a Vaio laptop (don't know the model number off the top of my head, but it's a C2D so reasonably new) that also only resumes with a power button press. All the other laptops I've used with Linux resume on a lid open, so I just assumed that was a Vaio specific bug or a problem with her machine (it was a refurb). If there's a difference in sleep modes related to the power-button-to-wake phenomena, that would be an avenue to explore.

Vincent Law (vincentlaw) wrote :

I'm facing with this problem too as explained here https://answers.launchpad.net/ubuntu/+question/51749/+index.
Actually it seems to impact many owners of dv5 notebook series from HP.

Paul Swanson (paul-swanson) wrote :

Bill Liming: I think you may find that the behaviour on your mum's Vaio is a question of manufacturer configuration, not a bug. But, please experiment with your dv5 and leave the results here, also please include the error messages you are getting on resume. Thanks.

Vincent: Welcome, unfortunately. I've left a post on the question you mention in order to attract some traffic this way, the more numbers the more chance of attracting some help I figure. Also, could you leave some detail on the exact model of your laptop and the error messages you get here. Thanks.

Everybody else: I think Bill is right, we should each contact HP support and request that the suspend / resume feature be looked into for the next BIOS update. I plan to open / reopen a kernel bug tomorrow as it's still plausible that the current kernel approach to the resume method is flawed in some way; it does, after all, work under Vista.

description: updated

HP support's response to me was that they don't support linux on Pavilions, period, so I'm not sure how likely it is that this will be fixed by them other than accidentally.

Also, my dv5 is probably going back to HP for other reasons, so I won't be able to follow up further.

Vincent Law (vincentlaw) wrote :

My model: HP DV5-1130EF
I like to point out this link http://hardware4linux.info/computers/sysinfo/3637/ to let anyone interested have some details of my hardware configuration.
But in addition, you can look at my lspci-vvnn in attachment

The error messages I have noticed are almost the same you have reported Paul :
{ Many error messages before errors before but scrolling too fast to be noted }

ata1: irq_stat 0x00000040, connection status changed
ata1: SError: {DevExch }
ata2: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen

ata2: irq_stat 0x00000040, connection status changed
ata2: SError: {DevExch }
ata1: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen

And as I mentionned in answer to the question i previously refered to, when coming back from suspend to ram, the process stops to a black graphical screen with movable cursor - but nothing more - and when i switch to a console by hitting CTRL+ALT+F1 the terminal is filled with the above error messages.

neub (benpaka) wrote :

Hello,

I'm using a HP DV5 1073ez and I have exactly the same the same problem.

ata1: irq_stat 0x00000040, connection status changed
ata1: SError: {DevExch}
ata2: exception Emask 0x10 SAct 0x0 SErr 0x40000000 action 0xe frozen.

And i also think that it is better to correct the bug in the kernel rather than asking hp to update the BIOS.

You can look to my lspci in this post http://forum.ubuntu-fr.org/viewtopic.php?id=265413 (French)

Hello,

I have also the problem with HP Pavilion DV5t-1000. As neub, I think the kernel should be fixed there.

http://hardware4linux.info/computers/sysinfo/3646/

Paul Swanson (paul-swanson) wrote :

I'm going to assign this bug to the Ubuntu Kernel Team as according to https://wiki.ubuntu.com/KernelTeamBugPolicies

I've been able to determine that the problem with resume is on account of 'some' device driver, that effects the SATA controller, not waking up after going into S3 (suspend to RAM) mode. I've also been able to determine that S1 (standby only) mode is not available under under the current Ubuntu kernel on my dv5; so no plan B available. :(

From what I've read on the above wiki page, the problem is likely not to lie with the power management drivers but some other hardware driver, maybe the SATA controller in our case. Unfortunately, when ever I follow the instructions for running a PM trace I don't get any extra clues, other than what's expected.

Paul Swanson (paul-swanson) wrote :
Paul Swanson (paul-swanson) wrote :

Assigning bug to the Ubuntu Kernel Team now that there are enough confirmed cases of this behaviour.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
Jorge_C (jorge.c) wrote :

I was having the same problem (this error: irq_stat 0x00000040, connection status changed) when waking up from suspend, and I'd like to confirm that updating the BIOS to F21 solves the problem and everything is fully functional afterwards. Unfortunately, it is in a dv7-1080es.

Paul Swanson (paul-swanson) wrote :

I ran a test suspend on booting that I read about in the kernel documentation and got a curious result.

I added test_suspend=mem to the kernel boot time parameters (in grub) and my laptop did the following:

* Blanked the display
* Let out a series of system beeps
* Continued to boot AFTER I hit the keyboard (I could see the hard drive light going for a little while)
* The display did not reactivate

So I hit the power button and it shut itself down (while the screen remained blank). I'm sure it resumed, somewhat properly, because it was able to WRITE the kernel log file. Kern.log had an entry "PM: Finishing wakeup.", evidencing something of a suspend / resume event and subsequent hard drive activity.

I guess you could call that a partially successful suspend / resume. It is worth reiterating that this was a kernel test suspend run during the boot process.

Hello guys.

I have the HP Pavilion dv-5 1138tx, and I can confirm to having this exact problem. I am using 8.10, fully updated and such.

Just to test it out, does anyone know how to install the HP bios updates from a bootable cd? HP help site mentions something called ROMPaq, but it doesn't have clear instructions on how to use it.

Cheers.

sshlyk (sshlyk) wrote :

I have the same problem

Someone mentioned bios f.21
I only can see f.21 for dv7. Did someone tried to flash dv5? Probably bad idea :)

Can't wait for this bug to be fixed. Resume is the most used feature of my laptop

sshlyk (sshlyk) wrote :

can you believe that HP puts pre-installed OS name(maybe something else) directly into the BIOS? Way to ruin their business

Bill Liming (bill-limings) wrote :

Just FWIW, I did in fact try flashing the DV5 with the DV7 F.21 BIOS. It wouldn't do the update.

sshlyk (sshlyk) wrote :

I guess we have to wait for some magic from HP or I am going to sell my new laptop I've just bought
Why all this companies hate linux? :( Microsoft b*hes

Vincent Law (vincentlaw) wrote :

@Starcraftmazter : I've already been using bootable CDROM HP ROM Paq in professional enviromnent. My observations are that they seems to be bundled for one precise range of server and contain firmware updates for SCSI cards and disks, BIOS, netcards and many other components. One more thing to be noticed is that they seem to be linux based !!
Example: http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=15351&prodSeriesId=1121486&prodNameId=3288144&swEnvOID=2025&swLang=8&mode=2&taskId=135&swItem=MTX-3d1aaa0b48c04b628789e598d3

@sshlyk : As you can see in my previous link, at least on their servers ... HP actually DOES support Linux :-)

sshlyk (sshlyk) wrote :

Right, Vincent, but you are talking about HP servers, not Desktops
HP does not support Linux on Any desktop machine or laptop :(

Changed in linux:
status: Unknown → Invalid
Jshack (ennearch) wrote :

I have a dv4 with the same problem and I updated the BIOS to f.22, the current for my model, and the problem still exists. In fact, hibernation delivers the message:

ata2: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
ata2: irq_stat 0x00000040, connection status changed
ata1: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
ata1: irq_stat 0x00000040, connection status changed

before it completes and it takes 1.5 times longer to go into hibernation and resume. But it does still work.

Changed in linux:
status: Invalid → Unknown
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
status: Confirmed → In Progress
description: updated
description: updated
description: updated
tags: added: jaunty
Changed in linux (Ubuntu):
assignee: nobody → Kernel Bugs (kernel-bugs)
description: updated
140 comments hidden view all 220 comments
Jim Raredon (decoy-umd) wrote :

Update for HDX 16 users: the recently released F.20A BIOS update does NOT fix this problem. All it does is update the firmware on the GPU for NVIDIA users.

On a side note... Paul, thank you so much for all of your efforts!!!

Paul Swanson (paul-swanson) wrote :

Don't mention it! I just wish a I had the ability to carve some magical code and be done with all of this. All I can carve is comments. ;)

Let's keep up the pressure! They're bound to give in some time. :D

Paul Swanson (paul-swanson) wrote :

Don't mention it! I just wish I had the ability to carve some magical code and be done with all of this. All I can carve is comments. ;)

Let's keep up the pressure! They're bound to give in some time. :D

Ivan (ivanhuertas) wrote :

Same error on a dv5-1235dx recentrly buyed.
Attaching dmesg, lspci & lsusb

I think this is fixed in the latest HP bios updates for the dv4, dv6, and dv7, released March-May 2009. I'd guess the corresponding dv5 update will be soon.

Anyone knows if this bug affects also some other distro like openSuse or
Mandriva? Maybe it may be only a distro problem

2009/5/28 WC Epperson <email address hidden>

> I think this is fixed in the latest HP bios updates for the dv4, dv6,
> and dv7, released March-May 2009. I'd guess the corresponding dv5
> update will be soon.
>
> --
> HP Pavilion dv5: ATA exception on resume from suspend
> https://bugs.launchpad.net/bugs/301353
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: In Progress
> Status in “linux” source package in Ubuntu: Confirmed
>
> Bug description:
> On resume from suspend in Ubuntu 8.10 (Intrepid Ibex) the ATA driver throws
> a series of exceptions, as a result the filesystems can not be accessed and
> the computer needs to be rebooted. Hibernate, however, does work and does
> not have this problem, suspend / resume only. The linux kernel version is
> the latest 2.6.27-7.
>
> * Update 16th of May 2009 * The problem remains unchanged under Ubuntu 9.04
> (Jaunty Jackalope).
>
> The initial error message on resume is:
>
> btusb_intr_complete: hci0 urb f7d94a00 failed to resubmit (2)
> ata2: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
> ata2: irq_stat 0x00000040, connection status changed
> ata1: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
> ata1: irq_stat 0x00000040, connection status changed
> sd 0:0:0:0: rejecting I/O to offline device
> PM: Device 0:0:0:0; failed to resume: error 65536
>
> Then, as nothing is able function properly, the most repeated error message
> is as follows:
>
> ata1: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
> ata1: SError: { DevExch }
> ata2: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
> ata2: irq_stat 0x00000040, connection status changed
> ata2: SError: { DevExch }
>
> There are a variety of other error messages thrown about ext3 file systems
> not being to be re-mounted, but I haven't been able to capture those yet.
>
> I'm running a fresh copy of Ubuntu 8.10 (Intrepid Ibex), with the latest
> updates, on a reasonably new HP Pavilion dv5 (1075er) notebook.
>
> Rationale:
>
> Originally I posted my problem under bug #158050 but later I realised that
> this was for an older kernel version. Then I thought that bug #273323 would
> be a better fit, but that has since digressed into a KDE discussion,
> entirely irrelevant to my problem. I've looked at every Intrepid suspend /
> resume bug listed and none are specific to my distribution version, kernel
> version or hardware so I'm starting a new one.
>
> * Update 16th of May 2009 * There has been a Kernel Bug Report open on this
> for some time now http://bugzilla.kernel.org/show_bug.cgi?id=12276
>
> * Update 18th of May 2009 * There is also evidence, anecdotal and
> otherwise, to suggest that the same problem is present on HDX and some other
> models of HP laptop.
>

It's been verified that this bug affects other distros and there is a
kernel bug open for this afaik

lordlukas wrote the following on 05/28/2009 12:18 AM:
> Anyone knows if this bug affects also some other distro like openSuse or
> Mandriva? Maybe it may be only a distro problem
>
> 2009/5/28 WC Epperson <email address hidden>
>
>
>> I think this is fixed in the latest HP bios updates for the dv4, dv6,
>> and dv7, released March-May 2009. I'd guess the corresponding dv5
>> update will be soon.
>>
>> --
>> HP Pavilion dv5: ATA exception on resume from suspend
>> https://bugs.launchpad.net/bugs/301353
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in The Linux Kernel: In Progress
>> Status in “linux” source package in Ubuntu: Confirmed
>>
>> Bug description:
>> On resume from suspend in Ubuntu 8.10 (Intrepid Ibex) the ATA driver throws
>> a series of exceptions, as a result the filesystems can not be accessed and
>> the computer needs to be rebooted. Hibernate, however, does work and does
>> not have this problem, suspend / resume only. The linux kernel version is
>> the latest 2.6.27-7.
>>
>> * Update 16th of May 2009 * The problem remains unchanged under Ubuntu 9.04
>> (Jaunty Jackalope).
>>
>> The initial error message on resume is:
>>
>> btusb_intr_complete: hci0 urb f7d94a00 failed to resubmit (2)
>> ata2: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
>> ata2: irq_stat 0x00000040, connection status changed
>> ata1: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
>> ata1: irq_stat 0x00000040, connection status changed
>> sd 0:0:0:0: rejecting I/O to offline device
>> PM: Device 0:0:0:0; failed to resume: error 65536
>>
>> Then, as nothing is able function properly, the most repeated error message
>> is as follows:
>>
>> ata1: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
>> ata1: SError: { DevExch }
>> ata2: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
>> ata2: irq_stat 0x00000040, connection status changed
>> ata2: SError: { DevExch }
>>
>> There are a variety of other error messages thrown about ext3 file systems
>> not being to be re-mounted, but I haven't been able to capture those yet.
>>
>> I'm running a fresh copy of Ubuntu 8.10 (Intrepid Ibex), with the latest
>> updates, on a reasonably new HP Pavilion dv5 (1075er) notebook.
>>
>> Rationale:
>>
>> Originally I posted my problem under bug #158050 but later I realised that
>> this was for an older kernel version. Then I thought that bug #273323 would
>> be a better fit, but that has since digressed into a KDE discussion,
>> entirely irrelevant to my problem. I've looked at every Intrepid suspend /
>> resume bug listed and none are specific to my distribution version, kernel
>> version or hardware so I'm starting a new one.
>>
>> * Update 16th of May 2009 * There has been a Kernel Bug Report open on this
>> for some time now http://bugzilla.kernel.org/show_bug.cgi?id=12276
>>
>> * Update 18th of May 2009 * There is also evidence, anecdotal and
>> otherwise, to suggest that the same problem is present on HDX and some other
>> models of HP laptop.
>>
>>
>
>

Newsflash: HP has released a new BIOS update (F.16 A) for the dv5 (well at least for my model). It claims the following improvements:

* Updates the Intel MRC Code to version 2.7.
* Updates the Intel AHCI OP ROM to version iSrc 1.20_E.0012 11252008.
* Updates the BIOS to support Microsoft Windows Vista Operating Systems with Service Pack 2 (SP2).

The good news: This update looks very promising
The bad news: The download is currently NOT working (file not found)

So it seems we must wait a little longer still ... fingers crossed.

Dan Joakim Eiworth (jeiworth) wrote :

Hi Paul,

Thanks for the update and I am having my fingers crossed that this will fix the issue (I am using my lap for work so this bug really annoys me a _lot_)

How do you guys install the BIOS update? I guess I am not the only one here who completely deleted the Vista installation,thanks for help!

---------- Forwarded message ----------
From: Lester Wade <email address hidden>
Date: Thu, May 28, 2009 at 2:39 PM
Subject: dv5 BIOS 2851715-3961544-0518:1431-AAGENX
To: <email address hidden>
Cc: <email address hidden>

Hi Sergey,

You wrote:

> I am the owner of a HP dv5 laptop and I have learned that my firmware
> has a bug which is causing me some big problems. My laptop will
> suspend,
> but when it wakes up the hard drive will not reactivate so I need to
> reboot. You can imagine how much of a pain this is on laptop!

Thank you for contacting HP.

You have reached the HP team focused on addressing questions and
feedback from our customers relating to Linux on HP products.

Thank you for the information you supplied.

I have spoken to the BIOS teams and this was indeed a known issue. A
BIOS update has recently be released to fix this, please visit
http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-71090-1&lc=en&dlc=en&cc=us&lang=en&os=2093&product=3759509

Kind Regards,

--
Lester Wade
Linux.helpcustomers Team
--
HP is committed to respecting your privacy. For more information, visit
http://welcome.hp.com/country/us/en/privacy/worldwide_privacy.html

I have just applied HP's F16A BIOS to my DV5-1000ea. This has solved the suspend/resume issue.

A BIG thanks to Paul, TJ and all who took time to get involved.

I've applied the latest update to my DV5-1138tx, and I can too confirm that sleep now works!!

Thanks a lot to Paul Swanson and everyone else who worked hard to make this happen :D
And to HP for finally fixing it, hehe.

This is great news! Thanks to all of you for your time and effort

On Thu, May 28, 2009 at 2:53 PM, Corruptor1972
<email address hidden> wrote:
> I have just applied HP's F16A BIOS to my DV5-1000ea.  This has solved
> the suspend/resume issue.
>
> A BIG thanks to Paul, TJ and all who took time to get involved.
>
> --
> HP Pavilion dv5: ATA exception on resume from suspend
> https://bugs.launchpad.net/bugs/301353
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: In Progress
> Status in “linux” source package in Ubuntu: Confirmed
>
> Bug description:
> On resume from suspend in Ubuntu 8.10 (Intrepid Ibex) the ATA driver throws a series of exceptions, as a result the filesystems can not be accessed and the computer needs to be rebooted. Hibernate, however, does work and does not have this problem, suspend / resume only. The linux kernel version is the latest 2.6.27-7.
>
> * Update 16th of May 2009 * The problem remains unchanged under Ubuntu 9.04 (Jaunty Jackalope).
>
> The initial error message on resume is:
>
> btusb_intr_complete: hci0 urb f7d94a00 failed to resubmit (2)
> ata2: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
> ata2: irq_stat 0x00000040, connection status changed
> ata1: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
> ata1: irq_stat 0x00000040, connection status changed
> sd 0:0:0:0: rejecting I/O to offline device
> PM: Device 0:0:0:0; failed to resume: error 65536
>
> Then, as nothing is able function properly, the most repeated error message is as follows:
>
> ata1: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
> ata1: SError: { DevExch }
> ata2: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
> ata2: irq_stat 0x00000040, connection status changed
> ata2: SError: { DevExch }
>
> There are a variety of other error messages thrown about ext3 file systems not being to be re-mounted, but I haven't been able to capture those yet.
>
> I'm running a fresh copy of Ubuntu 8.10 (Intrepid Ibex), with the latest updates, on a reasonably new HP Pavilion dv5 (1075er) notebook.
>
> Rationale:
>
> Originally I posted my problem under bug #158050 but later I realised that this was for an older kernel version. Then I thought that bug #273323 would be a better fit, but that has since digressed into a KDE discussion, entirely irrelevant to my problem. I've looked at every Intrepid suspend / resume bug listed and none are specific to my distribution version, kernel version or hardware so I'm starting a new one.
>
> * Update 16th of May 2009 * There has been a Kernel Bug Report open on this for some time now http://bugzilla.kernel.org/show_bug.cgi?id=12276
>
> * Update 18th of May 2009 * There is also evidence, anecdotal and otherwise, to suggest that the same problem is present on HDX and some other models of HP laptop.
>

--
Thanks & Regards,
Ameya Lokare

sshlyk (sshlyk) wrote :
Download full text (5.7 KiB)

and shame on HP
Now think twice before buying their "linux-friendly" hardware
Booo HP

On Thu, May 28, 2009 at 6:02 PM, juggernaut <email address hidden> wrote:

> This is great news! Thanks to all of you for your time and effort
>
> On Thu, May 28, 2009 at 2:53 PM, Corruptor1972
> <email address hidden> wrote:
> > I have just applied HP's F16A BIOS to my DV5-1000ea. This has solved
> > the suspend/resume issue.
> >
> > A BIG thanks to Paul, TJ and all who took time to get involved.
> >
> > --
> > HP Pavilion dv5: ATA exception on resume from suspend
> > https://bugs.launchpad.net/bugs/301353
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in The Linux Kernel: In Progress
> > Status in “linux” source package in Ubuntu: Confirmed
> >
> > Bug description:
> > On resume from suspend in Ubuntu 8.10 (Intrepid Ibex) the ATA driver
> throws a series of exceptions, as a result the filesystems can not be
> accessed and the computer needs to be rebooted. Hibernate, however, does
> work and does not have this problem, suspend / resume only. The linux kernel
> version is the latest 2.6.27-7.
> >
> > * Update 16th of May 2009 * The problem remains unchanged under Ubuntu
> 9.04 (Jaunty Jackalope).
> >
> > The initial error message on resume is:
> >
> > btusb_intr_complete: hci0 urb f7d94a00 failed to resubmit (2)
> > ata2: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
> > ata2: irq_stat 0x00000040, connection status changed
> > ata1: exception Emask 0x10 SAct 0x0 SErr 0x0 action 0x9 t4
> > ata1: irq_stat 0x00000040, connection status changed
> > sd 0:0:0:0: rejecting I/O to offline device
> > PM: Device 0:0:0:0; failed to resume: error 65536
> >
> > Then, as nothing is able function properly, the most repeated error
> message is as follows:
> >
> > ata1: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
> > ata1: SError: { DevExch }
> > ata2: exception Emask 0x10 SAct 0x0 SErr 0x4000000 action 0xe frozen
> > ata2: irq_stat 0x00000040, connection status changed
> > ata2: SError: { DevExch }
> >
> > There are a variety of other error messages thrown about ext3 file
> systems not being to be re-mounted, but I haven't been able to capture those
> yet.
> >
> > I'm running a fresh copy of Ubuntu 8.10 (Intrepid Ibex), with the latest
> updates, on a reasonably new HP Pavilion dv5 (1075er) notebook.
> >
> > Rationale:
> >
> > Originally I posted my problem under bug #158050 but later I realised
> that this was for an older kernel version. Then I thought that bug #273323
> would be a better fit, but that has since digressed into a KDE discussion,
> entirely irrelevant to my problem. I've looked at every Intrepid suspend /
> resume bug listed and none are specific to my distribution version, kernel
> version or hardware so I'm starting a new one.
> >
> > * Update 16th of May 2009 * There has been a Kernel Bug Report open on
> this for some time now http://bugzilla.kernel.org/show_bug.cgi?id=12276
> >
> > * Update 18th of May 2009 * There is also evidence, anecdotal and
> otherwise, to suggest that the same problem is present on HDX and some other
> models of HP laptop.
> >
>
>
> -...

Read more...

I also applied the latest bios to my DV5t-1000, suspend-to-ram now works
flawlessly.

Big thanks to everybody !

Starcraftmazter wrote:
> I've applied the latest update to my DV5-1138tx, and I can too confirm
> that sleep now works!!
>
> Thanks a lot to Paul Swanson and everyone else who worked hard to make this happen :D
> And to HP for finally fixing it, hehe.
>
>

I opened the link you posted, but it says that the BIOS update applies only to AMD-cpu-laptop! I have an Intel, what should I do??

Junior_sampa (juniorperes-ig) wrote :

In my case I have a Compaq Presario V5306US (Turion 64 processor) and problems persists. The Bios seems to be incompatible. Whats the idea on my case?

Thank you!

shockdiode (shockdiode) wrote :

Confirmed that this bios update resolves the problem on my HP DV5-1002nr - bios version F.33. Also, thermal sensors are now functioning finally.

Thanks everyone for sending those emails! Hopefully this will be resolved for others as well soon...

shockdiode (shockdiode) wrote :

Also,

Hey jeiworth - I kept a small vista partition and so flashed the bios from there. I'm not so sure I'd attempt to run their installer in wine. Did you delete the recovery partition as well? I'm guessing yes... Perhaps you could get recovery disks and attempt to flash the bios from there.

Perhaps someone else has a brilliant idea - it is quite annoying that the bios utility is a vista-only app.

Fortunately, I kept my vista partition (i think this is a waste of hard drive). You can take your computer to HP warranty service if you deleted vista, but I think they will wipe out your disk, so be careful.
Now Ubuntu fully support HP-dv5t-1000CTO, I'm very pleasure to unsubscribe me from this bug

Changed in linux (Ubuntu):
assignee: Kernel Bugs (kernel-bugs) → nobody
status: Confirmed → Fix Committed
Jim Raredon (decoy-umd) wrote :

They released a BIOS update for the HDX 16 that fixed it as well! I'm shocked that they responded on this... I never thought I'd say it, but kudos to HP's BIOS team!

Also, thanks to Paul and everyone who contributed! Good luck to anyone who is still hanging on.

Mateo (chellew620) wrote :

New F16 BIOS confirmed working for HP dv5-1235dx running Jaunty 9.04!!! Thanks HP!

Paul Swanson (paul-swanson) wrote :

I haven't yet applied the BIOS to update to my dv5 as I need to help Tejun with some patch testing this weekend but ...

CONGRATULATIONS to everyone that has had their suspend / resume fixed by this BIOS update!

I'd like to encourage you all to contact HP Support with a "thank you" message. They have done the right thing and we should encourage them to continue supporting Linux users.

Finally a big "thank you" to Tejun, who works on the Linux ATA driver, and to all of you, for your cooperation and community spirit!

PS. If you have a NON HP Pavilion dXXXX/HDXxx laptop that is still experiencing suspend resume problems, my advice is that you start a NEW Ubuntu bug report. Get on the Ubuntu and HP forums, gather as much data as you can on the problem and petition HP, or whoever can help you, to fix it. Open source is about community ... in your face Microsoft!

I have applied the F.16A patch successfully to my dv5- 1104TU ( Intel based
).
I can confirm that suspend/resume WORKS with Jaunty 9.04 :-)
Thank You, Paul and everyone for their efforts.
Thank You, HP.
Cheers! :-)

On Fri, May 29, 2009 at 9:28 AM, Paul Swanson <email address hidden> wrote:

> I haven't yet applied the BIOS to update to my dv5 as I need to help
> Tejun with some patch testing this weekend but ...
>
> CONGRATULATIONS to everyone that has had their suspend / resume fixed by
> this BIOS update!
>
> I'd like to encourage you all to contact HP Support with a "thank you"
> message. They have done the right thing and we should encourage them to
> continue supporting Linux users.
>
> Finally a big "thank you" to Tejun, who works on the Linux ATA driver,
> and to all of you, for your cooperation and community spirit!
>
> PS. If you have a NON HP Pavilion dXXXX/HDXxx laptop that is still
> experiencing suspend resume problems, my advice is that you start a NEW
> Ubuntu bug report. Get on the Ubuntu and HP forums, gather as much data
> as you can on the problem and petition HP, or whoever can help you, to
> fix it. Open source is about community ... in your face Microsoft!
>
> --
> HP Pavilion dv5: ATA exception on resume from suspend
> https://bugs.launchpad.net/bugs/301353
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
With Regards
          Aditya Jaltade
---------------------------------------------------------------------------------------------------------------------------------------------------------
"Do not try to bend the spoon...that's impossible. Instead only try to
realize the truth...There is no spoon."
Registered Linux User # 458953

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I've similarly applied the new BIOS and it works perfectly.

Thanks to HP for recognising the bug, and to Paul for helping to push
this forward :)

Tom

Aditya wrote:
> I have applied the F.16A patch successfully to my dv5- 1104TU ( Intel based
> ).
> I can confirm that suspend/resume WORKS with Jaunty 9.04 :-)
> Thank You, Paul and everyone for their efforts.
> Thank You, HP.
> Cheers! :-)
>
> On Fri, May 29, 2009 at 9:28 AM, Paul Swanson <email address hidden> wrote:
>
>> I haven't yet applied the BIOS to update to my dv5 as I need to help
>> Tejun with some patch testing this weekend but ...
>>
>> CONGRATULATIONS to everyone that has had their suspend / resume fixed by
>> this BIOS update!
>>
>> I'd like to encourage you all to contact HP Support with a "thank you"
>> message. They have done the right thing and we should encourage them to
>> continue supporting Linux users.
>>
>> Finally a big "thank you" to Tejun, who works on the Linux ATA driver,
>> and to all of you, for your cooperation and community spirit!
>>
>> PS. If you have a NON HP Pavilion dXXXX/HDXxx laptop that is still
>> experiencing suspend resume problems, my advice is that you start a NEW
>> Ubuntu bug report. Get on the Ubuntu and HP forums, gather as much data
>> as you can on the problem and petition HP, or whoever can help you, to
>> fix it. Open source is about community ... in your face Microsoft!
>>
>> --
>> HP Pavilion dv5: ATA exception on resume from suspend
>> https://bugs.launchpad.net/bugs/301353
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
>

- --
Tom Simnett
Director
initforthe Ltd
W: www.initforthe.com
T: 020 7183 3116
M: 07786 441 844
E: <email address hidden>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkofn6IACgkQcqOpPRWIadeAYQCeLvUTTdGMU9sGLTw9tO3OdQSF
LX8AoJGbjiOaUyWpuORrTZn6fv6p+Mis
=WaPD
-----END PGP SIGNATURE-----

I installed the F.16 bios into my dv5-1140el. Things works better now, but not flawlessy.

-The resume takes long and an error message about my dvb-t card unable to find the firmware shows. Some errors about bluetooth show also.
-I hear annoying and loud clicks coming from the speakers everytime i go up/down with the volume or use skype. This doesn't happen before resume.
-Sometimes, the laptop hangs when trying to turn off after resume.

Anyway, it looks like the "scratching" sounds that i heard when i turned off my computer are gone away.

Thanks for your effort in solving this odyssey.

--- Ven 29/5/09, Paul Swanson <email address hidden> ha scritto:

Da: Paul Swanson <email address hidden>
Oggetto: [Bug 301353] Re: HP Pavilion dv5: ATA exception on resume from suspend
A: <email address hidden>
Data: Venerdì 29 maggio 2009, 05:58

I haven't yet applied the BIOS to update to my dv5 as I need to help
Tejun with some patch testing this weekend but ...

CONGRATULATIONS to everyone that has had their suspend / resume fixed by
this BIOS update!

I'd like to encourage you all to contact HP Support with a "thank you"
message. They have done the right thing and we should encourage them to
continue supporting Linux users.

Finally a big "thank you" to Tejun, who works on the Linux ATA driver,
and to all of you, for your cooperation and community spirit!

PS. If you have a NON HP Pavilion dXXXX/HDXxx laptop that is still
experiencing suspend resume problems, my advice is that you start a NEW
Ubuntu bug report. Get on the Ubuntu and HP forums, gather as much data
as you can on the problem and petition HP, or whoever can help you, to
fix it. Open source is about community ... in your face Microsoft!

--
HP Pavilion dv5: ATA exception on resume from suspend
https://bugs.launchpad.net/bugs/301353
You received this bug notification because you are a direct subscriber
of the bug.

Icarosaurus (giuschet) wrote :

Here attached there's what dmesg shows after resume.

--- Ven 29/5/09, Paul Swanson <email address hidden> ha scritto:

Da: Paul Swanson <email address hidden>
Oggetto: [Bug 301353] Re: HP Pavilion dv5: ATA exception on resume from suspend
A: <email address hidden>
Data: Venerdì 29 maggio 2009, 05:58

I haven't yet applied the BIOS to update to my dv5 as I need to help
Tejun with some patch testing this weekend but ...

CONGRATULATIONS to everyone that has had their suspend / resume fixed by
this BIOS update!

I'd like to encourage you all to contact HP Support with a "thank you"
message. They have done the right thing and we should encourage them to
continue supporting Linux users.

Finally a big "thank you" to Tejun, who works on the Linux ATA driver,
and to all of you, for your cooperation and community spirit!

PS. If you have a NON HP Pavilion dXXXX/HDXxx laptop that is still
experiencing suspend resume problems, my advice is that you start a NEW
Ubuntu bug report. Get on the Ubuntu and HP forums, gather as much data
as you can on the problem and petition HP, or whoever can help you, to
fix it. Open source is about community ... in your face Microsoft!

--
HP Pavilion dv5: ATA exception on resume from suspend
https://bugs.launchpad.net/bugs/301353
You received this bug notification because you are a direct subscriber
of the bug.

wollombi (wollombi) wrote :

And raised raised the DV5-1000 up on high, saying, "O Lord, bless this the F.16 bios, that with it thou mayst add suspend/restore, in thy mercy." And the Lord did grin. And the people did feast upon the lambs and sloths, and carp and anchovies, and orangutans and breakfast cereals, and fruit-bats and large chu...

It works! I have none of the issues described by Icarosaurus at this time, but haven't done any extensive testing other than "does it suspend/restore"? And I'm NOT going to do the "does it blend?" test, so don't even ask. =P

Kudos to HP for finally fixing this, even if they did take a while. Thanks Paul for spearheading this!

Sean

I see that the HDX18 has an updated F.23 BIOS released on 5/26. I'll be
applying it tonight to see if it resolves the issues I'm having.

I'll report with my findings.

DanL

************* *********** ******* ***** *** **
"Quis custodiet ipsos custodes?" (Who can watch the watchmen?) -- from the
Satires of Juvenal
"I do not fear computers, I fear the lack of them." -- Isaac Asimov (Author)
** *** ***** ******* *********** *************

HDX18(1080EG) with F.23 BIOS works flawlessly. Thanks to everyone!

Not only does my DV5-1000ea now suspend & resume... The Remote Control has suddenly started to work! xev shows events happening when I press the buttons whereas before the Bios update, only the I0I button did something.

I wonder what other lovely secrets are waiting to be revealed... !

jonbonjovi (jonbonjovi-84) wrote :

I can confirm that the BIOS update solved the suspend/resume problem. And also the multimedia buttons (I don't know how to define them, my english doesn't reach so far...) at the top of keyboard are working a little better (before, changing the volume had become a really serious ability proof!). Now I'm waiting only for the cracking/static noise from speaker on reboot to be solved...any solution for that yet?

I don't hear those static noises anymore, but i still have to test it well.

I confirm that multimedia buttons seems to work better.

I eliminated the clicking noise by disabling the hda_intel energy
saving in the laptop_mode_tools configuration. Anyway this is a
workaround, not a solution.

The resume still takes about one minute, the first time. I suppose this is caused by the internal dvb card driver.

Sometimes I can't shutdown my pc. Pressing ctrl-alt-del shows "stopping
all md devices" and the computer reboots. This problem was already
present before the update.

I own a DV5-1140el.

--- Sab 30/5/09, jonbonjovi <email address hidden> ha scritto:

Da: jonbonjovi <email address hidden>
Oggetto: [Bug 301353] Re: HP Pavilion dv5: ATA exception on resume from suspend
A: <email address hidden>
Data: Sabato 30 maggio 2009, 00:14

I can confirm that the BIOS update solved the suspend/resume problem.
And also the multimedia buttons (I don't know how to define them, my
english doesn't reach so far...) at the top of keyboard are working a
little better (before, changing the volume had become a really serious
ability proof!). Now I'm waiting only for the cracking/static noise from
speaker on reboot to be solved...any solution for that yet?

--
HP Pavilion dv5: ATA exception on resume from suspend
https://bugs.launchpad.net/bugs/301353
You received this bug notification because you are a direct subscriber
of the bug.

Icarosaurus (giuschet) wrote :

I confirm that the crackling sounds on reboot are gone for me.

My delay in resume is caused by the dvb-usb card. Removing the driver module speeds up the resume making it almost immediate.

Does anyone know the solution? the driver complains about the firmware, but it is regularly loaded at boot.

I also see messages about bluetooth on resume. Is any message shown at resume, for you all?

I'll try to catch those messages and be more detailed.

--- Sab 30/5/09, jonbonjovi <email address hidden> ha scritto:

Da: jonbonjovi <email address hidden>
Oggetto: [Bug 301353] Re: HP Pavilion dv5: ATA exception on resume from suspend
A: <email address hidden>
Data: Sabato 30 maggio 2009, 00:14

I can confirm that the BIOS update solved the suspend/resume problem.
And also the multimedia buttons (I don't know how to define them, my
english doesn't reach so far...) at the top of keyboard are working a
little better (before, changing the volume had become a really serious
ability proof!). Now I'm waiting only for the cracking/static noise from
speaker on reboot to be solved...any solution for that yet?

--
HP Pavilion dv5: ATA exception on resume from suspend
https://bugs.launchpad.net/bugs/301353
You received this bug notification because you are a direct subscriber
of the bug.

Dear colleagues,

In contact with HP support center, I'd mentioned the case of DV5-1001xx above that was solved with new Bios version, to be used as reference for my case with Compaq Presario V5306US.

They informed me that the following change in kernell could solve our problem but they don't give support for third part software:
_______________________________________________________________________
Change drivers/usb/host/uhci-hcd.c:suspend_allowed() to always return 0 (don't suspend on uhci_suspend the but reset), usb seems to work after a suspend/resume with apm."

For more detail. I request you to follow given below link.

http://his.luky.org/ML/linux-kernel.2004/msg01745.html
_______________________________________________________________________

The question now is how to implement the change in Ubuntu 9.04. Does anybody could help with that?

The bug is opened in launchpad https://bugs.launchpad.net/bugs/350083

Thank you all for any assistance.
Adilson

Paul Swanson (paul-swanson) wrote :

And Paul Swanson did say unto Wollombi ... "Truly, 'tis the funniest post I've seen on this bug report"; and he did join in the celebrations and the feasting as resume did now also work upon his dv5!

My dv5 finally feels like a laptop whilst running Ubuntu. Thank you HP (and everyone else.

Changed in linux:
status: In Progress → Fix Released
description: updated
tags: added: fixed
summary: - HP Pavilion dv5: ATA exception on resume from suspend
+ HP Pavilion dv5: ATA exception on resume from suspend [FIXED]
neub (benpaka) wrote :

I've a HP dv5 1073ez and I've installed the last Bios update F16.A.
The suspend now works correctly for me and I still have some cracking on reboot.

However, my bluetooth module completely disappear from windows (device manager) and ubuntu 9.04 (lsmod). I think it's due to the BIOS update, but i'm not sure... so someone has the same problem since the BIOS update?

Hi,

There is no bios update for the hp dv2201ca, and suspend does not
work. It causes the hard drive to click in some kind of stuck loop.
Suspend worked fine in Ubuntu since Edgy, but it stopped working in
Jaunty.

Karim

On Tue, Aug 25, 2009 at 5:21 AM, neub<email address hidden> wrote:
> I've a HP dv5 1073ez and I've installed the last Bios update F16.A.
> The suspend now works correctly for me and I still have some cracking on reboot.
>
> However, my bluetooth module completely disappear from windows (device
> manager) and ubuntu 9.04 (lsmod). I think it's due to the BIOS update,
> but i'm not sure... so someone has the same problem since the BIOS
> update?
>
> --
> HP Pavilion dv5: ATA exception on resume from suspend [FIXED]
> https://bugs.launchpad.net/bugs/301353
> You received this bug notification because you are a direct subscriber
> of the bug.
>

lord_dingo (lord-dingo) on 2009-09-27
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux:
importance: Unknown → High
Nec (nicolas-ecarnot) wrote :

(HP pavilion dv7-1103ef)

Three (!) years after discovering this bug, I finally took the time to unplug my hard drive, install another hard drive, install this marvellous OS : windows vista, then run the HP bios updater.
Then unplug the temp drive, replace the original and beloved ubuntu drive, and test :

THIS IS F*****G WORKING!
Suspend and hibernate are working smoothly.

Displaying first 40 and last 40 comments. View all 220 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.