coretemp doesn't support intel atom processors

Bug #296478 reported by masjan on 2008-11-10
112
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I've tried to get lm-sensors working, but it didn't found any supported chips. Then I found a bug-report for Hardy where stands, that it's possibly coretemp's issue.

If i try to modprobe coretemp I receive "No such device" and in /var/log/messages: coretemp: Unknown CPU model 1c

I have an Acer Aspire One (a150l) Netbook, with Intel Atom N270 1.6 GHz and Ubuntu 8.10 (2.6.27-7-generic)

casgroot (cas-casgroot) wrote :

I encounter the same problem using the Intel atom D945GCLF board in combination with Ubuntu 8.10 server.

If you look at the coretemp.c file in driver/hwmon/coretemp.c (from linux-source) the x86 model 0x1c is not caught by the if statement. I changed the coretemp.c file and build the module, but when trying to load the rebuild module it gave me an "Invalid model format" error. I must confess not being an hero in building kernel/modules stuff :-(

I really would like to read my CPU temperature's without rebooting and entering the BIOS... Although the problem seem easy to solve, it requires someone with experience I guess?

viaimpedita (viaimpedita) wrote :

Also ii have the same problem.....any solutions?

SpeedyGonsales (stem) wrote :

http://bugzilla.kernel.org/show_bug.cgi?id=11161

Will be solved upstream, Jaunty brings 2.6.28 kernel (haven't checked is 28 patched, but as I write this on Atom PC, I'm interested).

SpeedyGonsales (stem) wrote :

Just checked 2.6.28.8 and 2.6.29-rc8, neither is patched (although patch exist).

So patch kernel yourself & compile now, or hopefully ubuntu crew will add patch to Jaunty kernel.

Changed in linux:
status: Unknown → In Progress
kernel-janitor (kernel-janitor) wrote :

Hi masjan,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/karmic .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 296478

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
MT (micdhack) wrote :

I have the same problem here. I upgraded to karmic and still the problem persists. cpu temperature is stuck at 27 Celsius.
If you want me to send any info from my system i will be glad to do so.

Changed in linux:
status: In Progress → Fix Released
MT (micdhack) wrote :

I tried a dist-upgrade on the karmic and the problem still persists..

This bug still presists on karmic at 09 october 2009

AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mz 4212 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x58540000 irq 16'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,1025015b,00100101'
   Controls : 9
   Simple ctrls : 6
DistroRelease: Ubuntu 9.10
MachineType: Acer AOA150
Package: linux (not installed)
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-14-generic root=UUID=b18b0704-8c10-4efb-993b-fd704c930208 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.23
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: ubuntu-unr
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/06/2008
dmi.bios.vendor: Acer
dmi.bios.version: v0.3309
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAcer:bvrv0.3309:bd10/06/2008:svnAcer:pnAOA150:pvr1:rvnAcer:rn:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: AOA150
dmi.product.version: 1
dmi.sys.vendor: Acer

masjan (masjan) wrote : IwConfig.txt
masjan (masjan) wrote : Lspci.txt
masjan (masjan) wrote : Lsusb.txt
masjan (masjan) wrote : UdevDb.txt
masjan (masjan) wrote : UdevLog.txt
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
masjan (masjan) on 2009-10-17
tags: removed: needs-upstream-testing
tags: removed: needs-kernel-logs
masjan (masjan) wrote :

so, I did some testing today. I use Ububtu 9.10 with latest updates.

I tested kernel 2.6.31.4 (2.6.31-02063104) where the problem still persists.
Then I tested kernel 2.6.32 (2.6.32-999.200910171000) and IT WORKS!

No error if I modprobe coretemp and lm-sensors does work!

Is it possible to backport these changes to karmic or we have to wait until ubuntu 10.04?

andypiper (andypiperuk) wrote :

I have the same issue on an Acer Aspire One 110L which has an Atom processor. A patch exists to enable coretemp to read the Atom (a 2.6.28 version is at http://mabene.icomedias.com/coretemp.patch and should apply to the 2.6.30 kernel easily). Can this please be added to Karmic?

MT (micdhack) wrote :

Yes i agree that adding that to karmic should be easy although since 2.6.32 kernel has already the fix i dont see the point of patching an old kernel. They can just add the new kernel as an official with the release or put it in the backports.
Although i believe that it would be smarter to add it in the new release of karmic since it would be a complete solution for all atom processors and it will help in the sense that the karmic will be released as "bug" free. Promotional-wise it would be better.

maxstirner (philipp-d) wrote :

I also get this "coretemp: Unknown CPU model 1c" on Atom 230.. Hope we don't have to wait for 10.04 :)

X3 (x3lectric) wrote :

well this is really silly from a stable sort of release that has been tested for months.
my uname -r is 2.6.31-14-generic I have this issue and further more on jaunty kernel 2.6.28-16 modprobe coretemp worked perfectly after I replaced sensors-detect in /usr/sbin/ with this file http://www.lm-sensors.org/svn/lm-sensors/trunk/prog/detect/sensors-detect chmod 755 this file and added a prepatched coretemp.ko from http://mabene.icomedias.com/coretemp.ko and place it in its path which varies on kernel name but is in my instance /lib/modules/2.6.31-14-generic/kernel/drivers/hwmon/ obviously I renamed the existing files by doing e.g. filename.extension-orig.

when I do # modprobe coretemp or # modprobe -v coretemp I get a silly error FATAL: Error inserting coretemp (/lib/modules/2.6.31-14-generic/kernel/drivers/hwmon/coretemp.ko): Invalid module format

this procedure worked fine in jaunty kernels with no issues and all my cpu temps were posted when doing # sensors

makes anyone wonder if bug reports are addressed or even read in some cases. silly bugs are allowed to travel down for years without being fixed in some cases.

ok I get it its all free and ppl do it in their spare time they have families/jobs/live like most of us do well I do anywho... just dont get it why this is reported and not fixed. or when ppl just add it as a duplicate of e.g. bug #1524614 and so sometimes even having dozens of 'duplicate' bugs that when u read have nothing in relation in the majority of cases. As a obvious result it gets ignored. So much for karmic im back to jaunty. Since Karmic as more kernel issues then I care to spend weeks fixing.

This bug is still here today on my eee PC...
(Karmic 2.6.31-15-generic)

vajorie (vajorie) wrote :

> This bug is still here today on my eee PC... (Karmic 2.6.31-15-generic)

Upstream says fix is in 2.6.32 (did not work for me but not sure if I did it right -> compiled into 2.6.31, it shows me hdd temp as if it were cpu temp...)

Vink (vink) wrote :

I've backported the fix for Ubuntu karmic (2.6.31-16-generic).

Feel free to try:

http://www.lx-soft.com/ion/coretemp.ko

MT (micdhack) wrote :

Hello i have replaced the file coretemp.ko in the folder /lib/modules/2.6.31-17-generic/kernel/drivers/hwmon/coretemp.ko but after restarting the problem still persists.
Am i doing something wrong?

Same problem here...

simon@aristurtle:~$ uname -r
2.6.31-16-generic

fipe (fipeop) wrote :

Same problem in 2.6.32...
Aspire One d250.

vajorie (vajorie) wrote :

Re: comment #36

when you say "same problem," do you mean you're having coretemp report hdd temperature or nothing at all?

Re: comment #34

I'm not sure how good an idea it is to replace files from unknown sources (no offence to comment #33). Not a good security practice. I think you might instead wanna compile coretemp from its source file as a module. Get its latest version (source, not compiled; I browsed Linus' git tree -??- at kernel.org to get it) and try using the following link to compile it into your kernel: http://www.cyberciti.biz/tips/compiling-linux-kernel-module.html (it is not a step by step guide but more like a reference point to start your compilation) Make sure you have build-essential and kernel-headers packages installed...

"modinfo coretemp" proved useful for me when I was doing this (shows, among other things, which file you are using as your module).

Re: comment #30

This is not an ubuntu-specific issue (hence the link to the upstream bug report). It got introduced with a new upstream kernel, hence a new version of ubuntu... I'm using Arch and having issues...

Vikram Dhillon (dhillon-v10) wrote :

Unfortunately it seems this bug is still an issue. Can you confirm this issue exists with the most recent Lucid Lynx 10.04 release - http://cdimage.ubuntu.com/releases/lucid/alpha-2/. If the issue remains in Lucid, please test the latest 2.6.32 upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . Let us know your results. Thanks.

Changed in linux (Ubuntu):
status: New → Incomplete
X3 (x3lectric) wrote :

there is a easy fix for all this, however coretemp is a pretty crappy inacurate sensor driver.

1st step is to compile coretemp.ko cause you will most likely run into trouble when you modprobe coretemp.
http://forum.xbmc.org/showpost.php?p=438276&postcount=2

Yes that works for any linux distribution I made sure of it.

2nd is to get an updated version of sensors-detect file which has to be placed in /usr/sbin & chmod 755
http://www.mediafire.com/file/umcjzryjm01/sensors-detect.rar

If your paranoid about getting a file from 3rd party then,
the sensors-detect file can be downloaded from lm-sensors.org (if site loads at all) on this page
http://dl.lm-sensors.org/lm-sensors/snapshots/

choose the most recent and unpack file is inside prog folder.

I wouldnt expect ubuntu to release proper fixes any time soon if at all.

dvh (dusan-halicky) wrote :

I can confirm this bug is still present in 10.10 (maverick meerkat, final release) and also in 10.04. This bug is marked "fix released", somebody please change it so something else.

Changed in linux:
importance: Unknown → High

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.