Fix zstar vimicro webcam (0ac8:303b)

Bug #292086 reported by Jani Monoses on 2008-11-01
76
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Andy Whitcroft
Intrepid
Medium
Andy Whitcroft

Bug Description

A webcam that used to work in Hardy does no longer work with the Intrepid kernel.

 Device 003: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

It is assigned to the zc0301 driver whereas gspca should support it as with the other zc__ chips.

===

SRU Justification

Justification: webcams support regression from Hardy

Impact: zstar webcams with id 0ac8:303b which worked in Hardy stopped working in Intrepid.

Fix Description: moved web cams over to the new new gspca infrastructure

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=commit;h=0feccfbc02792f9555bd77aa611b863f82974214

Risks: Low, this fix is tied to this specific device ID and four holders of this hardware have tested with this patch and reported success.

TEST CASE: see bug report

Jani Monoses (jani) wrote :

there's only one USB ID left to be handled by the zc driver, maybe that should move too and the driver removed if someone confirms that too is better handled by gspca.

Changed in linux:
status: Unknown → Confirmed

Thank Jani,

I'll have the kernel team take a look. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Ulisse (ulipo) wrote :

same issue here with this similar device:
Bus 002 Device 002: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 WebCam

used to work nicely in 8.04 - 32bit, no luck with 8.10 - 64bit.

Jani Monoses (jani) wrote :

Ulisse,
does it not work if you modprobe gspca_zc3xx instead of the zc0301 module?
It is a separte bug anyway as your webcam is already in gspca whereas this bug is about one that _should_ be in gspca.

Ulisse (ulipo) wrote :

sorry, I totally missed the third line in the bug description. Actually it doesn't work anymore neither with gspca, I'll write in the appropriate bug.

mciancio (mciancio) wrote :

My webcam doesn't work, too: It worked with 8.04

# lsusb
Bus 002 Device 004: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 WebCam

# lsmod | grep gspca
gspca_zc3xx 55936 0
gspca_main 29312 1 gspca_zc3xx
videodev 41344 1 gspca_main
usbcore 148848 8 gspca_zc3xx,gspca_main,usb_storage,libusual,usbhid,ehci_hcd,uhci_hcd

Andy Whitcroft (apw) on 2008-11-28
Changed in linux:
assignee: ubuntu-kernel-team → apw
status: Triaged → In Progress
assignee: ubuntu-kernel-team → apw
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

@Jani Monoses, @mciancio -- I have built kernels based on the latest Intrepid -proposed kernel with your @Jani's patch applied and uploaded them to the URL below. Perhaps you could test those kernels and report back here for us.

    http://people.ubuntu.com/~apw/lp292086/

amdlin (amdlintuxos) wrote :

Hi all. I have the same problem on Interpid
Bus 002 Device 005: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 WebCam

I checked with new kernel linux-image-2.6.27-10-generic_2.6.27-10.21~lp292086apw1_i386
This is not work in skype and video flash chat also.
Was working fine in Hardy 8.04

gspca_zc3xx 55936 1
gspca_main 29312 1 gspca_zc3xx
v4l1_compat 22404 1 videodev

ppttpp (ahmedbassi) wrote :

I can confirm similar behavior.

Kernel:
2.6.27-9-generic

~ lsusb

Bus 001 Device 004: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 WebCam

Not working in kopete and it crashes skype

Was working in Hardy in kopete - perhaps screwed after the intrepid upgrade

Andres Mujica (andres.mujica) wrote :

Andy, i've got a doubt.. is this the same bug #144745 that is being worked by Stephan?

Changed in linux:
importance: Unknown → Undecided
status: Confirmed → New
modprobe (modprobe) wrote :

Hi. There's no doubt, guys, about this webcam: in my case it worked on Hardy, but today, after a clean install of Intrepid, it stopped working, just shows an array of scrambled lines, instead of some kind of comprehensible video output.

Please fix it!

Z-Star Microelectronics Corp. ZC0305 WebCam.

Thanks!

Jani Monoses (jani) wrote :

I guess I should have posted the hack to fix it on Intrepid when I originally reported the bug:

http://janimo.blogspot.com/2008/11/making-vimicrozstara4tech-webcam-work.html

Jani Monoses (jani) wrote :

Since that post described a fix for an older kernel here's what to run as root on an updated 8.10

xxd /lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_zc3xx.ko |sed '/^000a370:/ s/1b30/3b30/' |xxd -r | sponge /lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_zc3xx.ko

Andy Whitcroft (apw) wrote :

@Andres Mujica -- that is a different device id (0ac8:301b) so although in the very same area, its technically different.

@Jani Monoses -- are you able to test the kernels I built to confirm this patch is sufficient:

    http://people.ubuntu.com/~apw/lp292086/

@amdlin -- your webcam is in the same family but has a different device id (0ac8:305b), so this patched kernel would not help directly. We should get a separate bug filed for that device id combination.

Andy Whitcroft (apw) wrote :

I have rebuilt the test kernels against the latest -11 kernel. They can be found at the URL below:

    http://people.ubuntu.com/~apw/webcams1/

Please test and report back. This fix is only for the 0ac8:303b device.

Jani Monoses (jani) wrote :

will test later tonight (Europe)

Jani Monoses (jani) wrote :

Andy, it works :)

Cillean (mirpud) wrote :

@ Andy: Yep, works for me like a charm - finally, my webcam's useable again! Many thanks! :D
Also, thanks to Jani for the patch of course!

Marcelo Atie (marceloatie) wrote :

On Ubuntu 8.04 and 7.10 I simply used

#rmmod zc0301
#rmmod gspca
#modprobe gspca

to get it working, but in Ubuntu 8.10 (64bits) i don't have the module gspca, and i ever get a error when i try to compile it using

#apt-get install gspca-source
#m-a prepare
#m-a a-i gspca

later i will try this kernel ;)

Marcelo Atie (marceloatie) wrote :

another thing, to get the webcam ever working on Ubuntu 7.10 and 8.04 without ever use

#rmmod zc0301
#rmmod gspca
#modprobe gspca

i simply added zc0301 to /etc/modprobe.d/blacklist

Inox (inox) wrote :

My camera is still not working!!!

However you can follow my steps to get yours back to live...

This patch by Jani Monoses (https://bugs.launchpad.net/~jani):

xxd /lib/modules/2.6.27-11-generic/kernel/drivers/media/video/gspca/gspca_zc3xx.ko |sed '/^000a370:/ s/1b30/3b30/' |xxd -r | sponge /lib/modules/2.6.27-11-generic/kernel/drivers/media/video/gspca/gspca_zc3xx.ko

makes my Vimicro webcam create /dev/video1 (video0 is the video tuner in my case), but the received image parameters make camorama crash and Skype display some green floating boxes with just static around :(

That's why I decided to try kernel patch by Andy Whitcroft (https://bugs.launchpad.net/~apw).
I cannot simply apply his ready-to-use kernel, because of my other specific needs. So...

#apt-get update
#apt-get install kernel-package libncurses5-dev fakeroot bzip2
#apt-get install linux-source
#cd /usr/src
#bzip2 -d linux-source-2.6.27.tar.bz2
#tar xvf linux-source-2.6.27.tar
#ln -s linux-source-2.6.27 linux
#cd linux
#cp /boot/config-2.6.27-11-generic ./.config
#cat ../0001-UBUNTU-SAUCE-gspca-Let-gspca-handle-the-webcams-0.patch | patch -p1 --dry-run
#cat ../0002-UBUNTU-SAUCE-Fix-webcam-having-USB-ID-0ac8-303b.patch | patch -p1 --dry-run
#cat ../0001-UBUNTU-SAUCE-gspca-Let-gspca-handle-the-webcams-0.patch | patch -p1
#cat ../0002-UBUNTU-SAUCE-Fix-webcam-having-USB-ID-0ac8-303b.patch | patch -p1
#make menuconfig
Loaded .config file. Exited saving.
#make-kpkg clean
#fakeroot make-kpkg --initrd --append-to-version=-webcam+kernel kernel_image kernel_headers
Was REALLY, REALLY patient and got new shiny kernel in ready-to-use deb package as usual.
My machine boots properely and creates /dev/video1 for my 0ac8:303b (proper modules are loaded) but effect is the same as for Jani's patch :( just static and floating green, blue boxes. Camera LED turns on. Nothing else happens.

Any suggestions? Thank you in advance!

volkris (volkris) wrote :

Inox, could you link to the UBUNTU-SAUCE patches directly? I can't find them readily.

I suspect that your specific problem might be related to the switch from v4l to v4l2.

Inox (inox) wrote :

Yes sure :) I got them from here:

http://people.ubuntu.com/~apw/webcams1/

volkris (volkris) wrote :

Oh, THOSE patches :) I had forgotten where this bug has been.

Anyway, Inox, it sounds like the patch did its job and fixed this bug for you. Try gstreamer-properties to make sure you're going through v4l2 instead of v4l. It sounds like you're still configured for the latter.

Inox (inox) wrote :

Unfortunately everything seems to be set up just as you say it should be...

Inox (inox) wrote :

Wow! Forget my previous comment :)
Camera started to work in Multimedia Systems Selector (gstreamer-properties) with the following pipeline: v4l2src device="/dev/video1" with acceptable frame rate and lively colors :) :) :)

But in Skype and Camorama it still looks bad :( Cheese works perfectly now. Maybe it is all about resolution? I'll try to guess and pass some parameters to Camorama and Skype!

Thank you Chris, Jani and Andy! Now I started to believe in Linux again :D

Inox (inox) wrote :

Skype works when started with the script I attach.

shemgp (shemgp) wrote :

Using pre-released kernel 2.6.27-11.23-generic and i don't think the patch from http://people.ubuntu.com/~apw/webcams1/ was not included. Here are some of the relevant dmesg lines:

[ 0.000000] Linux version 2.6.27-11-generic (buildd@palmer) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11) ) #1 SMP Thu Jan 8 08:38:33 UTC 2009 (Ubuntu 2.6.27-11.23-generic)
[ 9.669572] Linux video capture interface: v2.00
[ 9.739003] zc0301: V4L2 driver for ZC0301[P] Image Processor and Control Chip v1:1.10
[ 9.739040] usb 3-2: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x303B)
[ 9.766691] iTCO_vendor_support: vendor-support=0
[ 9.805172] udev: renamed network interface eth1 to eth0
[ 9.805462] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.03 (30-Apr-2008)
[ 9.805532] iTCO_wdt: Found a ICH7 or ICH7R TCO device (Version=2, TCOBASE=0x0460)
[ 9.805619] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[ 9.806338] udev: renamed network interface eth0_rename to eth1
[ 9.811411] usb 3-2: No supported image sensor detected
[ 9.811451] usbcore: registered new interface driver zc0301
[ 1395.168057] usb 3-2: USB disconnect, address 3
[ 1396.648045] usb 3-2: new full speed USB device using uhci_hcd and address 4
[ 1396.845835] usb 3-2: configuration #1 chosen from 1 choice
[ 1396.848757] usb 3-2: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x303B)
[ 1396.922670] usb 3-2: No supported image sensor detected

taha (tahamassalha) on 2009-01-12
Changed in linux:
assignee: apw → tahamassalha
assignee: apw → tahamassalha
Andres Mujica (andres.mujica) wrote :

shemgp: why did you changed the assignee?

i'm putting back Andy as he's the one working on this. (unless i'm unaware of something)

Changed in linux:
assignee: tahamassalha → andy
Andres Mujica (andres.mujica) wrote :

undo shemgp change

Changed in linux:
assignee: andy → apw
assignee: tahamassalha → apw
Gustavo Azambuja (gazambuja) wrote :

@Andy, the packages of kernel work fine in my PC:

Ubuntu Intrepid, i386:
Bus 001 Device 005: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

Thanks!!

How i install the patch without change my kernel? (the new kernel have some problems with my video card)

Marcelo Atie (marceloatie) wrote :

My webcam is working again ...

Ubuntu Intrepid / 8.10, ia64 :
Bus 004 Device 002: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

I'm using the module zc0301, and gspca isn't loaded

i'm using only official packages

volkris (volkris) wrote :

May I ask, what is the status with this bug?

We've had a fix submitted for a month now (longer if you count kernel.org discussion) with numerous reports of success. What else is needed to get this fix committed?

Marcelo Atie (marceloatie) wrote :

we need hold this bug in confirmed / in progress still it work for anybody

volkris (volkris) wrote :

Above we have at least seven reports of the patch working with no reports of failure. We KNOW there are failures without the patch. And, of course, this patch is the recommended solution as per the kernel developers.

That seems like quite a compelling record... how many successes without failure do you need before we can suspect that it will work for anybody?

Andy Whitcroft (apw) wrote :

@Chris Carlin -- the issue is not how many people it works for but is there anyone it regresses. So far I can see one person who has not been helped by the change (not a regression), and several saying it helps. I will propose this one for updates and see if we can get it through.

volkris (volkris) wrote :

Thanks for the update, Andy.

If more testing is needed I can try the patch out on a few more computers at work.

vbeico (vbeico) wrote :

Please help!
Who can patch kernel 2.6.27-11.23 ?
This kernel not support my webcam.

vbeico (vbeico) wrote :

I forgot my webcam logitech E2500
I'm finde patch quickcamE2500.diff and instruction how to patch gspca.
but i can't compile gspca, I think because kernel not support gspca.
Who can help to patch kernel 2.6.27-11.23+gspca+quickcamE2500.diff??????

volkris (volkris) wrote :

@vbeico, your question is not related to this bug.

If you found the patch in a different bug report, perhaps they have directions for patching there. Also, there are other bugs about problems compiling gspca with current kernels; you might want to review those.

Andy Whitcroft (apw) wrote :

In support of a proposal for SRU to intrepid it is helpful to have some testing against the latest kernels (to which this would be applied). I have therefore rebased these patches onto the latest -proposed kernel and build some updates test kernels. If those of you who are able could test the kernels at the URL below and report back that would be very helpful:

    http://people.ubuntu.com/~apw/webcams1/

NOTE: these are updated images based on the new Inprepid kernels, as compared to the ones in my previous call for testing.

Cillean (mirpud) wrote :

@ Andy: Installed the i386 kernel, and it's still working flawlessly. Tested with Cheese and aMSN ;)

volkris (volkris) wrote :

i386 kernel working fine for me with no need for blacklisting or manual module loading. Tested with empathy and cheese.

Marcelo Atie (marceloatie) wrote :

I tested the kernel from http://people.ubuntu.com/~apw/webcams1/ and now my webcam is working better, lsmod now gives me 2 modules that before wasn't loaded: gspca_zc3xx and gspca_main

Tim Kersten (timkersten) wrote :

I just wanted to comment that my camera (0ac8:303b) now works too, using the latest kernel from http://people.ubuntu.com/~apw/webcams1/ .

Andy Whitcroft (apw) on 2009-01-17
Changed in linux:
status: In Progress → Fix Committed
Andy Whitcroft (apw) on 2009-01-17
description: updated
description: updated
Andy Whitcroft (apw) on 2009-01-17
Changed in linux:
status: In Progress → Fix Committed

:D great !

fix committed in Ubuntu !

anyone can work together with
http://bugzilla.kernel.org/show_bug.cgi?id=11932 to hold this solution in
future releases of the kernel ?

Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
importance: Unknown → Undecided
status: Unknown → New
Launchpad Janitor (janitor) wrote :
Download full text (18.6 KiB)

This bug was fixed in the package linux - 2.6.28-5.12

---------------
linux (2.6.28-5.12) jaunty; urgency=low

  [ Ante ]

  * Update drbd to 8.3.0

  [ Dave Airlie ]

  * i915/drm: provide compat defines for userspace for certain struct

  [ Eric Anholt ]

  * drm/i915: Don't double-unpin buffers if we take a signal in
  * drm/i915: Don't complain when interrupted while pinning in execbuffers.
  * drm/i915: Don't allow objects to get bound while VT switched.

  [ Jani Monoses ]

  * Fix webcam having USB ID 0ac8:303b
    - LP: #292086

  [ Jesse Barnes ]

  * drm/i915: set vblank enabled flag correctly across IRQ
  * drm/i915: don't enable vblanks on disabled pipes

  [ Michael Casadevall ]

  * [arm] Fix kexec on ARM by properly calling the relocation function

  [ Tim Gardner ]

  * Enabled CONFIG_PID_NS=y for i386/amd64
  * SAUCE: Increase ATA_TMOUT_PMP_SRST_WAIT to 5 seconds.
    - LP: #318978
  * Update armel versatile config
    - LP: #314789
  * Enabled CONFIG_RT2860=m for i386/amd64
  * Enabled CONFIG_RT2870=m for i386/amd64

  [ Upstream Kernel Changes ]

  * Input: atkbd - add keyboard quirk for HP Pavilion ZV6100 laptop
    - LP: #291878
  * ALSA: hda - Add quirk for another HP dv7
  * ALSA: hda - Add quirk for HP6730B laptop
  * ALSA: caiaq - Fix Oops with MIDI
  * ALSA: hda - Fix typos for AD1882 codecs
  * x86: fix intel x86_64 llc_shared_map/cpu_llc_id anomolies
  * x86: default to SWIOTLB=y on x86_64
  * CIFS: make sure that DFS pathnames are properly formed
  * ring-buffer: prevent false positive warning
  * ring-buffer: fix dangling commit race
  * iwlwifi: use GFP_KERNEL to allocate Rx SKB memory
  * tx493[89]ide: Fix length for __ide_flush_dcache_range
  * tx4939ide: Do not use zero count PRD entry
  * SCSI: eata: fix the data buffer accessors conversion regression
  * USB: emi26: fix oops on load
  * x86, UV: remove erroneous BAU initialization
  * x86: fix incorrect __read_mostly on _boot_cpu_pda
  * vmalloc.c: fix flushing in vmap_page_range()
  * fs: symlink write_begin allocation context fix
  * cgroups: fix a race between cgroup_clone and umount
  * dm raid1: fix error count
  * dm log: fix dm_io_client leak on error paths
  * minix: fix add link's wrong position calculation
  * md: fix bitmap-on-external-file bug.
  * sched_clock: prevent scd->clock from moving backwards, take #2
  * devices cgroup: allow mkfifo
  * SCSI: aha152x_cs: Fix regression that keeps driver from using shared
    interrupts
  * ioat: fix self test for multi-channel case
  * USB: isp1760: use a specific PLX bridge instead of any bdridge
  * USB: isp1760: Fix probe in PCI glue code
  * USB: unusual_devs.h additions for Pentax K10D
  * inotify: fix type errors in interfaces
  * Move compat system call declarations to compat header file
  * Convert all system calls to return a long
  * Rename old_readdir to sys_old_readdir
  * Remove __attribute__((weak)) from sys_pipe/sys_pipe2
  * Make sys_pselect7 static
  * Make sys_syslog a conditional system call
  * System call wrapper infrastructure
  * powerpc: Enable syscall wrappers for 64-bit
  * s390: enable system call wrappers
  * System call wrapper special cases
  * System call wrappers part 0...

Changed in linux:
status: Fix Committed → Fix Released
Gustavo Azambuja (gazambuja) wrote :

So @Janitor, how we apply this update in us kernel (Ubuntu Intrepid): 2.6.27-9-generic?

Andy Whitcroft (apw) wrote :

On Wed, Jan 21, 2009 at 11:15:31AM -0000, Gustavo Azambuja wrote:
> So @Janitor, how we apply this update in us kernel (Ubuntu Intrepid):
> 2.6.27-9-generic?

@Gustavo -- the Janitor is an automated bot updating bugs as releases hit
the archives. This update tells us the fix has hit the Jaunty release,
which is easier to get things into being development. The fix in Intrepid
is stuck behind the current Intrepid update kernel. We are expecting
the Intrepid -proposed kernel to release to -updates very soon and when
it does a new -proposed kernel cycle wil start, and this fix will be in
it.

Gustavo Azambuja (gazambuja) wrote :

ups. hehehe, thanks a lot and sorry.

On Thu, Jan 22, 2009 at 15:16, Andy Whitcroft <email address hidden> wrote:

> On Wed, Jan 21, 2009 at 11:15:31AM -0000, Gustavo Azambuja wrote:
> > So @Janitor, how we apply this update in us kernel (Ubuntu Intrepid):
> > 2.6.27-9-generic?
>
> @Gustavo -- the Janitor is an automated bot updating bugs as releases hit
> the archives. This update tells us the fix has hit the Jaunty release,
> which is easier to get things into being development. The fix in Intrepid
> is stuck behind the current Intrepid update kernel. We are expecting
> the Intrepid -proposed kernel to release to -updates very soon and when
> it does a new -proposed kernel cycle wil start, and this fix will be in
> it.
>
> --
> Fix zstar vimicro webcam (0ac8:303b)
> https://bugs.launchpad.net/bugs/292086
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Gustavo Azambuja - Linux User: 275813

Carcass (carcass-debianclan) wrote :

Hi

my Z-Star have [b]ID 0ac8:0302[/b] someone can help me for my webcam???

root@M-16:/home/carcass# lsmod | grep gspca
gspca_zc3xx 60032 0
gspca_main 35200 1 gspca_zc3xx
videodev 53760 2 compat_ioctl32,gspca_main
usbcore 175888 12 snd_usb_audio,snd_usb_lib,gspca_zc3xx,gspca_main,usblp,btusb,usbhid,ehci_hcd,uhci_hcd

there is a kernel patched for this webcam, or a mode to make UP this cam???

thanks a lot

carcass

Steve Langasek (vorlon) wrote :

Accepted linux into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

volkris (volkris) wrote :

Update manager has not invited me to upgrade to the proposed kernel. I see the 12.28 release of various packages sitting in the repository, but of course the upgrade is distributed across various packages ranging from linux-image to fs-core-modules.

So, before I go back and forth to see what's installed now versus what I can install, does anyone know offhand what packages are needed to update to this proposed release?

Changed in linux:
importance: Undecided → Unknown
status: New → Unknown
Andres Mujica (andres.mujica) wrote :

@chris: as the proposed kernel is changing number you'll have to explicitely install it.

sudo apt-cache search linux-image-2.6.27-12
linux-image-2.6.27-12-generic - Linux kernel image for version 2.6.27 on x86/x86_64
linux-image-2.6.27-12-server - Linux kernel image for version 2.6.27 on x86/x86_64
linux-image-2.6.27-12-virtual - Linux kernel image for version 2.6.27 on x86/x86_64
andres@vostro:~$ sudo apt-cache policy linux-image-2.6.27-12
W: No se ha podido localizar el paquete linux-image-2.6.27-12
andres@vostro:~$ sudo apt-cache policy linux-image-2.6.27-12-generic
linux-image-2.6.27-12-generic:
  Instalados: (ninguno)
  Candidato: 2.6.27-12.28
  Tabla de versión:
     2.6.27-12.28 0
        500 http://co.archive.ubuntu.com intrepid-proposed/main Packages

use sudo apt-get install linux-image-2.6.27-12-generic

and you'll get it

volkris (volkris) wrote :

Andres, my real wonder was whether installing only the image was sufficient. There are at least a dozen packages related to the update... updating only the image sounds dangerous. But I'll happilyl take your word for it.

Also, I did find it odd that there was no metapackage proposed update pulling in the latest proposed kernel image through dependency, but no matter.

volkris (volkris) wrote :

verified fixed by 2.6.27-12-generic

Incidentally, this fixed two other webcam related bugs I was watching.

Inox (inox) wrote :

Andreas & Chris

Installing the following packages would be enough to satisfy your needs:

linux-headers-2.6.27-12
linux-headers-2.6.27-12-generic
linux-image-2.6.27-12-generic
linux-restricted-modules-2.6.27-12-generic
linux-restricted-modules-common

Those meta-packages were made obsolete during 2.6.27-11 to 2.6.27-12 upgrade, however I do not think it is a good policy.

linux-generic
linux-headers-generic
linux-image-generic
linux-restricted-modules-generic

Changed in linux:
status: Unknown → Confirmed
Andres Mujica (andres.mujica) wrote :

@Chris, which ones?

Hebert (hebert-bernardo) wrote :

Bus 001 Device 002: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

I'm using the latest Jaunty alpha 5 with the linux kernel 2.6.28-8-generic

It's not fixed for me.

Now, I have activity on the webcam, but the image is totally garbled.

http://i41.tinypic.com/dzjb09.png

As you can see in this picture above.

My hand is appearing upside down and the image is starting where it should be the middle of it.

Anyone?

Thanks for reading.

volkris (volkris) wrote :

@Andres, sorry for the delay. Other bugs fixed by this, for me, are bug #93417 and bug #317000

@Hebert, have you tried different camera programs? I, for example, test through cheese and gstreamer-properties. It could be that the program you're using happens to have problems with some other changes that were made in Linux recently.

When I tried to use sudo apt-get install linux-image-2.6.27-12-generic, skype was not downloaded. Terminal read: E: couldn't find package linux-image 2.6.27-12 generic.

Please advise on how to install computer. Not sure if I'm running 32-bit or 64 bit even. Not a linux expert yet.

volkris (volkris) wrote :

@sheeshee It looks like you forgot a dash.

In any case, I'm pretty sure these fixes are now in the standard distribution. You computer should have updated itself to the latest version which includes the fixes. There should be no need to run any commands at all; it should just work.

If you want to be absolutely sure, run the following commands:
apt-get update
apt-get upgrade

Hebert (hebert-bernardo) wrote :

"@Hebert, have you tried different camera programs? I, for example, test through cheese and gstreamer-properties. It could be that the program you're using happens to have problems with some other changes that were made in Linux recently."

@Chris Carlin, It doesn't work at all. I even tried - today - aMSN and the image is upside down and magenta.

Do you or anybody else here knows which programs in fact already make use from the latest changes?

I'm using Jaunty with the very latest upgrades.

Thanks for reading!

volkris (volkris) wrote :

Herbert, it sounds like this bug is completely done with, so I don't think your problems relate to this particular bug. You might want to ask elsewhere or file a separate bug.

Hebert (hebert-bernardo) wrote :

I have just tested my webcam "ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam" on Windows Vista using XP drivers (DELL Inspiron 1525) and definitely is not a hardware problem.

It works, I may say, surprisingly well.

This bug is not yet fixed.

It is alive and kicking.

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"

$ lsusb | grep Z-Star
Bus 005 Device 002: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

$lsmod | grep gspca
gspca_zc3xx 59392 1
gspca_main 34560 3 gspca_zc3xx
compat_ioctl32 18304 1 gspca_main
videodev 45184 2 gspca_main,compat_ioctl32

Screenshot taken while testing gstreamer-properties v4l2: http://i42.tinypic.com/29bj8qr.jpg

The image is still upside down and yellow/green

I was using Fedora Rawhide last week and this bug is also present there. ( 2.6.29 Kernel)

So, There is something odd or missing on the bug.

I hope the kernel dev team have a look on this issue in the Karmic cycle.

I'm available for further testing through launchpad.

Thanks for reading

volkris (volkris) wrote :

Hebert, this bug is about a specific problem: the webcam was being assigned the wrong driver.

From what you pasted we can see that the webcam is now being assigned the correct driver: gspca_zc3xx is the correct driver for the 0ac8:303b webcam. Therefore, this bug is fixed.

You're having other troubles, yes, but they aren't the troubles described in this bug. Feel free to open a new bug or look through similar reports to see if others are having the same trouble as you.

Launchpad Janitor (janitor) wrote :
Download full text (27.1 KiB)

This bug was fixed in the package linux - 2.6.27-14.33

---------------
linux (2.6.27-14.33) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Fix FTBS due to a mysteriously missing ABI directory.

linux (2.6.27-14.32) intrepid-proposed; urgency=low

  [Stefan Bader]

  * Rebuild of 2.6.27-14.30 with 2.6.27-11.31 security patches applied

linux (2.6.27-14.30) intrepid-proposed; urgency=low

  [ Alexey Starikovskiy ]

  * SAUCE: ACPI: EC: Limit workaround for ASUS notebooks even more
    - LP: #288385

  [ Huaxu Wan ]

  * SAUCE: report rfkill changes event if interface is down
    - LP: #193970

  [ Scott James Remnant ]

  * SAUCE: floppy: Provide a PnP device table in the module.
    - LP: #255651

  [ Steve Beattie ]

  * fix apparmor memory leak on deleted file ops
    - LP: #329489

  [ Stefan Bader ]

  * Revert "ACPI: Fix compiler warnings introduced by 32 to 64 bit acpi
    conversions"
    - LP: #337019
  * Revert "ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit
    kernels"
    - LP: #337019

  [ Upstream Kernel Changes ]

  * KVM: MMU: Add locking around kvm_mmu_slot_remove_write_access()
    - LP: #335097, #333409
  * ricoh_mmc: Handle newer models of Ricoh controllers
    - LP: #311932

linux (2.6.27-13.29) intrepid-proposed; urgency=low

  [ Colin Ian King ]

  * SAUCE: Bluetooth USB: fix kernel panic during suspend while streaming
    audio to bluetooth headset
    - LP: #331106, #322082

  [ Stefan Bader ]

  * Revert "SAUCE: Work around ACPI corruption upon suspend on some Dell
    machines." (replaced by stable update)
    - LP: #330200
  * Revert "SAUCE: Add back in lost commit for Apple BT Wireless Keyboard"
    (replaced by stable update)
    - LP: #330902

  [ Upstream Kernel Changes ]

  * Revert "vt: fix background color on line feed"
    - LP: #330200
  * ti_usb_3410_5052: support alternate firmware
    - LP: #231276
  * fuse: destroy bdi on umount
    - LP: #324921
  * fuse: fix missing fput on error
    - LP: #324921
  * fuse: fix NULL deref in fuse_file_alloc()
    - LP: #324921
  * inotify: clean up inotify_read and fix locking problems
    - LP: #324921
  * mac80211: decrement ref count to netdev after launching mesh discovery
    - LP: #324921
  * sysfs: fix problems with binary files
    - LP: #324921
  * x86, mm: fix pte_free()
    - LP: #324921
  * alpha: nautilus - fix compile failure with gcc-4.3
    - LP: #324921
  * it821x: Add ultra_mask quirk for Vortex86SX
    - LP: #324921
  * libata: pata_via: support VX855, future chips whose IDE controller use
    0x0571
    - LP: #324921
  * rtl8187: Add termination packet to prevent stall
    - LP: #324921
  * serial_8250: support for Sealevel Systems Model 7803 COMM+8
    - LP: #324921
  * SUNRPC: Fix a memory leak in rpcb_getport_async
    - LP: #324921
  * SUNRPC: Fix autobind on cloned rpc clients
    - LP: #324921
  * USB: fix char-device disconnect handling
    - LP: #324921
  * USB: storage: add unusual devs entry
    - LP: #324921
  * USB: usbmon: Implement compat_ioctl
    - LP: #324921
  * ALSA: hda - add another MacBook Pro 4, 1 subsystem ID
    - LP: #324921
  * ALSA: hda - Add quirk for HP DV6700 laptop
    - LP: #324921
  * ALSA: ...

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Oleg Kolomiets (okolomiets) wrote :

I'v just found that my cam
"Bus 002 Device 003: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam"
doesn't work for me, at Ubuntu 9.04 (2.6.28-14-generic).

:~$ lsmod | grep gspca
gspca_zc3xx 55680 0
gspca_main 29952 1 gspca_zc3xx
videodev 41600 1 gspca_main

wat's wrong with it again?
any suggestions?

Fabián Rodríguez (magicfab) wrote :

In Jaunty this camera works just fine for me, my kernel is 2.6.28-15. Cheese for example displays the expected image at good refresh rates.

The latest Skype beta doesn't work unless I use this known workaround:
1) Open a terminal window
2) Start Skype using this command
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

I am not sure it this would require a separate bug report, as it relates more to Skype (or Skype compatibility) than to the actual camera driver, though.

Oleg Kolomiets (okolomiets) wrote :

2 Fabián Rodríguez:
despite my newest kernel 2.6.28-15 I have same trouble: Camorama is crashed.
I had tried to fix it by starting Camorama with your Skype-related command - and it had worked.
 So, this is camera driver bug or something else?

volkris (volkris) wrote :

There was an old system (v4l) for accessing cameras, and it was changed to a new, incompatible system (v4l2). A lot of programs (most?) were updated to use the new system, but some programs were not updated.

The LD_PRELOAD trick allows old-style programs to operate with the new system, but it's meant to be only a temporary patch.

In short, if the LD_PRELOAD trick fixes an issue you're having, then the problem is in the program, not the driver.

Gustavo A. Díaz (gdiaz) wrote :

Hi,

I dont know if related but in Jaunty this webcam was working and in Karmic latest does not:

Bus 002 Device 006: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 Webcam

In Skype (the lates new beta) does no work, in amsn does not work, in kopete does not work... in cheese does work. What is going on?

Roniku (dumbomuk) wrote :

After updating to ubuntu Karmic webcam is not working anymore. tried with cheese -only show my tv card as video output. can see the webcam with mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video0.
lsusb:
Bus 002 Device 003: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 Webcam
Is there any solution

Roniku (dumbomuk) wrote :

After updating to ubuntu Karmic webcam is not working anymore. tried with cheese -only show my tv card as video output. can see the webcam with mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video0.
lsusb:
Bus 002 Device 003: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 Webcam
Is there any solution?

Pablo Estigarribia (pablodav) wrote :

Same issue here, Samsung pleomax pwc-3800 was working on Jaunty, but now since I upgraded to Karmic this camera does not works anymore.

[ 3853.850055] usb 5-1: new full speed USB device using uhci_hcd and address 3
[ 3854.069142] usb 5-1: configuration #1 chosen from 1 choice
[ 3854.072120] gspca: probing 0ac8:0302
[ 3854.314244] zc3xx: probe sif 0x0000
[ 3854.393987] zc3xx: probe sensor -> 0000
[ 3854.393992] zc3xx: Find Sensor HV7131B
[ 3854.398072] gspca: probe ok

volkris (volkris) wrote :

File a new bug. This one was fixed long ago.

If you're having a problem now, then it's no longer the same bug.

Changed in linux:
importance: Unknown → Medium
Changed in linux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.