Some gspca Webcams not detected in ubuntu 8.10 and Kernel 2.6.27 anymore (for which in 8.04 an alternative driver had to be blacklisted)

Bug #293259 reported by yasou on 2008-11-03
This bug report is a duplicate of:  Bug #292086: Fix zstar vimicro webcam (0ac8:303b). Edit Remove
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
linux (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

== Regression details ==
Discovered in version: linux-image-2.6.27-7-generic
Last known good version: linux-image-2.6.24-21-generic

I have a Z-Star Microelectronics Corp. ZC0303 WebCam
GSPCA-driver: gspca_zc3xx

the camera is detected when the zc0301 driver is loaded, but only with v4l2 and thus only with ekiga. (no v4l support in this driver) In Hardy 8.04 I just blacklisted zc0301 and gspca took over the cam automatically and cam worked flawlessly.

Since 8.10 the cam is not detected after blacklisting zc0301 anymore. Dmesg only gives me:
[29143.996060] usb 2-1: new full speed USB device using uhci_hcd and address 6
[29144.197121] usb 2-1: configuration #1 chosen from 1 choice

I think it is connected with the kernel 2.6.27, and I have found a similar bug at bugzilla.kernel.org:
http://bugzilla.kernel.org/show_bug.cgi?id=11920

Compiling the newest version of gspca using these instructions: http://moinejf.free.fr/gspca_README.txt
does not help immediately.

to solve this problem you have to simply uncheck the zc0301 driver when compiling gspca (see here for instructions: http://moinejf.free.fr/gspca_README.txt) using e.g. make menuconfig. Compiling it with the zc0301 driver was not putting the vend:prod into the gspca module, as described by Moine in the kernel bug report, and so was preventing the gspca driver from detecting the camera. In Hardy 8.04 it was enough to backlist the zc0301 module.

The entry in the bugzilla kernel talks about the sn9c102 driver, that has to be removed, so it seems it applies to more than one model/type of webcams. For sn9c102 the driver has also to be removed when compiling gspca. In both cases it was enough to blacklist the drivers in Hardy.

yasou (yasou) wrote :

Here the dmesg from the 2.6.24 Kernel (camera runs with no problems) :
[ 154.723670] usb 2-1: new full speed USB device using uhci_hcd and address 2
[ 154.836856] usb 2-1: configuration #1 chosen from 1 choice
[ 155.053726] Linux video capture interface: v2.00
[ 155.121625] /build/buildd/linux-ubuntu-modules-2.6.24-2.6.24/debian/build/build-generic/media/gspcav1/gspca_core.c: USB GSPCA camera found.(ZC3XX)
[ 155.374039] usbcore: registered new interface driver gspca
[ 155.374049] /build/buildd/linux-ubuntu-modules-2.6.24-2.6.24/debian/build/build-generic/media/gspcav1/gspca_core.c: gspca driver 01.00.20 registered

yasou (yasou) wrote :

I have found the solution to this problem, as described by Jean-Francois Moine, who is I believe the maintainer of v4l/gspca in the kernel:
http://bugzilla.kernel.org/show_bug.cgi?id=11920

what I had to do was simply uncheck the zc0301 driver when compiling gspca (http://moinejf.free.fr/gspca_README.txt) using make config. Compiling it with the zc0301 driver was not putting the vend:prod into the gspca module, as described by Moine, and so was preventing the gspca driver from detecting the camera. In Hardy 8.04 it was enough to unload the zc0301 module.

The entry in the bugzilla kernel talks about the sn9c102 driver, that has to be removed, so it seems it applies to more than one model/type of webcams.

I hope this is helpful to some people and that it might get fixed soon so that others can use their webcams again.

yasou (yasou) wrote :

Still for some applications you need to preload v4l1compat.so as described here:
http://hansdegoede.livejournal.com/3636.html

you need to install the libv4l package

for vlc for example you have to use the following command:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so vlc

OT: Isn't there a way to edit a comment?

Changed in linux:
status: Unknown → Fix Released
Andres Mujica (andres.mujica) wrote :

as this webcam uses gspca module, i'm marking this as dupe from bug #260918, please further comments in that bug.

thanks a lot

yasou (yasou) wrote :

I disagree that this bug is a duplicate of Bug #260918. This bug is about how some drivers in gspca driver, like zc3xx, that were blocked by non-gspca drivers, in this case zc0301. Another non-gspca driver like sn9c102 is also preventing the gspca driver to load. For more information:
http://bugzilla.kernel.org/show_bug.cgi?id=11920

blacklisting is not enough since gspca has been built into the Kernel, but it has to be recompiled as described in my comments above. After all that the webcam is finally detected by the gspca driver. In case of Bug #260918, there is no problem with a webcam not being detected. The webcams are detected, but provided a distorted picture.

In my case I also got a distorted picture and had to apply v4l1compat.so, but only after I recompiled the driver and my webcam was detected. Those two bugs are completely separate. Again see the kernel bugzilla entry.

Andres Mujica (andres.mujica) wrote :

OK, you're right. So this is a regression introduced by 2.6.27 kernel.

Thanks for your input

Can you provide as separate attachments this files:

uname -a > uname-a.log

cat /proc/version_signature > version.log

dmesg > dmesg.log

sudo lspci -vvnn > lspci-vvnn.log

description: updated
Changed in linux:
status: New → Confirmed
status: New → Incomplete
yasou (yasou) wrote :

As it is a usb device, I have also attached lsusb -v. The device's name is Z-Star Microelectronics Corp. ZC0303 WebCam, as given in the initial inscription, and it is fairly in the middle of lsusb.log

I can't give you my full dmesg now because I have already fixed the problem in my kernel (see my second and third comment), but I already posted the relevant dmesg in my initial post, and I have attached it again.

Otherwise all the other files required are attached. I don't really know how the procedures work here, I am trying my best. I hope it is acceptable.

yasou (yasou) wrote :
yasou (yasou) wrote :
yasou (yasou) wrote :
yasou (yasou) wrote :
Andres Mujica (andres.mujica) wrote :

thks, any more info we'll let you know.

Changed in linux:
status: Incomplete → Confirmed
Andres Mujica (andres.mujica) wrote :

upstream is showing an easy fix for this one

Changed in linux:
assignee: nobody → ubuntu-kernel-team
Ezra Morris (ezramorris) wrote :

$ uname -a
Linux ezra-laptop 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux
$ cat /proc/version_signature
Ubuntu 2.6.27-7.16-generic

The last 11 lines from dmesg was me unplugging then plugging in the webcam.

Ezra Morris (ezramorris) wrote :
Ezra Morris (ezramorris) wrote :
Petar Velkovski (pvelkovski) wrote :

I already reported this as bug Bug #291906 but I didn't get any feedback so here it is again:

I have Mustek gSmart 300 web cam. It worked fine under Ubuntu 8.04 with the gspca drivers manually compiled and installed. When I plug the cam it beeps showing that it is being recognized by the system. Then It beeps again and I get a window with the following message:

Unable to mount Mustek Systems, Inc. gSmart 300
Error initializing camera: -60: Could not lock the device

After I click OK, there is an icon present at the desktop Mustek Systems, Inc. gSmart 300. by clicking on the icon i can open the location gphoto2://[usb:002,010]/. This probably gives me access to the photo function of the webcam. I can copy pictures from this directory(representing the cams internal memory), but I can't delete them. If I try to delete a picture, I get this message:

Error while deleting.
There was an error deleting Image001.jpg.
Show more details->Not supported

The webcam function is not functioning completely. There is no /dev/video created for it.

petar@aurora:~$ lsmod | grep gspca
gspca_spca500 21760 0
gspca_main 29312 1 gspca_spca500
videodev 41344 3 tuner,gspca_main,bttv
usbcore 148848 7 gspca_spca500,gspca_main,usbhid,ohci_hcd,ehci_hcd

lsusb gives:

petar@aurora:~$ lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 010: ID 055f:c200 Mustek Systems, Inc. gSmart 300
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 04b3:310b IBM Corp. Red Wheel Mouse
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

dmesg gives:

...
[ 2086.830502] usb 2-1: USB disconnect, address 10
[ 2091.428024] usb 2-1: new full speed USB device using ohci_hcd and address 11
[ 2091.749293] usb 2-1: configuration #1 chosen from 1 choice
[ 2091.751345] gspca: probing 055f:c200
[ 2091.754414] gspca: probe ok
[ 2091.754464] gspca: probing 055f:c200
[ 2092.207764] gspca: disconnect complete
------------------------------------------------------------------------------------------------------------------------------
uname -a
Linux aurora 2.6.27-7-generic #1 SMP Thu Oct 30 04:18:38 UTC 2008 i686 GNU/Linux

lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10

What confuses me most is the last message, [ 2092.207764] gspca: disconnect complete, because I am not disconnecting the webcam from my computer .

I am also not sure if this is important but my Ubuntu 8.10 is an upgrade from Ubuntu 8.04, so it is not a clean install. Also it might be important for you to know that I have Pinacle PCTV Studio TV tuner card installed on my computer. It uses BT878 driver. And it seams it is broken too. It is listed in the Multimedia Systems selector but when I test it the test doesn't show any errors, but there is no window showing the picture from the tuner.

If you need more information please ask.

Luca Ferretti (elle.uca) wrote :

From duplicated bug number #279519. The webcam now works (after some gstreamer/v4l/other update between Beta and final release), but not good as in 8.04, expecially: 1) strange "pixelated" images grabbed; 2) square aspect ratio, not rectangular

Starting to attach requested files

Luca Ferretti (elle.uca) wrote :
Luca Ferretti (elle.uca) wrote :
Luca Ferretti (elle.uca) wrote :
Luca Ferretti (elle.uca) wrote :
Andres Mujica (andres.mujica) wrote :

@Petar thanks for the info but it seems to be related to another bug report, so let me check that one, and if needed we'll check de gspca part in this one.

I have the same problem.

Perculiar is that webcam Logitech pro 4000 (and old type) is working. Other Logitech webcam which formerly worked in 8.04 now don't work in 8.10 release.

Should like to finish that the guys and girls who will fix that need a compliment for this.

Greetings
Frans

Gustavo A. Díaz (gdiaz) wrote :

And guys? fixed released? where? I have many genius webcams in my Linux Centre a those use as well the gspca. Non are working....
The only cam i have that works is in my laptop, but of course.. it does not use this driver...

yasou (yasou) wrote :

@ Diaz, this problem does not apply to all webcams that use gspca, only ones for which an alternative v4l2 driver exists, like zc0302 or sn9c102. Did the webcams work in Hardy? Did you have to blacklist a driver for gspca to work?

in case you did not have to blacklist a driver in Hardy and your webcams are detected but not working in interprid (mine wasn't detected at all) look at the following bug:
https://bugs.launchpad.net/bugs/260918

If you do have this same problem and you need a solution, look at my second and third comment

Yes, all Webcams where detected and working in Hardy and older version of
K/Ubuntu.

Five of the cams are Bus 002 Device 013: ID 093a:2471 Pixart Imaging, Inc.
SoC PC-Camera (Genius)

I've neved blacklisted those webcams to work.

I've already have installed libv4l, and does not work either. I did the
preload (in many apps, skype, kopete and amsn) and does not work... the cam
shows weird image...

2008/11/23 yasou <email address hidden>

> @ Diaz, this problem does not apply to all webcams that use gspca, only
> ones for which an alternative v4l2 driver exists, like zc0302 or
> sn9c102. Did the webcams work in Hardy? Did you have to blacklist a
> driver for gspca to work?
>
> in case you did not have to blacklist a driver in Hardy and your webcams
> are detected but not working in interprid (mine wasn't detected at all) look
> at the following bug:
> https://bugs.launchpad.net/bugs/260918
>
> If you do have this same problem and you need a solution, look at my
> second and third comment
>
> --
> Webcam (gspca) is not detected anymore since ubuntu 8.10 and Kernel 2.6.27
> https://bugs.launchpad.net/bugs/293259
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Gustavo A. Díaz
GDNet Projects
www.gdnet.com.ar

Gustavo A. Díaz (gdiaz) wrote :

By the way, I've followed this http://moinejf.free.fr/gspca_README.txt and
still it shows black image or weird image.
I've tried as suggested there with
LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so and it says:

ERROR: ld.so: object '/usr/local/lib/libv4l/v4l1compat.so' from LD_PRELOAD
cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/local/lib/libv4l/v4l1compat.so' from LD_PRELOAD
cannot be preloaded: ignored.

I am attaching the image from Kopete (for example).

2008/11/23 Gustavo A. Díaz <email address hidden>

> Yes, all Webcams where detected and working in Hardy and older version of
> K/Ubuntu.
>
> Five of the cams are Bus 002 Device 013: ID 093a:2471 Pixart Imaging, Inc.
> SoC PC-Camera (Genius)
>
> I've neved blacklisted those webcams to work.
>
> I've already have installed libv4l, and does not work either. I did the
> preload (in many apps, skype, kopete and amsn) and does not work... the cam
> shows weird image...
>
>
>
> 2008/11/23 yasou <email address hidden>
>
> @ Diaz, this problem does not apply to all webcams that use gspca, only
>> ones for which an alternative v4l2 driver exists, like zc0302 or
>> sn9c102. Did the webcams work in Hardy? Did you have to blacklist a
>> driver for gspca to work?
>>
>> in case you did not have to blacklist a driver in Hardy and your webcams
>> are detected but not working in interprid (mine wasn't detected at all) look
>> at the following bug:
>> https://bugs.launchpad.net/bugs/260918
>>
>> If you do have this same problem and you need a solution, look at my
>> second and third comment
>>
>> --
>> Webcam (gspca) is not detected anymore since ubuntu 8.10 and Kernel 2.6.27
>> https://bugs.launchpad.net/bugs/293259
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
>
>
> --
> Gustavo A. Díaz
> GDNet Projects
> www.gdnet.com.ar
>

--
Gustavo A. Díaz
GDNet Projects
www.gdnet.com.ar

You are preloading the wrong path, it should be:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so

make sure you have the following package installed
sudo apt-get install libv4l-0

yasou (yasou) on 2008-11-24
description: updated

Is installed, since is a dependency for amsn0.98svn. So, yes.

2008/11/24 yasou <email address hidden>

> You are preloading the wrong path, it should be:
> LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
>
> make sure you have the following package installed
> sudo apt-get install libv4l-0
>
> --
> Webcam (gspca) is not detected anymore since ubuntu 8.10 and Kernel 2.6.27
> https://bugs.launchpad.net/bugs/293259
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Gustavo A. Díaz
GDNet Projects
www.gdnet.com.ar

Gustavo A. Díaz (gdiaz) wrote :

@yasou: Yes I Did that.. just I pasted wrong and I figured it later. Still the cams does not work... are being detected like i said, but no image even using the LD_PRELOAD.

sparks40 (sparks40) wrote :

Good Morning!

For anyone interested, I am using Ubuntu 8.10 and have installed package libv4l-0, so that I can continue to use skype. The library shows up as version 0.5.20b and my camera shows up as:

Bus 001 Device 003: ID 093a:2460 Pixart Imaging, Inc. Q-TEC WEBCAM 100

The camera is currently able to produce video in Skype but the frame rate is only about 1/2 of what it used to be under Ubuntu 8.4.1. Under 8.4.1 the CPU utilization was appx. 95%m while under 8.10 the utilization is only appx. 35%. I assume that this is due to the format conversion taking place in kernel space under 8.4.1. While I am pleased that the camera is working again, it can hardly be referred to as "full motion video" any longer. I borrowed a Logitech Quickcam Deluxe for Notebooks (which is supposed to work under Open Source) just as a check, but that didn't work at all.

Thanks for sharing all this valuable information with everyone as I have read the posts with great interest. I'm hoping that things will ultimately get ironed out to where they used to be.

Gustavo A. Díaz (gdiaz) wrote :

What is going on guys with webcams on Intrepid? Now my 5986:0102 Acer, Inc Crystal Eye webcam stopped to work... what the hell? Even was the only webcam i have that does not use gspca driver (it uses uvcvideo which was working perfectly). What is going on? you plan to break more these things? I have to tell my students at my Linux Centre that stop using Ubuntu cause tends to breaks things? when i fully support it here in my country... this is insane...
No errors at ddmegs, no other logs... just for example in amsn (and does not work in NOWHERE) says: Unable to capture device and when dmesg says: uvcvideo: device Acer Crystal Eye webcam requested null bandwidth, defaulting to lowest. (always says this btw, even when was working iirc).

I used to be a supporter of linux/ubuntu.
I changed from 8.04 to 8.10 because of eth/wired/wireless problems.
Now wireless is no longer a problem. but wired still is.
And the builtin webcam (vaio vgn-tz170n) is no longer detected, e.g.,
israel@israel-laptop:~$ xawtv
This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.27-9-generic)
xinerama 0: 1366x768+0+0
can't open /dev/video0: No such file or directory
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No such file or directory
v4l2: open /dev/video0: No such file or directory
v4l: open /dev/video0: No such file or directory
no video grabber device available
I've never before spent so much time trying to get things working, to no avail. getting old...:-(

Levente Torok (toroklev) wrote :

With Interpid Ibex (ubuntu 8.10) I found the solution.
Here I repeat myself from
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/205970
I hope it helps for many.

"
  On my Interpid Ibex / Acer eMachine e520 the solution found at
  http://forum.notebookreview.com/showthread.php?t=291894
  solved the case.
  Since it is forgotten at each reboot you can make it start automatically as

  sudo gedit /etc/modules

  add line

  uvcvideo

  sudo gedit /etc/modprobe.d/options

  add line

  options uvcvideo quirks=2

"

Michael Jones (jmjones) wrote :

@Gustavo Please don't blame the Ubuntu folks for this. The gspca drivers were merged into the kernel tree with version 2.6.27 (which is in Intrepid), and it seems to be causing a lot of problems. None of my webcams work now either on my main system, which runs on Arch Linux. It's not just limited to Ubuntu.

I can't speak for the other drivers, but gspca is pretty messed up right now.

Andres Mujica (andres.mujica) wrote :

In fact, the problem is not only related to drivers, a libv4l merging and gstreamer changes trigered a lot of bugs.

The solutions are coming in a good pace, please bear with us while the issues are solved.

Andres Mujica (andres.mujica) wrote :

Hi again, i'm marking this bug as dupe from bug #144745 that is actually being worked on by Stephan so please follow your comments there.

Thanks again for you valuable help.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

nitrofurano (nitrofurano-3t) wrote :

I confess i am a bit curious about for when this problem will be solved in a milestone - would it be ready on 9.04 ?
Anyway, i suggested somewhere about 9.04 and 9.10 live-cd installer having also a webcam support, allowing you to have a '~/.face' acquired from that during the install process - i think this will help focusing the importance of a default and out-of-box webcam support...
Another question: in the meanwhile, is someone having any kind of webcam working on Ubuntu 8.10 ? if it is, and if it's easy to install, which ones are reccomended?
Thanks! =)

nitrofurano (nitrofurano-3t) wrote :

My concern is about i'm using webcams in some experimental development (for hacklabs and alike) which i'm delaying just because this annoying bug... - it's very sad some hardware support you're really counting with, suddenly brokes and gets still broken for a long time...

On Mon, Mar 2, 2009 at 9:52 AM, nitrofurano <email address hidden>wrote:

> *** This bug is a duplicate of bug 144745 ***
> https://bugs.launchpad.net/bugs/144745
>
> My concern is about i'm using webcams in some experimental development
> (for hacklabs and alike) which i'm delaying just because this annoying
> bug... - it's very sad some hardware support you're really counting
> with, suddenly brokes and gets still broken for a long time...
>

According to the list, your webcam should be working with the latest version
of gspca: http://moinejf.free.fr/webcam.html (search by the ID)

Have you tried making and installing the latest gspca from source:
http://linuxtv.org/hg/~jfrancois/gspca/ ? I had a similar problem and that
was able to fix it for my webcam. If you need further instructions, I'm
sure someone will be able to provide them or you can contact the gspca dev
from http://moinejf.free.fr/ (he was able to help me with a problem I was
having running "make" correctly). Now my hope is just that these updates to
gspca get pulled into Jaunty...

If anyone whose webcam is listed on http://moinejf.free.fr/webcam.html as
working still cannot get their camera to work, I can briefly list the steps
I took to get mine working correctly, and you're free to apply the same
logic to your camera. I'm not knowledgeable enough to give technical help,
but perhaps others can or the developer can if you contact him.

I knew a little bit about what was going wrong with my camera. The kernel
module sn9c102 was loading instead of the correct gspca kernel module. Even
if I blacklisted sn9c102 that was loading incorrectly, the current version
of gspca was not handling my camera. My camera is 0c45:613c and should have
been loading gspca_sonixj (from the link above). I downloaded the latest
gspca source from:
http://linuxtv.org/hg/~jfrancois/gspca/archive/tip.tar.gz, extracted
it, moved to the directory in terminal and ran "make". I then
had to edit my .config file in its v4l folder and comment out the line for
configuring SN9C102 by changing "CONFIG_USB_SN9C102=m" to "#
CONFIG_USB_SN9C102 is not set". I also deleted .myconfig in the v4l
folder. Then I re-ran "make" in terminal, and once it was done, I ran "sudo
make install". (I realize there probably is a less stupid way of doing
this, but I didn't want to mess with "make config"). I also ran "sudo rmmod
sn9c102" in terminal to remove the conflicting kernel module and blacklisted
it in /etc/modprobe.d/blacklist . I think I had to restart my computer as
well after installing. Once all that was done, I only had to plug in my
webcam and it works in everything: Cheese, Skype, Ekiga, etc. I only had to
do this process once, although i'm not sure that I've had to upgrade my
kernel yet and I'm not sure if that'll screw this up at all. Maybe having
dkms installed will mitigate that potential problem.

It looks like this will still be an issue in Jaunty (or it is currently at
least). Is there any sort of bug I should file or info I can provide that
would help get things working ootb for my webcam (and others)? Or is the
problem just that these gspca changes haven't made their way in to the
kernel version being used by Jaunty?

(Also, I apologize for this long response if all this information is
redundant to you.)

Jonathan

Looking more closely at this report I see that yasou, the original bug reporter, has the following device:

0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

This bug would then seem to be a duplicate of bug 292086 which is specifically about this particular device 0ac8:303b. As a result I'm un-duping this from bug 144745 which is about device 0ac8:301b and marking this a duplicate of bug 292086. Note that bug 292086 has fixes available for testing so it would be good to test and provide feedback at that bug report.

For anyone else who has a different device, it would be best to open a new report as it will likely require a slightly different fix. eg. Jonathan it would be great if you opened a separate report regarding the comment you posted above (https://bugs.edge.launchpad.net/ubuntu/+bug/293259/comments/43). Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.