Ubuntu

[regression] WPA not available on ThinkPad T30 (hostap broken)

Reported by Marc Deslauriers on 2008-10-13
70
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned

Bug Description

WPA wireless worked out of the box in Hardy on a ThinkPad T30 with integrated MiniPCI wireless Card.

In Intrepid, WPA is not available.

It seems in Intrepid, both orinoco_pci and hostap_pci get loaded for the wireless card. orinoco_pci grabs the card first and doesn't support WPA.

Even after blacklisting hermes, orinoco and orinoco_pci, the hostap driver won't connect to a WPA-protected wireless network. Dmesg shows: wifi0: invalid skb->cb magic.

Here are a bunch of log files from three configurations:

1- WPA working by default in Hardy
2- WPA not available with orinoco_pci in Intrepid
3- WPA not working with hostap in Intrepid

Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :

I just tested linux-image-2.6.26-5-generic_2.6.26-5.17 and hostap works fine (although it still loads orinoco_pci first).

It seems the bug in hostap was introduced in 2.6.27.

Aino de Vries (aino-vries) wrote :

Same here (Thinkpad A31, Intersil Corporation Prism 2.5 Wavelan chipset): 2.6.27 does not work, 2.6.24 works

Marc Deslauriers (mdeslaur) wrote :

Upstream bug and patch:

http://bugzilla.kernel.org/show_bug.cgi?id=11802

Supposedly fixed with kernel 2.6.27.4-1 from the testing repository.

Marc Deslauriers (mdeslaur) wrote :

Scratch my last comment about 2.6.27.4.

Changed in linux:
status: Unknown → Confirmed
irson (mehranson) wrote :

I had this problem and could fix it by adding hostap_pci to the blacklist. Now it loads orinoco_pci and wireless works fine.

Here is the output of "lspci -vv"

02:02.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 01)
 Subsystem: Intel Corporation Device 2513
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 11
 Region 0: Memory at f8000000 (32-bit, prefetchable) [size=4K]
 Capabilities: <access denied>
 Kernel driver in use: orinoco_pci
 Kernel modules: orinoco_pci, hostap_pci

Marc Deslauriers (mdeslaur) wrote :

orinoco_pci does work for this card, but it doesn't support WPA. hostap supports WPA.

Changed in linux:
status: Confirmed → Fix Released
Marc Deslauriers (mdeslaur) wrote :

hostap driver now works in Jaunty.

Marking as fix released.

Changed in linux:
status: New → Fix Released
cornbread (corn13read) wrote :

How can I fix this in intrepid? Or do I need to upgrade to jaunty?

cornbread (corn13read) wrote :

I did a fresh install to alpha 4 and ran all of the updates and it connection manager still doesn't give me the wpa encryption option.

Damien Gray (adchaos) wrote :

Fresh install of Xubuntu 9.10 has this issue. It was previously working with 9.04. Blacklisting the orinico driver results in a hang on boot.

ktp420 (ktp420) wrote :

same here working great in 9.04 and now fails in 9.10...system hangs.

ktp420 (ktp420) wrote :

the hang can be seen when you remove hostap* and orinico* mod and adding hostap_pci mod....

sudo rmmod -f hostap hostap_pci orinico orinico_pci
sudo modprobe hostap
sudo modprobe hostap_pci <-- hang right after this.

ccasper (ccasper) on 2010-01-01
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Chris Hemsing (c-hemsing) wrote :

Same here with Intersil prism (1260:3873) wlan device on 9.10.
Detailed information:

a) Standard boot: both orinoco_pci and hostap_pci get loaded (modules.pcimap really has two drivers for the same device!), orinoco takes the device: no WPA !

b) Blacklisting orinoco_pci: boot stops (rather stalls forever) when loading hostap_pci with kernel message:
BUG: soft lockup - CPU#0 stuck for 61s!

c) after standard boot: unloading both hostap_pci and orinoco_pci and modprobe hostap_pci afterwards again leads to a system lockup with
BUG: soft lockup - CPU#0 stuck for 61s!
(I first didn't see it, because - of course - you have to wait 1 minute before the first message gets emitted!)

d) With 8.04.1 only hostap_pci got loaded and everything worked fine with WPA

e) When you blacklist hostap_pci: again it works but no WPA

f) when you manually modprobe hostap_pci with orinoco_pci loaded, this pulls the lib80211 module and the kernel emits
lib80211: common routines for IEEE802.11 drivers
lib80211_crypt: registered algorithm 'NULL'
(this does not seem to be a healthy crypt algorithm ... it might be the reason why using hostap_pci without orinoco_pci loaded fails)
However, the system does not stall.

To summarize: orinoco_pci will not provide WPA (at least not for this device) and hostap_pci does not work (anymore!)!

Chris Hemsing (c-hemsing) wrote :

Nobody cares, right?

This is already the second formerly perfectly working wireless driver I know, which has been "destroyed" by an upgrade.
Linux is getting exactly the quality that MS DOS had, when Linus was so fed up with MS DOS to write his own OS.
Also: modprobe hostap_pci immediately leads to a soft lockup of the kernel. So it is clear where the kernel hangs. That does not sound like a terribly difficult bug to track.

mabawsa (mabawsa) wrote :

This is an old bug. Perhaps bug 432636 would be more appropriate\?

madbiologist (me-again) wrote :

Since this is a kernel bug, and Linus Torvalds is still the person ultimately responsible for the kernel, perhaps you could tell him that you think he has achieved nothing. He can be contacted via the mailing list at http://lkml.org/ I doubt he will agree with you.

> Nobody cares, right?
>
> This is already the second formerly perfectly working wireless driver I know, which has been "destroyed" by an upgrade.
> Linux is getting exactly the quality that MS DOS had, when Linus was so fed up with MS DOS to write his own OS.
> Also: modprobe hostap_pci immediately leads to a soft lockup of the kernel. So it is clear where the kernel hangs. That does not > sound like a terribly difficult bug to track.

Changed in linux:
importance: Unknown → Medium

Marc Deslauriers, This bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/282840/comments/17 regarding this being fixed with an update. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

tags: added: intrepid kernel-wifi needs-kernel-logs needs-upstream-testing regression-release
Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.