Ubuntu

Mute button not properly working on current Lenovo Thinkpads x200/x200s , t400/t500, X300/X301, & W series

Reported by ccc1 on 2008-10-11
214
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Géza Búza

Bug Description

two problems with the mute button on my thinkpad x200:

1) There is no OSD
2) to unmute one has to hit "volume up" or "volume down" key.

I'm using intrepid.

description: updated
description: updated
description: updated

provisionally assigning to xserver-xorg-input-keyboard

Dimitrios Symeonidis (azimout) wrote :

can you please run "xev" in a terminal? then press the "mute key" and tell us if you see any output... thank you

There is no output pressing the "mute key".

i found out more about this "bug":

pressing the mute button writes 0 to /proc/acpi/ibm/volume. so in order to get the desired
behavior it would be necessary to read out the volume level from /proc/acpi/ibm/volume
before setting it to 0. save it somewhere and then if the users push the mute button again
write the saved value back.

Bryce Harrington (bryce) wrote :

There's been numerous improvements in hotkey handling in Jaunty. Please re-test and report here if it works or if there are still problems.

I can confirm this bug on up-to-date Kubuntu Jaunty on ThinkPad x200s.

Pressing Mute button does not generate HAL event (lshal -m) and does not issue KeyPress X event (xev). I can confirm that pressing Mute button changes state reported by /proc/acpi/ibm/volume:

Before:
level: 7
mute: off
commands: up, down, mute
commands: level <level> (<level> is 0-15)

After:
level: 7
mute: on
commands: up, down, mute
commands: level <level> (<level> is 0-15)

Volume Up/Down keys work properly and generate both HAL and X event:

lshal -m
=====

Start monitoring devicelist:
-------------------------------------------------
10:25:04.550: platform_i8042_i8042_KBD_port_logicaldev_input condition ButtonPressed = volume-up
10:25:05.323: platform_i8042_i8042_KBD_port_logicaldev_input condition ButtonPressed = volume-down

xev:
===
FocusIn event, serial 31, synthetic NO, window 0x3400001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 31, synthetic NO, window 0x0,
    keys: 68 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyRelease event, serial 31, synthetic NO, window 0x3400001,
    root 0xb4, subw 0x0, time 8684461, (66,77), root:(1119,215),
    state 0x0, keycode 123 (keysym 0x1008ff13, XF86AudioRaiseVolume), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

FocusOut event, serial 34, synthetic NO, window 0x3400001,
    mode NotifyGrab, detail NotifyAncestor

FocusOut event, serial 34, synthetic NO, window 0x3400001,
    mode NotifyUngrab, detail NotifyPointer

FocusIn event, serial 34, synthetic NO, window 0x3400001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 34, synthetic NO, window 0x0,
    keys: 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyRelease event, serial 34, synthetic NO, window 0x3400001,
    root 0xb4, subw 0x0, time 8685027, (66,77), root:(1119,215),
    state 0x0, keycode 122 (keysym 0x1008ff11, XF86AudioLowerVolume), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

I am not sure hal-info is the right package for this - I think most of special keys are now handled in kernel.

Changed in hal-info:
status: Incomplete → Confirmed
Stefan Hammer (j-4) wrote :

hi!

I have just done the troubleshooting-checklist on https://wiki.ubuntu.com/Hotkeys/Troubleshooting !

1. run xev to test whether a keypress event is seen:
This gives no keypress event with thinkpad extrabuttons!

5. enumerate the available input devices as seen by hal:
hal-find-by-capability --capability input | xargs -n1 lshal -u

udi = '/org/freedesktop/Hal/devices/computer_logicaldev_input_4'
  button.has_state = true (bool)
  button.state.value = true (bool)
  button.type = 'radio' (string)
  info.addons.singleton = {'hald-addon-input'} (string list)
  info.callouts.add = {'hal-setup-keymap', 'debian-setup-keyboard'} (string list)
  info.capabilities = {'input', 'input.keys', 'input.switch', 'button', 'input.keymap'} (string list)
  info.category = 'input' (string)
  info.parent = '/org/freedesktop/Hal/devices/computer' (string)
  info.product = 'ThinkPad Extra Buttons' (string)
  info.subsystem = 'input' (string)
  info.udi = '/org/freedesktop/Hal/devices/computer_logicaldev_input_4' (string)
  input.device = '/dev/input/event10' (string)
  input.keymap.data = {'0x01:screenlock', '0x02:battery', '0x03:sleep', '0x04:radio', '0x06:switchvideomode', '0x07:f22', '0x08:f24', '0x0b:suspend', '0x0f:brightnessup', '0x10:brightnessdown', '0x11:kbdillumtoggle', '0x13:zoom', '0x14:volumeup', '0x15:volumedown', '0x16:mute', '0x17:prog1', 'e05d:menu'} (string list)
  input.product = 'ThinkPad Extra Buttons' (string)
  input.x11_driver = 'evdev' (string)
  input.xkb.layout = 'de' (string)
  input.xkb.model = 'pc105' (string)
  input.xkb.rules = 'evdev' (string)
  input.xkb.variant = 'nodeadkeys' (string)
  linux.device_file = '/dev/input/event10' (string)
  linux.hotplug_type = 2 (0x2) (int)
  linux.subsystem = 'input' (string)
  linux.sysfs_path = '/sys/devices/virtual/input/input10/event10' (string)

with "sudo input-events 10" and pressing the hotkey (mute button and volume up/down) there is also no event shown.

10. If the events are reported by more than one input device then report a kernel bug (Ubuntu linux package) because it should only send the event on one device.
11. if not found with input-events, use acpi_listen to determine whether the key is coming through as an ACPI event instead of a keypress

acpi_listen gives only an output pressing other thinkpad keys: (ThinkVantage, FN+F3, Brightness up/down,...)
ibm/hotkey HKEY 00000080 00001018
ibm/hotkey HKEY 00000080 00001003
ibm/hotkey HKEY 00000080 00001010
video LCD0 00000086 00000000
ibm/hotkey HKEY 00000080 00001011
video LCD0 00000087 00000000

13. if there is neither an ACPI event nor an input event, this is probably also a kernel bug, though probably harder to diagnose (WMI, perhaps?)

further information:

lshal |grep system.hardware
  system.hardware.primary_video.product = 10818 (0x2a42) (int)
  system.hardware.primary_video.vendor = 32902 (0x8086) (int)
  system.hardware.product = '2767B35' (string)
  system.hardware.serial = 'L3D9557' (string)
  system.hardware.uuid = 'B2999701-49A6-11CB-9FF6-9729DA065BC4' (string)
  system.hardware.vendor = 'LENOVO' (string)
  system.hardware.version = 'ThinkPad T400' (string)

Stefan Hammer (j-4) wrote :

another useful information

jonas (jonas73x) wrote :

i have the same issue with a thinkpad t400. as suggested elsewhere, updating the bios and adding the boot option acpi_osi="Linux" fixes the issue. both mute and unmute works and i get the correct OSD. however, since i don't really know what other things the acpi_osi="Linux" boot option alters i'm reluctant to use it.

Hao-Yu LEE (mutekinootoko) wrote :

same issue in 9.04 with x200.

Charles Profitt (cprofitt) wrote :

Same issue with 9.04 and a T500

Charles Profitt (cprofitt) wrote :

lshal | grep system.hardware
  system.hardware.primary_video.product = 10818 (0x2a42) (int)
  system.hardware.primary_video.vendor = 32902 (0x8086) (int)
  system.hardware.product = '2081CTO' (string)
  system.hardware.serial = 'L3A7271' (string)
  system.hardware.uuid = 'CC121001-4A86-11CB-9A5A-B71BA3F45B24' (string)
  system.hardware.vendor = 'LENOVO' (string)
  system.hardware.version = 'ThinkPad T500' (string)

Charles Profitt (cprofitt) wrote :
Charles Profitt (cprofitt) wrote :
Charles Profitt (cprofitt) wrote :

sorry about the duplicate...

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

Currently the button on my T500 is no longer muting. The mute state changes in /proc/acpi/ibm/volume, but the sound still plays ok

Charles Profitt (cprofitt) wrote :

I just tested the mute function on my T500 and hitting mute still mutes the sound, but hitting the mute button again (which should unmute the sound) does not work... the music stays muted.

Hao-Yu LEE (mutekinootoko) wrote :

Ubuntu 9.04 on x200,
mute button works after adding the boot option acpi_osi="Linux".

Jerone Young (jerone) wrote :

I'm about to submit a kernel patch for Karmic to fix this issue for many Thinkpads. For the T61 this is the case. But in the kernel it is listed to expose itself as Linux when the Bios queries it.

Lenovo has logic in the bios that will change the mute key from a just a controling the speakers at the hardware level. To sending the OS the mute key press instead.

This can be found in the kernel in
drivers/acpi/blacklist.c

Jerone Young (jerone) wrote :

Also can someone post the output of "dmidecode" command on a x200 & x200s.

Luka Renko (lure) wrote :

My dmidecode output attached. Thanks for taking care for this bug.

Stefan Hammer (j-4) wrote :

I can post the output of an X200 in a few hours. I am not at home right now.
Do you need the information from other models too?
Attached it from T400

Thanks a lot for solving the problem!

T500 attached

Jerone Young (jerone) on 2009-08-28
summary: - Mute button on thinkpad x200/x200s
+ Mute button not properly working on current Lenovo Thinkpads x200/x200s
+ , t400/t500, X300/X301, & W series
Jerone Young (jerone) wrote :

Can you guys tryout the kernel deb package I posted here and post if the mute button now works on your Thinkpads.

http://people.canonical.com/~jerone/test_kernels/thinkpads/

Luka Renko (lure) wrote :

Is it possible to get amd64 test package?

bofphile (bofphile) wrote :

With the test kernels, the mute button now works on my T500 but only when using the speaker. If I use headphones, the sound is not muted although the master channel is marked as muted (and I also get the notification).

Jerone Young (jerone) wrote :

@bofphile
    That is odd. Are you using 9.10 with your test? But even with 9.04 or 8.04 if the master channel is muted the headphones should not be hearing anything, can you check the mixers? This is most likely a issue with the audio driver.

@Luka
   I'll produce an amd64 one shortly, hopefully tonight.

bofphile (bofphile) wrote :

I'm using Jaunty for the test. If I mute the sound with the headphones plugged in, I can still hear sound although the master channel is marked as "MM" in alsamixer, as soon as I unplug them there's no more sound on the speakers.

Changed in linux:
status: Unknown → Confirmed
Stefan Hammer (j-4) wrote :

Hi everyone!
I tested the patched kernel using Kamic on my T400.
Everything now works as it should.
The mute-button mutes the sound, a notification therefore is shown. Speakers and also plugged-in headphones are muted.
Pressing again or pressing the volume-up button unmutes everything.
Love it!
Jango

Stefan Hammer (j-4) wrote :

maybe you need it...

Jerone Young (jerone) wrote :

@jango
    Can you also try the kernel on the X200. It will have the same behavior .. but just verifying to be 100% sure.

@bofphile
     You probably want to file a bug for that for 9.04. Since things are controled by pulse audio in 9.10 you wouldn't have that issue.

Jerone Young (jerone) wrote :

@Luka Renko
      amd64 kernel now up:
http://people.canonical.com/~jerone/test_kernels/thinkpads/

Stefan Hammer (j-4) wrote :

@ Jerone:
Sorry, i can't install Karmic on the X200, there is too less disc space. Installing a new Kernel on an live system does't work eather. And on Jaunty i can't test the kernel because of the new UXA with intel graphics. I get a black screen then.

Jerone Young (jerone) wrote :

Working around I've found the following Thinkpads have this issue & solution:

X200
X200s
X200t

X300
X301

T400
T500

W500
W700
W700ds

Though I cannont figure out anything about the "SL" line of Thinkpads.

@jango
    You don't need to test it. I've verified it's the same problem & solution as all the other thinkpads

Jerone Young (jerone) wrote :

Just to add I've summited the patches so hopefully they will make it into the Karmic kernel.

I have left platforms that I couldn't verify from the patch set though:

SL 400
SL 500

T400s

Luka Renko (lure) wrote :

I can confirm Mute button working with notifications in KDE on X200s using test kernel. Thanks.

Changed in linux:
status: Confirmed → Fix Released
Changed in linux:
status: Fix Released → Confirmed
Changed in linux:
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

Isn't this bug an extension of bug #357673? The thinkpad_acpi kernel maintainer has said he's opposed to forwarding these keypresses to userspace, on the grounds that the kernel behavior is already consistent with how these keys operate under Windows - controlling the hardware/BIOS mixer instead of acting on the OS mixer.

In fact, I see Henrique has commented in the upstream bug, apparently to exactly this effect.

TomasHnyk (sup) wrote :

Thanks for fixing the mute button. The same issue goes for power button as well. It also does not have any effect, does not generate any xev events and so on. I do not know whether this was fixed with this patch (I will test soon).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-10.30

---------------
linux (2.6.31-10.30) karmic; urgency=low

  [ Amit Kucheria ]

  * [Config] Enable CONFIG_USB_DEVICEFS
    - LP: #417748
  * [Config] Populate the config-update template a bit more

  [ Andy Whitcroft ]

  * rebase to v2.6.31-rc9
  * [Config] update configs following rebase to v2.6.31-rc9
  * [Config] update ports configs following rebase to v2.6.31-rc9

  [ Colin Ian King ]

  * SAUCE: wireless: hostap, fix oops due to early probing interrupt
    - LP: #254837

  [ Jerone Young ]

  * [Upstream] ACPI: Add Thinkpad T400 & Thinkpad T500 to OSI(Linux)
    white-list
    - LP: #281732
  * [Upstream] ACPI: Add Thinkpad X200, X200s, X200t to OSI(Linux)
    white-list
    - LP: #281732
  * [Upstream] ACPI: Add Thinkpad X300 & Thinkpad X301 to OSI(Linux)
    white-list
    - LP: #281732
  * [Upstream] ACPI: Add Thinkpad R400 & Thinkpad R500 to OSI(Linux)
    white-list
    - LP: #281732
  * [Upstream] ACPI: Add Thinkpad W500, W700, & W700ds to OSI(Linux)
    white-list
    - LP: #281732

  [ John Johansen ]

  * SAUCE: AppArmor: Fix profile attachment for regexp based profile names
    - LP: #419308
  * SAUCE: AppArmor: Return the correct error codes on profile
    addition/removal
    - LP: #408473
  * SAUCE: AppArmor: Fix OOPS in profile listing, and display full list
    - LP: #408454
  * SAUCE: AppArmor: Fix mapping of pux to new internal permission format
    - LP: #419222
  * SAUCE: AppArmor: Fix change_profile failure
    - LP: #401931
  * SAUCE: AppArmor: Tell git to ignore generated include files
    - LP: #419505

  [ Stefan Bader ]

  * [Upstream] acpi: video: Loosen strictness of video bus detection code
    - LP: #333386
  * SAUCE: Remove ov511 driver from ubuntu subdirectory

  [ Tim Gardner ]

  * [Config] Exclude char-modules from non-x86 udeb creation
  * SAUCE: Notify the ACPI call chain of AC events
  * [Config] CONFIG_SATA_VIA=m
    - LP: #403385
  * [Config] Build in all phylib support modules.
  * [Config] Don't fail when sub-flavour files are missing
    - LP: #423426
  * [Config] Set CONFIG_LSM_MMAP_MIN_ADDR=0
    - LP: #423513

  [ Upstream ]

  * Rebased against v2.6.31-rc9

 -- Andy Whitcroft <email address hidden> Mon, 07 Sep 2009 11:33:45 +0100

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Simon Déziel (sdeziel) wrote :

I have a Thinkpad SL400 running Karmic and mute/volume up/down don't work even with 2.6.31-10.30.

Chris Jones (cmsj) wrote :

This was not previously an issue on my X301, OSD for volume worked fine as did the mute button.

The behaviour for unmuting has been like it was for some time now (i.e. the mute button mutes, it's not a toggle. You can tell it's not a toggle because the little picture next to it is a speaker with a line through it), so I believe this change is wrong.

Additionally, muting no longer lights up the LED for the mute button which it did in the previous karmic kernel.

Finally, is it not terrifically bad to use osi=Linux? Does Lenovo specifically support this?

Chris Jones (cmsj) wrote :

so it does actually seem that this fixes the problem where the mute button wasn't previously muting the headphone socket, but I have to wonder why we can't fix that without changing the behaviour of the mute button and breaking the LED and switching to OSI=Linux?

Simon Déziel (sdeziel) wrote :

This bug was fixed in the package linux - 2.6.31-10.31 for Thinkpad SL serie (tested on SL400 only).

---------------
linux (2.6.31-10.31) karmic; urgency=low

  [ Andy Whitcroft ]

  * rebase to v2.6.31 final

  [ Colin Watson ]

  * [Config] Recommend grub-pc in linux-image
    - LP: #385741

  [ Ike Panhc ]

  * [Upstream] Pull latest update of lenovo-sl-laptop

  [ Peter Feuerer ]

  * [Upstream] (drop after 2.6.31) acerhdf: fix fan control for AOA150
    model
    - LP: #426691

  [ Tim Gardner ]

  * [Config] De-macro some package names.

  [ Upstream Changes ]

  * rebase to 2.6.31 final.

Stefan Hammer (j-4) wrote :

This bug was already fixed, but seems to be lost with 2.6.31-11.
If pressing the mute button on my T400 its the same issue than it was before fixing the bug.
There is no OSD and pressing again doesn't unmute.
Can you confirm, that the function got lost again?

Changed in linux (Ubuntu):
status: Fix Released → Confirmed

I actually _like_ the "Pressing again does not unlock" feature, and quite a lot. Pressing mute works at all times, even when the computer is not fully booted, and I can make sure that it is muted by pressing the mute button once.

Having an OSD would be nice though.

Steve Langasek (vorlon) wrote :

The "fix" has been reverted because it worked by having Linux tell ACPI that it's not a Windows-compatible OS. That can have any number of side effects, and kernel upstream considers it a serious bug to do this.

Upstream work is in progress to expose the BIOS mixer as an ALSA mixer so that we will have OSD notification for this without having to break ACPI handling. Unfortunately this won't be ready for karmic, so 9.10 will have the same behavior as 9.04; but I expect we'll have a solution available in time for lucid.

The mute button not being a toggle is probably not going to be fixed unless the vendor decides to change their BIOS implementation.

Lars Volker (lv) wrote :

I'm not sure I understand 100% of what Steve explained. But if it was fixed in Karmic before (as it was here) and is broken now (as it is here as well), then I can't see why we aren't able to rebreak it so it works again. :)

For me it seems rather strange to break the functionality on purpose because kernel upstream likes to see it broken and calls the working state "a bug".

Any clarification on this would be welcome, including a way to fix it again.

Stefan Hammer (j-4) wrote :

The fix was reverted, because it is dangerous. Do you understand now?
So we have to wait, until they found an other solution for this problem - and luckily they are working on it right now.

Luka Renko (lure) wrote :

What Steve wanted to explain is that the "fix" for mute button was that we told to BIOS/ACPI that we are "Linux", which may not only "fix" mute button, but may have other side effects, which cannot be seen immediately. This is why upstream kernel developers did not like the "fix".
Some time ago, it was decided in the Linux kernel community, that it is better to notify the BIOS/ACPI that we are "Windows"-compatible, in order to get all the bells and whistles from the BIOS/ACPI as Windows gets. In our particular case, this has also drawback: missing mute functionality, due to missing BIOS mixer availability through ALSA. This makes mute button only HW switch, with no support for SW (kernel, applications).

The right fix is therefore to implement missing functionality (expose BIOS mixer to ALSA), rather than changing overall behavior with potentially bad side effects.
Even though I do not like the change, I can understand why it was made.

Lars Volker (lv) wrote :

So if I would enter osi=Linux to the kernel boot parameters the mute button would work again (this was the fix, right?) and i'd expose my system to unknown side effects?

Luka Renko (lure) wrote :

Lars: yes, I think this is correct

maticmatija (maticmatija) wrote :

I can confirm this bug in Ubuntu 9.04 and Ubuntu 9.10 beta 1 on Thinkpad r50e. The volume keys do not trigger any software response and no osd is shown. Additionally, this is the case also for brightness buttons, but both work well. And I also agree that the mute button should not restore volume level.

Géza Búza (medve) wrote :

I can confirm the issue too. Tested on Thinkpad T500 with 9.10 beta1 Ubuntu karmic (development branch) live CD.

Luis Carlos Cobo (luiscarlos) wrote :

It affects Thinkpad T60 too, in Karmic.

pico (pico-cocco) wrote :

Same problem on IBM T41 with new fresh 9.10 installed.
Mute button work for mute... but not for unmute.
Also.... every "special keys" works but nothing is show on desktop when you push it

clark3934 (clark3934) wrote :

I am still affected by this bug while running Ubuntu 9.10 on my T500, running 2.6.31-16. It neither mutes nor unmutes.

Jerone Young (jerone) wrote :

@Clark
        Upstream now has the fix for T400 & T500. I think it is in 2.6.32 .. but definetely in 2.6.33. So 10.04 will have the fix for sure. Though looks like the other platforms did not make it in.

Setting acpi_osi=Linux also works on my Thinkpad x200. You can add it to the blacklist and submit as an upstream patch.

Steve Langasek (vorlon) wrote :

acpi_osi=Linux is a wrong solution, it introduces the previously described problems of bypassing the in-BIOS mixer handling. It will not be accepted upstream or in Ubuntu.

Stefan Hammer (j-4) wrote :

it is already fixed in lucid. Maybe we should close this bug?

James Hewitt (jammy) wrote :

@jango: It isn't fixed on my W500 with lucid. The keypress doesn't register in xev and I get no osd for mute.

bofphile (bofphile) wrote :

The mute/unmute button works great now on Lucid beta 2

bofphile (bofphile) wrote :

I forgot to add this was with my T500

Timothy Pearson (kb9vqf) wrote :

Broken again under Lucid with my T500 on 4/21/2010.

It was working well for a week or so before then (i.e., ever since I upgraded to Lucid)

Christophe (christophe-wk3) wrote :

This is still broken in Lucid on my Thinkpad R60. The buttons work, but completely bypass Pulseaudio or Alsa mixers.

Huygens (huygens-25) wrote :

That is weird. The mute button is now working perfectly for me in Lucid, since I started beta testing it, and today it is still working (with latest updates applied). Though I had also the problem with Karmic like everyone.
I have a Lenovo Thinkpad T500 and I'm using the 32bit version of Ubuntu Desktop.

allan999 (allan-laal) wrote :

kernel: Linux 2.6.31-20-generic-pae #58-Ubuntu SMP Fri Mar 12 06:25:51 UTC 2010 i686 GNU/Linux
Ubuntu 10.04 on a Thinkpad T500

when no headphone jack connected:
the "mute" button mutes sound, but does not unmute - you have to press vol up/down to unmute
vol up/down work as expected

when headphones/ext. speakers are connected via the headphone jack:
the "mute" button does absolutely nothing
vol up/down work as expected

Also:
when i press "mute" with no headphones and then connect headphones - they are not muted
I kinda like this feature/bug, but maybe its connected somehow.

mnttnlyzr (kevincmann-gmail) wrote :

Using Thinkpad R400 the mute and power buttons do nothing in 10.04 and do not show any result in xev.

mnttnlyzr (kevincmann-gmail) wrote :

Correction: mute button works but shows no indication on screen.

TomasHnyk (sup) wrote :

10.4 and mute works as expected (OSD and it toggles mute). Power button still unregistered. However, I got used to the old mute behaviour meanwhile:-).

TomasHnyk (sup) wrote :

I use T500, forgot to add.

I use a Lenovo Thinkpad X200s with the 2.6.32-22-generic i686 Kernel.

On my external Thinkpad Keyboard, the button does work. On the laptop itself, it doesn't. No matter if headphones/ext. speakers are connected via the headphone jack. The "mute" button on the machine does not work.

I hope this helps to solve this little problem.

Mark Cocker (mark-earth) wrote :

Thinkpad W500 with Ubuntu 10.04 and kernel 2.6.32-24-generic-pae I observe:
- Thinkpad volume up & down buttons work and get OSD fine
- When not in a docking station Thinkpad mute button mutes sound but no OSD
- When in a docking station, the Thinkpad mute button does *NOT* mute sound nor OSD

nachiket (nachiket) wrote :

I can confirm "unmute" does not work on a W500, Ubuntu 10.04 and kernel 2.6.32-22-generic.

kiu (kiu) wrote :

On my new x200s running 10.04 amd64 (2.6.32-24-generic) i have this behaviour (no docking station):

- volume up: osd ok, builtin speaker ok, line out ok
- volume down: osd ok, builtin speaker ok, line out ok
- volume mute: no osd showing, builtin speaker ok, no mute for line out

Additionally had a funny bug, where a hanging sshfs mountpoint killed the volume keys completely. After "umount -f" all (queued) volume events have been applied in order.

Dmitriy Kropivnitskiy (nigde) wrote :

Confirming this bug on an R400 running Maverick. The xev still doesn't report anything when pressing Mute button. The Volume Up/Down buttons work fine and show the OSD volume change. The mute button mutes, but the muteness doesn't register with the mixer applet or anything else, except that the mute state is noted in /proc/acpi/ibm/volume. It doesn't unmute, to unmute a volume up/down button needs to be pressed.

While I understand that telling ACPI that Linux is not Windows might lead to side effects, I am not sure pretending to be Windows is a good policy in the long run. Wouldn't this make kernel vulnerable to potential incompatibility bugs? Why does upstream insist on doing it this way?

I don't understand the argument about not letting Mute key events into user space. Why not? I understand it is already operating on BIOS mixer, but something needs to react to this by updating user interface. How is it supposed to work, check the BIOS mixer state all the time?

Christophe (christophe-wk3) wrote :

This bug is still present on Maverick. The buttons work but there's no OSD and volume changes are not linked to GNOME volume manager.

ThinkPad R60 9461DXG
Linux 2.6.35-22-generic x86_64

OBIEKTYWNY (obiektywny) wrote :

Like Christophe, same problem here, but under Maverick on the ThinkPad T60 machine.
2.6.35.23-generic x86

Changed in linux:
importance: Unknown → Medium
arndt (arndtt) wrote :

Speaker + Mic mute LEDs still do not work for a Thinkpad T400s running Kubuntu Natty Beta 1 ( Kernel 2.6.38-8-generic amd64).

Florian M. (flomar) wrote :

>This bug is still present on Maverick. The buttons work but there's no OSD and volume changes are not linked to GNOME >volume manager.

Still present in up to date 11.04 on TP X200.

Matt R (matt-pequod) wrote :

I'm getting this problem in Natty on my R500 - no keypress detected in xev when I hit the mute key.

Seth Forshee (sforshee) wrote :

Matt: This bug has actually been fixed for a long time and should be fixed in all supported versions of Ubuntu. It looks like no one ever marked this bug as fixed though, so I'm doing so now. Since it doesn't appear this fixes the problem for your model, I suggest that you open a new bug by running 'ubuntu-bug linux' from a terminal.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released

Matt: I am also still experiencing this issue. I opened a bug for my X200s and it is bug #810048

I would suggest opening a separate bug report (similarly written to mine) for your laptop model as the fix could be different between the two.

Vladimir Kulev (me-lightoze) wrote :

Seth: If this bug is fixed, how would you explain the fact that it is still present for Matt's R500 (#81) , Greg's X200s (#83) and my R400. As well as others I use Ubuntu Natty.

My symptoms are exactly as in the bug description. Additional diagnostics show:
1) xev shows nothing
2) keymap shows nothing
3) acpi_listen shows nothing
4) /proc/acpi/ibm/volume shows level:unsupported and a correct mute state
But the mute is actually working, but see bug description.

Seth Forshee (sforshee) wrote :

Vladimir: We know a fix was merged for some models. If the problem is fixed for the original reporter then the bug should be marked fixed, but since the original reporter seems to have fallen silent I can't really confirm that the original issue is fixed. So what makes the most sense to me is to mark this bug as fixed and let the original reporter reopen it if necessary.

In this case there are more models that may be affected (which I am more than happy to help get working), but since the original fix didn't catch those models what makes sense now is to open a new bug or bugs for the additional models. And actually the fix that was applied is kind of a last resort way of working around problems like this, so I'd like to go through the due diligence of verifying that there really isn't any other solution before starting to add quirks for additional models. It should be okay to have only a single bug for any models that really can't be fixed any other way. I'll try go back through the information here more carefully tomorrow to see which models have had sufficient testing and which might need a little more.

Mark Cocker (mark-earth) wrote :

With Lenovo Thinkpad W500 + Ubuntu 11.04 + kernel 2.6.38-10-generic-pae + Unity:
- Thinkpad mute button mutes sound, but no OSD. Pressing mute a second or more times does not unmute.
- Thinkpad volume up & down buttons work as expected and shows OSD.

Matt R (matt-pequod) wrote :

I opened a new bug for this issue earlier --> #809899

TomasHnyk (sup) wrote :

For anybody with problems with the power button, see this bug (currently only for T500), see bug 893560.

Christer (christer-madsen) wrote :

Well, I am on X200s with up to date 12.10 i386, and NOT working. It is exactly the same behaviour as described several times in these comments!.... The mute works on the internal speakers, but does not unmute, nor shows osd notification. When headphones or external speakers connected, it does absolutely nothing.... How long can this simple fix take? I am not a hardcore user, so would't know how to fix myself or contribute to a fix, but this is really irritating me that the mute button does not work.... I thought linux was about fast updates, since everyone can contribute... Everything else works on my thinkpad, and having mute button disabled is a bummer...

TomasHnyk (sup) wrote :

This is an old fixed bug. Open a new bug (possibly with link to this one) for your problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.