Comment 11 for bug 280657

Luckily, as I did an upgrade from Hardy, I still have the old kernel (2.6.24-21-generic #1 SMP) installed as a fall-back option. Camera works as before with this kernel.
The difference is that it's loading the 2.6.24-21-generic/ubuntu/media/gspcav1/gspca.ko which no longer exists in the Interpids kernel package. No module in 2.6.27-7-generic/kernel/drivers/media/video/gspca/ can handle my camera (045e:00f5) so the sn9c102 module is loaded which obviously doesn't work. I tried blacklisting that module but then no module is loaded.