Intrepid kernel 2.6.27-6 no supported image sensor dected for SN9C105 (045e, 00f7)

Bug #280657 reported by sjhstorm on 2008-10-09
170
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Undecided
Andy Whitcroft
Nominated for Intrepid by Tandl McSich
Nominated for Jaunty by Tandl McSich

Bug Description

Image sensor not detected for Microsoft VX1000 web cam in kernel 2.6.27-6 kernel, worked previously in 2.6.26 kernels. This may be an upstream issue as I tried Suse 11.1 beta with 2.6.27 kernel and had same issue.

This is what should be detected the image sensor being OV7760.

( {USB_DEVICE(0x045e, 0x00f7), BSI(SN9C105, OV7660, 0x21)})

My results can be found below:

dmesg - result:
[ 318.096282] usb 6-1: new full speed USB device using uhci_hcd and address 4
[ 318.254802] usb 6-1: configuration #1 chosen from 1 choice
[ 318.259737] usb 6-1: SN9C105 PC Camera Controller detected (vid:pid 0x045E:0x00F7)
[ 318.382372] usb 6-1: No supported image sensor detected for this bridge

steve@Dell:~$ lsmod | grep video
video 25104 0
output 11008 1 video
videodev 41344 1 sn9c102
v4l1_compat 22404 1 videodev

steve@Dell:~$ lsusb
Bus 006 Device 004: ID 045e:00f7 Microsoft Corp. LifeCam VX-1000.
Bus 006 Device 003: ID 03f0:1411 Hewlett-Packard PSC 750
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 0644:0200 TEAC Corp.
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 001 Device 003: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical WheelMouse
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

More info
-------------
Mode probe shows that sn9c105, which is required for this webcam is not found

steve@Dell:~$ modprobe -v sn9c105
FATAL: Module sn9c105 not found.

deadite66 (deadite.66) wrote :

really hope this gets fixed.

I can confirm that my webcam no longer works in Intrepid. It did work in Hardy, using kernel module sn9c102. I can supply more info if needed. The webcam is an Ezonics EZ-368. I believe this is the same (or related) issue.

godot (godotcg-launchpad) wrote :

Same problem, with same Webcam (Microsoft VX-1000).

sjhstorm (sjhstorm-sky) on 2008-10-15
description: updated

Mee too. Same problem, with same Webcam (Microsoft VX-1000). :-(
Working (bad) in Hardy, now totally out...

Shinji (thorsten-reichelt) wrote :

I have the same problem. Under Hardy the VX1000 worked not that good as logitech cams (I had a very bad image quality) but now the support for this sensor seems totaly broken :(

Does anyone know if this has to do with gspca? I'm not very knowledgeable about these things, but as I recall with the new kernel, didn't a lot of webcam support switch to gspca. I'm showing that module loaded in Hardy but not in Intrepid. when I try "sudo modprobe gspca" i get "FATAL: Module gspca not found."

Is there something else I can try?

And to reiterate, my webcam works in Hardy (when gspca loads automatically) but not in Intrepid, where gspca does not load.

Me too, I had great expectations upgrading to 8.10, but it seems that this webcam in unusable!

dsvilko (dsvilko) wrote :

I've got the same problem with the Microsoft VX-3000. Worked perfectly on Hardy. What's going on here?

uname -a:
 Linux Hobbit 2.6.27-7-generic #1 SMP

dmsg:
[ 8650.152362] usb 1-2.2: new full speed USB device using ehci_hcd and address 15
[ 8650.250659] usb 1-2.2: configuration #1 chosen from 1 choice
[ 8650.254913] usb 1-2.2: SN9C105 PC Camera Controller detected (vid:pid 0x045E:0x00F5)
[ 8650.299471] usb 1-2.2: No supported image sensor detected for this bridge

lsusb:
Bus 001 Device 015: ID 045e:00f5 Microsoft Corp. LifeCam VX-3000.

lsmod:
video 25104 0
v4l1_compat 22404 1 videodev
videodev 41344 1 sn9c102
sn9c102 149124 0

Changed in linux:
status: New → Confirmed
Luis Alberto Pabón (copong) wrote :

Same here, working in Hardy, not working in Intrepid...
luis@ordenata:~$ uname -a
Linux ordenata 2.6.27-7-generic #1 SMP Thu Oct 30 04:18:38 UTC 2008 i686 GNU/Linux

dmesg:
[160890.964059] usb 3-1: new full speed USB device using uhci_hcd and address 2
[160891.129755] usb 3-1: configuration #1 chosen from 1 choice
[160892.589965] Linux video capture interface: v2.00
[160892.693791] sn9c102: V4L2 driver for SN9C1xx PC Camera Controllers v1:1.47pre49
[160892.705514] usb 3-1: SN9C120 PC Camera Controller detected (vid:pid 0x0C45:0x613B)
[160892.854083] usb 3-1: No supported image sensor detected for this bridge
[160892.855262] usbcore: registered new interface driver sn9c102

lsusb:
Bus 003 Device 002: ID 0c45:613b Microdia Win2 PC Camera

lsmod:
sn9c102 149124 0
videodev 41344 1 sn9c102
v4l1_compat 22404 1 videodev
video 25104 0

dsvilko (dsvilko) wrote :

Luckily, as I did an upgrade from Hardy, I still have the old kernel (2.6.24-21-generic #1 SMP) installed as a fall-back option. Camera works as before with this kernel.
The difference is that it's loading the 2.6.24-21-generic/ubuntu/media/gspcav1/gspca.ko which no longer exists in the Interpids kernel package. No module in 2.6.27-7-generic/kernel/drivers/media/video/gspca/ can handle my camera (045e:00f5) so the sn9c102 module is loaded which obviously doesn't work. I tried blacklisting that module but then no module is loaded.

Luis Alberto Pabón (copong) wrote :

I knew I should've kept the old kernel for a little bit longer... but webcam I don't use often. I understand there were some big changes in webcam handling between 2.6.24 and 2.6.27, am I right?

sbas (sbas) wrote :

Same problem with vx 3000 after upgrading to intrepid ibex. in hardy the webcam worked.
i hope this bug will fixed as soon as possible :)

crimescene (foschi-e) wrote :

Same problem here please fix this bug soon!

crimescene (foschi-e) wrote :

I've tryed to compile the module........this is the log...

/usr/bin/make -C /usr/src/modules/gspca KERNEL_VERSION=2.6.27-7-generic KERNELDIR=/usr/src/linux-headers-2.6.27-7-generic
make[2]: Entering directory `/usr/src/modules/gspca'
/usr/bin/make -C /usr/src/linux-headers-2.6.27-7-generic SUBDIRS=/usr/src/modules/gspca CC=gcc modules
make[3]: Entering directory `/usr/src/linux-headers-2.6.27-7-generic'
  CC [M] /usr/src/modules/gspca/gspca_core.o
/usr/src/modules/gspca/gspca_core.c:54:27: error: asm/semaphore.h: Nessun file o directory
/usr/src/modules/gspca/gspca_core.c: In function ‘spca5xx_ioctl’:
/usr/src/modules/gspca/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
/usr/src/modules/gspca/gspca_core.c: At top level:
/usr/src/modules/gspca/gspca_core.c:2604: error: ‘v4l_compat_ioctl32’ undeclared here (not in a function)
/usr/src/modules/gspca/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
/usr/src/modules/gspca/gspca_core.c:2609: warning: initialization from incompatible pointer type
/usr/src/modules/gspca/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
/usr/src/modules/gspca/gspca_core.c: In function ‘spca50x_create_sysfs’:
/usr/src/modules/gspca/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
/usr/src/modules/gspca/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
/usr/src/modules/gspca/gspca_core.c: In function ‘spca5xx_probe’:
/usr/src/modules/gspca/gspca_core.c:4301: error: incompatible types in assignment
make[4]: *** [/usr/src/modules/gspca/gspca_core.o] Error 1
make[3]: *** [_module_/usr/src/modules/gspca] Error 2
make[3]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/usr/src/modules/gspca'
make[1]: *** [binary-modules] Error 2
make[1]: Leaving directory `/usr/src/modules/gspca'
make: *** [kdist_build] Error 2

I hope can help to fix

tibike (eusunttibi) wrote :

same here!
vx1000 + intrepid ibex = bleah!
the LED on my cam is always on but no /dev/video0

sbas (sbas) wrote :

also my vx 3000 has the led always on but no /dev/video0
i see that the bug is not assigned :(

bigwullie (william-pearson3) wrote :

Same problem with Microsoft VX-1000. Hope there is soon a fix.
This http://ph.ubuntuforums.com/showthread.php?s=2fbb3721c0a8ed9fdc319613a4ff0ae1&t=966398
looks like a possible answer. Not brave enough to try it.

As pointed out in:
https://bugs.launchpad.net/bugs/293259

This appears to be a kernel bug (patch available):
http://bugzilla.kernel.org/show_bug.cgi?id=11920

Also, I've been wondering if this bug is a dupe of 260918. My thought is no, since it appears to kernel/hardware and not specifically gspca/application related.

Changed in linux:
status: Unknown → Fix Released
Luis Alberto Pabón (copong) wrote :

Why did you close this bug Jonathan? Has an updated kernel been added to ubuntu's repositories?

Luis Alberto Pabón (copong) wrote :

My mistake, didn't read the header properly.

pgreenland (philip-pgreenland) wrote :

Trying to fix my camera.

Recompiled and installed gspca - when i plug the camera in now i get the following appear in the syslog and the camera appears as /dev/video0 but i still cant use it.

As the system booted:
Nov 14 01:27:45 philip-desk kernel: [ 105.844011] usb 5-1: new full speed USB device using uhci_hcd and address 2
Nov 14 01:27:45 philip-desk kernel: [ 106.058434] usb 5-1: configuration #1 chosen from 1 choice
Nov 14 01:27:45 philip-desk kernel: [ 106.156620] Linux video capture interface: v2.00
Nov 14 01:27:45 philip-desk kernel: [ 106.179276] gspca: main v2.4.0 registered
Nov 14 01:27:45 philip-desk kernel: [ 106.189124] gspca: probing 045e:00f7
Nov 14 01:27:45 philip-desk kernel: [ 106.194040] sonixj: Sonix chip id: 11
Nov 14 01:27:45 philip-desk kernel: [ 106.197137] gspca: probe ok
Nov 14 01:27:45 philip-desk kernel: [ 106.197148] gspca: probing 045e:00f7
Nov 14 01:27:45 philip-desk kernel: [ 106.197157] gspca: probing 045e:00f7
Nov 14 01:27:45 philip-desk kernel: [ 106.197177] usbcore: registered new interface driver sonixj
Nov 14 01:27:45 philip-desk kernel: [ 106.197181] sonixj: registered
Nov 14 01:27:45 philip-desk kernel: [ 106.226397] sn9c102: V4L2 driver for SN9C1xx PC Camera Controllers v1:1.47pre49
Nov 14 01:27:45 philip-desk kernel: [ 106.226447] usbcore: registered new interface driver sn9c102
Nov 14 01:27:45 philip-desk kernel: [ 106.306376] usbcore: registered new interface driver snd-usb-audio

After disconnecting and reconnecting camera:
Nov 14 01:45:02 philip-desk kernel: [ 1143.304021] usb 5-1: new full speed USB device using uhci_hcd and address 5
Nov 14 01:45:03 philip-desk kernel: [ 1143.518196] usb 5-1: configuration #1 chosen from 1 choice
Nov 14 01:45:03 philip-desk kernel: [ 1143.521111] gspca: probing 045e:00f7
Nov 14 01:45:03 philip-desk kernel: [ 1143.526054] sonixj: Sonix chip id: 11
Nov 14 01:45:03 philip-desk kernel: [ 1143.529234] gspca: probe ok
Nov 14 01:45:03 philip-desk kernel: [ 1143.529271] gspca: probing 045e:00f7

If i try to view the camera from vlc as either a V4L or a V4L2 device the light comes on and i either get a messed up cube of colour or no image at all.

Any ideas?

Lucio Crusca (lucrus) wrote :

Sorry for placing trivial questions (maybe trivial for others, not for me), but what exactly is the solution? Should I recompile the kernel and remove the sn9c102 driver?

peddy (peddy22) wrote :

Confirmed on 64-bit Hardy with 2.6.27-6 kernel.

Krzysztof N. (krzych-nowak) wrote :

I've got same problem with Intrepid and Microsoft vx1000, what is the solution ?

Lucio Crusca (lucrus) wrote :

Sorry for asking again, but does "Fix Released" mean that there already exists a solution?

pgreenland (philip-pgreenland) wrote :

Hi,

I've been in contact with the developer / maintainer of the gspca driver used by the Microsoft VX-1000.

We have been exchanging emails for a while, he has been extremely helpful and has released a fixed version of the driver which can be found at: http://linuxtv.org/hg/~jfrancois/gspca/

To my knowledge and from the information provided to me by Jean-Francois Moine this driver is what is included in the kernel and due to a bug the camera isn't being initialised correctly.

To solve this problem:

1. Download the latest release of the driver from the above address (its the bz2 or gz link at the top)
2. run make config and disable the SN9C102 driver (USB_SN9C102) - although this may not be necessary?
3. run make
4. if the drivers were built successfully start the os with the camera disconnected to prevent the old modules from loading (again this may not be neccessary)
5. run sudo make install
6. Connect the camera and test with an application such as cheese or vlc.

Upon connection the system messages log should show something similar:

Nov 22 18:25:38 philip-desk kernel: [44058.288046] usb 5-1: new full speed USB device using uhci_hcd and address 5
Nov 22 18:25:38 philip-desk kernel: [44058.446370] usb 5-1: configuration #1 chosen from 1 choice
Nov 22 18:25:38 philip-desk kernel: [44058.449279] gspca: probing 045e:00f7
Nov 22 18:25:38 philip-desk kernel: [44058.454234] sonixj: Sonix chip id: 11
Nov 22 18:25:38 philip-desk kernel: [44058.458785] gspca: probe ok
Nov 22 18:25:38 philip-desk kernel: [44058.459112] gspca: probing 045e:00f7
Nov 22 18:25:38 philip-desk pulseaudio[6376]: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 16000 Hz.
Nov 22 18:25:38 philip-desk pulseaudio[6376]: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.

NB: for some video applications to function it may be necessary to execute them using the following in a terminal window
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

The above example loads skype after pre loading the v4l compatibility? library.

However for test purposed cheese definitely works without having to use the above method.

I haven't been using Linux for long but would like to try to help (especially because I have a Microsoft VX-1000 with wasn't but now is working) and do apologise if some of my terminology is wrong, please correct me on any mistakes or if there is better way to go about doing some of the things above.

Hope this helps,

Phil

Krzysztof N. (krzych-nowak) wrote :

Thank You very much Phil,

For me it was enough to just run make, sudo make install.
Chese detected camera without any additional steps, for skype i used:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

Now everything works fine

pgreenland (philip-pgreenland) wrote :

Hi,

That's great news Krzysztof, just wondering - is the sound working ok on you're webcam?

I'm having a few issues with mine, haven't decided whether its something I've done while trying to get it to work or something to do with alsa.

Thanks,

Phil

Krzysztof N. (krzych-nowak) wrote :

Hi,

I've just tested it with Cheese and it works,
I've double clicked on Volume control icon and chosen USB Camera (Alsa mixer).

But, it is possible that my sound setting are not 'default'. When i installed Ubuntu i had problems with sound in Skype, so i had found some commands to run in shell and executed them. (sorry for 'some' but I've started using linux couple days ago)

I've the same problem and when I want to fix it with the tip of Phil, I have :

alex@alex-desktop:~/.local/share/Trash/files/gspcav1-20071224$ sudo make config
make: *** Pas de règle pour fabriquer la cible « config ». Arrêt.
alex@alex-desktop:~/.local/share/Trash/files/gspcav1-20071224$ make
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/alex/.local/share/Trash/files/gspcav1-20071224 CC=cc modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.27-7-generic »
  CC [M] /home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.o
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: Aucun fichier ou dossier de ce type
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:2463: erreur: implicit declaration of function ‘video_usercopy’
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c: Hors de toute fonction :
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:2609: erreur: unknown field ‘owner’ specified in initializer
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:2609: attention : initialization from incompatible pointer type
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:2611: erreur: unknown field ‘type’ specified in initializer
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:2769: erreur: implicit declaration of function ‘video_device_create_file’
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:2780: erreur: implicit declaration of function ‘video_device_remove_file’
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:4301: erreur: incompatible types in assignment
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c: Hors de toute fonction :
/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.c:4407: erreur fatale: ouverture du fichier de dépendances /home/alex/.local/share/Trash/files/gspcav1-20071224/.gspca_core.o.d: Permission non accordée
compilation terminée.
make[2]: *** [/home/alex/.local/share/Trash/files/gspcav1-20071224/gspca_core.o] Erreur 1
make[1]: *** [_module_/home/alex/.local/share/Trash/files/gspcav1-20071224] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.27-7-generic »
make: *** [default] Erreur 2

pgreenland (philip-pgreenland) wrote :

Hi Alex,

It looks like you may be attempting to compile an older version of the gspca driver and the compiler can no longer find asm/semaphore.h.

You will almost certainly want to download the latest release of the gspca driver which should be available here:

http://linuxtv.org/hg/~jfrancois/gspca/archive/tip.tar.bz2

Thanks,

Phil

sjhstorm (sjhstorm-sky) wrote :

Where I had microphone but no video, after compiling new driver I now have video but no microphone. This is back to the situation I had under Hardy 8.04.

Does anyone have both video and microphone working on their VX1000 ?

Steve

crimescene (foschi-e) wrote :

I confirm that the last relase of the new driver work fine for me also with the new kernel relase 2.7.27-10-generic x86_64 version with Philips SPC 900NC.
The webcam work fine on cheese, ekiga, skype, but iì've an error on camorama.

pgreenland (philip-pgreenland) wrote :

Hey Steve,

I've had exactly the same problem, seems that the old driver supported the audio but not the video - now the new one supports the video and not the audio.

I've let the developer know.

We'll see what he says.

Phil

Mike (farlo144) wrote :

Anyone have an idea when the 2.7.27-10-generic kernel will be released? Is there a patch for the 2.7.27-9-generic kernel (i.e. the kernel currently shipping with 8.10)? Seems like a far-stretch to call this bug fixed when the currently shipping version of the kernel is still broken.

On Sat, Dec 13, 2008 at 04:54:50PM -0000, Mike wrote:
> Anyone have an idea when the 2.7.27-10-generic kernel will be released?
> Is there a patch for the 2.7.27-9-generic kernel (i.e. the kernel
> currently shipping with 8.10)? Seems like a far-stretch to call this
> bug fixed when the currently shipping version of the kernel is still
> broken.

The -10 kernel is in -proposed. You can ask for that to be included and
installed via update-manager. The kernel in -proposed should move to
-updates relativly soon.

Thanks for the info Andy. If I get really antsy, I'll force the -10 install.

sjhstorm (sjhstorm-sky) wrote :

I am using the -10 kernel and you will still have to install the patch, I am surprised that this has not been patched by Kubuntu yet.

Mike (farlo144) wrote :

Thanks sjhstorm. Yesterday when I tried to download the patch above, the link was dead. Today it was alive, and now my webcam is working! I'm still using the -9 kernel. Big thanks to everyone!

Andres Mujica (andres.mujica) wrote :

Hi i've marked some dupes from this bug report.

Thanks

Andy Whitcroft (apw) on 2008-12-15
Changed in linux:
assignee: nobody → apw
status: Confirmed → In Progress
Andy Whitcroft (apw) wrote :

I have built test kernels against the latest -11 kernel containing a backport of the patches for this device. They can be found at the URL below:

    http://people.ubuntu.com/~apw/webcams1/

Please test and report back. This fix is only for the 045e:00f7 device.

Hi I have loaded the three deb files into my machine it did create a /dev/video0 file but the out put is green static. as well now the mike stop working. This was working before the patch.

Please see attachment. I am trying to set up this box as a gift for Xmas, I know it is not your problem but I will truly appreciate it if you can help me.

Thanks.

KWolf (arctos) wrote :

As of 2.6.27-10 the bug is still present with my VX-3000. Yes, this bug affects the VX-3000 as well as the VX-1000 in case the devs weren't sure.

Following the instructions given by pgreenland above resolved the issue (fwiw, I did not have to disable the driver he mentioned during installation). I'm going to be sad if I have to keep recompiling the drivers for each new kernel though.

When will there be a kernel with the newer drivers for the VX-1000 and VX-3000 webcams already included?

Andres Mujica (andres.mujica) wrote :

Hi would it be possible for the reporters to test the linux-image packages created by Andy . Please note there are for 386 and 64bits arch.

Also is possible that you need to LD_PRELOAD libv4l and it's strongly recommended that you test with libv4l-0.5.7 available in proposed repos.

Thanks!

Andy Whitcroft (apw) wrote :

There was little response to my previous call for testing. I have therefore rebased these patches onto the latest -proposed kernel and build some updates test kernels. If those of you who are able could test the kernels at the URL below and report back that would be very helpful:

    http://people.ubuntu.com/~apw/webcams1/

NOTE: these are updated images based on the new Inprepid kernels, as compared to the ones in my previous call for testing.

sjhstorm (sjhstorm-sky) wrote :

@Andy Whitcroft

I have installed your patched 32 bit kernel as above, (with libv4l-0.5.7) and have unsuccessfully tested on skype and cheese, see below output.

steve@Dell:~$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese
libv4l2: error dequeuing buf: Input/output error
libv4l2: error dequeuing buf: Input/output error

(cheese:7035): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(cheese:7035): GStreamer-CRITICAL **: gst_object_unref: assertion `object != NULL' failed

(cheese:7035): GStreamer-CRITICAL **: gst_object_unref: assertion `object != NULL' failed
steve@Dell:~$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Starting the process...
Skype Xv: Xv ports available: 64
Skype XShm: XShm support enabled
Skype Xv: Using Xv port 355
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
steve@Dell:~$

It's also worth noting as per my earlier post where I applied the patch to 2.6.27-10, which the camera worked but the built in microphone stopped working, the microphone doe's not work with your patched kernel.

Hope this helps

Steve

I am still seeing this on SN9C102 on Jaunty in Virtualbox. I would test the patches above in Intrepid, but I do not have the proper hardware.

I just wanted to say that I may have made a little bit of progress with this. I was playing around with loading/unloading different kernel modules to see if it affected anything. It appears to be kind of flaky, but I'm able to get it to detect my sensor sometimes. For this, I did:
sudo modprobe gspca_sonixj
sudo rmmod gspca_sonixj

This leaves gspca_main on, but not gspca_sonixj. Unfortunately, I don't think it was working with just loading gspca_main.
Here's a little more info from dmesg:

[24427.409166] usb 2-1: USB disconnect, address 5
[24431.700197] usb 2-1: new full speed USB device using uhci_hcd and address 6
[24431.857444] usb 2-1: configuration #1 chosen from 1 choice
[24431.944081] sn9c102: V4L2 driver for SN9C1xx PC Camera Controllers v1:1.47pre49
[24431.946202] usb 2-1: SN9C120 PC Camera Controller detected (vid:pid 0x0C45:0x613C)
[24432.070179] usb 2-1: No supported image sensor detected for this bridge
[24432.070216] usbcore: registered new interface driver sn9c102
[24701.273384] gspca: main v2.2.0 registered
[24701.287301] usbcore: registered new interface driver sonixj
[24701.287315] sonixj: registered
[24704.920119] usb 2-1: USB disconnect, address 6
[24711.732136] usb 2-1: new full speed USB device using uhci_hcd and address 7
[24711.891428] usb 2-1: configuration #1 chosen from 1 choice
[24711.896186] usb 2-1: SN9C120 PC Camera Controller detected (vid:pid 0x0C45:0x613C)
[24712.047202] usb 2-1: No supported image sensor detected for this bridge
[24764.729937] usbcore: deregistering interface driver sonixj
[24764.733141] sonixj: deregistered
[24766.424141] usb 2-1: USB disconnect, address 7
[24772.397129] usb 2-1: new full speed USB device using uhci_hcd and address 8
[24772.552444] usb 2-1: configuration #1 chosen from 1 choice
[24772.558177] usb 2-1: SN9C120 PC Camera Controller detected (vid:pid 0x0C45:0x613C)
[24772.614152] usb 2-1: HV7131R image sensor detected
[24772.936189] usb 2-1: Initialization succeeded
[24772.940713] usb 2-1: V4L2 device registered as /dev/video0
[24772.940724] usb 2-1: Optional device control through 'sysfs' interface disabled

jonathan@jonathan-ubuntu:~$ lsmod | grep gspca
gspca_main 33536 0
compat_ioctl32 18304 2 gspca_main,sn9c102
videodev 46720 3 gspca_main,sn9c102,compat_ioctl32
usbcore 175888 6 gspca_main,sn9c102,btusb,uhci_hcd,ehci_hcd

Previously, that command didn't bring up anything because gspca wasn't loading at all.

Unfortunately even though the sensor is detected, I can't get any apps to recognize it. Cheese and Ekiga both just hang like they're trying to use it, but can't. I also tried using the LD_PRELOAD stuff, but that didn't seem to help. So I'm thinking this is just a waste of time, but I thought I'd offer it up just in case anyone can make more sense of it than I can.

Also, I tried loading a few other modules, like gspca_sonixb, without much luck. If anyone has any other suggestions for things to try, I'll do it!

I finally got my webcam working this afternoon with a little help from the gspca dev. Basically, I just needed to install the latest version of gspca correctly from http://linuxtv.org/hg/~jfrancois/gspca/archive/tip.tar.gz . I checked that my sensor was supported here: http://moinejf.free.fr/webcam.html . I also had to blacklist the module that was loading incorrectly (sn9c102). If anyone wants more info on any of that, I'd be happy to help you out if I can. I hope that these gspca fixes can be brought in to Jaunty!

Andres Mujica (andres.mujica) wrote :

hmm, and about testing the Andy's kernel anyone can share the result?

sadly is a bit old now.

At this time there's a -12 proposed kernel, it would be worthwhile test it too.

Thanks

kotoroshinoto (mgooch) wrote :

it seemed that most of the make went off without a problem, but near the end this happened.

/home/michael/Desktop/gspca-7e51b9a19860/v4l/fdump "/usr/lib/hotplug/firmware/dvb-ttpci-01.fw" dvb_ttpci_fw /home/michael/Desktop/gspca-7e51b9a19860/v4l/av7110_firm.h
firmware file '/usr/lib/hotplug/firmware/dvb-ttpci-01.fw' not found
make[3]: *** [/home/michael/Desktop/gspca-7e51b9a19860/v4l/av7110_firm.h] Error 255
make[2]: *** [_module_/home/michael/Desktop/gspca-7e51b9a19860/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.27-11-generic'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/michael/Desktop/gspca-7e51b9a19860/v4l'
make: *** [all] Error 2

do I need to download, disable, or install something else first?

kotoroshinoto (mgooch) wrote :

Fixed it by changing from the default to the following:
/lib/firmware/dvb-ttpci-01.fw
There are now several warnings about some things not being string literals and not being arguments or something, but the make seems to be working, takes a long time.

kotoroshinoto (mgooch) wrote :

well the make install command completed without an error, but when I restart the cam still doesnt work for any programs even with the preload command.

Vince Forgetta (forgetta) wrote :

So close yet so far ... is there a fix yet to get both audio and video working? Thanks.

zerwas (zerwas) wrote :

Regarding 045e:00f5 Microsoft Corp. LifeCam VX-3000:
Webcam still does not work in Ubuntu Jaunty with kernel 2.6.28-11.37 because it does not contain the newest gspca.

Marc Cheng (bdgraue) wrote :

problems here, too

kubuntu jaunty with latest updates

camera(lsusb):
Bus 002 Device 004: ID 0c45:613c Microdia PC Camera (SN9C120)

kernel:
2.6.28-11-generic_2.6.28-11.37_amd64

dmesg:
[ 2051.873753] usb 1-4.3: reset high speed USB device using ehci_hcd and address 5
[ 2516.940547] usb 2-5: new full speed USB device using ohci_hcd and address 4
[ 2517.150141] usb 2-5: configuration #1 chosen from 1 choice
[ 2517.187734] Linux video capture interface: v2.00
[ 2517.190109] sn9c102: V4L2 driver for SN9C1xx PC Camera Controllers v1:1.47pre49
[ 2517.192051] usb 2-5: SN9C120 PC Camera Controller detected (vid:pid 0x0C45:0x613C)
[ 2517.273046] usb 2-5: HV7131R image sensor detected
[ 2518.239088] usb 2-5: Initialization succeeded
[ 2518.239230] usb 2-5: V4L2 device registered as /dev/video0
[ 2518.239235] usb 2-5: Optional device control through 'sysfs' interface disabled
[ 2518.239280] usbcore: registered new interface driver sn9c102
[ 2518.302589] usb 2-5: usb_submit_urb() failed, error -28

compiling the gspca-source with module-assistant failed

last time i remember that my camera was working, has been with gutsy or hardy.

Isak Frants (isakfrants) wrote :

Please fix this as soon as possible. If not in both Intrepid and Jaunty please make it work in at least Jaunty. It seems to me that different solutions, patches and so on already exist but for the non geek person this is a little bit complicated. Please fix this so that people with affected webcameras can have their camera working out of the box.

Somewhat sad that a kernel which should have had a better support for webcams simply makes ones camera unusable and the problem just keep existing month after month :/

Andres Mujica (andres.mujica) wrote :

The patch V4L/DVB (9711): gspca: Let gspca handle the webcams 045e:00f5 & 00f7 instead of sn9c102, probably address this issue.

http://lkml.org/lkml/2008/12/30/87

The commit is still at Mauro's git.

http://git.kernel.org/?p=linux/kernel/git/mchehab/linux-2.6.git;a=commit;h=a08d81af37b3d7547813219da68c3c946f742fb3

I'm attaching the diffs.

Andres Mujica (andres.mujica) wrote :
Isak Frants (isakfrants) wrote :

I installed kernel v2.6.29.1 i386 from http://kernel.ubuntu.com/~kernel-ppa/mainline/ and that made the webcam available in wxCam, emesene and Cheese. Skype though shows just some green pixels. Camorama doesn't work either but that doesn't really matter.

Download full text (4.9 KiB)

I try to use the Microsoft Corp. LifeCam VX-1000 in Jaunty AMD64 but have same problem:

root@area51:~# dmesg | grep Camera
[ 16.818571] sn9c102: V4L2 driver for SN9C1xx PC Camera Controllers v1:1.47pre49
[ 16.819480] usb 3-2: SN9C105 PC Camera Controller detected (vid:pid 0x045E:0x00F7)
root@area51:~# dmesg | grep 'usb 3-2'
[ 8.830277] usb 3-2: new full speed USB device using ohci_hcd and address 3
[ 9.008866] usb 3-2: configuration #1 chosen from 1 choice
[ 16.819480] usb 3-2: SN9C105 PC Camera Controller detected (vid:pid 0x045E:0x00F7)
[ 17.071773] usb 3-2: No supported image sensor detected for this bridge
root@area51:~# modprobe -v sn9c105
FATAL: Module sn9c105 not found.
root@area51:~# lsmod | grep gspca
root@area51:~# lsusb | grep VX-1000
Bus 003 Device 003: ID 045e:00f7 Microsoft Corp. LifeCam VX-1000.
root@area51:~#

I try make the gspca module:

root@area51:~# m-a auto-install gspca

Informações sobre 1 pacotes atualizadas
Getting source for kernel version: 2.6.28-11-server
Cabeçalhos de kernel disponíveis em /usr/src/linux
Criando ligação simbólica ...
Não foi possível criar a ligação simbólica /usr/src/linux !
apt-get install build-essential
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
build-essential já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Feito !
unpack
Extracting the package tarball, /usr/src/gspca.tar.bz2, please wait...
"/usr/share/modass/overrides/gspca-source" build KVERS=2.6.28-11-server KSRC=/usr/src/linux-headers-2.6.28-11-server KDREV=2.6.28-11.42 kdist_image

root@area51:~# cat /var/cache/modass/gspca-source.buildlog.2.6.28-11-server.1241644949
dh_testdir
dh_testroot
dh_clean
/usr/bin/make -C /usr/src/modules/gspca clean
make[1]: Entrando no diretório `/usr/src/modules/gspca'
rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \
 .gspca.o.cmd *.o *.ko *.mod.* .[a-z]* core *.i \
 *.symvers *.err
make[1]: Saindo do diretório `/usr/src/modules/gspca'
/usr/bin/make -f debian/rules kdist_clean kdist_config binary-modules
make[1]: Entrando no diretório `/usr/src/modules/gspca'
dh_testdir
dh_testroot
dh_clean
/usr/bin/make -C /usr/src/modules/gspca clean
make[2]: Entrando no diretório `/usr/src/modules/gspca'
rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \
 .gspca.o.cmd *.o *.ko *.mod.* .[a-z]* core *.i \
 *.symvers *.err
make[2]: Saindo do diretório `/usr/src/modules/gspca'
for templ in ; do \
    cp $templ `echo $templ | sed -e 's/_KVERS_/2.6.28-11-server/g'` ; \
  done
for templ in `ls debian/*.modules.in` ; do \
    test -e ${templ%.modules.in}.backup || cp ${templ%.modules.in} ${templ%.modules.in}.backup 2>/dev/null || true; \
    sed -e 's/##KVERS##/2.6.28-11-server/g ;s/#KVERS#/2.6.28-11-server/g ; s/_KVERS_/2.6.28-11-server/g ; s/##KDREV##/2.6.28-11.42/g ; s/#KDREV#/2.6.28-11.42/g ; s/_KDREV_/2.6.28-11.42/g ' < $templ > ${templ%.modules.in}; \
  done
dh_testdir
dh_testroot
dh_clean -k
# Build the module
/usr/bin/make -C /usr/src/modules/gspca KERNEL_VERSION=2.6.28-11-server KERNELDIR=/usr/src/linux-headers-2.6.28-11-server
make[2]: Entrando no...

Read more...

niknah (hankin0) wrote :

I have a vx3000
I just upgraded to linux-image-2.6.30-020630rc5-generic_2.6.30-020630rc5_i386
from http://kernel.ubuntu.com/~kernel-ppa/mainline/

Skype just shows random static pixels, camorama returned "unable to capture image", 'cheese' worked, and 'motion' worked. But the microphone didn't work for me in skype & audicity.

According to amazon the vx3000 is the 2nd best selling camera there...

http://www.amazon.com/s/qid=1242574919/ref=sr_st?keywords=webcam&rs=172282&page=1&bbn=172282&rh=n%3A172282%2Cn%3A!493964%2Ck%3Awebcam&sort=pmrank

Uter (shaggyott) wrote :

Hi i am using Jaunty 64 bit with 2.6.28-11-generic kernel.

My Webcam VX3000 doesn't work anymore in this Version, I am already tried all of you tipps but nothing works for me. The only Thing that I get is a green screen.

Are there any plans to fix this bug ?

cheers,
uter ;)

mizu12 (mizu12) wrote :

I can confirm the Microsoft LifeCam VX-1000 works with linux-image-2.6.30-020630 downloaded from http://kernel.ubuntu.com/~kernel-ppa/mainline/

Tested with Skype and Cheese, microphone not tested.

Andres Mujica (andres.mujica) wrote :

The last comment means that this cam should work in Karmic when Alpha 3 is available (we're still at Alpha 2)

@mizu12 can you check with a daily build livecd image?

Isak Frants (isakfrants) wrote :

Why wouldn't it work already with Alpha2 Karmic since this was fixed upstream in 2.6.29 but the fix just wasn't backported to Jaunty 2.6.28 kernel?

mizu12 (mizu12) wrote :

Not working with Karmic! (Yesterday daily-live). Tested with Cheese, Camorama, Motion.

Syslog from Karmic:
Jul 9 07:22:33 ubuntu kernel: [ 294.944114] usb 7-1: new full speed USB device using uhci_hcd and address 2
Jul 9 07:22:33 ubuntu kernel: [ 295.101355] usb 7-1: configuration #1 chosen from 1 choice
Jul 9 07:22:33 ubuntu kernel: [ 295.468412] Linux video capture interface: v2.00
Jul 9 07:22:33 ubuntu kernel: [ 295.598774] gspca: main v2.6.0 registered
Jul 9 07:22:33 ubuntu kernel: [ 295.606010] gspca: probing 045e:00f7
Jul 9 07:22:33 ubuntu kernel: [ 295.610270] sonixj: Sonix chip id: 11
Jul 9 07:22:33 ubuntu kernel: [ 295.612257] gspca: probe ok
Jul 9 07:22:33 ubuntu kernel: [ 295.612278] gspca: probing 045e:00f7
Jul 9 07:22:33 ubuntu kernel: [ 295.612297] gspca: probing 045e:00f7
Jul 9 07:22:33 ubuntu kernel: [ 295.612334] usbcore: registered new interface driver sonixj
Jul 9 07:22:33 ubuntu kernel: [ 295.612340] sonixj: registered
Jul 9 07:22:34 ubuntu kernel: [ 295.852633] usbcore: registered new interface driver snd-usb-audio

Cheese 2.27.3
Linux 2.6.31-2-generic #16-Ubuntu SMP Mon Jul 6 20:38:51 UTC 2009 i686 GNU/Linux

Syslog from Intrepid with 2.6.30 (the same except gspca version):
Jul 9 07:39:51 ubuntu kernel: [ 201.272061] usb 7-1: new full speed USB device using uhci_hcd and address 2
Jul 9 07:39:51 ubuntu kernel: [ 201.431989] usb 7-1: configuration #1 chosen from 1 choice
Jul 9 07:39:51 ubuntu kernel: [ 201.483681] Linux video capture interface: v2.00
Jul 9 07:39:51 ubuntu kernel: [ 201.495390] gspca: main v2.5.0 registered
Jul 9 07:39:51 ubuntu kernel: [ 201.505255] gspca: probing 045e:00f7
Jul 9 07:39:51 ubuntu kernel: [ 201.509864] sonixj: Sonix chip id: 11
Jul 9 07:39:51 ubuntu kernel: [ 201.512930] gspca: probe ok
Jul 9 07:39:51 ubuntu kernel: [ 201.512940] gspca: probing 045e:00f7
Jul 9 07:39:51 ubuntu kernel: [ 201.512948] gspca: probing 045e:00f7
Jul 9 07:39:51 ubuntu kernel: [ 201.512965] usbcore: registered new interface driver sonixj
Jul 9 07:39:51 ubuntu kernel: [ 201.512968] sonixj: registered
Jul 9 07:39:51 ubuntu kernel: [ 201.573150] usbcore: registered new interface driver snd-usb-audio

Cheese 2.26.0
Linux 2.6.30-020630-generic #020630 SMP Wed Jun 10 09:45:40 UTC 2009 i686 GNU/Linux

Marc Cheng (bdgraue) wrote :

works very well with karmic here

lsusb:

Bus 002 Device 004: ID 0c45:613c Microdia PC Camera (SN9C120)

dmesg:

[165348.541848] Linux video capture interface: v2.00
[165348.565461] gspca: main v2.6.0 registered
[165348.567570] gspca: probing 0c45:613c
[165348.578031] sonixj: Sonix chip id: 12
[165348.584089] gspca: probe ok
[165348.584109] usbcore: registered new interface driver sonixj
[165348.584111] sonixj: registered

uname -a:
Linux kristallei 2.6.31-2-generic #16-Ubuntu SMP Mon Jul 6 20:36:55 UTC 2009 x86_64 GNU/Linux

EPx (elvis-pfutzenreuter) wrote :

It is NOT working either with karmic or jaunty now.

Bartosz Wierzejewski (bartekw) wrote :

Damn, how much time we will wait for a resolution?

Isak Frants (isakfrants) wrote :

Nope it just doesn't work anymore. It worked with kernel 2.6.29.x in Jaunty :(
Right now I'm sitting in Karmic Koala daily 12.08.09.

ubuntu@ubuntu:~$ lsusb
Bus 003 Device 002: ID 045e:00f7 Microsoft Corp. LifeCam VX-1000

ubuntu@ubuntu:~$ lsmod | grep video
videodev 36640 1 gspca_main
v4l1_compat 14496 1 videodev
video 19092 1 i915
output 2780 1 video

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.31-5-generic #24-Ubuntu SMP Sat Aug 1 12:48:18 UTC 2009 i686 GNU/Linux

ubuntu@ubuntu:~$ dmesg
[ 27.664296] Linux video capture interface: v2.00
[ 27.685115] gspca: main v2.6.0 registered
[ 27.707073] gspca: probing 045e:00f7
[ 27.724778] sonixj: Sonix chip id: 11
[ 27.732607] gspca: probe ok
[ 27.732619] gspca: probing 045e:00f7
[ 27.732627] gspca: probing 045e:00f7
[ 27.732665] usbcore: registered new interface driver sonixj
[ 27.732668] sonixj: registered

Cheese and emesene latest 1.5-beta show a green big picture :/

Adam Konrád (spam-napalm) wrote :

I'm sitting on a box with vx-1000 and kernel 2.6.31, still green random dots in Skype.

Please fix this!

Isak Frants (isakfrants) wrote :
Download full text (3.9 KiB)

I've used Karmic Beta to play a little bit more with my VX-1000 and I've actually got a couple of images of myself :) Motion works and 1 of 10 (or something) images taken is actually showing my entire face and not just parts of it.
This is in Virtualbox 3.0.6 in a Jaunty host with 2.6.30.5 kernel.
Karmic has got latest gspca compiled and installed. However I had to compile it with "make -i all" since "firedtv-1394.o" had errors and compilation halted. I installed it since without it the camera wasn't working as it should and since a kernel downgrade to 2.6.30.5 didn't help, maybe a newer driver would help.

It looks like Cheese, Skype, vgrabbj and motion initialize the webcamera, the first frame is being captured and drawn but then something happens and the image shown is more or less corrupt. The result varies from 100% Isak to 100% green color.

Cheese, Skype and vgrabbj throw - as shown below - errors. I've tried all programs with the "LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so" switch and at least vgrabbj seems to work better with it.

isak@isak-desktop:~$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffff
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
isak@isak-desktop:~$ cheese
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffff
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ff99
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffff
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 6 more bits
libv4lconvert: Error decompressing JPEG: error: more then 63 AC components (68) in huffman unit
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffff
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffff
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
isak@isak-desktop:~$

Dmesg throws something that looks like this (the digits var...

Read more...

kyleabaker (kyleabaker) wrote :

I'm also having similar trouble getting the Microsoft LifeCam VX-1000 working in Ubuntu 9.10 Karmic x86_64. I can't get anything other than the green screen problem.

I've tried all of the preload options I could find, but none of them seem to work for 64-bit Karmic. Anyone know of a fix for Karmic 64-bit yet?

Vladimir Yakovlev (nagos) wrote :

>kyleabaker I'm also having similar trouble getting the Microsoft LifeCam VX-1000 working in Ubuntu 9.10 Karmic x86_64. I can't get anything other than the green screen problem.

Same problem
Ubuntu 9.10 x86_64, Microsoft LifeCam VX-1000, detected normally
[ 2163.988040] usb 4-2: new full speed USB device using uhci_hcd and address 2
[ 2164.150166] usb 4-2: configuration #1 chosen from 1 choice
[ 2164.197281] Linux video capture interface: v2.00
[ 2164.209611] gspca: main v2.6.0 registered
[ 2164.210897] gspca: probing 045e:00f7
[ 2164.215077] sonixj: Sonix chip id: 11
[ 2164.217132] gspca: probe ok
[ 2164.217143] gspca: probing 045e:00f7
[ 2164.217152] gspca: probing 045e:00f7
[ 2164.217170] usbcore: registered new interface driver sonixj
[ 2164.217173] sonixj: registered
[ 2164.272400] usbcore: registered new interface driver snd-usb-audio
[ 2237.128107] usb 4-2: USB disconnect, address 2
[ 2237.130253] gspca: disconnect complete
[ 2253.840053] usb 7-1: new full speed USB device using uhci_hcd and address 2
[ 2254.058178] usb 7-1: configuration #1 chosen from 1 choice
[ 2254.062236] gspca: probing 045e:00f7
[ 2254.067079] sonixj: Sonix chip id: 11
[ 2254.069144] gspca: probe ok
[ 2254.069218] gspca: probing 045e:00f7

in cheese and mplayer green screen (with some yellow haze), and
"Error decompressing JPEG: unknown huffman code: "

On ubuntu 9.04 with kernel 2.6.30 works good.

Isak Frants (isakfrants) wrote :

OMG! VX-1000 working in Karmic!! Thanks to:
http://www.uluga.ubuntuforums.org/showpost.php?p=8238570&postcount=4

Download http://linuxtv.org/hg/v4l-dvb/archive/tip.tar.bz2 , unpack, cd to directory and
make -i all
sudo make install
reboot

VX-1000 working in Skype and Cheese without any kind of LD_PRELOAD things.

niknah (hankin0) wrote :

I'm still getting random green in skype with this one..
http://linuxtv.org/hg/v4l-dvb/archive/tip.tar.bz2
but at least cheese works now, good resolution. :)

deadite66 (deadite.66) on 2010-03-18
description: updated
Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
David Robert Lewis (afrodeity) wrote :

This driver in Lucid generally works except for Skype.

kyleabaker (kyleabaker) wrote :

> David Robert Lewis: This driver in Lucid generally works except for Skype.

Are you using the Microsoft LifeCam VX-1000 in Ubuntu Lucid 32-bit or 64-bit? I was unable to get the microphone to work in Lucid 64-bit. Now that I'm testing Ubuntu 10.10 64-bit, the microphone works on its own until the video capture is started, in which case the microphone no longer works for that session.

Has anyone successfully gotten the microphone to work while capturing video with this driver and a 64-bit platform? Hardy seems to be the last point that this web cam was properly working.

Discussion for fixing this webcam/driver with latest release: http://ubuntuforums.org/showthread.php?t=1516541

Download full text (3.2 KiB)

I've completely given up on linux and web cam's they don't work and when
they do thy don't work properly.

On Sun, Jul 11, 2010 at 3:26 PM, kyleabaker <email address hidden>wrote:

> > David Robert Lewis: This driver in Lucid generally works except for
> Skype.
>
> Are you using the Microsoft LifeCam VX-1000 in Ubuntu Lucid 32-bit or
> 64-bit? I was unable to get the microphone to work in Lucid 64-bit. Now
> that I'm testing Ubuntu 10.10 64-bit, the microphone works on its own
> until the video capture is started, in which case the microphone no
> longer works for that session.
>
> Has anyone successfully gotten the microphone to work while capturing
> video with this driver and a 64-bit platform? Hardy seems to be the last
> point that this web cam was properly working.
>
> Discussion for fixing this webcam/driver with latest release:
> http://ubuntuforums.org/showthread.php?t=1516541
>
> --
> Intrepid kernel 2.6.27-6 no supported image sensor dected for SN9C105
> (045e, 00f7)
> https://bugs.launchpad.net/bugs/280657
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Fix Released
> Status in “linux” package in Ubuntu: In Progress
>
> Bug description:
> Image sensor not detected for Microsoft VX1000 web cam in kernel 2.6.27-6
> kernel, worked previously in 2.6.26 kernels. This may be an upstream issue
> as I tried Suse 11.1 beta with 2.6.27 kernel and had same issue.
>
> This is what should be detected the image sensor being OV7760.
>
> ( {USB_DEVICE(0x045e, 0x00f7), BSI(SN9C105, OV7660, 0x21)})
>
> My results can be found below:
>
> dmesg - result:
> [ 318.096282] usb 6-1: new full speed USB device using uhci_hcd and
> address 4
> [ 318.254802] usb 6-1: configuration #1 chosen from 1 choice
> [ 318.259737] usb 6-1: SN9C105 PC Camera Controller detected (vid:pid
> 0x045E:0x00F7)
> [ 318.382372] usb 6-1: No supported image sensor detected for this bridge
>
> steve@Dell:~$ lsmod | grep video
> video 25104 0
> output 11008 1 video
> videodev 41344 1 sn9c102
> v4l1_compat 22404 1 videodev
>
> steve@Dell:~$ lsusb
> Bus 006 Device 004: ID 045e:00f7 Microsoft Corp. LifeCam VX-1000.
> Bus 006 Device 003: ID 03f0:1411 Hewlett-Packard PSC 750
> Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 007 Device 002: ID 0644:0200 TEAC Corp.
> Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 004: ID 413c:2003 Dell Computer Corp. Keyboard
> Bus 001 Device 003: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical
> WheelMouse
> Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>
> More info
> -------------
> Mode probe shows that sn9c105, which is required for this webcam is not
> found
>
> steve@Dell:~$ modprobe -v sn9c105
> FATAL: Module sn9c105 not found.
>
>
>
> To unsubscribe from this bug, go to:
> http...

Read more...

Andy Whitcroft (apw) wrote :

The patches enabling this camera appear to have hit mainline as of v2.6.29 which means all releases Karmic and later should support this camera, closing off the development task Fix Released.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
assignee: nobody → Andy Whitcroft (apw)
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.