Comment 0 for bug 280657

Image sensor not detected for Microsoft VX1000 web cam in kernel 2.6.27-6 kernel, worked previously in 2.6.26 kernels. This may be an upstream issue as I tried Suse 11.1 beta with 2.6.27 kernel and had same issue.

This is what should be detected the image sensor being OV7760.

( {USB_DEVICE(0x045e, 0x00f7), BSI(SN9C105, OV7660, 0x21)})

My results can be found below:

dmesg - result:
[ 318.096282] usb 6-1: new full speed USB device using uhci_hcd and address 4
[ 318.254802] usb 6-1: configuration #1 chosen from 1 choice
[ 318.259737] usb 6-1: SN9C105 PC Camera Controller detected (vid:pid 0x045E:0x00F7)
[ 318.382372] usb 6-1: No supported image sensor detected for this bridge

steve@Dell:~$ lsmod | grep video
video 25104 0
output 11008 1 video
videodev 41344 1 sn9c102
v4l1_compat 22404 1 videodev

steve@Dell:~$ lsusb
Bus 006 Device 004: ID 045e:00f7 Microsoft Corp. LifeCam VX-1000.
Bus 006 Device 003: ID 03f0:1411 Hewlett-Packard PSC 750
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 0644:0200 TEAC Corp.
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 001 Device 003: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical WheelMouse
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub