Ubuntu

Low volume, No sound: Intel HDA 82801J (ICH10)

Reported by desertoak on 2008-09-17
86
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Klaas DC
Nominated for Intrepid by Klaas DC

Bug Description

Running Ubuntu 8.10 alpha 5

I get a little sound with low volume in ouput jack on the back.
No sound via optical spdif out.
The soundcard is integrated on motherboard Intel DG45ID.

#lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

#cat /proc/asound/card0/codec#* | grep Codec
Codec: IDT 92HD73E1X5

Mackenzie Morgan (maco.m) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information. Please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

Hew McLachlan (hew) wrote :

"Low volume" and "No sound" appear to be contradictions; could you please clarify your situation? Is it that you are getting sound from the analog output only, and you cannot output via optical spdif out?

Again, please follow the instructions at https://wiki.ubuntu.com/DebuggingSoundProblems and attach the requested information. Thanks in advance.

Changed in linux:
status: New → Incomplete
desertoak (danielc-brikks) wrote :

Ok, i have to clarify this.

I am now running Alpha 6.

I Have a Intel DG45ID motherboard with outputs on the backpanel.
The outputs are aka six-stack (4 analog ouputs, one mic-in and one spdif optical out).
The spdif is connected to a Sony DAV-DZ830W.

On the front-panel on my enclosure i also have one mic-in and one analog out.

I go though Debugging sound problems:

* Is your sound system plugged in and switched on. Yes

* Opened the alsa-mixer. Edit preferences. Unmuted everything. The volume is up. Clicked the "Test"-button in Sound events and music and movies in preferences -> Sounds.
Now the analog sound works :) but still no optical spdif sound.

* Enabled the IEC958 checkbox in the mixer switches and tested every sound server: No spdif sound.

* Checked sound device assignemets:
cat /proc/asound/cards:
0 [Intel ]: HDA-Intel - HDA Intel
                     HDA Intel at 0xff620000 irq 22
I know i have only one sound-card.

* Checking permissions and resources: Allowed my profile to "Use audio devices" No spdif sound.

* Tested different sound servers: No spdif sound.

* Ubuntu sporadically crashes and goes black screen, i have to reebot.

* Executed alsa-info.sh. Here the link: http://www.alsa-project.org/db/?f=19c5e4a69620296e269a8500b562e2089f4ed2ea

I have not tested the spdif audio with other sound than "Test"-button in Sound events and music and movies in preferences -> Sounds.
Now i'm not getting any sound from the spdif out only.

Thanks in advance!

Daniel T Chen (crimsun) wrote :

Can you try model=ref?

desertoak (danielc-brikks) wrote :

Tried adding the line:
options snd-hda-intel model=ref
to
/etc/modprobe.d/alsa-base

Rebooted
Still no spdif output sound.

desertoak (danielc-brikks) wrote :

forgot to say that the hdmi-audio is not working either.

proctor (donovan1-gmail) wrote :

I have the same problem in Alpha 6 with the Intel DG45ID motherboard

ALSA sound works through the analog jacks. However no sound from either the SPDIF Optical or HDMI jacks

alsa-info.sh ouput here: http://www.alsa-project.org/db/?f=11f3b01b74146eed348df6570a0520639f722d03

Hew McLachlan (hew) wrote :

Confirming based on the above comment.

Changed in linux:
importance: Undecided → Medium
status: Incomplete → Confirmed
proctor (donovan1-gmail) wrote :

SPDIF output is working with alsa 1.0.18rc3.

But no audio from the HDMI port.

Klaas DC (klaasdc) wrote :

I have the same problem on my Dell E6500 notebook. I have to crank the volume up to +90% to have something usable out of the headphone connector. I have tried the model=ref parameter but it does not make a difference.

desertoak (danielc-brikks) wrote :

Will this bug be fixed for Ubuntu 8.10 "Intrepid Ibex" final release?

Shawn Ostapuk (flagg) wrote :

I am just chiming in that I have a Dell Studio Slim 540s with the same issue. I have installed ALSA 1.0.18rc3 and have lockups when attempting to unmute the IEC958 device. I was able to successfully unmute the device in 1.0.17, however it had no audible effect.

Andrei (andreiashu) wrote :

Problems on a EG45M-DS2H motherboard with ICH10 with Ubuntu 8.10 with the updates. On the analog jacks sound is "working" but with interrupts and scratches. It isn't usable. I didn't try SPDIF Optical or HDMI jacks.

#lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

#cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC885

alsa-info.sh output: http://www.alsa-project.org/db/?f=93104246e46f4b3e3f063667b506937b5e875e35

Jan Newmarch (jan-newmarch) wrote :

On a Dell Latitude D830 the sound through the audio jack and internal speaker was fine under 8.04 but very low volume under 8.10 alpha 5+ as reported above .

$lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

$cat /proc/asound/card0/codec#* | grep Codec
Codec: SigmaTel STAC9205
Codec: Conexant ID 2c06

Nick (npaulin) wrote :

I have a very similar problem with a snd-hda-intel card. It shows up as HD Nvidia. I found, from another post, that by using a vesa or the nv driver instead of the nvidia driver will "magically" bring back sound (unfortunately while crippling video).

loeppel (loeppel) wrote :

Same Problem with

$ lspci -v
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
 Subsystem: Intel Corporation Device 5002
 Flags: bus master, fast devsel, latency 0, IRQ 22
 Memory at ff620000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

$ head -n 1 /proc/asound/card0/codec*
Codec: IDT 92HD73E1X5

Also my channels are wrong! They totaly mixed up (ie. Front Left and Front Right are not on the same cable).

OS: Ubuntu 8.10 final, fresh install.

Will a alsa upgrade zu rc3 or git help?

loeppel (loeppel) wrote :

Many things seems to be fixed for IDT 92HD73E1X5:

Look at: http://alsa-project.org/main/index.php/Changes_v1.0.17_v1.0.18

Search for IDT.

Any chance to get this into intrepid (maybe backports?).

register88 (johnw-mail) wrote :

------------------------------------------------------
Klaas DC:
I have the same problem on my Dell E6500 notebook. I have to crank the volume up to +90% to have something usable out of the headphone connector. I have tried the model=ref parameter but it does not make a difference.
------------------------------------------------------

I have this problem too, and still have on xubuntu-8.10.
My motherboard is Intel-DG45ID, the sound output/analog is very low volume.
Anyone know how to fix it?
I attached the lspci -v output and dmesg output.
Please help.
Thank you.
I

register88 (johnw-mail) wrote :

I attach dmesg.output again.

Confirming that the digital out isn't working on the Intel-DG45ID mainbord. But i have no problem with low volume on the rear analog out.

http://www.alsa-project.org/db/?f=b2fe084b6412838d83ecb7c13954a3a796a5806f

I updated to ALSA 1.0.19 and the digital out now works on Intel-DG45ID.

Jan Newmarch (jan-newmarch) wrote :

Tested today with Ubuntu 9.04 alpha nightly build on 21/1/09. The problem is still there: very low volume on internal speaker and headphones out.

Sav (saveriop) wrote :

I did some tests on my Dell Studio Slim (inspiron 540st), alc888 codec on inel ich10 chipset.

1) ubuntu 8.10 with the latest upgrades, default kernel, default alsa drivers: no digital output shown with "aplay -L". I can hear sounds only through the analog outputs and only after editing /etc/modprobe.d/alsa-base, inserting "options snd-hda-intel probe_mask=1 model=6stack-dell"

2) I upgraded alsa to the 1.0.19 version: now aplay -L returns:

iec958:CARD=Intel,DEV=0
HDA Intel, ALC888 Digital
IEC958 (S/PDIF) Digital Audio Output

but still no sounds trough spdif

Then I installed jaunty, ran a dist-upgrade and the digital output was recognized with no need to upgrade alsa (1.0.19 isn't in the jaunty repos). Still, no sounds from spdif.

@Magnus Englund
Did you use a particular configuration?

Shang Wu (shangwu) wrote :

Did anyone tried:

edit the/etc/modprobe.d/alsa-base file as root by using the command:

gksudo gedit /etc/modprobe.d/alsa-base

And append the following line to the file

options snd-hda-intel probe_mask=1

Reboot

register88 (johnw-mail) wrote :

Hi Shang Wu, when i append the following line to the "/etc/modprobe.d/alsa-base",
"options snd-hda-intel probe_mask=1"
then no sound anymore.

Sav (saveriop) wrote :

@Shang Wu

the probe_mask option doesn't affect the spdif output

Sav (saveriop) wrote :

I find peace, at last.
With the latest git version of alsa, all works fine (even the spdif output on my dell studio slim).
There is no need to edit alsa-base, too.

teknoprep (cm-rawlings) wrote :

****SOLVED*****

please open a terminal window

type 'alsamixer' and then press enter (without the quote)
goto Front and turn the volume all the way up
you may also have to turn up volume on other items depending on how you connect your devices but for me I had to up the front volume on the Dell XPS m1330.

I am using CrunchBang Linux 8.10 which is Ubuntu 8.10 with OpenBox WM.

Jan Newmarch (jan-newmarch) wrote :

Not solved, sorry. alsamixer v1.0.17 already shows full volume on my Dell Latitude D830 with Ubuntu 8.10, kernel 2.6.27-11-generic, Audio device (from lspci): Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Jan Newmarch (jan-newmarch) wrote :

Maybe solved after all??? A follow up to teknoprep's and my postings today.

Under Ubuntu 8.04 and 8.10 the volume has been really low. alsamixer showed the output as 100%. But I booted today into Ubuntu 9.04 beta, and there, alsamixer showed as only 50% output. When I boosted it to 100%, the sound was back to normal for the first time in 6 months. But odder was when I booted back into 8.10 - the volume was still okay! So it looks like alsa wasn't getting/setting correct values in the Ubuntu 8.X series but is okay in the 9.X series. At least, for me...

Sav (saveriop) wrote :

Update alsa with the latest daily build.
No need for further mods.

Rui Az. (astronomy) wrote :

In a netbook with the following hardware:

 lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Running Jaunty beta I'm facing a similar problem, sound is too low with all the controllers in its maximum.

Sav, which is the latest build you refer to?

Rui Az. (astronomy) wrote :

Ok, I've upgraded to alsa 1.0.19 and I'm still facing low sound. (Netbook Asus EEE 1000HE)

Sav (saveriop) wrote :

Every daily build should be ok.

Craig Keogh (cskeogh) wrote :

Same problem for me. I solved it by:
1. Open up the Volume Control (gnome-volume-control).
2. Click 'Preferences'. Enable Surround, Center, LFE, Side. Click Close.
3. Set Surround, Center, LFE, Side. Click Close to 100%.

The bug (for me) really is Surround, Center, LFE, Side should be 100% by default.

giev (vagelis-giannadakis) wrote :

Craig Keogh above is spot-on!

I had the same problem, although not in Ubuntu, but openSUSE!! My audio was functioning correctly, but at a very low level / volume.

I used the gnome Volume Control's Preferences dialog to select the Front channel and raise to 100%, it was at 50%, which kind of verified the impression I had of my audio. Raising it to 100% restored my audio to normal.

In fact, if you go through all the channels in the list, you'll see that many of them are at 50% by default!

So, this appears to be something ALSA / GNOME related, not to Ubuntu.

Mr.Gronka (mr-gronka) wrote :

Nice Craig!

However, for me, I simply have to drag up on either the PCM or the Front sliders. One or the other or both - doesn't seem to matter. When both are low is when the doesn't work. The options "Surround, Center, LFE, and Side" that Craig mentioned don't show up on my laptop as far as I can tell.

--Ubuntu 9.04 on Dell Latitude D830, Alsa 1.0.18

^rooker (rooker) wrote :

I'm also having the low-audio problem on a Dell Vostro 1320 in Hardy as well as Jaunty with all updates applied (today).
Soundcard according to "lspci -vv" is:
Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Audio output works fine, but really quiet. Additionally, there are *no* inputs shown for that soundcard (but that's another problem).

lspci -nv | grep -A1 0403

Is what will tell if two devices are the same or not. No inputs, though? You
need a quirk. If other folks here have inputs working, then you've got a
different bug.

^rooker (rooker) wrote :

What's the 0403? Seems to be some kind of ID. Anyway, the output of that command returns the following on my machine:

00:1b.0 0403: 8086:293e (rev 03)
        Subsystem: 1028:02bb

I've checked alsamixer and kmix - they're all showing the volume (PCM and Master) as 100%. Maybe it's a different bug, but I find it quite interesting that there are so many Dell notebooks showing similar symptoms. Will dig deeper into this. :)

Mackenzie Morgan (maco.m) wrote :

0403 signifies HDA audio, since lspci -nv doesn't give human-friendly output
but is (AFAIK) the only way to get that Subsystem: line.

Matt Hanyok (matthew-hanyok) wrote :

I also have an Intel DG45ID motherboard and am experiencing the "low volume" problem. After reading this thread I went and enabled all of the various outputs on my volume mixer (surround, center, etc). They were all at 100%.

However, I noticed that raising/lowering the "front" channel sliders had no effect on the volume. I then noticed the "headphone" slider was not at max. This slider seems to control the output for the front channel for me.

I know in the control panel they have for Windows it allows you to specify whether headphones or speakers are connected to this jack. There I have it set for speakers, not headphones, but here I can't find a way to specify. It seems that something has gotten the two switched around.

Also, I've noticed that when raising/lowering the volume sliders in the mixer for headphone and master that the audio falls off VERY quickly. For example, if I set either of them to 50% I get no sound at all. It seem that around 70% or so the audio can barely be heard. Perhaps this is related to my problem of the headphone/front being switched?

This is on 9.04, 64 bit.

Matt Hanyok (matthew-hanyok) wrote :

I just installed 9.10, 64 bit and my volume is functioning normally now.

Can other users confirm?

This chipset appears to still be improperly supported, even in 10.10 beta.

Until I added "options snd-hda-intel model=auto" to /etc/modprobe.d/alsa-base.conf, I only got sound out of the headphones. It appears to work fine after that one change.

Juhani (pentti-j-rautio) wrote :

No sound with this chipset in 10.10 released version.

Just being new in Ubuntu so I must ask what you exatly mean.

My alsa-base.conf looks following. Can I just add it in the options list and how to safely write in read only flies in Ubuntu?

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

Juhani (pentti-j-rautio) wrote :

Added "options snd-hda-intel model=auto" to /etc/modprobe.d/alsa-base.conf without effect.

In synaptic package manager searched with word "alsa" and re-installed everything with connections to alsa. It re-installed over 100MB of pakages.

Now I have sound in my 10.10!

Lee (qq510371827) wrote :

I think the problem is not just appearing on ubuntu distro but also on most distros' latest version. I tried ubuntu 11,debian 6,Fedora 16, linuxmint 12 archlinux etc,and all of them had low volume compared with windows7. The maximum volume is just like whispering especially on those laptops with intel onboard audio. Added "options snd-hda-intel model=auto/dell/laptop/acer/rel/dell-s14/hp-dm42/.../......" to /etc/modprobe.d/alsa-base.conf without effect. All of sliders in "alsamixer" were moved to maximum without effect. Why the bug is still persisting nowadays?

aplay -l
 Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
$cat /proc/asound/card0/codes#0
Codec: IDT 92HD81B1C5

desertoak, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

tags: added: kernel-sound needs-upstream-testing
removed: 82801j hda-intel ich10 sound spdif
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers