Worrying message " ata4: EH pending after 5 tries, giving up" from dmesg

Bug #269652 reported by Andrew on 2008-09-13
46
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Andy Whitcroft
Nominated for Jaunty by Dan Andreșan
Intrepid
Medium
Andy Whitcroft

Bug Description

In 64bit intrepid I find the following messages repeatedly appearing in the kernel ring buffer "ata4: EH pending after 5 tries, giving up" and "ata4: EH complete". The "ata4: EH pending after 5 tries, giving up" message seems to appear during periods of hard disk activity

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
LsUsb:
 Bus 002 Device 002: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Package: linux-image-2.6.27-3-generic 2.6.27-3.4 [modified: lib/modules/2.6.27-3-generic/modules.pcimap lib/modules/2.6.27-3-generic/modules.dep lib/modules/2.6.27-3-generic/modules.ieee1394map lib/modules/2.6.27-3-generic/modules.usbmap lib/modules/2.6.27-3-generic/modules.isapnpmap lib/modules/2.6.27-3-generic/modules.inputmap lib/modules/2.6.27-3-generic/modules.seriomap lib/modules/2.6.27-3-generic/modules.alias lib/modules/2.6.27-3-generic/modules.symbols]
ProcCmdLine: root=UUID=4127621c-1d84-43c1-befe-b2e0fdf1ff4b ro quiet splash
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.27-3.4-generic
SourcePackage: linux

===

SRU Justification

Justification: warning messages may flood the syslog following a suspend

Impact: warnings flood the syslog in response to disk activity

Fix Description: ensure the driver ports are thawed following suspend

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-intrepid.git;a=commit;h=d0d9905864bb51e89f50f73b7aedb4df45d7663a

Risks: this is a driver specific change

TEST CASE: see bug

Related branches

Andrew (fishpie) wrote :
Andrew (fishpie) wrote :

I notice that I do not get these messages when using linux 2.6.27-2-generic.

Dan Andreșan (danyer) wrote :

I get them on i386 too (amd64 processor) so they are not 64bit only

Daniel Hahler (blueyed) on 2008-09-15
Changed in linux:
importance: Undecided → Medium
status: New → Triaged
goto (gotolaunchpad) wrote :

I get them here as well. AMD64, 2.6.27-3, I did not see them prior to updating to this kernel from 2.6.27-2.

robinl (robin4home) wrote :

Can also confirm bug. i386 2.6.27-3, renders my phone unable to connect through USB. Did not have this problem in Hardy.

dninja (dninja) wrote :

Arch linux has worked out what the problem is, see here: http://bugs.archlinux.org/task/11535

waspbr (notaduck) wrote :

got the same problem on a amd32 box after installing intrepid alpha 6. cannot seem to be able to update, everytime I try to write the code 'apt-get update/grade" the error mesages flare up.

Pär Lindfors (paran) wrote :

I have verified this bug using an unpatched mainline linux-2.6 kernel, found the commit causing trouble, and reported the bug upstream.

Changed in linux:
status: Unknown → Confirmed
waspbr (notaduck) wrote :

small correction, I am able to input codes and update, (though that did not solve any problems yet) the bug prints the error message while typing, but it does not interfere with the command itself. Now we play the waiting game.

Dan Andreșan (danyer) wrote :

2.6.27-4-generic did *not* fix the problem

waspbr (notaduck) wrote :

I think this is a xorg related problem, at this point the computer does boot normally, exacept at the GDM screen the monitor turns itself off.

it is still possible to do "CTRL+ALT+F1" to access terminal, there I can at least try to update (successfuly so) where the message above keeps being printed.

I tried using the recovery boot to do a xfix or fix any broken packages, but that doesn't help.

Something was displayed when I tried to copy the xorg.conf of my hardy partition and substituted it into the intrepid one. The X cursor appeared and a dialogue saying that it could not load drivers came up.It asks if I wanted to fix it which I am given the options to reconfigure or to edit the xorg.conf file. None of the options seem to make any difference. Upon restart the same old problem resumes.

I am on a 32bit box with a radeon video card

Mårten Woxberg (maxmc) wrote :

According to the discussion on Arch it's a sata_nv.patch that came into the kernel that causes this.

It's anoying as hell.

Changed in linux:
status: Confirmed → In Progress
Pär Lindfors (paran) wrote :

waspbr:
No, this bug has nothing what so ever to do with Xorg, you should report a separate bug for your xorg problems.

Mårten:
Yes, it was a change in sata_nv that caused the problem. To be more specific it was commit 2fd673ecf0378ddeeeb87b3605e50212e0c0ddc6, as I wrote in my upstream bug report.

For those not following the upstream bug, Tejun Heo have found and fixed the problem. His patch is included in the newly released 2.6.27-rc8, which means that as soon as Ubuntus kernel is rebased on rc8 we will get the fix.

Lars Kumbier (derlars) wrote :

problem still exists in intrepid beta (64bit) from 3rd october

Dan Andreșan (danyer) wrote :

Don't worry, the fix is coming any minute now :)

The new Linux kernel has the fix, it is in the queue, at seems like it was approved to be uploaded in main. Just check Update Manager tonight, they should be there.

To keep you updated, check the freshly uploaded at:
https://launchpad.net/ubuntu/intrepid
and the queue (waiting for approval to be uploaded) at:
https://launchpad.net/ubuntu/intrepid/+queue

Changed in linux:
status: In Progress → Fix Released
Andrew (fishpie) wrote :

bug fixed in 2.6.27-5

Changed in linux:
status: Triaged → Fix Released
pliz (pliz) wrote :

I have a similar problem, can it be that sata_via has the same bug?
Thanks!

Changed in linux:
status: Fix Released → Confirmed
Dan Andreșan (danyer) wrote :

This is back again!!!

Jaunty, latest updates.

[ 87.684043] ata2: EH complete
[ 90.848035] ata2: EH pending after 5 tries, giving up
[ 90.848043] ata2: EH complete
[ 92.409286] ata2: EH pending after 5 tries, giving up

dan@shuttle:~$ apt-cache policy linux-generic
linux-generic:
  Installed: 2.6.28.8.8
  Candidate: 2.6.28.8.8
  Version table:
 *** 2.6.28.8.8 0
        500 http://archive.ubuntu.com jaunty/restricted Packages
        100 /var/lib/dpkg/status

Daniel Hahler (blueyed) wrote :

Re-opening as per last comment.

Changed in linux:
status: Fix Released → Triaged
Dan Andreșan (danyer) wrote :

The bug was reopened upstream and fixed by kernel developers http://bugzilla.kernel.org/show_bug.cgi?id=11615

Please pick up the new patch: libata-thaw-after-reset-skip.patch

Thanks,
Dan.

Changed in linux:
status: Confirmed → Fix Released

This patch is the one attached.

-apw

Changed in linux:
status: Triaged → In Progress
Andy Whitcroft (apw) on 2009-03-05
Changed in linux:
assignee: nobody → apw
Andy Whitcroft (apw) wrote :

I have picked up this patch and applied it to the latest Intrepid kernel. If those of you who are affected by this issue could test these kernels and report back here that would be helpful. The kernels are at the URL below:

    http://people.ubuntu.com/~apw/lp269652-intrepid/

Dan Andreșan (danyer) wrote :

Andy, I know that this bug was fixed for Intrepid 2.6.27 as of version 2.6.27-5 (around 6th of October 2008).
I don't think that it resurfaced in 2.6.27 (Intrepid) (I don't know, I moved to Jaunty).

My message refers to 2.6.28 (Jaunty). It seems that new stuff was introduced in 2.6.28 for nForce 2/3 chipsets which made the fixed bug reappear. From the patch explanation, by Tejun:

"This problem has always been there but is uncovered by recent sata_nv
nf2/3 change which dropped hardreset support while maintaining SCR
access."

I will gladly test an updated 2.6.28 Ubuntu kernel. I already tested vanilla 2.6.28 on the kernel's Bugzilla and Tejun's patch fixed the problem. By the way, it was vanilla, but compiled with Ubuntu's kernel config file.

pliz (pliz) wrote :

It was not fixed for me and I still have to use a custom built kernel using .config from debian.

I will try to test suggested packages later today.

kulight (kulight) wrote :

im also having this problem on jaunty kernel 2.6.28

Andy Whitcroft (apw) wrote :

Ok I have now built some test kernels for Jaunty as well (the intrepid kernels are unchanged).
If those of you who are affected by this issue could test these kernels and report back here that would be helpful. Please report which kernel you tested. The kernels are at the URLs below:

    http://people.ubuntu.com/~apw/lp269652-intrepid/
    http://people.ubuntu.com/~apw/lp269652-jaunty/

kulight (kulight) wrote :

link for jaunty is broken

Andy Whitcroft (apw) wrote :

On Fri, Mar 06, 2009 at 07:21:04PM -0000, kulight wrote:
> link for jaunty is broken

Seems to be working now, must have been syncing still.

Dan Andreșan (danyer) wrote :

Andy, I can no longer see the worrying message with your updated kernel for Jaunty.

Many thanks.

kulight (kulight) wrote :

the messages are gone for now ( andy's amd64 jaunty kernel )

Dan Andreșan (danyer) wrote :

kulight, you are right, I should have specified the architecture: i386

so both i386 and amd64 are tested, message disappeared

kulight (kulight) wrote :

i hope this is not the package that will be released and its only for testing because now i get gui crashes

pliz (pliz) wrote :

Hi Andy, the fix did not work for me on intrepid 32 bit. I am still getting:

[28568.152468] ata6: EH complete
[28580.073047] ata6.00: qc timeout (cmd 0xa0)
[28580.073071] ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[28580.073088] ata6.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
[28580.073091] cdb 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
[28580.073094] res 51/20:03:00:00:00/00:00:00:00:00/a0 Emask 0x5 (timeo
ut)
[28580.073102] ata6.00: status: { DRDY ERR }
[28580.073132] ata6: soft resetting link
[28580.284447] ata6.00: configured for PIO0
[28580.284484] ata6: EH complete

Thanks for trying to repair the bug.

Pliz, please read the bug description. The messages you are seeing are
not related to this bug report and this fix did not attempt to fix
them.

On 3/9/09, pliz <email address hidden> wrote:
> Hi Andy, the fix did not work for me on intrepid 32 bit. I am still
> getting:
>
> [28568.152468] ata6: EH complete
> [28580.073047] ata6.00: qc timeout (cmd 0xa0)
> [28580.073071] ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
> frozen
> [28580.073088] ata6.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
> [28580.073091] cdb 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
> [28580.073094] res 51/20:03:00:00:00/00:00:00:00:00/a0 Emask 0x5
> (timeo
> ut)
> [28580.073102] ata6.00: status: { DRDY ERR }
> [28580.073132] ata6: soft resetting link
> [28580.284447] ata6.00: configured for PIO0
> [28580.284484] ata6: EH complete
>
> Thanks for trying to repair the bug.
>
> --
> Worrying message " ata4: EH pending after 5 tries, giving up" from dmesg
> https://bugs.launchpad.net/bugs/269652
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Fix Released
> Status in “linux” source package in Ubuntu: In Progress
> Status in linux in Ubuntu Intrepid: New
>
> Bug description:
> In 64bit intrepid I find the following messages repeatedly appearing in the
> kernel ring buffer "ata4: EH pending after 5 tries, giving up" and "ata4: EH
> complete". The "ata4: EH pending after 5 tries, giving up" message seems to
> appear during periods of hard disk activity
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 8.10
> LsUsb:
> Bus 002 Device 002: ID 148f:2573 Ralink Technology, Corp. RT2501USB
> Wireless Adapter
> Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Package: linux-image-2.6.27-3-generic 2.6.27-3.4 [modified:
> lib/modules/2.6.27-3-generic/modules.pcimap
> lib/modules/2.6.27-3-generic/modules.dep
> lib/modules/2.6.27-3-generic/modules.ieee1394map
> lib/modules/2.6.27-3-generic/modules.usbmap
> lib/modules/2.6.27-3-generic/modules.isapnpmap
> lib/modules/2.6.27-3-generic/modules.inputmap
> lib/modules/2.6.27-3-generic/modules.seriomap
> lib/modules/2.6.27-3-generic/modules.alias
> lib/modules/2.6.27-3-generic/modules.symbols]
> ProcCmdLine: root=UUID=4127621c-1d84-43c1-befe-b2e0fdf1ff4b ro quiet splash
> ProcEnviron:
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.27-3.4-generic
> SourcePackage: linux
>

--
Sent from my mobile device

Linux is not for everyone. Neither are computers.

kulight (kulight) wrote :

" Linux is not for everyone. Neither are computers. "

but it should be!!!! (open a new bug ?)

Dan Andreșan (danyer) wrote :

Sorry, I did not intend to write that thing. This is my signature and it just appeared there because I replied to the bug notification in email program, instead of typing the response in this web page. I was in the metro, using Gmail Mobile and just hit reply. Sorry, I didn't want to offend anyone.

kulight (kulight) wrote :

no taken i should of added :-)

i kind of funny to see that kind of message in a bug report

Andy Whitcroft (apw) on 2009-03-10
Changed in linux:
importance: Undecided → Medium
status: New → In Progress
Dan Andreșan (danyer) wrote :

Newly updated official kernel, error still persists:

[ 347.060057] ata2: EH pending after 5 tries, giving up
[ 347.060065] ata2: EH complete
[ 347.736035] ata2: EH complete
[ 349.624043] ata2: EH complete
[ 350.700042] ata2: EH complete
[ 351.936042] ata2: EH complete

dan@shuttle:~$ uname -a
Linux shuttle 2.6.28-9-generic #29-Ubuntu SMP Sun Mar 8 02:03:17 UTC 2009 i686 GNU/Linux

dan@shuttle:~$ apt-cache policy linux-generic
linux-generic:
  Installed: 2.6.28.9.9
  Candidate: 2.6.28.9.9
  Version table:
 *** 2.6.28.9.9 0
        500 http://archive.ubuntu.com jaunty/restricted Packages
        100 /var/lib/dpkg/status

Seems like Andy's fix didn't get into this update.

kulight (kulight) wrote :

error continues after kernel update

uname -a
Linux kulight-desktop 2.6.28-9-generic #31-Ubuntu SMP Wed Mar 11 15:43:49 UTC 2009 x86_64 GNU/Linux

quote from kernel log

Mar 11 22:36:06 kulight-desktop kernel: [ 239.064080] ata3: EH pending after 5 tries, giving up
Mar 11 22:36:06 kulight-desktop kernel: [ 239.064085] ata3: EH complete
Mar 11 22:36:06 kulight-desktop kernel: [ 239.152029] ata4: EH pending after 5 tries, giving up
Mar 11 22:36:06 kulight-desktop kernel: [ 239.152034] ata4: EH complete
Mar 11 22:36:07 kulight-desktop kernel: [ 240.628026] ata3: EH pending after 5 tries, giving up
Mar 11 22:36:07 kulight-desktop kernel: [ 240.628030] ata3: EH complete
Mar 11 22:36:08 kulight-desktop kernel: [ 240.716023] ata4: EH pending after 5 tries, giving up
Mar 11 22:36:08 kulight-desktop kernel: [ 240.716027] ata4: EH complete

Dan Andreșan (danyer) wrote :

I was notified that the fix was added in the queue for the mainline kernel, 2.6.27 and 2.6.28.
So, at the next kernel update from kernel.org, the fix should be in.

Andy, just monitor the bug, no need to do anything now.

Andy Whitcroft (apw) on 2009-03-16
Changed in linux:
status: In Progress → Fix Committed
assignee: nobody → apw
Andy Whitcroft (apw) on 2009-03-16
Changed in linux:
status: In Progress → Fix Committed
Andy Whitcroft (apw) on 2009-03-16
description: updated
kulight (kulight) wrote :

one more kernel upgrade and the bug is still here

desktop:~$ uname -a
Linux kulight-desktop 2.6.28-10-generic #32-Ubuntu SMP Mon Mar 16 02:48:55 UTC 2009 x86_64 GNU/Linux

Dan Andreșan (danyer) wrote :

It will disappear after the official kernel upgrade (at kernel.org). Now, it is at 2.6.28.7 released on 20th of February.
Ubuntu kernel is based on this 2.6.28.7 (the fact that it is called 2.6.28-10 does not matter)

There is no need to patch it now, since the official update will fix the bug anyway and it will appear in time for Jaunty.
Otherwise, if the official kernel is not updated in time, I'm pretty sure that Andy will patch the Ubuntu's kernel.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-10.33

---------------
linux (2.6.28-10.33) jaunty; urgency=low

  [ Scott James Remnant ]

  * SAUCE: nbd: Change default partitions per device to 15
    - LP: #342563

  [ Tejun Heo ]

  * SAUCE: libata: make sure port is thawed when skipping resets
    - LP: #269652

  [ Tim Gardner ]

  * Revert "SAUCE: Auto-load esp module when device opened."
    This driver performs unsafe ISA probes (according to Alan Cox).
  * Enable CONFIG_USB_GADGET_DUMMY_HCD
    This facilitates gadget slave endpoints in virtual environments.
  * Build ehci, uhci, and ohci into the i386/amd64 kernels
    - LP: #296710

  [ Upstream Kernel Changes ]

  * Add "thumbee" to the hwcap_str array
    - LP: #343602
  * Add HWCAP_NEON to the ARM hwcap.h file
    - LP: #343602
  * x86: mtrr: don't modify RdDram/WrDram bits of fixed MTRRs
    - LP: #292619

 -- Tim Gardner <email address hidden> Mon, 16 Mar 2009 08:19:53 -0600

Changed in linux:
status: Fix Committed → Fix Released
Dan Andreșan (danyer) wrote :

Fixed indeed. Thanks.

kulight (kulight) wrote :

thank you

Martin Pitt (pitti) wrote :

Accepted linux into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Beattie (sbeattie) on 2009-06-16
tags: added: hw-specific
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-14.41

---------------
linux (2.6.27-14.41) intrepid-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: input: Blacklist digitizers from joydev.c"
    - LP: #300143

linux (2.6.27-14.40) intrepid-proposed; urgency=low

  [ Amit Kucheria ]

  * Disable DEVKMEM for all archs on Intrepid
    - LP: #354221
  * SAUCE: Quirk for BT USB device on MacbookPro to be reset before use
    - LP: #332443

  [ Andy Isaacson ]

  * LIRC_PVR150: depends on VIDEO_IVTV
    - LP: #341477
  * SAUCE: FSAM7400: select CHECK_SIGNATURE
    - LP: #341712

  [ Andy Whitcroft ]

  * SAUCE: hotkey quirks for various Zepto Znote and Fujitsu Amilo laptops
    - LP: #330259
  * SAUCE: unusual devs: add an entry for the ScanLogic SL11R-IDE 0.78
    - LP: #336189

  [ Anton Veretenenko ]

  * SAUCE: sony-laptop: add support for Sony Vaio FW series function/media
    keys
    - LP: #307592

  [ Ayaz Abdulla ]

  * SAUCE: forcedeth: msi interrupt fix
    - LP: #288281

  [ Chuck Short ]

  * SAUCE: [USB] Unusual Device support for Gold MP3 Player Energy
    - LP: #125250

  [ Ike Panhc ]

  * squashfs: correct misspelling
    - LP: #322306
  * SAUCE: Fixing symbol name in HECI module
    - LP: #336549
  * Copy header files for various kernel media driver
    - LP: #322732

  [ Stefan Bader ]

  * SAUCE: vgacon: Return the upper half of 512 character fonts
    - LP: #355057
  * SAUCE: input: Blacklist digitizers from joydev.c
    - LP: #300143

  [ Upstream Kernel Changes ]

  * libata: make sure port is thawed when skipping resets
    - LP: #269652
  * x86-64: fix int $0x80 -ENOSYS return
    - LP: #339743
  * rt2x00: Fix race conditions in flag handling
    - LP: #258985
  * USB: cdc-acm: Add another conexant modem to the quirks
    - LP: #323829
  * Bluetooth: Add fine grained mem_flags usage to btusb driver
    - LP: #268502
  * Bluetooth: Handle bulk URBs in btusb driver from notify callback
    - LP: #268502
  * Bluetooth: Submit bulk URBs along with interrupt URBs
    - LP: #268502
  * hwmon: (abituguru3) Match partial DMI board name strings
    - LP: #298798
  * x86: mtrr: don't modify RdDram/WrDram bits of fixed MTRRs
    - LP: #292619
  * sis190: add identifier for Atheros AR8021 PHY
    - LP: #247889
  * ath9k: implement IO serialization
    - LP: #373034
  * ath9k: AR9280 PCI devices must serialize IO as well
    - LP: #373034
  * acer-wmi: fix regression in backlight detection
    - LP: #333386

 -- Stefan Bader <email address hidden> Wed, 26 Aug 2009 11:48:11 +0200

Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Michael Sandford (sandford) wrote :

I'm getting this error on boot and it is rendering my two SATA drives unusable. The system still boots and runs off of the PATA disk. I'm running 9.04 and my kernel is up-to-date. I've seen this get fixed and opened and fixed and opened and I was wondering what it would take to re-open it. The machine in question is a Gateway GT5220 http://support.gateway.com/s/PC/R/1009151/1009151sp3.shtml

sandford@compy586:~$ uname -a
Linux compy586 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 18:40:08 UTC 2009 i686 GNU/Linux

sandford@compy586:~$ dmesg | tail -n 20
[ 837.538570] ata1: SATA link down (SStatus 100 SControl 300)
[ 837.538600] ata1: hard resetting link
[ 837.802550] ata2: SATA link down (SStatus 100 SControl 300)
[ 837.802571] ata2: hard resetting link
[ 838.271564] ata1: SATA link down (SStatus 100 SControl 300)
[ 838.271580] ata1: EH pending after 5 tries, giving up
[ 838.271587] ata1: EH complete
[ 838.287149] ata1: hard resetting link
[ 838.534566] ata2: SATA link down (SStatus 100 SControl 300)
[ 838.534598] ata2: hard resetting link
[ 839.022578] ata1: SATA link down (SStatus 100 SControl 300)
[ 839.022607] ata1: hard resetting link
[ 839.267605] ata2: SATA link down (SStatus 100 SControl 300)
[ 839.267634] ata2: hard resetting link
[ 839.754561] ata1: SATA link down (SStatus 100 SControl 300)
[ 839.754586] ata1: hard resetting link
[ 839.999574] ata2: SATA link down (SStatus 100 SControl 300)
[ 839.999594] ata2: EH pending after 5 tries, giving up
[ 839.999600] ata2: EH complete
[ 840.007298] ata2: hard resetting link

Pär Lindfors (paran) wrote :

Michael Sandford writes:

> I'm getting this error on boot and it is rendering my two SATA drives
> unusable.

No, this bug did not cause any hard resets of the sata link or any
SStatus 100, SControl 300 errors. It only flooded this type of messages:

ata4: EH complete
ata4: EH pending after 5 tries, giving up

This means that you have another problem and should open another bug.

Michael Sandford (sandford) wrote :

Oh, my apologies. I didn't realize that the additional messages would mean that it was a different bug. I'll file a new report. Thanks!

Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.