EeePC internal microphone does not function out-of-the-box with Ubuntu 8.04 Hardy Heron

Bug #232173 reported by Matt Austin on 2008-05-20
78
This bug affects 9 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Jackie Singleton
Nominated for Hardy by Matt Austin
Nominated for Intrepid by Matt Austin
linux (Ubuntu)
Wishlist
Unassigned
Nominated for Hardy by Matt Austin
Nominated for Intrepid by Matt Austin

Bug Description

Binary package hint: alsa-base

The Asus EeePC is a popular subnotebook computer.

With a fresh install of Ubuntu 8.04 LTS (Hardy Heron) the internal microphone does not function.

Expected function: Microphone works out-of-the-box

According to the instructions here: https://help.ubuntu.com/community/EeePC/Fixes#head-e0a73989f4da231d3f1b623f795ffc86e0d6a192
"options snd-hda-intel model=3stack-dig" needs to be added to /etc/modprobe.d/alsa-base

It would be great if this could be made to would work out-of-the-box with 8.04.1 or Intrepid.

I can definitely confirm this.

Changed in alsa-driver:
status: New → Confirmed

The comment above applies to both the EeePC 70x and EeePC 900 series (I can't speak for the EeePC 901 and EeePC 1000). They both do not have working microphones on a Ubuntu 8.04 install. However each has different sound hardware and a different fix.

EeePC 70x - Adding "options snd-hda-intel model=3stack-dig" to /etc/modprobe.d/alsa-base is a reported fix.

EeePC 900 - Adding "options snd-hda-intel model=auto" to /etc/modprobe.d/alsa-base is a reported partial fix to get the microphone hardware operating. However most people still cannot record reliably or with any volume. A full fix is not yet determined. The microphone done work under Xandros and XP.

Reference: http://www.eeeuser.com/ forum and wiki

Aaron.

Mjpatey (mjpatey) wrote :

Confirmed here.

Unfortunately, on my EeePC900 with a fresh install of Ubuntu 8.04, the "900 version" partial fix mentioned by Aaron Roydhouse had no effect.

-Mark

Matt Austin (mattaustin) wrote :

The internal microphone now seems to be working fine with Intrepid Ibex Alpha 1.

Matt Austin (mattaustin) wrote :

I should have added that I tested Intrepid Ibex Alpha 1 with the EeePC 701 (900 has not been tested).

Vladimer Sichinava (alinux) wrote :

on EeePC 900 (black) the same.

Mjpatey (mjpatey) wrote :

An update on my experience with the Eee 900 microphone in Hardy...

Using the custom kernel assembled by eeeuser forum member "adamm" has solved the problem. I do not know the specifics of what caused the mic to start working, but the custom kernel discussion can be found here:

http://forum.eeeuser.com/viewtopic.php?id=32303&p=1

...and the Web site devoted to the custom kernel is here:

http://www.array.org/ubuntu/index.html

I'm very satisfied with this setup on the Eee 900. Perhaps someone here can weed through and pick out the exact customization that fixed the microphone issue?

-Mark

Fabio Ornellas (fabio-ornellas) wrote :

Hello,

I've stresses a lot on the topic. My findings:

* Asus made some custom modifications on the snd-hda-intel driver to make it work on the EEE PC 900. However, such modifications were not ported to Vanilla kernels, and thus not for Ubuntu. As far as I could find, here is Asus' version: http://update.eeepc.asus.com/p900/misc/ . It is an old 2.6.21.4 kernel, but works.
* I read at forums that a "m-a a-i alsa" would do the trick (plus passing "model=auto" to the module). As a matter of fact, it does, partially. The mic then works, however, alsamixer controls are not the same as the ones found at the Asus driver. It lacks mic boost settings. Plus, Capture mixer must be set to a value below 68/100, because high values simply distorts a LOT the microphone. And at the end, if cpufreq is set to ondemand, skype can not work properly without generating a LOT of clicks to the other side. This effect is not seen on the factory Xandros, although I can't tell what is the cpufreq setting there.

So, my best bet to fix this issue permanently is to merge Asus's changes into mainstream kernel (or at least Ubuntu's). For now, "m-a a-i alsa" will work as a partial fix.

Adam McDaniel (adamrmcd) wrote :

The actual patch that fixes the microphone on eee 900 can be found here:
http://forum.eeeuser.com/viewtopic.php?pid=298419#p298419

This, as far as eeeuser.com user quickfire was able to determine, was the only piece that was unique to the xandros snd_hda_intel driver that was missing from ubuntu's linux-ubuntu-modules package.

Adam McDaniel (adamrmcd) wrote :

From what I've found, the EeePC 901/1000/1000h devices also have a similar problem with the internal microphone.

As of Alsa 1.0.17, the 900's internal mic has been fixed but the 901/1000/1000h's internal mic is still a problem.

These later devices were fixed in alsa-kmirror.git: commit df5d08005f3b78dab8aef45fa5e2ca9f8b52220f
posted after the v1.0.17 tag. Presumably, these will be fixed in Alsa 1.0.18

Daniel Miles (themono) wrote :

I'll confirm that the EEE901 (which I am writing this post on) does not have a working internal microphone under Ubuntu Intrepid, all updates current to now. Given that Intrepid is being pitched heavily at mobile users, and given that a fix is available in alsa git, this really should be patched in if possible.

Daniel Miles (themono) wrote :

I have opened a different bug for the 901 since it uses different hardware. it can be found at https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/259878

Eugenia Loli-Queru (eloli) wrote :

Any news on this? Can this be fixed for 8.10?

Daniel T Chen (crimsun) wrote :

Will need to isolate specific git changesets for ubuntu-intrepid.git.

Changed in alsa-driver:
assignee: nobody → ubuntu-audio
importance: Undecided → Wishlist
Adam McDaniel (adamrmcd) wrote :

I just posted a patch to Daniel Miles' bug report that fixes the EeePC 1000's internal microphone.

From my experience, as of tag "Ubuntu-2.6.27-2.3" in ubuntu-intrepid.git, support exists for the 901 and earlier.

Support for the EeePC 1000's internal microphone (and headphone jack) will be provided by Alsa v1.0.18rc3, or by my simple patch, posted at:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/259878/comments/11

Adam McDaniel (adamrmcd) wrote :

FWIW, Ubuntu-2.6.27-2.3 was tagged on 2008-08-28, 12 days after Daniel Miles reported that Intrepid lacked 901 internal microphone support.

If he were to upgrade to the 2.6.27-3-generic kernel (latest version as of today,) support should be available for his eeepc 901.

Sitsofe Wheeler (sitsofe) wrote :

Someone seems to have filed a separate bug about sound in the 901 over in bug #259878 ...

lolikandr (lolikandr) wrote :

Microphone is working on my 701, but it is near silently.

ksg (keith-groves) wrote :

I'm not having any luck using the microphone on a eeepc 8g (702). It did work on the original xandros.

I have tried with
options snd-hda-intel model=auto
and
options snd-hda-intel model=3stack-dig
in
/etc/modprobe.d/snd-hda-intel

Have tried using Intrepid and the latest alpha of Jaunty.

Does the 702 have the same audio hardware as the 701? 702:
keith@eee-pc:/etc/modprobe.d$ alsactl init
Unknown hardware: "HDA-Intel" "Realtek ALC662 rev1" "HDA:10ec0662,104382a1,00100101" "" ""
Hardware is initialized using a guess method

Changed in linux (Ubuntu):
assignee: Ubuntu Audio Team (ubuntu-audio) → nobody
Sitsofe Wheeler (sitsofe) wrote :

I don't have this issue on my EeePC 900 with 9.10...

Brad Figg (brad-figg) wrote :

Hi Matt,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 232173

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: no-sound-mic
tags: added: needs-test-current-image
tags: added: needs-required-logs
tags: added: kj-triage
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Mjpatey (mjpatey) wrote :

Same EeePC 900 as tested in my original post (#7) above, this time tested with Ubuntu Netbook Remix 10.04 Beta. Internal microphone works perfectly out of the box with the stock kernel, after a quick adjustment of the mic level using the volume applet.

:-)

Matt Austin (mattaustin) wrote :

This no longer appears to be an issue in Lucid Beta 2. Tested on both EeePC 701 and EeePC 1000HE.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Released
Changed in alsa-driver (Ubuntu):
assignee: nobody → Jackie Singleton (jackiesmickeymouse1964)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers