Ubuntu

USB DVB card floods the console with recv bulk message failed -ETIMEOUT

Reported by Anders Häggström on 2008-05-13
48
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
Invalid
Unknown
linux (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Jimbot

Bug Description

Hello, I am running Ubuntu 8.04 Server (amd64) and I have a "Devico FusionHDTV DVB-T Dual Digital". It is a PCI-card but the second tuner is plugged in thru USB2.
The first tuner (PCI-based) is working properly. I can tune signals, watch livetv with it and I have not found any error messages when using it alone. The PIC-tuner is located at "/dev/dvb/adapter0"
The second tuner is only found in cold state during boot and is not activated. To solve that I had to download the "bluebird"-firmware from http://www.linuxtv.org/downloads/firmware/dvb-usb-bluebird-01.fw and save it in /lib/firmware.

When I do a cold boot with the firmware available the second tuner (USB-tuner) is found but I sometimes receive this message during boot: "dvb-usb: bulk message failed: -71 (2/0)". The tuner is found and activated anyway and I see the second tuner as "/dev/dvb/adapter1" with the same nodes/files as the PCI-tuner (demux0, dvr0, frontend0, net0). I have not tried to use it yet.

When the computer has been online, idling, for some short random time (typically 10-15 minutes) I start to get floods of the following error message in the consol (typically one per second): "dvb-usb: bulk message failed: -110 (1/0)".

If I do a warm reboot I sometime reboot fine (without error messages shown at boottime) and sometimes with some similar error messages. I have seen "-71", "-22" and "-110".

During a forum-search I found this tread, but it does not seams related to my problem: http://ubuntuforums.org/showthread.php?t=373192

Bug #78949 seems to be related to this one, but its old and not for my hardware.

$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

$ uname -a
Linux gandalf 2.6.24-16-server #1 SMP Thu Apr 10 13:15:38 UTC 2008 x86_64 GNU/Linux

==========================

I saw from another thread the opinion that it was due to the -ETIMEOUT
value which was short in Ubuntu/Mythbuntu compared to Archlinux. I
erased mythbuntu and installed Linhes (which is based on Arch). The
problem disappeared.

Anders Häggström (hagge) wrote :
Anders Häggström (hagge) wrote :
Anders Häggström (hagge) wrote :

Is there anyone that can help me with this bug, please?

Here is some more information I've discoverd.
When I try to install Mythbuntu 8.04 (amd64) with the usb-adapter installed my keyborard acts wierd. First the keyboard acts normal (while the DVB-adapter is in normal state) and when the adapter starts to flood error-messages the keyboard takes aproximately 5seconds for each keypress and at some random time the keyboard flood inputs when a key is pressed (if I press "k" I get "kkkkkkkkkkkkkkkkkkkkkkkkkkkkk" of random length). After the install I end up with a corrupt disk (Grub Error 5 after reboot from LiveCD).

This is a very serious problem for me and I need help to solve it.

Another thing to know is that Mythbuntu comes bundled with the firmware on the LiveCD and that causes this behaivor by default. Ubuntu does not have the firmware loaded by default.

Anders Häggström (hagge) wrote :

I found this tread and the post from 2007-12-15 looks intresting but I don't know if that is a sulotion for my card. http://www.itee.uq.edu.au/~chrisp/Linux-DVB/DVICO/

What is the defenition of "a newer card"?
I have a "FuionHDTV DVB-T Dual Digital" is that the same card as the post mention ("FusionHDTV DVB-T Dual Express")?

The new version of the firmware sounds interesting but is that one for my hardware or not?

The FusionHDTV DVT-T Dual Digital is different fromt he Dual Express - The Dual Express is a PCI-Express card

DVICO makes two USB/PCI cards - the Dual Digital (2), which has an actual USB port (that's the one I have, and i think the one you have?) and the dual digital 4 which has a pci -> usb bridge for the USB tuner.

I'm also running ubuntu 8.04 server and having the same problem Anders is having - the PCI tuner loads fine:

[ 67.505751] cx88/2: cx2388x MPEG-TS Driver Manager version 0.0.6 loaded
[ 67.505886] cx88[0]: subsystem: 18ac:db50, board: DViCO FusionHDTV DVB-T Dual Digital [card=44,autodetected]
[ 67.505889] cx88[0]: TV tuner type 4, Radio tuner type -1
[ 67.511394] cx88/0: cx2388x v4l2 driver version 0.0.6 loaded

but the USB one gives error messages after it loads:

[ 69.092019] dvb-usb: found a 'DViCO FusionHDTV DVB-T Dual USB' in cold state, will try to load a firmware
[ 69.139716] dvb-usb: downloading firmware from file 'dvb-usb-bluebird-01.fw'
[ 69.236381] usb 2-3: USB disconnect, address 3
[ 69.240610] dvb-usb: generic DVB-USB module successfully deinitialized and disconnected.
(so the firmware is loading fine, but then)
[ 71.057474] usb 2-3: new high speed USB device using ehci_hcd and address 4
[ 71.209202] usb 2-3: configuration #1 chosen from 1 choice
[ 71.209539] dvb-usb: found a 'DViCO FusionHDTV DVB-T Dual USB' in warm state.
[ 71.210596] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 71.220371] DVB: registering new adapter (DViCO FusionHDTV DVB-T Dual USB)
[ 71.222823] DVB: registering frontend 1 (Zarlink MT352 DVB-T)...
[ 71.224278] input: IR-receiver inside an USB DVB receiver as /devices/pci0000:00/0000:00:02.1/usb2/2-3/input/input6
[ 71.257178] dvb-usb: schedule remote query interval to 150 msecs.
[ 71.257185] dvb-usb: DViCO FusionHDTV DVB-T Dual USB successfully initialized and connected.
[ 72.606458] dvb-usb: recv bulk message failed: -75
[ 82.039426] dvb-usb: bulk message failed: -71 (1/0)
[ 83.379617] dvb-usb: bulk message failed: -71 (1/0)
[ 84.057324] dvb-usb: bulk message failed: -71 (1/0)
[ 84.978737] dvb-usb: bulk message failed: -71 (1/0)
[ 85.730943] dvb-usb: bulk message failed: -71 (1/0)
[ 86.242278] dvb-usb: bulk message failed: -71 (1/0)
[ 87.117679] dvb-usb: bulk message failed: -71 (1/0)
[ 87.357889] dvb-usb: bulk message failed: -71 (1/0)
[ 88.003277] dvb-usb: bulk message failed: -71 (1/0)
... and so on.

I'm going to try the desktop kernel as i notice Anders is also running the server kernel. Will post my findings shortly.

Interestingly enough, the bulk message problems don't show up under the generic kernel until i actually try to tune a channel, but the same errors show up and I am still unable to tune anything.

I also think bug 93695 is related

damien_d (d-dusha) wrote :
Download full text (3.1 KiB)

I too have a Dvico dual digital card, and can confirm that it likes to spam the console.

In my case, it manifested itself by slowing down my keyboard responses to sometimes waiting seconds before all my keys appeared in the console at once (is it requiring a lot of kernel interrupts?)

It took a while for the drivers for this to become stable when I was using fedora about 18 months ago, and had to compile them from source, but after that, they worked well.

If I remember right, all I had to do for ubuntu was to install the firmware for the card, and after that, it was all fine... until, now. I have definately noticed it since 8.04, but it may have existed in 7.10 as well.

Here are some bits of the system log that alerted me to the problem:
{{{
898.916822] dvb-usb: bulk message failed: -110 (5/0)
[128899.915577] dvb-usb: bulk message failed: -110 (5/0)
[128900.914732] dvb-usb: bulk message failed: -110 (5/0)
[128901.913500] dvb-usb: bulk message failed: -110 (1/0)
[128902.912306] dvb-usb: bulk message failed: -110 (5/0)
[128903.911558] dvb-usb: bulk message failed: -110 (5/0)
[128904.909919] dvb-usb: bulk message failed: -110 (5/0)
[128905.908790] dvb-usb: bulk message failed: -110 (1/0)
[128906.907713] dvb-usb: bulk message failed: -110 (5/0)
[128907.906397] dvb-usb: bulk message failed: -110 (5/0)
[128908.905360] dvb-usb: bulk message failed: -110 (5/0)
[128909.903821] dvb-usb: bulk message failed: -110 (1/0)
[128910.902627] dvb-usb: bulk message failed: -110 (5/0)
[128911.901683] dvb-usb: bulk message failed: -110 (5/0)
[128912.900577] dvb-usb: bulk message failed: -110 (5/0)
[128913.899364] dvb-usb: bulk message failed: -110 (1/0)
[128914.898236] dvb-usb: bulk message failed: -110 (5/0)
[128915.896978] dvb-usb: bulk message failed: -110 (5/0)
[128916.895805] dvb-usb: bulk message failed: -110 (5/0)
[128917.894643] dvb-usb: bulk message failed: -110 (1/0)
[128918.893449] dvb-usb: bulk message failed: -110 (5/0)
[128919.892255] dvb-usb: bulk message failed: -110 (5/0)
[128920.891060] dvb-usb: bulk message failed: -110 (5/0)
[128921.889928] dvb-usb: bulk message failed: -110 (1/0)
[128922.888736] dvb-usb: bulk message failed: -110 (5/0)
[128923.887529] dvb-usb: bulk message failed: -110 (5/0)
[128925.365044] dvb-usb: bulk message failed: -110 (5/0)
[128926.505461] dvb-usb: bulk message failed: -110 (1/0)
[128927.504135] dvb-usb: bulk message failed: -110 (5/0)
[128928.503084] dvb-usb: bulk message failed: -110 (5/0)
[128929.501941] dvb-usb: bulk message failed: -110 (5/0)
[128930.500736] dvb-usb: bulk message failed: -110 (1/0)
[128931.499536] dvb-usb: bulk message failed: -110 (5/0)
[128932.498348] dvb-usb: bulk message failed: -110 (5/0)
[128933.497205] dvb-usb: bulk message failed: -110 (5/0)
[128934.496009] dvb-usb: bulk message failed: -110 (1/0)
[128935.494565] dvb-usb: bulk message failed: -110 (5/0)
[128936.493489] dvb-usb: bulk message failed: -110 (5/0)
[128937.492552] dvb-usb: bulk message failed: -110 (5/0)
[128938.950128] dvb-usb: bulk message failed: -110 (1/0)
}}}

Once reconnected, it caused lsusb to lock up, and I couldn't ctrl-c out of it.

Once I reboot the system, I'll see if I can get better system logs and lsusb o...

Read more...

Roy Jamison (xteejx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in linux:
status: New → Incomplete
Javier Jardón (jjardon) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
Anders Häggström (hagge) wrote :

What information is missing? I have not seen anyone asking for more information, other than me.

I own one of this cards and will help you with outputs and testing of the hardware if anyone tells me what to do.

Please, don't close/ignore this bug, it's not fixed. The USB-part of the hardware is not working.

Javier Jardón (jjardon) wrote :

Hello Anders,

Thank you for your interest in this bug.

The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Jaunty Jackalope. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in linux:
status: Invalid → Incomplete
Jimbot (jkennon1) wrote :

I also have a DVICO Dual Digital 4 (PCI, not PCIe) and am running amd64 architecture. I'm running Mythbuntu 8.04 - I'm assuming this is based on the desktop kernel. My card identifies itself as 0fe9:db78 in lsusb. I set it up based on the instructions shown here: http://ubuntuforums.org/showthread.php?t=616103 and it works. However, I have a similar problem to that which Anders describes.

Frequently when I do a warm boot, the system exhibits similar behaviour:

- I get the "dvb-usb: bulk message failed: -110" at a frequency of about once a second
- I get similar keyboard issues with my usb keyboard (press k once and I get a dozen or so: "kkkkkkkkkkkkkkkkkk")

The only way I can get my system back to 'normal' again is to remove the dvb_usb_cxusb module:

modprobe -r dvb_usb_cxusb

of course I have to stop the mythbackend first.Doing all this is very difficult when every few keypresses get repeated a heap of times. Especially when I have to login as root to do it. Though my system is now usable, the tuner card won't work (not without that module I just removed) so I have to reboot for me to use the system as intended.

I could live with the issue on warm reboot; I just have to shutdown, wait a bit, then start up again. However, the system has recently started doing it whenever I shut down the mythbackend (for configuration for instance), and when I tested connecting with XBMC from another machine it did it as well.

Based on the forum thread I followed to set the card up, this seems to be a known issue among users of the card, but it's a royal pain in the neck and it would be great if it got fixed some time. I'm happy to provide additional information if that would be of assistance.

Cheers.

you could try using building a vanilla kernel thats what i used on 8.04 and
now im using intrepid i have no problems with the stock kernel 2.6.27-11

On Thu, Mar 12, 2009 at 8:36 PM, Jimbot <email address hidden> wrote:

> I also have a DVICO Dual Digital 4 (PCI, not PCIe) and am running amd64
> architecture. I'm running Mythbuntu 8.04 - I'm assuming this is based on
> the desktop kernel. My card identifies itself as 0fe9:db78 in lsusb. I
> set it up based on the instructions shown here:
> http://ubuntuforums.org/showthread.php?t=616103 and it works. However, I
> have a similar problem to that which Anders describes.
>
> Frequently when I do a warm boot, the system exhibits similar behaviour:
>
> - I get the "dvb-usb: bulk message failed: -110" at a frequency of about
> once a second
> - I get similar keyboard issues with my usb keyboard (press k once and I
> get a dozen or so: "kkkkkkkkkkkkkkkkkk")
>
> The only way I can get my system back to 'normal' again is to remove the
> dvb_usb_cxusb module:
>
> modprobe -r dvb_usb_cxusb
>
> of course I have to stop the mythbackend first.Doing all this is very
> difficult when every few keypresses get repeated a heap of times.
> Especially when I have to login as root to do it. Though my system is
> now usable, the tuner card won't work (not without that module I just
> removed) so I have to reboot for me to use the system as intended.
>
> I could live with the issue on warm reboot; I just have to shutdown,
> wait a bit, then start up again. However, the system has recently
> started doing it whenever I shut down the mythbackend (for configuration
> for instance), and when I tested connecting with XBMC from another
> machine it did it as well.
>
> Based on the forum thread I followed to set the card up, this seems to
> be a known issue among users of the card, but it's a royal pain in the
> neck and it would be great if it got fixed some time. I'm happy to
> provide additional information if that would be of assistance.
>
> Cheers.
>
> --
> My DVB-card is flooding the consol with "recv bulk message failed"
> https://bugs.launchpad.net/bugs/229879
> You received this bug notification because you are a direct subscriber
> of the bug.
>

this is affecting me too.

I can avoid it by shutting down for time instead of restarting...

What information could I collect to cast more light on it?

Kemble Wagner (oobe-trouble) wrote :

has anyone tried installing newer v4l-dvb drivers

sudo -i

apt-get update

apt-get install install mercurial build-essential linux-headers-`uname -r`

hg clone http://linuxtv.org/hg/v4l-dvb

cd v4l-dvb

make && make install

exit

or as i mentioned above dowloading the newest kernel from http://kernel.org and compiling it youself will also fix this
http://www.howtoforge.com/kernel_compilation_ubuntu

i for one can say that this used to fix the trouble for me however now in intrepid the stock kernel works fine for me.

Jean-Yves Avenard (jyavenard) wrote :

Unfortunately, even with the latest v4l-dvb drivers I too experience those bulk errors in the log

They show up every 2 seconds

Kemble Wagner (oobe-trouble) wrote :

as mentioned im using 2.6.27-11-generic and as i said i havent had a problem yet well the other day i did i experienced the same problems that others here report including spam console etc. but i have not had it before or since just chiming in to say that even when i have somthing that i consider stable it still ends up like this on occasion so there is yet to be a completely stable kernel or v4l-dvb tree on this matter.

 it would be sensable if someone started a thread on the v4l-dvb mailing list about this as ubuntu developers cannot fix this due to the fact they only package the code that v4l-dvb produce which intern goes into the kernel which distros then patch and package.

Paul Elliott (omahn) wrote :

I also have this issue. I was originally running 7.10, then upgraded to 8.10 via 8.04. I think the suggestion from Kemble to post to the v4l-dvb mailing list is sound. If the OP can create an initial posting I'll also post to the same thread to highlight that this is affecting multiple users.

moaxey (moaxey) wrote :

i dont know how a problem like this can get progressively worse... i was able to cold reboot and have and work, but now not... ever.

and it alternately seems to break usb, remote desktop and sometimes appears but is untunable.

I think i might re-install kernel and go back to chis pascoe patches and see what happens...

bojo42 (bojo42) wrote :

just for the record it still persist in up-to-date jaunty with the following device:
ID 0ccd:0038 TerraTec Electronic GmbH Cinergy T^2 DVB-T Receiver

my current message is also:
dvb-usb: bulk message failed: -71 (1/0)

"sudo modprobe -r dvb_usb_cinergyT2" is not working:
FATAL: Module dvb_usb_cinergyT2 is in use.

but unplugging usb and reconnecting it helps and my box is running again. but i have no clue what's going on. with intrepid (AFAIR) i had this behaviour more often, as i always needed to de- & attach the usb cabel after boot for getting the device working.

@all: has someone experienced this issue after having the device dettached during boot and plugged in on the fully loaded system? and could all affected by this bug post their hardware (-> lsusb) and the driver they're using (->lsmod -> dvb_usb_WHATEVER), so we may isolate the problem to specifc hardware & drivers.

best regards
bojo42

Roy Jamison (xteejx) wrote :

In Jaunty, can you run "apport-collect 229879" (without quotes), this should provide some more info for us to look at.

lynton (lyntonr) wrote :

Hi, I have exactly this problem using fedora 9 and a DVICO FusionHDTV DVB-T Dual Digital 4 card so this is not an ubuntu issue.

uname -r
2.6.27.23-78.2.50.fc9.x86_64

The problem seems to occur randomly (usually immediately after boot) and when it does I get various
" dvb-usb: bulk message failed" messages sometimes accompanied by i2c read errors.

I also get the keyboard stickyness and delay problem which can be "fixed" by

$ sudo rmmod dvb_usb_cxusb

This stops the messages and returns the keyboard to normal (once you are able to successfully type the command in that is)

In my case the system will eventually hang (in the sense that I cannot use the mouse or keyboard or ping the machine)

$ sudo lsusb
Bus 003 Device 003: ID 0fe9:db78 DVICO FusionHDTV DVB-T Dual Digital 4 (ZL10353+xc2028/xc3028) (initialized)
Bus 003 Device 002: ID 0fe9:db78 DVICO FusionHDTV DVB-T Dual Digital 4 (ZL10353+xc2028/xc3028) (initialized)
$ dmesg | grep -i dvico
usb 3-1: Manufacturer: Dvico
usb 3-2: Manufacturer: Dvico
dvb-usb: found a 'DViCO FusionHDTV DVB-T Dual Digital 4' in warm state.
DVB: registering new adapter (DViCO FusionHDTV DVB-T Dual Digital 4)
dvb-usb: DViCO FusionHDTV DVB-T Dual Digital 4 successfully initialized and connected.
dvb-usb: found a 'DViCO FusionHDTV DVB-T Dual Digital 4' in warm state.
DVB: registering new adapter (DViCO FusionHDTV DVB-T Dual Digital 4)
dvb-usb: DViCO FusionHDTV DVB-T Dual Digital 4 successfully initialized and connected.

Its hard to know where to point the finger with this one, but my guess is
the usb subsystem somewhere perhaps related to x86_64 arch.

Sometimes the system will work perfectly (including the TV card) (< 50%) other times not,
perhaps related to the order the the usb devices are initialized.

No new info here, just wanted to note that this occurs on fedora too.

regards

lynton

Roy Jamison (xteejx) wrote :

In Jaunty, can you please run "apport-collect 229879" and allow it full access so it can give more system specific information. Also it may be helpful to see if any of the debugging information at https://wiki.ubuntu.com/DebuggingUdev helps. Can you provide any logs/information as separate attachments. Thank you.

summary: - My DVB-card is flooding the consol with "recv bulk message failed"
+ USB DVB card floods the console with recv bulk message failed
Roy Jamison (xteejx) on 2009-05-22
Changed in linux (Fedora):
importance: Undecided → Unknown
status: New → Unknown
Changed in linux (Fedora):
status: Unknown → Invalid
Jimbot (jkennon1) wrote :

Sorry - dropped the entire message.

I'm still having this issue, with Mythbuntu 8.04, kernel 2.6.24-24-generic, and v4l-dvb mercurial as at today.

I get the issue when I do a warm boot, or when I shut down the mythbackend.

It seems the reason I get characters flooding the console is probably related to the usb driver crashing, and the fact that I'm using a usb keyboard & mouse.

When I do a warm boot, most times I get this issue. When this happens, the mouse and keyboard won't even connect (no lights on mouse or keyboard, and no reaction to keypresses)

In the attached dmesg dump it can be seen that it starts up okay (cold boot). Then I've shutdown the mythtv backend and then the error messages start. At the end, you can see the problem stops once I remove dvb_usb_cxusb from the kernel.

I'm not sure how to progress this. I understand the problem is likely to be with the dvb_usb_cxusb module, or the drivers, but not the kernel. I have seen this thread on the V4L-DVB mailing list, but I can't tell if there's anything happening with it or not. Is there anything else I can do to help get a resolution?

Roy Jamison (xteejx) wrote :

Would it be possible to try this with Jaunty at all, so we can find out if this is fixed in a newer version. Thank you.

or better yet start a thread with the developers of the drivers or the
kernel since that is where the problem is and ubuntu dev's cannot control
that instead of
leeching onto a thread thats vaguely related to your problem despite the
fact it has already been proven irrelevent and uneffective.

On Tue, Jun 2, 2009 at 3:43 AM, Teej <email address hidden> wrote:

> Would it be possible to try this with Jaunty at all, so we can find out
> if this is fixed in a newer version. Thank you.
>
> --
> USB DVB card floods the console with recv bulk message failed
> https://bugs.launchpad.net/bugs/229879
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hello,
I have just installed the latest ver. of mythbuntu (Jaunty), and this bug still exists.
Has there been anymore updates on this issue?
Thank you.

Alistair (tlli) wrote :

Sorry Teej, when I get home tonight i'll update the bug after I run the command you suggested ("apport-collect 229879") on Jaunty.
Cheers.

I had the same bug with Mythbuntu 9.04 and Dvico Dual Digital 4 rev 2.
I saw from another thread the opinion that it was due to the -ETIMEOUT
value which was short in Ubuntu/Mythbuntu compared to Archlinux. I
erased mythbuntu and installed Linhes (which is based on Arch). The
problem disappeared.

Ozman

----- Original message -----
From: "Alistair" <email address hidden>
To: <email address hidden>
Date: Fri, 12 Jun 2009 02:14:02 -0000
Subject: [Bug 229879] Re: USB DVB card floods the console with recv bulk
       message failed

Sorry Teej, when I get home tonight i'll update the bug after I run the
command you suggested ("apport-collect 229879") on Jaunty.
Cheers.

--
USB DVB card floods the console with recv bulk message failed
https://bugs.launchpad.net/bugs/229879
You received this bug notification because you are a direct subscriber
of the bug.

Status in “linux” source package in Ubuntu: Incomplete
Status in “linux” source package in Fedora: Invalid

Bug description:
Hello, I am running Ubuntu 8.04 Server (amd64) and I have a "Devico
FusionHDTV DVB-T Dual Digital". It is a PCI-card but the second tuner is
plugged in thru USB2.
The first tuner (PCI-based) is working properly. I can tune signals,
watch livetv with it and I have not found any error messages when using
it alone. The PIC-tuner is located at "/dev/dvb/adapter0"
The second tuner is only found in cold state during boot and is not
activated. To solve that I had to download the "bluebird"-firmware from
http://www.linuxtv.org/downloads/firmware/dvb-usb-bluebird-01.fw and
save it in /lib/firmware.

When I do a cold boot with the firmware available the second tuner
(USB-tuner) is found but I sometimes receive this message during boot:
"dvb-usb: bulk message failed: -71 (2/0)". The tuner is found and
activated anyway and I see the second tuner as "/dev/dvb/adapter1" with
the same nodes/files as the PCI-tuner (demux0, dvr0, frontend0, net0). I
have not tried to use it yet.

When the computer has been online, idling, for some short random time
(typically 10-15 minutes) I start to get floods of the following error
message in the consol (typically one per second): "dvb-usb: bulk message
failed: -110 (1/0)".

If I do a warm reboot I sometime reboot fine (without error messages
shown at boottime) and sometimes with some similar error messages. I
have seen "-71", "-22" and "-110".

During a forum-search I found this tread, but it does not seams related
to my problem: http://ubuntuforums.org/showthread.php?t=373192

Bug #78949 seems to be related to this one, but its old and not for my
hardware.

$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

$ uname -a
Linux gandalf 2.6.24-16-server #1 SMP Thu Apr 10 13:15:38 UTC 2008
x86_64 GNU/Linux
Regards,
Oz Viewer

Thanks for the alternative, but i'd like to stick with ubuntu/mythbuntu. I've got a rev1 card, and worst case I will just cold boot my machine everytime the error occurs.

I read somewhere (http://ubuntuforums.org/showthread.php?t=616103&highlight=dvico) that chris pascoes firmware is not used anymore.Would it help to use his again, if this is true?

Roy Jamison (xteejx) wrote :

Setting Triaged, Low. There should be enough information here for a developer to have a look and see where the root cause is, so I shall let them take it from here. If they need any more information and ask for it, please give it to them. Thank you very much.

summary: - USB DVB card floods the console with recv bulk message failed
+ USB DVB card floods the console with recv bulk message failed -ETIMEOUT
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
status: Confirmed → Triaged
description: updated
Robert Lowery (rglowery) wrote :

See bug 459523, post #16 for a possible workaround to this issue.

Kemble Wagner (oobe-trouble) wrote :

i was wondering if anyone has a work around with karmic as the whole OS become unusuable with this tuner and kernel 2.6.31 and compiling v4l-dvb does not seem to fix it yet?

Download full text (3.4 KiB)

Robert Lowery's suggested work around addresses the issue in Mythbuntu 8.04
(Hardy). I have done the update suggested:

adding

options dvb-core dvb_powerdown_on_sleep=0

to /etc/modprobe.d/options.conf
I have tested by doing a warm reboot, and also by stopping and restarting
myth-backend. Both of these techniques would consistently reproduce the bug
previously. Now I can do both operations multiple times and the bug is not
reproduced. Looks like this workaround works for this bug as well, at least
in Hardy. I will try in Karmic later this week.

I have run Karmic, prior to testing this workaround, and the problem still
existed. In addition, I still needed to put the xc3208-*v27*.fw firmware
file in /lib/firmware.

Many thanks to Robert Lowery for analysing this problem and suggesting the
workaround.

On Tue, Nov 3, 2009 at 11:35 PM, Kemble Wagner <email address hidden>wrote:

> i was wondering if anyone has a work around with karmic as the whole OS
> become unusuable with this tuner and kernel 2.6.31 and compiling v4l-dvb
> does not seem to fix it yet?
>
> --
> USB DVB card floods the console with recv bulk message failed -ETIMEOUT
> https://bugs.launchpad.net/bugs/229879
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Triaged
> Status in “linux” package in Fedora: Invalid
>
> Bug description:
> Hello, I am running Ubuntu 8.04 Server (amd64) and I have a "Devico
> FusionHDTV DVB-T Dual Digital". It is a PCI-card but the second tuner is
> plugged in thru USB2.
> The first tuner (PCI-based) is working properly. I can tune signals, watch
> livetv with it and I have not found any error messages when using it alone.
> The PIC-tuner is located at "/dev/dvb/adapter0"
> The second tuner is only found in cold state during boot and is not
> activated. To solve that I had to download the "bluebird"-firmware from
> http://www.linuxtv.org/downloads/firmware/dvb-usb-bluebird-01.fw and save
> it in /lib/firmware.
>
> When I do a cold boot with the firmware available the second tuner
> (USB-tuner) is found but I sometimes receive this message during boot:
> "dvb-usb: bulk message failed: -71 (2/0)". The tuner is found and activated
> anyway and I see the second tuner as "/dev/dvb/adapter1" with the same
> nodes/files as the PCI-tuner (demux0, dvr0, frontend0, net0). I have not
> tried to use it yet.
>
> When the computer has been online, idling, for some short random time
> (typically 10-15 minutes) I start to get floods of the following error
> message in the consol (typically one per second): "dvb-usb: bulk message
> failed: -110 (1/0)".
>
> If I do a warm reboot I sometime reboot fine (without error messages shown
> at boottime) and sometimes with some similar error messages. I have seen
> "-71", "-22" and "-110".
>
>
> During a forum-search I found this tread, but it does not seams related to
> my problem: http://ubuntuforums.org/showthread.php?t=373192
>
> Bug #78949 seems to be related to this one, but its old and not for my
> hardware.
>
> $ lsb_release -rd
> Description: Ubuntu 8.04
> Release: 8.04
>
> $ uname -a
> Linux gandalf 2.6.24-16-server #1 SMP Th...

Read more...

anewman (alan-an1) wrote :

This has all just gone bad for me :( Seems to have been caused by a recent Ubuntu update as it worked fine on 9.10 Karmic until I installed updates.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

Richard Pillay (richardpillay) wrote :
Download full text (4.7 KiB)

This issue was triaged under Ubuntu, with a final comment asking that it be changed to new if it still persists.

I've had this issue constantly through Mythbuntu 0904, 0910 and it still exists in 1004.

I don't really know what information is needed to solve this, so please ask. The machine concerned is not a development machine, but please don't hesitate to ask if you need debugging tools or other aids to be installed on the machine. If you need me to install something which may be detrimental to performance, I've got no problem with taking an image of the machine beforehand and restoring it after.

The machine has a Gigabyte GA-EP45-UDP motherboard with Intel P45 chipset, E5200 processor, Generic Nvidia 9800 graphics. It has two DVB cards - one Winfast DTV1000T (single tuner), and one Dvico FusionHDTV dual digital 4.

On my system:

root@MythBuntu:~# uname -a
Linux MythBuntu 2.6.32-24-generic-pae #42-Ubuntu SMP Fri Aug 20 15:37:22 UTC 2010 i686 GNU/Linux

lsusb:
root@MythBuntu:~# lsusb
Bus 011 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 010 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 002: ID 045e:00f1 Microsoft Corp.
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 002: ID 15c2:0038 SoundGraph Inc.
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 0fe9:db98 DVICO
Bus 003 Device 002: ID 0fe9:db98 DVICO
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

root@MythBuntu:~# lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.3 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 4
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
00:1d.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB Controller: Intel Corporation 8...

Read more...

Changed in linux (Ubuntu):
status: Triaged → New
Cafuego (cafuego) wrote :
Download full text (9.5 KiB)

Same issue here on 10.04. After booting the kernel log is spammed with:

[ 544.968189] dvb-usb: bulk message failed: -110 (4/0)
[ 544.968198] cxusb: i2c read failed

... and the system load sits on 1.00 consistently (Single core single CPU system) despite nothing showing in top and the cpu being listed as 99.3% idle. vmstat doesn't show any oddly high interrupt rates and there system is not swapping.

It did NOT occur on 9.04, so it seems to be it might be some sort of regression. I have yet to reboot with the 9.04 kernel to see if that makes any difference, though. I also have two cards, a DViCO Fusion HDTV Dual Digital 4 and a LeadTek DTV2000H.

Adding the following line to a file in /etc/modprobe.d did not affect the issue:
options dvb-core dvb_powerdown_on_sleep=0

lsusb:
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 1241:f728 Belkin
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 0fe9:db78 DVICO FusionHDTV DVB-T Dual Digital 4 (ZL10353+xc2028/xc3028) (initialized)
Bus 002 Device 002: ID 0fe9:db78 DVICO FusionHDTV DVB-T Dual Digital 4 (ZL10353+xc2028/xc3028) (initialized)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 152d:2329 JMicron Technology Corp. / JMicron USA Technology Corp.
Bus 001 Device 002: ID 152d:2329 JMicron Technology Corp. / JMicron USA Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lspci -v:
00:00.0 Host bridge: nVidia Corporation nForce3 250Gb Host Bridge (rev a1)
 Flags: bus master, 66MHz, fast devsel, latency 0
 Memory at f0000000 (32-bit, prefetchable) [size=32M]
 Capabilities: <access denied>
 Kernel driver in use: agpgart-amd64
 Kernel modules: amd64-agp

00:01.0 ISA bridge: nVidia Corporation nForce3 250Gb LPC Bridge (rev a2)
 Subsystem: Giga-byte Technology Device 0c11
 Flags: bus master, 66MHz, fast devsel, latency 0

00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
 Subsystem: Giga-byte Technology Device 0c11
 Flags: 66MHz, fast devsel, IRQ 10
 I/O ports at e400 [size=32]
 I/O ports at 1c00 [size=64]
 I/O ports at 2000 [size=64]
 Capabilities: <access denied>
 Kernel driver in use: nForce2_smbus
 Kernel modules: i2c-nforce2

00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1) (prog-if 10)
 Subsystem: Giga-byte Technology Device 5004
 Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
 Memory at fa003000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: <access denied>
 Kernel driver in use: ohci_hcd

00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1) (prog-if 10)
 Subsystem: Giga-byte Technology Device 5004
 Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
 Memory at fa004000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: <access denied>
 Kernel driver in use: ohci_hcd

00:02.2 USB Controller: nVidia Corporation nForce3 EHCI USB 2.0 Controller (rev a2) (prog-if 20)
 Subsystem: Giga-byte Technology Device 5004
 Flags: bus master, 66MHz, fast devs...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.