Ubuntu

S-ATA2 HDD not recongnized (Samsung T166 Spinpoint)/ Nvidia Sata Controller (nforce 780a) not working

Reported by Christoph on 2008-03-07
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
thanatos

Bug Description

1.) Ubuntu Hardy Heron, updated 7th of Feb. 2008
        Installation from CD not possible (Desktop-, Alternate-i386 CDs)

2.) HDD: Samsung T166 Spinpoint 320GB, S-ATA2
        Motherboard: Asus M3N78-EMH HDMI (with Geforce 8200 GPU onboard, nforce 780a)
        CPU: AMD 64 X2 BE-2400
        RAM: 4 GB DDR2-800 Mhz A-DATA

3.) The HDD is not recognized while installing Hardy from CD:
        * partition window is empty, can't make any changes (Desktop CD)
        * driver-list is prompting, you have to choose, which one could fit (Alternate CD)

4.) Problematic recognition with gutsy, too. After formating the hdd gutsy recognizes the hdd.
 (...hardy not)

My HDDs partitions now:
1.NTFS 30GB
2.NTFS 50GB
3.ext3 25GB ← primary, root
4.ext3 ~210GB ← logical, \home
----------------------------

Booting:

If I choose the standard Hardy Heron Mode (kernel 2.6.24-11), it hangs up at the following point:

[ 4.276000] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 4.288000] ata1.00: qc timeout (cmd0xec)
[ ... ] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[ ... ] ata1.00: failed to recover some devices
..
...
....
sr 6:0:1:0 Attached scsi generic sg1 type5
Done.

Check root= bootarg cat /proc/cmdline
or missing modules, devices: cat /proc/modules ls/dev
ALERT! /dev/disk/by-unid/9ae09019-d95f-4cd3-bd46-16c7bfddf2dd does not exist
Dropping to a shell!

Debian BusyBox...
--------------

under hardy/gutsy with kernel 2.6.22-14 :

[ 4.276000] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 4.288000] ata1.00: ATA-8: SAMSUNG HD321KJ, CP100-12, max UDMA7

----------------------------

After reading about S-ATA a little bit. Maybe it could be a problem of the S-ATA Controller on the Mainboard, which should be from Nvidia in my case. (nforce 780a)
I tried a Debian Installation and it, of course, didn't work, too. In the large list of possible drivers I choosed "Sata_nv" but, like I said, it didn't work.
So maybe I'm just too much of an idiot choosing the right sata-controller driver. Or.. the "driver modul" isn't implemented into the kernel, yet?!

---------------------------

A Samsung SH S203P Sata DVD Burner isn't working, too.. If this is of interest.
[4.........] ata2: softreset failed etc.

Christoph (sc0186) wrote :
Christoph (sc0186) wrote :
Christoph (sc0186) wrote :
Christoph (sc0186) wrote :
Christoph (sc0186) on 2008-03-08
description: updated
description: updated
description: updated
description: updated
Christoph (sc0186) on 2008-03-08
description: updated
Christoph (sc0186) on 2008-03-09
description: updated
Christoph (sc0186) on 2008-03-09
description: updated
Christoph (sc0186) on 2008-03-11
description: updated
Christoph (sc0186) on 2008-03-12
description: updated
Christoph (sc0186) on 2008-03-12
description: updated
Christoph (sc0186) on 2008-03-14
description: updated
Christoph (sc0186) on 2008-03-14
description: updated
thanatos (info-mynetworks) wrote :

I have the same problem with the mainboard M3N-78 EMH HDMI.
The other Hardware is totally different from the one of Christoph!
It really seems to be a problem with the chipset Nforce 780a, this is a really new one.

In addition there are problems with the ethernet controller, so in my opinion it
is the whole chipset, which is temporary unsupported.

It would be nice if it could be fixed soon!

Mfg thanatos

thanatos (info-mynetworks) wrote :

same problem, seems to be the mainboard -> nforce 780a chipset ! for more info read my comment

Changed in linux:
assignee: nobody → info-mynetworks
status: New → Confirmed
Christoph (sc0186) wrote :

Solution:

After activating AHCI in the bios setting and booting from CD/DVD one need to press F6 to enter further boot parameter: pci=nomsi
Now the hdd and other sata devices are recognized correctly due the installation. Don't know if its really a bug..

Marco Scholl (traxanos) wrote :

i can reproduce it on a 730a nforce chipset

Harrison Metzger (harrisonmetz) wrote :

Thanks Chrestoph! Once I switched my BIOS to AHCI and adding pci=nomsi to grub, I can boot fine. What exactly do all those commands do?

Christoph (sc0186) wrote :

AHCI is a open controller interface (developed by Intel). If your devices are working with this standart, you don't need to search for the "right" (closed?!), special sata-controller driver. So its not a bug - but a feature. ^.^

But one has to know it..

(I don't know what pci=nomsi is doing in detail. Its some kind of hind for the kernel finding/recognizing your sata devices, as far as I know.)

basti (ubuntu-bastis) wrote :

I have the same problem with an an ECS GF8200A mainboard.
After adding pci=nomsi to grub the sata-hdd was detected.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Christoph (sc0186) wrote :

I've tested the Ubuntu 8.10 Alpha5 Live-CD with the 2.6.27 kernel today. The hdd is recognized correctly, now! My Bios setting is still set to the AHCI Mode, but I didn't had to enter special parameters - the partition program worked fine.

(Maybe someone else could check, if the 2.6.26 kernel is working, too.)

David Hall (satconcook) wrote :

I want to mention that I just set up a new PC using the SAMSUNG Spinpoint F1 HD103UJ 1TB 7200 RPM SATA 3.0Gb/s Hard Drives. I tried Ubuntu 8.04 and Kubuntu 7.04 with no luck on even seeing the drives. I just downloaded Intrepid Alpha 6 and already see them in the partitioner and in the process of installing.

Since Christoph is the original bug reporter and David has also commented that this apprears to be resolved I'm marking this "Fix Released" for Intrepid. Thanks.

Changed in linux:
status: Confirmed → Fix Released
Francewhoa (francewhoa) wrote :

Confirming that this bug is still present in Ubuntu 8.04.4 LTS Desktop. When installing a new Ubuntu from the CD.

SATA controller: On board. SATA channel (3.0 Gb/s) via ICH10R.
Motherboard: Intel Desktop Board DP45SG
Hard drive: 1x Western Digital

The following fixed it for me http://ubuntuforums.org/showthread.php?p=8952609#post8952609

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers