[Asus Zenbook UX3402ZA] Sound doesn't work at all

Bug #1981433 reported by Jack
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Sound/speakers don't work at all on Asus Zenbook 14 OLED and other similar models with Realtek ALC294.

No solution works. Audio is not muted, tried adding snd-hda arguments - no dice.

This has been reported numerous times, when will a fix finally be rolled out?!

ProblemType: Bug
DistroRelease: Ubuntu 22.04
Package: linux-image-5.15.0-41-generic 5.15.0-41.44
ProcVersionSignature: Ubuntu 5.15.0-41.44-generic 5.15.39
Uname: Linux 5.15.0-41-generic x86_64
ApportVersion: 2.20.11-0ubuntu82.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: martin 1730 F.... pulseaudio
CRDA: N/A
CasperMD5CheckResult: pass
CurrentDesktop: ubuntu:GNOME
Date: Tue Jul 12 13:57:05 2022
InstallationDate: Installed on 2022-07-12 (0 days ago)
InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - Release amd64 (20220419)
MachineType: ASUSTeK COMPUTER INC. Zenbook UX3402ZA_UX3402ZA
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.15.0-41-generic root=UUID=40c924aa-99ad-4770-a66d-33d3359f6053 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-5.15.0-41-generic N/A
 linux-backports-modules-5.15.0-41-generic N/A
 linux-firmware 20220329.git681281e4-0ubuntu3.2
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/15/2022
dmi.bios.release: 5.25
dmi.bios.vendor: American Megatrends International, LLC.
dmi.bios.version: UX3402ZA.305
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX3402ZA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 31
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.ec.firmware.release: 3.5
dmi.modalias: dmi:bvnAmericanMegatrendsInternational,LLC.:bvrUX3402ZA.305:bd06/15/2022:br5.25:efr3.5:svnASUSTeKCOMPUTERINC.:pnZenbookUX3402ZA_UX3402ZA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX3402ZA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct31:cvr1.0:sku:
dmi.product.family: Zenbook
dmi.product.name: Zenbook UX3402ZA_UX3402ZA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Revision history for this message
Jack (jack9389) wrote :
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Chris Guiver (guiverc) wrote : Re: Sound doesn't work at all

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Bug reporting is about finding & fixing problems thus preventing future users from hitting the same bug.

I suspect a Support site would be more appropriate, eg. https://answers.launchpad.net/ubuntu. You can also find help with your problem in the support forum of your local Ubuntu community http://loco.ubuntu.com/ or asking at https://askubuntu.com or https://ubuntuforums.org, or for more support options please look at https://discourse.ubuntu.com/t/community-support/709

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

> This has been reported numerous times, when will a fix finally be rolled out?!

I can't find any other reports about UX3402ZA, but for ALC294 I can see a few and have grouped them here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bugs?field.tag=alc294

summary: - Sound doesn't work at all
+ [Asus Zenbook UX3402ZA] Sound doesn't work at all
tags: added: alc294
Revision history for this message
Arun (openarun) wrote :

Same here, I tried almost everything possible searching through the web. No sound, might be issue with Cirrus amps driver issue? A quick work around or fix would be appreciated. :)

Revision history for this message
Arun (openarun) wrote :

On using linux-oem-5.17 kernel, no sound yet. But I got the following log in dmesg related to Cirrus driver, I assume.

[ 11.845962] cs35l41_hda: probe of spi0-CSC3551:00-cs35l41-hda.0 failed with error -22
[ 11.846034] cs35l41_hda: probe of spi0-CSC3551:00-cs35l41-hda.1 failed with error -22

Revision history for this message
Khaled El Mously (kmously) wrote :

Was audio working previously on this hardware and then stopped after a kernel (or other package) update? If so, we can try bisecting.

Note also that the 5.15.0-41.44 kernel has been out for a while now. The most recent kernel is 5.15.0-48.54 so maybe that is worth trying as well.

Revision history for this message
Arun (openarun) wrote (last edit ):

It never worked with Ubuntu/Linux kernel. It works fine when booted to Microsoft Windows.
I even tried the latest upstream kernel 6.0.0-rc6-next-20220921, no luck with it either.

Revision history for this message
Chris Chiu (mschiu77) wrote :

@Arun, does the headset work OK on audio input/output?

Revision history for this message
Arun (openarun) wrote :

Yes, the headset works fine with the plug-in jack.

Revision history for this message
Arun (openarun) wrote :

Even the audio input of the machine works fine. Just the speaker doesn't have sound.

Revision history for this message
Chris Chiu (mschiu77) wrote :

Got it. Just google for the UX3402ZA, it supports multi-dimensional audio and may indicate the it needs some extra settings for the speakers. The fixup ALC289_FIXUP_ASUS_GA401 may be useful. Could you help try my test kernel debian and update the result for me?

https://people.canonical.com/~mschiu77/lp1981433/

Revision history for this message
Arun (openarun) wrote :

Tried the kernel from the link you sent, still no sound yet. :(

Revision history for this message
Arun (openarun) wrote :

Do let me know if there is anything you want me to look/check/test.

Revision history for this message
Chris Chiu (mschiu77) wrote :

According to the init_pin_configs of the attached alsainfo.txt, this machine has already been applied with the fixup ALC294_FIXUP_ASUS_HPE. But you might need more EAPD setting to enable the speaker.

Please try the following commands to see if speaker works.
sudo hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x40
sudo hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x8800

Remember to install alsa-tools if command `hda-verb` not found.

Revision history for this message
Arun (openarun) wrote :

The above hda-verb command didn't get the speaker working.
No sound yet.
Here I have attached my dmesg output. Hope that gets us somewhere useful.
Thanks!

Revision history for this message
Arun (openarun) wrote :

Hello there, is there anything I can do to help fix this issue please?

Revision history for this message
Chris Chiu (mschiu77) wrote :

Hi @Arun, can you share the output file of the command `alsa-info`?
And please share the output of the following commands:

sudo hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x40
sudo hda-verb /dev/snd/hwC0D0 0x20 GET_PROC_COEF 0

Revision history for this message
Arun (openarun) wrote :

Here are the output of the above hda-verb commands.

arun@arunpc:~$ sudo hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x40
[sudo] password for arun:
nid = 0x20, verb = 0x500, param = 0x40
value = 0x0
arun@arunpc:~$ sudo hda-verb /dev/snd/hwC0D0 0x20 GET_PROC_COEF 0
nid = 0x20, verb = 0xc00, param = 0x0
value = 0x420

This didn't solve either.

Revision history for this message
Chris Chiu (mschiu77) wrote :

Hi, please try my test kernel here https://people.canonical.com/~mschiu77/lp1981433/5.15/.

Revision history for this message
Arun (openarun) wrote :

Hi there,

The above kernel didn't help either.

I can still see the following output in dmesg.

[ 12.011038] cs35l41_hda: probe of spi0-CSC3551:00-cs35l41-hda.0 failed with error -22
[ 12.014729] cs35l41_hda: probe of spi0-CSC3551:00-cs35l41-hda.1 failed with error -22

Thanks!

Revision history for this message
Chris Chiu (mschiu77) wrote :

That's pretty weird. Can you post the full dmesg log here?

And the output of `pacmd list cards`, `pacmd list sinks`. Thanks

Revision history for this message
Arun (openarun) wrote :
Revision history for this message
Arun (openarun) wrote :
Revision history for this message
Arun (openarun) wrote :
Revision history for this message
Arun (openarun) wrote :

I have send you the output of the above commands. Hope they are useful :)

Revision history for this message
Swastik Harish (swastikharish) wrote : Re: [Bug 1981433] Re: [Asus Zenbook UX3402ZA] Sound doesn't work at all

I am facing the same problem. Same machine running Ubuntu 21.10. Would it
help if i also uploaded the outputs of the commands?

On Wed, 26 Oct, 2022, 2:00 am Arun, <email address hidden> wrote:

> I have send you the output of the above commands. Hope they are useful
> :)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1981433
>
> Title:
> [Asus Zenbook UX3402ZA] Sound doesn't work at all
>
> Status in linux package in Ubuntu:
> Confirmed
>
> Bug description:
> Sound/speakers don't work at all on Asus Zenbook 14 OLED and other
> similar models with Realtek ALC294.
>
> No solution works. Audio is not muted, tried adding snd-hda arguments
> - no dice.
>
> This has been reported numerous times, when will a fix finally be
> rolled out?!
>
> ProblemType: Bug
> DistroRelease: Ubuntu 22.04
> Package: linux-image-5.15.0-41-generic 5.15.0-41.44
> ProcVersionSignature: Ubuntu 5.15.0-41.44-generic 5.15.39
> Uname: Linux 5.15.0-41-generic x86_64
> ApportVersion: 2.20.11-0ubuntu82.1
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: martin 1730 F.... pulseaudio
> CRDA: N/A
> CasperMD5CheckResult: pass
> CurrentDesktop: ubuntu:GNOME
> Date: Tue Jul 12 13:57:05 2022
> InstallationDate: Installed on 2022-07-12 (0 days ago)
> InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - Release amd64
> (20220419)
> MachineType: ASUSTeK COMPUTER INC. Zenbook UX3402ZA_UX3402ZA
> ProcFB: 0 i915drmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.15.0-41-generic
> root=UUID=40c924aa-99ad-4770-a66d-33d3359f6053 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-5.15.0-41-generic N/A
> linux-backports-modules-5.15.0-41-generic N/A
> linux-firmware
> 20220329.git681281e4-0ubuntu3.2
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 06/15/2022
> dmi.bios.release: 5.25
> dmi.bios.vendor: American Megatrends International, LLC.
> dmi.bios.version: UX3402ZA.305
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: UX3402ZA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 31
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.ec.firmware.release: 3.5
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInternational,LLC.:bvrUX3402ZA.305:bd06/15/2022:br5.25:efr3.5:svnASUSTeKCOMPUTERINC.:pnZenbookUX3402ZA_UX3402ZA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX3402ZA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct31:cvr1.0:sku:
> dmi.product.family: Zenbook
> dmi.product.name: Zenbook UX3402ZA_UX3402ZA
> dmi.product.version: 1.0
> dmi.sys.vendor: ASUSTeK COMPUTER INC.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1981433/+subscriptions
>
>

Revision history for this message
Ashok Pahadi (pokhrelashok2) wrote :

Same laptop same issue

Revision history for this message
Arun (openarun) wrote :

Hi there,
Any update on the fix please?
Thanks!

Revision history for this message
Chris Chiu (mschiu77) wrote :

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1995957 should be helpful. Will try to build a test kernel for it.

Revision history for this message
Swastik Harish (swastikharish) wrote :

Thank you. Please let us know how it goes. Is there any way i could help?
I'm not a coder but can find my way around trying fixes.

On Thu, 10 Nov, 2022, 12:05 am Chris Chiu, <email address hidden>
wrote:

> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1995957 should be
> helpful. Will try to build a test kernel for it.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1981433
>
> Title:
> [Asus Zenbook UX3402ZA] Sound doesn't work at all
>
> Status in linux package in Ubuntu:
> Confirmed
>
> Bug description:
> Sound/speakers don't work at all on Asus Zenbook 14 OLED and other
> similar models with Realtek ALC294.
>
> No solution works. Audio is not muted, tried adding snd-hda arguments
> - no dice.
>
> This has been reported numerous times, when will a fix finally be
> rolled out?!
>
> ProblemType: Bug
> DistroRelease: Ubuntu 22.04
> Package: linux-image-5.15.0-41-generic 5.15.0-41.44
> ProcVersionSignature: Ubuntu 5.15.0-41.44-generic 5.15.39
> Uname: Linux 5.15.0-41-generic x86_64
> ApportVersion: 2.20.11-0ubuntu82.1
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: martin 1730 F.... pulseaudio
> CRDA: N/A
> CasperMD5CheckResult: pass
> CurrentDesktop: ubuntu:GNOME
> Date: Tue Jul 12 13:57:05 2022
> InstallationDate: Installed on 2022-07-12 (0 days ago)
> InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - Release amd64
> (20220419)
> MachineType: ASUSTeK COMPUTER INC. Zenbook UX3402ZA_UX3402ZA
> ProcFB: 0 i915drmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.15.0-41-generic
> root=UUID=40c924aa-99ad-4770-a66d-33d3359f6053 ro quiet splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-5.15.0-41-generic N/A
> linux-backports-modules-5.15.0-41-generic N/A
> linux-firmware
> 20220329.git681281e4-0ubuntu3.2
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 06/15/2022
> dmi.bios.release: 5.25
> dmi.bios.vendor: American Megatrends International, LLC.
> dmi.bios.version: UX3402ZA.305
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: UX3402ZA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 31
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.ec.firmware.release: 3.5
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInternational,LLC.:bvrUX3402ZA.305:bd06/15/2022:br5.25:efr3.5:svnASUSTeKCOMPUTERINC.:pnZenbookUX3402ZA_UX3402ZA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX3402ZA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct31:cvr1.0:sku:
> dmi.product.family: Zenbook
> dmi.product.name: Zenbook UX3402ZA_UX3402ZA
> dmi.product.version: 1.0
> dmi.sys.vendor: ASUSTeK COMPUTER INC.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1981433/+subscriptions
>
>

Revision history for this message
Arutyun (arutyun-akopov) wrote :

Do you have any news on this bug? I want to buy this laptop, but I'm afraid that the sound will not be fixed.

Revision history for this message
Swastik Harish (swastikharish) wrote :
Revision history for this message
Swastik Harish (swastikharish) wrote :

Not yet. Sending energy to Chris :-)

Attaching my pacmd command outputs here.

On 18/11/22 13:13, Arutyun wrote:
> Do you have any news on this bug? I want to buy this laptop, but I'm
> afraid that the sound will not be fixed.
>

Revision history for this message
Arun (openarun) wrote :

Hi Chris,
Any update on the new test kernel please?
Thanks!

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
vikas gamit (vikasgamit36) wrote :

Sorry. I accidentally clicked on fix released button 😔.

i also try to found solution last 2 months. but not got any solution.

Please changed the bug status.. i can't change access from my side now.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Arun (openarun) wrote :

Thanks @mitya57 for reverting :)

Revision history for this message
Gazdag Sándor (gsanya) wrote :

Hi all! I experienced the same problem on my UX582HS (ZenBook Pro Duo OLED 11th gen). Is there an update or could anyone solve the problem?
Thanks!

To post a comment you must log in.