alsa/sof: load different firmware on different platforms

Bug #1857409 reported by Hui Wang on 2019-12-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
OEM Priority Project
Undecided
Che Cheng
linux (Ubuntu)
Status tracked in Focal
Eoan
Medium
Unassigned
Focal
Medium
Hui Wang
linux-oem-osp1 (Ubuntu)
Undecided
Unassigned
Bionic
Medium
Unassigned

Bug Description

[Impact]
In our ubuntu kernel, the sof driver will load the sof-cnl.ri (firmware)
on all platforms, but mainline kernel already supported the multi
firmwares on differnt platforms, and OEM project needs us to
support the mutli-firmware names in the ubuntu kernel

[Fix]
cherry-pick 3 upstream patches, then on cnl platforms, it will
load sof-cnl.ri, on cml platfomrs, it will load sof-cml.ri, on cfl
platforms, it will load sof-cfl.ri

[Test Case]
Prepare the firmware from https://github.com/thesofproject/linux-firmware
master branch, then boot the kernel with these patches.

[Regression Risk]
Low, just let different platforms load differnt firmware, and these
patches are in the upstream kernel.

Hui Wang (hui.wang) on 2019-12-24
Changed in linux (Ubuntu):
importance: Undecided → Critical
tags: added: originate-from-1856130 somerville

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1857409

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Hui Wang (hui.wang) on 2019-12-24
description: updated
no longer affects: linux-oem (Ubuntu)
Changed in linux-oem-osp1 (Ubuntu Focal):
status: New → Invalid
Changed in linux-oem-osp1 (Ubuntu Eoan):
status: New → Invalid
no longer affects: linux-oem-osp1 (Ubuntu Eoan)
no longer affects: linux-oem-osp1 (Ubuntu Focal)
no longer affects: linux (Ubuntu Bionic)
Changed in linux (Ubuntu Focal):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Eoan):
status: New → Confirmed
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: New → Confirmed
Stefan Bader (smb) on 2020-01-07
Changed in linux-oem-osp1 (Ubuntu Bionic):
importance: Undecided → Critical
Changed in linux (Ubuntu Focal):
importance: Critical → Medium
Changed in linux (Ubuntu Eoan):
importance: Undecided → Medium
Changed in linux (Ubuntu Eoan):
status: Confirmed → Fix Committed
Timo Aaltonen (tjaalton) on 2020-01-07
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Confirmed → Fix Committed
Che Cheng (cktenn) on 2020-01-14
affects: linux → oem-priority
Changed in oem-priority:
assignee: nobody → Che Cheng (cktenn)
Marcelo Cerri (mhcerri) wrote :

I dropped the patches from the eoan:linux master-next branch due to the regression reported in #1860642

Changed in linux (Ubuntu Eoan):
status: Fix Committed → Confirmed
Timo Aaltonen (tjaalton) wrote :

same for osp1

Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-osp1 - 5.0.0-1037.42

---------------
linux-oem-osp1 (5.0.0-1037.42) bionic; urgency=medium

  * bionic/linux-oem-osp1: 5.0.0-1037.42 -proposed tracker (LP: #1860784)

  * [Dell Vostro 5490] proposed linux-oem-osp1 suspend resume fails
    (LP: #1860642)
    - Revert "ASoC: SOF: Intel: Fix CFL and CML FW nocodec binary names."
    - Revert "ASoC: Intel: acpi-match: split CNL tables in three"
    - Revert "ASoC: SOF: Intel: hda: use fallback for firmware name"

 -- Timo Aaltonen <email address hidden> Fri, 24 Jan 2020 15:02:03 +0200

Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in linux-oem-osp1 (Ubuntu):
status: Invalid → Fix Released
Hui Wang (hui.wang) wrote :

The patches are merged to osp1 kernel from 1034 and are reverted from 1037. Will resubmit the patches after getting the fixing patches.

Rex Tsai (chihchun) wrote :

The patch has been reverted by https://bugs.launchpad.net/bugs/1860642

Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Fix Released → Confirmed
Hui Wang (hui.wang) wrote :

Intel (Mengdong@Intel) told us it is too complicated to backport the fixing patches to 5.0-oem-osp1 kernel, and these 3 patches are not very important. we will not backport these 3 patches to osp1 kernel until Intel backport the fixing patches to osp1 kernel.

Set it to Medium first.

Changed in linux-oem-osp1 (Ubuntu Bionic):
importance: Critical → Medium
Rex Tsai (chihchun) wrote :

Hi, Hui

I think we have misalignment here, there are two set of patches

1. The patch to load the firmware from the different path (the patches are reverted by LP #1860642.
2. The patch to fix hanging issues when sof_probe_continue() is failed[2].

Intel (Mengdong@Intel) is not planning to backport [2]patches to sof-v5.0 and mainline-kernel-5.3.

But Canonical should still be able to land[1] patches to load the firmware from the different path, isn't it? We need to align how we plan to to ship the firmware, and in which version of path.

[1] https://bugs.launchpad.net/bugs/1860642
[2] Fix sof core error handling (v3, alternative to R1743/1745) by kv2019i · Pull Request #1746 · thesofproject/linux - https://github.com/thesofproject/linux/pull/1746/commits

Hui Wang (hui.wang) wrote :

@ Rex,

If we apply the [1], it will make users easily reproduce the [2], that is why kernel maintainer reverted the [1].

I thought I backport the [2] to the kernel first, then backport [1] to the kernel, I tried to backport the [2] to the osp1 kernel myself, but it didn't work at all, so I asked for help to Intel, they estimated a couple of days then tell me it is not easy and they will not help backport the [2] to 5.0 and 5.3, and without [1], the dmic function will not be affected.

About the linux-firmware, already sru them to Eoan and Bionic with this bug: https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1859387, the firmware under Eoan and Bionic can support the kernel both with [1] and without [1].

Because this bug will not affect the dmic function, just lower the priority, when I finish the more urgent bug, I will spend more time investigating backport [2], then resend the patch [1].

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers