intel/sof: update the intel sof firmware to v1.3-0f73628 for cml and cnl

Bug #1859387 reported by Hui Wang on 2020-01-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Che Cheng
linux-firmware (Ubuntu)
High
Hui Wang
Bionic
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

[Impact]
Intel released a new version sof firmware to Canonical, they suggested
that we should integrate the version v1.3-0f73628 and we should only
pick the cml and cnl firmwares since other firmwares are not fully
tested. Since we have a couple of Lenovo and Dell cnl and cml machines
which need to enable sof driver, we integrate the firmwares to
ubuntu.

[Fix]
 - fix the hang issue in the firmware for the cml and cnl
 - introduce the ldc file which helps to do the firmware debug
 - divide the firmware to cml and cnl specific ones

[Test Case]
These firmwares are already widely used in oem project, the audio
functions worked very well under both Lenovo and Dell dmic machines.

[Regression Risk]
Low, Intel released these firmware to us, and we already did large
numbers audio test in the oem project.

Hui Wang (hui.wang) on 2020-01-13
Changed in linux-firmware (Ubuntu):
importance: Undecided → High
Hui Wang (hui.wang) on 2020-01-13
description: updated
Che Cheng (cktenn) on 2020-01-14
Changed in oem-priority:
assignee: nobody → Che Cheng (cktenn)
Hui Wang (hui.wang) on 2020-01-15
tags: added: originate-from-1856130 somerville
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.185

---------------
linux-firmware (1.185) focal; urgency=medium

  * Rebase against git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
    1eb2408c6feacccd10b02a49214745f15d1c6fb7
    - i915: Add GuC firmware v33.0.4 for EHL
    - i915: Add HuC firmware v9.0.0 for EHL
    - i915: Add GuC firmware v35.2.0 for TGL
    - i915: Add HuC firmware v7.0.3 for TGL
    - amdgpu: update navi10 vcn firmware
    - amdgpu: update navi14 vcn firmware
    - linux-firmware: Update firmware file for Intel Bluetooth 9260
    - linux-firmware: Update firmware file for Intel Bluetooth 9560
    - linux-firmware: Update firmware file for Intel Bluetooth AX200
    - linux-firmware: Update firmware file for Intel Bluetooth AX201
    - linux-firmware: Update NXP Management Complex firmware to version 10.18.0
    - rtl_nic: add firmware rtl8168fp-3
    - qcom: Add SDM845 modem firmware
    - qcom: Add SDM845 Audio DSP firmware
    - qcom: Add SDM845 Compute DSP firmware
    - brcm: Add BCM43455 NVRAM for Raspberry Pi 4 B
    - cxgb4: Update firmware to revision 1.24.11.0
    - qcom: update venus firmware files for v5.4
    - WHENCE: Add raspberry-pi4 SDIO file
    - inside-secure: add new "mini" firmware for the EIP197 driver
    - linux-firmware: Update AMD cpu microcode
    - ath10k: QCA6174 hw3.0: update board-2.bin
    - ath10k: QCA9887 hw1.0: update firmware-5.bin to 10.2.4-1.0-00047
    - ath10k: QCA9888 hw2.0: update firmware-5.bin to 10.4-3.9.0.2-00070
    - ath10k: QCA988X hw2.0: update firmware-5.bin to 10.2.4-1.0-00047
    - ath10k: QCA9984 hw1.0: update firmware-5.bin to 10.4-3.9.0.2-00070
    - ath10k: WCN3990 hw1.0: add firmware WLAN.HL.2.0-01387-QCAHLSWMTPLZ-1
    - linux-firmware: add NXP firmware licence file
    - qcom: Switch SDM845 WLAN firmware
    - Adjust WHENCE entry to check_whence doesn't complain
    - qed: Add firmware 8.42.2.0
    - amdgpu: add TA microcode for Raven asics
    - amdgpu: update navi14 microcode for 19.50
    - amdgpu: update navi10 microcode for 19.50
    - amdgpu: update raven microcode for 19.50
    - amdgpu: update raven2 microcode for 19.50
    - amdgpu: update picasso microcode for 19.50
    - amdgpu: update vega10 microcode for 19.50
    - amdgpu: update vega12 microcode for 19.50
    - amdgpu: update vega20 microcode for 19.50
    - radeon: update oland rlc microcode from amdgpu
    - Mellanox: Add new mlxsw_spectrum firmware xx.2000.2714
    - mediatek: update MT8173 VPU firmware to v1.1.3
    - amdgpu: Add navi10 TA ucode
    - amdgpu: update navi10 firmware for 19.50
    - nvidia: add TU102/TU104/TU106 signed firmware
    - linux-firmware: Update firmware file for Intel Bluetooth 9260
    - linux-firmware: Update firmware file for Intel Bluetooth 9560
    - linux-firmware: Update firmware file for Intel Bluetooth AX201
    - linux-firmware: Update firmware file for Intel Bluetooth AX200

  * intel/sof: update the intel sof firmware to v1.3-0f73628 for cml and cnl
    (LP: #1859387)
    - Update cml and cnl sof firmware files to v1.3-0f73628

 -- Seth Forshee <email address hidden> Tue, 28 Jan 2020 15:14:26 -0600

Changed in linux-firmware (Ubuntu):
status: Confirmed → Fix Released

Hello Hui, or anyone else affected,

Accepted linux-firmware into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.183.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in linux-firmware (Ubuntu Eoan):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello Hui, or anyone else affected,

Accepted linux-firmware into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/1.173.15 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in linux-firmware (Ubuntu Bionic):
status: New → Fix Committed
Hui Wang (hui.wang) wrote :

Verified the 1.183.4 for Eoan on a Lenovo dmic machine, it worked as good as before.

Verified the 1.173.15 for Bionic on a Dell dmic machine, it worked as good as before.

Seth Forshee (sforshee) wrote :

Thanks for the regression testing. What about the hang that the update is intended to fix?

Hui Wang (hui.wang) wrote :

Found those 2 Dell machines which have hang issue before, and tested the new firmware on them (one is installed bionic, the other is installed eoan), the hang issue is fixed by new firmware.

tags: added: verification-done-bionic verification-done-eoan
Hui Wang (hui.wang) wrote :

BTW, the focal also need these firmwares, and I put unstable/F in the title when sending the SRU.

On Thu, Feb 06, 2020 at 02:26:07AM -0000, Hui Wang wrote:
> BTW, the focal also need these firmwares, and I put unstable/F in the
> title when sending the SRU.

They have been applied (and released) for focal. There isn't any
unstable linux-firmware tree/package.

Hui Wang (hui.wang) wrote :

OK, got it. thx.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.183.4

---------------
linux-firmware (1.183.4) eoan; urgency=medium

  * Fix throttled clock on AMD Oland (LP: #1858751)
    - radeon: update oland rlc microcode from amdgpu

  * intel/sof: update the intel sof firmware to v1.3-0f73628 for cml and cnl
    (LP: #1859387)
    - SAUCE: Update cml and cnl sof firmware files to v1.3-0f73628

 -- Seth Forshee <email address hidden> Wed, 29 Jan 2020 13:12:52 -0600

Changed in linux-firmware (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers