Ubuntu 18.10 / Linux 4.19 -rc7/8/Final - System slows / stops

Bug #1799180 reported by Christopher Patti on 2018-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hi there folks sorry if it's inappropriate to report a bug in an upstream release candidate kernel, but as a suggested test / fix for https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1796743 I was told to install an upstream kernel, which I did.

When I run with that kernel for any length of time, or do anything involving high CPU (like run Firefox for instance) the system fan begins to whine and the system slows down to the point where it finally hangs.

I tried to run 'ubuntu-bug linux' from the terminal, but when I do I get the error seen in the screenshot (attached).

I'll go back to running 4.18 for now because not being able to sleep the laptop isn't a show stopper, but it's definitely something I consider important for a fully fledged operating system / work environment :)

Thanks and please let me know if there's anything I can do to provide more data / help with testing / etc.
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.10
InstallationDate: Installed on 2018-10-07 (14 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Beta amd64 (20180927)
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Tags: cosmic
Uname: Linux 4.19.0-041900rc8-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
DistroRelease: Ubuntu 18.10
InstallationDate: Installed on 2018-10-07 (20 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Beta amd64 (20180927)
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Tags: cosmic
Uname: Linux 4.19.0-041900-generic x86_64
UnreportableReason: The running kernel is not an Ubuntu kernel
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True

Christopher Patti (feoh) wrote :

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1799180

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: cosmic

apport information

tags: added: apport-collected
description: updated

Feel free to close this if it makes sense. I am researching how best to report this upstream. The documentation on reporting kernel bugs makes it clear you need to identify the affected subsystem or your bug will be bit-bucketed. More hard core log diving is called for :)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Christopher Patti (feoh) wrote :

I'll bet dollars for donuts this is the nouveau driver. I see a bunch of lines like this as the system slows to a crawl (Also there's a juddering/tearing band in the center of the screen)

Oct 27 17:01:44 yamato kernel: [ 402.710539] nouveau 0000:01:00.0: DRM: base-0: timeout

Full kernel log copied away before the system slowed to a crawl and had to be restarted.

FWIW this was running 4.19 final. I'll update the summary accordingly.

Changed in linux (Ubuntu):
status: Triaged → New
Christopher Patti (feoh) wrote :

Also marked this for re-triage since I have some usable evidence and a smoking gun.

summary: - Ubuntu 18.10 / Linux 4.19 -rc7/8 - System slows / stops
+ Ubuntu 18.10 / Linux 4.19 -rc7/8/Final - System slows / stops

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1799180

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Christopher Patti (feoh) wrote :

Also attaching nouveau driver info a-la modinfo.

apport information

description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Christopher Patti (feoh) wrote :

Interestingly, this ONLY happens with Gnome.

I've been running i3wm now for days with zero issues.

I guess this is telling me it's time to choose a lighter window manager alternative? :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers