Ubuntu 18.10 - Alienware 17 R5 crashes on sleep

Bug #1796743 reported by Christopher Patti on 2018-10-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

If the machine goes to sleep, either because I close the lid or because it idles too long, it ends up in a weird state when I try to resume. If I press the power/Alien button, the fan runs and the keyboard/trackpad light up but nothing happens.

Ultimately I need to hard power off the laptop (by holding the power button in for three seconds) which causes it to boot from scratch.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: linux-image-4.18.0-8-generic 4.18.0-8.9
ProcVersionSignature: Ubuntu 4.18.0-8.9-generic 4.18.7
Uname: Linux 4.18.0-8-generic x86_64
ApportVersion: 2.20.10-0ubuntu11
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: feoh 2895 F.... pulseaudio
CurrentDesktop: GNOME
Date: Mon Oct 8 14:25:16 2018
InstallationDate: Installed on 2018-10-07 (0 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Beta amd64 (20180927)
MachineType: Alienware Alienware 17 R5
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-8-generic root=UUID=c3d3798c-6179-472a-ba82-55ef94f4d382 ro quiet splash vt.handoff=1
RelatedPackageVersions:
 linux-restricted-modules-4.18.0-8-generic N/A
 linux-backports-modules-4.18.0-8-generic N/A
 linux-firmware 1.175
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/10/2018
dmi.bios.vendor: Alienware
dmi.bios.version: 1.5.0
dmi.board.name: Alienware 17 R5
dmi.board.vendor: Alienware
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Alienware
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnAlienware:bvr1.5.0:bd08/10/2018:svnAlienware:pnAlienware17R5:pvr1.5.0:rvnAlienware:rnAlienware17R5:rvrA00:cvnAlienware:ct10:cvrNotSpecified:
dmi.product.family: Alienware
dmi.product.name: Alienware 17 R5
dmi.product.sku: 0877
dmi.product.version: 1.5.0
dmi.sys.vendor: Alienware

Christopher Patti (feoh) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.19-rc7 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19-rc7/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Hello,

Open bug in launchpad.net
https://bugs.launchpad.net/bugs/1796743

"If the machine goes to sleep, either because I close the lid or because it idles too long, it ends up in a weird state when I try to resume. If I press the power/Alien button, the fan runs and the keyboard/trackpad light up but nothing happens.

Ultimately I need to hard power off the laptop (by holding the power button in for three seconds) which causes it to boot from scratch."

Best regards,
--
Cristian Aravena Romero (caravena)

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Christopher Patti (feoh) wrote :

Yay this is in fact fixed in 4.19-rc7! Thanks very much this was a real show stopper :)

tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Triaged → Confirmed

Excellent! Thank you...
--
Cristian Aravena Romero (caravena)

Changed in linux:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.